Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 17 Dec 2017, 02:45
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Firefox52/Pulseaudio/No Sound (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [30 Posts]   Goto page: Previous 1, 2
Author Message
spiritwild


Joined: 03 Oct 2016
Posts: 107

PostPosted: Sun 12 Mar 2017, 10:07    Post subject:  

With the release of Firefox 52, we are pleased to welcome the 50 developers who contributed their first code change to Firefox in this release, 45 of whom were brand new volunteers! Please join us in thanking each of these diligent and enthusiastic individuals, and take a look at their contributions:

https://blog.mozilla.org/community/2017/03/03/firefox-52-new-contributors/


Found this on Donald Trumps Twitter Laughing
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1498
Location: Italy

PostPosted: Sun 12 Mar 2017, 13:06    Post subject:  

Now I am in xenialpup64 7.0.8.1. Wanted to run firefox 52.0 with pulseaudio. There is a simple way to do this. Install in PPM pulseaudio_8.0 again even though it is declared already installed. A symlink is needed to start firefox:

Code:
ln -s /usr/lib/libGL.so /usr/lib/libGL.so.1


Then in console:

Code:
pulseaudio --start
firefox


I'm posting from it and it plays sound.
Back to top
View user's profile Send private message 
Bud

Joined: 27 Apr 2010
Posts: 23

PostPosted: Sun 12 Mar 2017, 14:00    Post subject: Re: pulseaudio-4.0-tahr606-i386.pet
Subject description: works in slacko 14.2 and xenialpup
 

I think I've spent enough time with this, I got it working now its not.
Thanks all, until there's a simple fix that works it's goodbye Firefox.
Guess I should have posted in Beginners Help, after years of using Puppies this is the first thing I can't fix.
No doubt the 50 Mozilloids are in a drum circle exchanging congratulatory badges Rolling Eyes
Back to top
View user's profile Send private message 
spiritwild


Joined: 03 Oct 2016
Posts: 107

PostPosted: Sun 12 Mar 2017, 22:53    Post subject:  

you may try redirecting alsa in (etc/asound.conf)

adding these lines.

pcm.pulse { type pulse }
ctl.pulse { type pulse }
pcm.!default { type pulse }
ctl.!default { type pulse }
Back to top
View user's profile Send private message 
frenchiveruti

Joined: 15 Feb 2017
Posts: 93

PostPosted: Mon 13 Mar 2017, 02:14    Post subject:  

The mozilloids screwed my audio too... I really don't get why.
Back to top
View user's profile Send private message 
Bud

Joined: 27 Apr 2010
Posts: 23

PostPosted: Mon 13 Mar 2017, 22:14    Post subject:  

frenchiveruti wrote:
The mozilloids screwed my audio too... I really don't get why.

Guess they wanted me to use Seamonkey 2.46.Smile
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1301
Location: N.E. USA

PostPosted: Tue 14 Mar 2017, 11:03    Post subject:  

If you are buggered by PulseAudio, try fireFox 45.8esr. It is the update-equivilent to 52.0 (which is an esr BTW). Does NOT require GTK3.0.

Linux 32-bit i686

Linux x86-64bit

Regards
8Geee

PS: using the 32bit on Slacko5.7... so far so good. LOTSA TWEAKING in about:config needed. Very Bloated.

_________________
Linux user #498913

Good God!, by the stars in the sky we are lost!
And into the breach we got tossed!
And the world is comin' on fast! --Florence Welch
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1301
Location: N.E. USA

PostPosted: Tue 14 Mar 2017, 11:06    Post subject:  

Semme wrote:
Now Oscar, is this a band-aid or a Very HappyWink splint?


Anything installed to /tmp should be considered a band-aid. Put it in /usr or /opt... then we're talking fix.

_________________
Linux user #498913

Good God!, by the stars in the sky we are lost!
And into the breach we got tossed!
And the world is comin' on fast! --Florence Welch
Back to top
View user's profile Send private message 
Bud

Joined: 27 Apr 2010
Posts: 23

PostPosted: Tue 14 Mar 2017, 20:54    Post subject:  

8Geee wrote:
If you are buggered by PulseAudio, try fireFox 45.8esr.
Thanks but no thanks, Mozilla need to do something about his, maybe listen to the community outside the Cone of Silence.

@ https://bugzilla.mozilla.org/show_bug.cgi?id=1345661

Don't forget to vote.. (Before Mozilla bury it Wink) click Details to reveal.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1498
Location: Italy

PostPosted: Wed 15 Mar 2017, 05:56    Post subject: apulse-git032017-x86_64.pet
Subject description: For slacko64 6.9.6.4
 

apulse-git032017-x86_64.pet:

https://drive.google.com/file/d/0B9iMb4UZBeFkbWJoTzRxUnZEc2M/view?usp=sharing

For slacko64 beta. Pulseaudio 9.0 from slackware does not work for me. This package does not work in xenialpup64 beta.

Code:
apulse /path-to/firefox
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1644
Location: London, England

PostPosted: Wed 15 Mar 2017, 07:03    Post subject:  

If you install the libraries to the default path of /usr/lib (or presumably /usr/lib64) you do not need to use the
Code:
apulse
command at all. It is just a little wrapper script to find the libs if they are not in standard path. You don't even need to install it in /usr/bin

The readme suggests that for installation in /usr/lib you should build with
Code:
cmake -DAPULSEPATH=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
but I don't know if the first option does anything other than setting the install path for make install

What it appears to be doing is substituting the standard pulseaudio runtime library with a modified apulse library which handles the audio and redirects it to alsa so we can hear it as normal.

It is always best to compile in the distro you are running, but I built the apulse-0.1.8 release in Wheezy ( http://smokey01.com/OscarTalks ) and have tested this (briefly) in Slacko 5.7 / Slacko 6.3.0 / TahrPup 6.0.5 / Dpup Stretch and in all cases the sound worked and Firefox 52 could be started in any of the normal ways.

_________________
Oscar in England

Back to top
View user's profile Send private message 
Bud

Joined: 27 Apr 2010
Posts: 23

PostPosted: Sun 02 Apr 2017, 18:10    Post subject:  

Solved here: http://www.murga-linux.com/puppy/viewtopic.php?p=949869#949869

Thanks all.

Bud Smile
Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 639

PostPosted: Tue 29 Aug 2017, 22:47    Post subject:  

Hello watchdog

Code:
ln -s /usr/lib/libGL.so /usr/lib/libGL.so.1

which you recommended cannot possibly work
and was rejected when I tried.
Code:
root# ln -s /usr/lib/libGL.so /usr/lib/libGL.so.1
ln: failed to create symbolic link ‘/usr/lib/libGL.so.1’: File exists
root#

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
idontregister

Joined: 10 Oct 2017
Posts: 2

PostPosted: Tue 10 Oct 2017, 03:04    Post subject: Nothing Working Here
Subject description: pulse puppy followup (Solved my Ass)
 

Compiling and installing apulse does not solve problem. when run "apulse firefox" then youtube videos never load. If run "firefox" then same as before apulse.

pulseaudio always was installed from PPM but never did nothings for Firefox 52.

Also installed pulseaudio-4.0-tahr-i686.pet but only now I see:

:~] pulseaudio
bash: /usr/bin/pulseaudio: No such file or directory

Is anyone successful?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 9710
Location: Charleston S.C. USA

PostPosted: Tue 10 Oct 2017, 09:41    Post subject:  

Uninstall any PulseAudio you installed.
Should be able to uninstall using PPM (Puppy Package Manager)

Use this fix.
Make sure to get the correct bit version for the Puppy you are using.

Fix audio in Firefox 52 without having to install PulseAudio.
http://www.murga-linux.com/puppy/viewtopic.php?p=947398#947398

Here is the 32bit pet:
http://www.murga-linux.com/puppy/viewtopic.php?p=947398#947398

Here is the 64bit pet:
http://www.murga-linux.com/puppy/viewtopic.php?p=948558#948558

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [30 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0558s ][ Queries: 14 (0.0065s) ][ GZIP on ]