Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 12 Dec 2019, 00:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
pBluetooth 3.2 - the bluetooth manager
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [40 Posts]   Goto page: Previous 1, 2, 3
Author Message
did18

Joined: 19 Nov 2014
Posts: 417

PostPosted: Tue 13 Feb 2018, 13:06    Post subject:  

Hello mistfire

Would it be possible to modify pBluettoth so that the button "Bring device up (if down)" displays the real state of the device?
For example a green circle if the device is active.
Round orange if it's on standby.
Red circle if stopped.

Would it also be possible to display the signal strength as a percentage?
Thanks.

Have a nice day.

translated by deepl
Back to top
View user's profile Send private message 
Pro

Joined: 12 Feb 2010
Posts: 112

PostPosted: Mon 19 Feb 2018, 08:33    Post subject:  

Signal strength without realtime update - not needed for all. Realtime indication from script not implemented
Back to top
View user's profile Send private message 
reliant_turbo

Joined: 28 Nov 2017
Posts: 5

PostPosted: Tue 25 Dec 2018, 18:00    Post subject:  

i just installed this pet today and the required libraries and got this error.

bluetooth-agent: error while loading shared libraries: libdbus-1.so.3: wrong ELF class: ELFCLASS64

any ideas? im not quite done digging yet but wondered if anyone had this same issue here.

thanks

Brian
Back to top
View user's profile Send private message 
reliant_turbo

Joined: 28 Nov 2017
Posts: 5

PostPosted: Tue 25 Dec 2018, 19:22    Post subject:  

hmmmm loaded the 32 bit libraries and it seemed to take care of the first issue.

now i have this error when i try to pair:

Pairing...
Can't get default adapter
Method "DefaultAdapter" with signature "" on interface "org.bluez.Manager" doesn't exist

Done.

more fiddling.....

Brian
Back to top
View user's profile Send private message 
reliant_turbo

Joined: 28 Nov 2017
Posts: 5

PostPosted: Tue 25 Dec 2018, 19:51    Post subject:  

hmmmm. maybe i jumped the gun and didnt RTFM......

I installed the packages via the puppy package manager and they were newer revisions.

should i have stuck to the ones in the thread?

i think ill whip up a fresh usb and stick to the instructions to a T.

also, im using an ASUS BT211 usb dongle.

Brian
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 8021
Location: World_Hub

PostPosted: Wed 26 Dec 2018, 07:28    Post subject:  

Hello Brian >> <Content removed due to lack of interest....>
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1277
Location: PH

PostPosted: Thu 30 May 2019, 02:11    Post subject:  

New version of pbluetooth is released

It has a big improvements on detection management and it has now send file feature (highly experimental)

UPDATE: Sending file over bluetooth works. Requires obexftp
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1277
Location: PH

PostPosted: Thu 30 May 2019, 22:12    Post subject:  

Take note dependencies of this package was changed.
Back to top
View user's profile Send private message 
soniabu


Joined: 01 Feb 2018
Posts: 102
Location: Paris

PostPosted: Sat 19 Oct 2019, 07:56    Post subject:  

Hello to all.
As Reliant_turbo (msg up) I have the same error (img attach). My S.O. it's bionicpup64 and I've installed all these blurtooth products: bluez - bluez-tools - obexd - openobex - obexftp.
I also downloaded the 'Bluetooth-3.2.pet' taken from the first page of this topic.
The thing that happens is this:
if I send a photo from my desktop to my cell phone, everything works fine;
vice versa, it gives me an error of non-connection.
In addition - as you can see from following image - if from desktop I request the pairing it gives me an error.
Does anyone have any ideas?
txs Sonia

P.S. sorry for the big picture; otherwise the error message could not be seen.

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1277
Location: PH

PostPosted: Fri 08 Nov 2019, 05:49    Post subject:  

@soniabu as of now pBluetooth was 32-bit. I'm trying to make pbluetooth architecture free. Your puppy was 64-bit so you must install 32-bit compatiblity sfs modules
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [40 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0558s ][ Queries: 12 (0.0182s) ][ GZIP on ]