Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Oct 2017, 18:45
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Slacko5.7 eons2018A with WPA supplicant patch
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Author Message
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 07 Aug 2017, 22:03    Post subject: dont feel alone !
Subject description: rockstar theme stored in my suitcase.
 

hello 8Geee, pelo back again on your puppies, which i remember. That is something nice for you. There are many that pass and go away without leaving you any souvenir.
I must admit that I don't care of date of release of distros. On the contrary i should say as a french wine, the older are the best
mini-eee2.iso: 133 M this one is running in my isobooter pendrive. AH i like a lot the colours. I will pick up theme to decorate the sad Slacko born last years
Users now don't post a lot.. Linux students can work quiet. No questions posted by newbies about trouble. It looks like only linux people have troubles;.
I feel ad when our Puppy builders don't have any feed back, even from colleagues.
About my screenshot, these things are ubknown. Are they really useful.. I ignore.
Of course i install firefox 17.0.11 ESR, because a brower is the main application when you pay for a wireless connection.
About isobooter, it's really a nice tool to test fast several OS, even Ubuntu.. No longer use virtualbos. These 19k0 do as well, they do even better.
couleurs.jpg
 Description   Avidemux 2.5.5 included.
 Filesize   71.35 KB
 Viewed   347 Time(s)

couleurs.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Mon 07 Aug 2017, 23:23; edited 3 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 07 Aug 2017, 22:32    Post subject: Do businessmen buy eeepc.. ? that the question..
Subject description: http://www.lesnumeriques.com/ordinateur-portable/asus-eee-pc-1018p-p9495/test.html
 

Asus Eee Pc 1018p is for businessmen.. (french feed-back)
.
My IsoBooter (DOGs anre now smaller than Puppies, and however full featured.. Wake-up, Puppy builders !)
title mini-eee2
partnew (hd0,3) 0x00 (hd0,0)/mini-eee2.iso
map --heads=0 --sectors-per-track=0 (hd0,0)/mini-eee2.iso (0xff)
map --hook
root (0xff)
kernel /vmlinuz pmedia=cd psavemark=1 pfix=fsck
initrd /initrd.gz

title StretchDog32-2017-07-04
partnew (hd0,3) 0x00 (hd0,0)/StretchDog32-2017-07-04.iso
map --heads=0 --sectors-per-track=0 (hd0,0)/StretchDog32-2017-07-04.iso (0xff)
map --hook
root (0xff)
chainloader (0xff)

title TrunkPup540
partnew (hd0,3) 0x00 (hd0,0)/TrunkPup540.iso
map --heads=0 --sectors-per-track=0 (hd0,0)/TrunkPup540.iso (0xff)
map --hook
root (0xff)
kernel /vmlinuz pmedia=cd psavemark=1 pfix=fsck
initrd /initrd.gz
1018p.jpg
 Description   Asus Eee PC 1018P
 Filesize   43.69 KB
 Viewed   315 Time(s)

1018p.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Tue 08 Aug 2017, 12:21; edited 1 time in total
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 08 Aug 2017, 03:31    Post subject: openssl 1.0.2k, pcap, and tcpdump  

EONS 2017B iwith new updates to openssl 1.0.2k, pcap, and tcpdump. All of these have been needed. that cannot be translated. Wo do you speak 8Geee, to your colleagues puppy-builders ? they are busy, no time to spend on other babies than their own..
What does that means these strange words .What to update in my mini ?
My laptop is medion Akoya. no wieless at all available to move, indoor, and outdoor. Kernel 3.4.82 not listed by rcrsn51, for dongles
dommage. I have just bought a battery (expensive) to get outside..
unchained.jpg
 Description   iwlwifi obtained thanks to emergency kit at home
 Filesize   88.91 KB
 Viewed   311 Time(s)

unchained.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Thu 10 Aug 2017, 20:15    Post subject: curl update  

Recently there has been an update to curl 7.51 --> 7.55. There are security concerns in how the certificates are handled, and a few errors.

NOTE: if you get a "broken link" error in the Updates Package in Slacko 5.7, please
use this link. Answer "Yes" and the Puppy Package Manager will install the update. You may remove the /usr/doc files, and place the "curl7.55_files" in /root/.config into the built_in folder.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Sat 12 Aug 2017, 22:39    Post subject: YouTube Videos fix  

Recently I have noticed that YouTube has refused to play in all four spins.

There is a fix for this with a few quirks;
1.) Videos will not play in a new tab.
2.) Videos are not paused at start.
3.) The gear icon at lower right of video must be used to turn off
annotations and autoplay.

By pausing the Vid, the settings in item 3 can be changed. Then resume play.

To accomplish this;
1.) Disconnect from internet
2.) Open Firefox and click OK in "not connected" dialog.
3.) Click on TOOLS. Select Add-ons. Find YouTube ALL HTML5 2.1.3,
and Click on PREFERENCES.
a.) UNCHECK Disable SPF
b.) CHANGE Internet Explorer to API by clicking on the API option.

4.) Open a new tab using the "+" at top of page, and close the other tab.
5.) In the address bar type about:config and click OK
6.) In the search bar type media
7.) Scroll to media.mediasource.enabled and double-click to "TRUE"
8.) Close Firefox
9.) Goto MENU ---> SHUTDOWN and select "Restart Graphical Server"

Step 9. is needed in case FF hangs on closure (it does sometimes when
there are setting changes).

When you connect to the internet you can try the settings at YouTube.
The unsupported whine can be ignored using the "NO THANKS" button.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Sat 23 Sep 2017, 02:40    Post subject: eons2018 ready for D/L  

BASH has been tested and apparently fixed using version 4.1.17. So the EONS version is now "ready". On Page #1 Post #1 is the link. with new notes, and the sha1sums.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Sun 08 Oct 2017, 21:06    Post subject: 2 updates  

It figures as soon as the new general updates get U/L for use that two security updates from Uncle Slack are released.

The first one (was) is libxml2 (9/23/17). This does not have a CVE entry, but was discovered internally by Slackware. A symlink is needed after removing the older version. The DOC files can be removed and the .packages file in root can be moved to builtin_files with removal of the most recent version.
----------------------------------------------------
The second is curl7.56 This one has CVE entries and the write up suggests that this one be done.

"Due to a flaw in the string parser for the directory name, a directory name passed without a closing double quote would lead to libcurl not adding a trailing NUL byte to the buffer holding the name. When libcurl would then later access the string, it could read beyond the allocated heap buffer and crash or wrongly access data beyond the buffer, thinking it was part of the path."

As with the first update a symlink is needed, and the .packages file moved. Folks that are directly using CURL might want to keep the DOC files.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Wed 11 Oct 2017, 20:05    Post subject: Firefox27 bug/typo  

The August 2017 version of the FF27 thats installed has a bug/typo in about:config and its an important one...

Change the "4" value in security.tls.version.max to a "3" w/o quotes. It appears that the 4 value DOES NOT imply TLS1.3, but rather recycles to a ZERO setting allowing TLS 1.0 (not secure). And it appears in Edit --> Preferences I left the popup blocker on... thats a nuissance here, and elsewhere when internally re-directing to another page.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Wed 18 Oct 2017, 23:15    Post subject: wpa_supplicant  

A very important update for wi-fi users... Slackware has published the wpa_supplicant update to mitigate "KRACK" vunerabilities. Its about as mandatory as possible, since this is a global failure of wpa_supplicant.

Note that MENU --> Setup --> Updates from Slackware MUST show version 2.6

If it does not, goto MENU --> System --> Puppy Package Manager and click on the crossed wrench

Make sure only these boxes are checked

puppy-slacko-official
Slackware-14.0-official
Slackware-14.0-patches
Option: Slackware-14.0-salix (European)

When set close both the Wrench window and PPM window.
Reopen the PPM and the wrench window and click on UPDATE NOW
Press enter for all options
When done: close both windows

Now you will have the latest updates available from Uncle Slacky, and can D/L the patch for wpa_supplicant.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Fri 20 Oct 2017, 00:26    Post subject:  

Folks that are still using the elder "mini-eee" version can use the updates posted here for EONS. This particular wifi security update should be applied. And BTW, after accomplishing the update, its a good time to remaster considering BASH (use slacko 13.37 version! ) and WPA2 are fixed.

Carry on
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1217
Location: N.E. USA

PostPosted: Yesterday, at 13:56    Post subject: EONS 2018A
Subject description: patched for WPA supplicant
 

I have decided to release an "A" revision of EONS 2018 due to the severity of the WPA_supplicant security concerns. Please see the 1st Post on 1st Page.

Regards
8Geee

_________________
Linux user #498913
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0518s ][ Queries: 14 (0.0080s) ][ GZIP on ]