Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Jul 2017, 18:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
libcurl-gnutls.so.4 to run Netsurf 3.0
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Wed 08 Feb 2017, 11:04    Post subject:  libcurl-gnutls.so.4 to run Netsurf 3.0
Subject description: Running Netsurf in 412 lite
 

I'm trying to run netsurf_lucid-3.0.pet in 412 lite. It shows libcurl-gnutls.so.4 as a missing dependency. I have tried to find this but have had no luck. Could some more knowledgable person point me in the right direction as to where I can get this file. If not does anybody know off a version of Netsurf(3.0 or greater) that would work in 412 lite without this file.

Regards,

Ken.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1457
Location: lincoln, uk

PostPosted: Wed 08 Feb 2017, 12:03    Post subject:  

this version comes from the '412collection'

https://sourceforge.net/projects/old412forever/files/Internet/netsurf-2.6.tar.gz/download

hth

Smile
Back to top
View user's profile Send private message Visit poster's website 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Wed 08 Feb 2017, 14:05    Post subject:  

Hello Ally,
Thanks for the reply. I've tried the version you linked to but have found it a bit prone to crashing. I thought a later version might be a bit more stable. As the one I'm trying to use is a lucid pet I tried looking for the file in the latest lucid using pfind. I was surprised not to find it.

Regards,

Ken.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1457
Location: lincoln, uk

PostPosted: Wed 08 Feb 2017, 14:11    Post subject:  

the following is from my libs repo on the archive

no idea if it will be correct:

http://archive.org/download/Puppy_Linux_Skami_Lib_Repo/libcurl-3.0.0.tar.gz

Smile
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks


Joined: 05 Feb 2012
Posts: 1549
Location: London, England

PostPosted: Wed 08 Feb 2017, 14:44    Post subject:  

Well libcurl-gnutls.so.4 is part of the curl package. You could probably compile it from source. It may be that you would need to have gnutls already installed at build time, not sure.

However I wouldn't expect a Netsurf compiled in Lucid to run in Puppy 412 anyway. Even if you install that library I reckon others in 412 would be too old.

Latest Netsurf release is 3.6 and I tried compiling it in several Puppies. In Wheezy or anything later it is fine, but in Lucid and Wary although it builds to completion it looks a bit odd when you run it. The letters in web pages are squashed against each other. Not sure if this is because of the older glib version or something else. Anyway the point is that with older Puppies you will probably only be able to use older versions of Netsurf and experimenting with this could prove time-consuming.

_________________
Oscar in England

Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Wed 08 Feb 2017, 16:05    Post subject:  

@Ally
Thanks for the link. I'll download and try it and report how I get on.

@OscarTalks
Yes I take your point about only being able to run older versions of netsurf on 412 but the one on the 412 site (I think it's 2.6) is a bit flaky. I'm trying to get a small fast browser that works. Netsurf did look quite promising. I also use qtweb but it too has it's problems. I'll try Ally's link and see if I can get somewhere with that.
Thanks for the help.

Ken.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Wed 08 Feb 2017, 17:51    Post subject:  

http://archive.org/download/Puppy_Linux_Skami_Lib_Repo/libcurl-3.0.0.tar.gz

I downloaded and extracted the above but the file I'm looking for is not there. I'm not sure if I should expect it to be there.
I downloaded netsurf-gtk_3.2+dsfg-3.deb and installed it in the recently updated lucid 5287 s2, which I also use, to see if it would work in lucid. It is missing the following libraries, libmozjs185.so.1.0 and libpng16.so.16 and so I seem to be in a similar position as I am with 412. I don't know where to go from here.

Ken.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1457
Location: lincoln, uk

PostPosted: Wed 08 Feb 2017, 19:31    Post subject:  

what about dillo?

Smile
Back to top
View user's profile Send private message Visit poster's website 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Thu 09 Feb 2017, 10:08    Post subject:  

@Ally
Quote:
what about dillo?


I've tried it in the past. Very fast but a bit awkward to use. I've found why I've had some problems with netsurf 2.6 which does run on 412. I could not find a way of bookmarking a site or bringing up a bookmarks list. I've found you have to customize the toolbar. This is hampered by the fact that the theme that comes with it does not contain icons for bookmarking or bookmarks list so can't be shown on the toolbar. I have tried downloading other themes but these are for higher versions of netsurf and do not appear to install. I will do a bit more fiddling in the hope I can get round this.

Ken.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0368s ][ Queries: 13 (0.0064s) ][ GZIP on ]