Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Sep 2017, 09:52
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
exfat [RESOLU]
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 4 [58 Posts]   Goto page: 1, 2, 3, 4 Next
Author Message
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Fri 23 Dec 2016, 07:12    Post subject:  exfat [RESOLU]  

Bonjour,
J'ai installé tahrpup chez un ami il y a plusieurs mois et il vient de me laisser son portable car impossible de lire sa nouvelle clé usb3 lexar 64Go. Et effectivement elle commence à clignoter puis plus rien. J'ai testé sur d'autres portables de la maison et même comportement sous tahrpup comme raring par exemple.
Par contre le portable de madame qui a un an est en dual boot avec cubuntu (basé sur tahr) et là ça fonctionne : sous tahrpup ça ne fonctionne pas.
J'ai récupéré au boulot un disque externe usb3 Lacie de 500Go et un autre usb3 lacie également mais de 1To : celui de 500Go se comporte comme la clé alors que celui de 1To fonctionne parfaitement ! Celui de 500Go a un câble usb très gros alors que celui du 1To est beaucoup moins gros : de là à penser que puppy a un problème de gestion de l'alimentation des prises usb....
Est-ce que vous avez remarqué ce genre de dysfonctionnement chez vous ?
Une solution ?
Joyeux Noël,
Philippe

Last edited by augras on Sat 07 Jan 2017, 09:22; edited 2 times in total
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Fri 23 Dec 2016, 08:04    Post subject:  

En complément d'info le contenu du fichier /var/log/messages
Code:
Dec 24 11:01:18 puppypc28639 user.info kernel: usb 1-1.2: new high-speed USB device number 5 using ehci-pci
Dec 24 11:01:18 puppypc28639 user.info kernel: usb-storage 1-1.2:1.0: USB Mass Storage device detected
Dec 24 11:01:18 puppypc28639 user.info kernel: scsi6 : usb-storage 1-1.2:1.0
Dec 23 13:01:18 puppypc28639 user.info mtp-probe: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2"
Dec 23 13:01:18 puppypc28639 user.info mtp-probe: bus: 1, device: 5 was not an MTP device
Dec 24 11:01:19 puppypc28639 user.notice kernel: scsi 6:0:0:0: Direct-Access     Lexar    USB Flash Drive  1100 PQ: 0 ANSI: 6
Dec 24 11:01:19 puppypc28639 user.notice kernel: sd 6:0:0:0: [sdb] 125038592 512-byte logical blocks: (64.0 GB/59.6 GiB)
Dec 24 11:01:19 puppypc28639 user.notice kernel: sd 6:0:0:0: [sdb] Write Protect is off
Dec 24 11:01:19 puppypc28639 user.debug kernel: sd 6:0:0:0: [sdb] Mode Sense: 43 00 00 00
Dec 24 11:01:19 puppypc28639 user.notice kernel: sd 6:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Dec 24 11:01:19 puppypc28639 user.info kernel:  sdb: sdb1
Dec 24 11:01:19 puppypc28639 user.notice kernel: sd 6:0:0:0: [sdb] Attached SCSI removable disk

La clé est donc bien détectée mais rien ne se passe et Pmount ne la voit pas !
Philippe
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12505
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 29 Dec 2016, 05:05    Post subject: As-tu essayée de la brancher sous Windows avant ?
Subject description: Quant à la grosseur du câble, je n'en sais rien
 

As-tu essayée de la brancher sous Windows avant ? Windows installe le pilote et ensuite Puppy la lit. C'est fréquent avec des marques de super-marché. Mais jusqu'apresent je n'ai pas eu de soucis (j'en ai deux 3.0).
Les 2.0 vont très bien. et sont même plus rapides.
Tout dépend de la taille, 4GB sont plus rapides à lire que 32 ou 64 ou les 350 GB d'un disque dur).
Quant à la grosseur du câble, je n'en sais rien. Si les autres OS la font fonctionner, puppy devrait y arriver aussi.
Pour la petite histoire j'ai une souris achetée chez carrefour que je n'ai jamais réussi à utiliser, ni sous Windows, ni sous Puppy. Désormais je prfère tourner avec du matériel listé dans le forum, même si ce n'est pas du juste sorti.
Tests USB vitesse
Desactiver le secure Boot ?
Avec une Puppy 32 bits, il faut ajouter exfat-fuse exfat-utils pour utilier une clé 64 bits
lexar64.jpeg
 Description   exFAT = EXT64 Clé Lexar 64 bits
 Filesize   5.27 KB
 Viewed   77 Time(s)

lexar64.jpeg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Sun 01 Jan 2017, 10:28; edited 4 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Thu 29 Dec 2016, 05:55    Post subject:  

Bonjour Pelo,
Merci d'avoir regardé.
Peu de choses à se mettre sous la dent puisque apparemment il s'agit d'un problème plutôt ancien de pilote, rapidement résolu. Et effectivement sous une kubuntu basée sur tahrpup ça fonctionne... mais sous tahrpup sur le même portable en dualboot et bien ça ne fonctionne pas.
Pas de windows à la maison mais le copain m'a indiqué que ça clé fonctionnait très bien sous windows.
C'est comme si la cure d'amaigrissement que subisse les puppies était un peu trop forte !
Comme on le voit dans le fichier messages la clé est parfaitement détectée... sauf qu'elle n'est pas gérée, et même chose avec mon disque de 500Go alors que les deux 1 To fonctionnent parfaitement : je suppose qu'ils n'utilisent pas le même pilote.
L'usb3 est géré sous linux depuis longtemps et même avant que windows ne le fasse.
Je suis sous le noyau 3.14.56, celui d'origine de tahrpup, et il est bien possible qu'avec un noyau plus récent ce problème d'usb3 n'existe pas.
Mais je n'ai jamais joué à changer de noyau.
Pour aller dans ce sens il me faudrait une puppy avec un noyau relativement récent : si ça fonctionne, possible que la solution soit là.
Philippe
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 2976
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 29 Dec 2016, 06:50    Post subject:  

Bonjour,
Quote:
Pour aller dans ce sens il me faudrait une puppy avec un noyau relativement récent : si ça fonctionne, possible que la solution soit là.

As-tu essayé Arrow Xenialpup CE 7.0.4 (kernel 4.1.31)?

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Thu 29 Dec 2016, 07:07    Post subject:  

Merci Argolance.
C'est ce que j'avais trouvé comme solution : à tester sur l'ordi avec kubuntu et tahrpup. Les autres ne vont pas la digérer !
Retour quand j'aurai testé.
Philippe
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12505
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 29 Dec 2016, 09:06    Post subject: Je suis tes essais avec intérêt  

Mouais, xenialpup a de gros soucis, entre autres avec les kernels. Je serais toi j'essaierai LxPupXenial-16.05.1-pae.iso: 282 M (branche LXpup) et une Slacko.
Qu'as-tu comme systeme de boot ? essais un Grub4Dos depuis un de tes ordis tournant sur une Puppy..
Je parierais que le souci vient du systeme de boot et pas des pilotes.
Je suis tes essais avec intérêt.

Exclamation Je vais éviter d'acheter des clés USB 3.0 jusqu'à nouvel ordre..

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Thu 29 Dec 2016, 10:44    Post subject:  

Test négatif sur xenialpup !
Par contre il y a du nouveau sous tahrpup : j'ai laissé mon disque de 500Go connecté et après redémarrage il est correctement géré ! Toujours rien pour la clé de 64 Go.
Dans les logs on a pour le disque correctement géré :
Code:
Dec 30 11:22:47 puppypc28639 user.info kernel: usb 2-1.2: new high-speed USB device number 3 using ehci-pci
Dec 30 11:22:47 puppypc28639 user.info kernel: usb-storage 2-1.2:1.0: USB Mass Storage device detected
Dec 30 11:22:47 puppypc28639 user.info kernel: scsi8 : usb-storage 2-1.2:1.0
Dec 30 11:22:47 puppypc28639 user.notice kernel: scsi 8:0:0:0: Direct-Access     ST950032 5AS              0002 PQ: 0 ANSI: 5
Dec 30 11:22:47 puppypc28639 user.notice kernel: sd 8:0:0:0: [sdd] 976773168 512-byte logical blocks: (500 GB/465 GiB)
Dec 30 11:22:47 puppypc28639 user.notice kernel: sd 8:0:0:0: [sdd] Write Protect is off
Dec 30 11:22:47 puppypc28639 user.debug kernel: sd 8:0:0:0: [sdd] Mode Sense: 23 00 00 00
Dec 30 11:22:47 puppypc28639 user.err kernel: sd 8:0:0:0: [sdd] No Caching mode page found
Dec 30 11:22:47 puppypc28639 user.err kernel: sd 8:0:0:0: [sdd] Assuming drive cache: write through
Dec 30 11:22:47 puppypc28639 user.err kernel: sd 8:0:0:0: [sdd] No Caching mode page found
Dec 30 11:22:47 puppypc28639 user.err kernel: sd 8:0:0:0: [sdd] Assuming drive cache: write through
Dec 30 11:22:47 puppypc28639 user.info kernel:  sdd: sdd1 sdd2
Dec 30 11:22:47 puppypc28639 user.err kernel: sd 8:0:0:0: [sdd] No Caching mode page found
Dec 30 11:22:47 puppypc28639 user.err kernel: sd 8:0:0:0: [sdd] Assuming drive cache: write through
Dec 30 11:22:47 puppypc28639 user.notice kernel: sd 8:0:0:0: [sdd] Attached SCSI disk

Je reviens mettre le code quand il n'est pas correctement géré pour comparer.

EDIT : code dans /var/log/messages quand non géré
Code:
Dec 30 13:48:00 puppypc28639 user.info kernel: usb 2-1.2: new high-speed USB device number 3 using ehci-pci
Dec 30 13:48:00 puppypc28639 user.info kernel: usb-storage 2-1.2:1.0: USB Mass Storage device detected
Dec 30 13:48:00 puppypc28639 user.info kernel: scsi6 : usb-storage 2-1.2:1.0
Dec 29 15:48:00 puppypc28639 user.info mtp-probe: checking bus 2, device 3: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2"
Dec 29 15:48:00 puppypc28639 user.info mtp-probe: bus: 2, device: 3 was not an MTP device
Dec 30 13:48:22 puppypc28639 user.info kernel: usb 2-1.2: reset high-speed USB device number 3 using ehci-pci


Voilà pour les données.
Concernant la clé elle est flash, contrairement au disque dur : ça a peut-être une importance.

Tous mes pc utilisent grub, dont un grub2 : aucun ne boot avec grub4dos. Il me semble avoir une clé qui utilise grub4dos. Mais je ne vois pas comment le système de boot pourrait rentrer en ligne de compte.
Philippe
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12505
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 29 Dec 2016, 12:19    Post subject:  

Voir pour booter des Puppies
Quand on a des OS différents sur la même clé, Puppy marié avec des grosses Linux, çà devient plus difficile. Ubuntu ayant les consignes de boot à un endroit différent de Opensuze ou Debian par exemple.
Il faut rectifier manuellement le menu.lst.
Si tu as Kubuntu à côté de Puppy, les deux ne sont pas structurés pareil; il faut mettre manuellement l'adresse du boot manager initrd.lz, gz ou ressemblant
Je reviens, avec la synthaxe exacte.. Ce qui est sûr, il faut que tu déballes la Puppy dans un repertoire spécifique.
Dual boot avec Antix

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Thu 29 Dec 2016, 13:07; edited 1 time in total
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 12505
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 29 Dec 2016, 12:45    Post subject:  

le gallois Mike Walsh dit de booter sa clé 3.0 sur un port 2.0, sur les vieux ordis , look his topic
Lui aussi n'arrivais pas à booter ses Puppy sur sa clé USB 3.0. Il l'a changé de trou (de port), et sa Puppy a démarré. (translation rapide)

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Mdor


Joined: 24 Jul 2010
Posts: 1660
Location: France

PostPosted: Thu 29 Dec 2016, 12:55    Post subject:  

Infos utiles sur l'usb3 et la connectique ici
Quote:
Les distributions GNU/Linux au noyau 2.6.31 supportent nativement les contrôleurs USB 3.0 xHCI.


Voir aussi les commandes : lsusb / lsusb -t et lsmod ...


Cordialement,
Médor..

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Thu 29 Dec 2016, 13:15    Post subject:  

Testé sur fatdog64710 et slacko632 : ça fonctionne sur fatdog mais pas sur slacko.
Je fais toutes mes installation à la main en modifiant le menu.lst en conséquence : beaucoup plus rapide et plus sûr quant aux erreurs possibles.
Je n'ai pas de ports usb3 sauf sur un seul pc, celui avec kubuntu et tahrpup, et donc je branche sur de l'usb2 et j'ai testé différents ports.
C'est tout de même fort qu'en démarrant la machine avec le disque branché ça fonctionne, mais alors impossible de retirer le disque car il faut redémarrer pour qu'il soit à nouveau géré, et que ça ne fonctionne pas pendant la session ! Pour la clé ça ne fonctionne pas du tout, au moins c'est logique.
Les commandes :
Code:
root# lsusb
Bus 002 Device 003: ID 059f:1051 LaCie, Ltd
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 046d:c05b Logitech, Inc. M-U0004 810-001317 [B110 Optical USB Mouse]
Bus 001 Device 004: ID 17ef:1005 Lenovo
Bus 001 Device 003: ID 05dc:a838 Lexar Media, Inc.
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code:
root# lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 5: Dev 4, If 0, Class=Hub, Driver=hub/4p, 480M
            |__ Port 1: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M

Code:
root# lsmod
Module                  Size  Used by
fan                     1496  0
joydev                  5936  0
snd_hda_codec_hdmi     23845  1
snd_hda_codec_conexant    24340  1
snd_hda_codec_generic    28868  1 snd_hda_codec_conexant
psmouse                56825  0
snd_pcsp                4241  0
rtl8192se              41528  0
rtl_pci                10360  1 rtl8192se
rtlwifi                29460  2 rtl_pci,rtl8192se
mac80211              181284  3 rtl_pci,rtlwifi,rtl8192se
cfg80211              133384  2 mac80211,rtlwifi
intel_ips               7297  0
i2c_i801                6904  0
snd_hda_intel          22516  1
snd_hda_codec          45380  4 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_intel
snd_pcm_oss            24016  0
snd_mixer_oss           8668  1 snd_pcm_oss
snd_pcm                45956  5 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_pcsp
snd_seq_dummy            605  0
lpc_ich                11052  0
snd_seq_oss            15932  0
snd_seq_midi            2864  0
snd_seq_midi_event      2760  2 snd_seq_oss,snd_seq_midi
snd_rawmidi            10304  1 snd_seq_midi
snd_seq                26592  6 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy,snd_seq_midi
snd_seq_device          2924  5 snd_seq,snd_rawmidi,snd_seq_oss,snd_seq_dummy,snd_seq_midi
snd_timer              10302  2 snd_pcm,snd_seq
snd                    29832  16 snd_pcm_oss,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_oss,snd_seq_device,snd_mixer_oss,snd_pcsp
i915                  491840  7
e1000e                124404  0
drm_kms_helper         23752  1 i915
ptp                     4692  1 e1000e
pps_core                3976  1 ptp
drm                   145780  3 i915,drm_kms_helper
i2c_algo_bit            3456  1 i915
intel_agp               7072  0
intel_gtt               7248  3 i915,intel_agp
wmi                     5142  0
battery                 8568  0
video                   8814  1 i915
thinkpad_acpi          36924  1
nvram                   3366  1 thinkpad_acpi
acpi_cpufreq            4360  1
rfkill                  5402  2 cfg80211,thinkpad_acpi
ac                      2848  0
hwmon                   1328  1 thinkpad_acpi

Le disque est le LaCie et la clé la Lexar.
Philippe
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12505
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 29 Dec 2016, 14:18    Post subject: Ta clé usb est bootable, évidemment  

çà fonctionne avec Fatdog64.... Twisted Evil
Ta clé usb est bootable, évidemment ??? Pourquoi ne veut-tu pas lancer un Grub4Dos dessus. Tu ne risques rien..FATDOG a bien grub4Dos dans son menu...

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Thu 29 Dec 2016, 14:34    Post subject:  

La clé n'est pas bootable, le disque dur est bootable et utilise grub4dos : c'est à partir du disque dur que j'ai testé fatdog et slacko... en complétant à la main le menu.lst.
philippe
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12505
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 29 Dec 2016, 14:41    Post subject:  

Ben copies tes repertoires Puppy sur ta clé et lance le grub4dos. il mettra le boot et çà roule.. Normalement. Sinon il faut voir si le BIOS a bien les clés USB prévues dans son sommaire.. Mais çà tu le sais, non ?
Mon menu list actuel
# menu.lst produced by grub4dosconfig-v1.9.2
#color #blue/cyan yellow/blue white/black cyan/black
gfxmenu /gfxfile
default 0
timeout 10

# Frugal installed Puppy

title Puppy jessie 6.4.1 (sdb1/Jessie)
find --set-root --ignore-floppies --ignore-cd /Jessie/initrd.gz
kernel /Jessie/vmlinuz psubdir=Jessie pmedia=usbflash pfix=fsck
initrd /Jessie/initrd.gz

title Zdrv slaxen 6.3.2 (sdb1/SlaxenHiv)
find --set-root --ignore-floppies --ignore-cd /SlaxenHiv/initrd.gz
kernel /SlaxenHiv/vmlinuz psubdir=SlaxenHiv pmedia=usbflash pfix=fsck
initrd /SlaxenHiv/initrd.gz

title Puppy slacko 5.3.3 (sdb1/trunkpup)
find --set-root --ignore-floppies --ignore-cd /trunkpup/initrd.gz
kernel /trunkpup/vmlinuz psubdir=trunkpup pmedia=usbflash pfix=fsck
initrd /trunkpup/initrd.gz

title Zdrv xenial 7.0.1 (sdb1/XeniaLXpup)
find --set-root --ignore-floppies --ignore-cd /XeniaLXpup/initrd.gz
kernel /XeniaLXpup/vmlinuz psubdir=XeniaLXpup pmedia=usbflash pfix=fsck
initrd /XeniaLXpup/initrd.gz

title Puppy jessie 6.4.1 (sdb1/Jessie) Safe mode (without X)\nTry 'xorgwizard' after bootup succeed to start graphic mode.
find --set-root --ignore-floppies --ignore-cd /Jessie/initrd.gz
kernel /Jessie/vmlinuz psubdir=Jessie pfix=ram,nox nosmp noapic i915.modeset=0 radeon.modeset=0 nouveau.modeset=0
initrd /Jessie/initrd.gz

title Puppy jessie 6.4.1 (sdb1/Jessie) RAM mode\nBoot up Puppy without pupsave
find --set-root --ignore-floppies --ignore-cd /Jessie/initrd.gz
kernel /Jessie/vmlinuz psubdir=Jessie pfix=ram
initrd /Jessie/initrd.gz

# Windows

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 4 [58 Posts]   Goto page: 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0654s ][ Queries: 12 (0.0039s) ][ GZIP on ]