Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 12 Dec 2017, 23:57
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
DLNA Quirky Xerus64 Pup V2 - released 3rd July 2017
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 4 [47 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Wed 06 Jul 2016, 15:51    Post subject:  

Both, former and secondary downloads img checksums "checkout" in ALL cases. Maybe a platform problem or an environmental problem during the boot subsystem processing. It is repeatable no matter which, 1st or 2nd IMGs I use. Upon desktop arrival, root system is "locked" in RO mode.
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Thu 07 Jul 2016, 12:11    Post subject: DLNA Quirky Xerus64 Pup V1 - released 2nd July 2016
Subject description: Testing
 

Hi gc,

In view of the problems that you have experienced I have amended the installation instructions
in the OP to reflect the advice given in my last post. This will avoid problems that can arise with
GPT partition tables when a stick larger than 8GB is targeted which has previously had a GPT layout.
In any future issues I will be reverting to an MSDOS partition system. Smile

_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Sun 10 Jul 2016, 04:47    Post subject: DLNA Quirky Xerus64 Pup V1 - released 2nd July 2016
Subject description: Alternate image of V1
 

Please find below an alternative image of this Pup. There are no changes to the Pup itself but
the GPT two partition layout in the 8GB image has been changed in favour of a 3 partition MSDOS partition layout.
The 2 test videos are now on the 2nd partition.

Where to obtain the revised image: (dlnaxerus64v1msdos.img.xz [982 MB] & md5sums & additional screenshots)

https://drive.google.com/folderview?id=0B_iVVJCd9q09Z1NILUR3TUZobDg&usp=sharing

If writing the image to a stick larger than 8GB, you may if you wish, use GParted to create a 4th partition in the unallocated space.

Installation:

Using an 8GB USB2/3 stick:

An 8GB stick may be used if and only if its true capacity is not a single byte less than 8002732032 bytes.
To test the true capacity of any 8GB stick that you possess use the following command substituting the drive letter for x

Code:
# fdisk -l /dev/sdx


If it does not meet this requirement you must use a larger stick.
You may opt to use a larger stick at the outset if you intend to create a media repository partition in the free unallocated space.

1. Commence by returning the stick to its "as new" state before targeting it with the image.

In Linux use GParted to do that:

A. Click on “device” then select “Create Partition Table” (MSDOS)

B. Then create a single fat32 partition spanning the whole stick accepting all other defaults.

(Do not set any flags or change anything else)

2. Extract the xz compressed image with UExtract first making sure that you have enough free space as it will expand to 8 GB.
The UExtract pet can be found here:

http://www.murga-linux.com/puppy/viewtopic.php?t=87864

3. Then use the following command in a terminal to place the extracted image on the unmounted stick:
(This may take up to 30 minutes with just a flashing cursor as feedback until it finishes)

Code:
dd bs=4M if=/root/Downloads/dlnaxerus64v1msdos.img of=/dev/sdx && sync


If the stick is seen as sdb1 you would target the device /dev/sdb
Anything on it will be wiped. Do not target a partition number.

_________________
Regards ETP



Kennels

Last edited by ETP on Wed 12 Oct 2016, 12:45; edited 2 times in total
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Thu 14 Jul 2016, 23:01    Post subject:  

I cannot seem to get sound working. It appears to turned off and nothing I do via Taskbar's Sound "Full Window" activates audio.

Ideas.
capture18429.png
 Description   Message when trying to play a music file
 Filesize   11 KB
 Viewed   414 Time(s)

capture18429.png


_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 168

PostPosted: Fri 15 Jul 2016, 02:40    Post subject: Wanna try it, but...  

Morning:

I'm really interested about this puPPy, but I need a easier distro for newbies, so .....


PLEASE... can you try to make a really easy to install distro using an .iso to install it using the most traditional method (that is using UnetBooting)??

THANKS

_________________
I am using puPPy_Tahr_Linux 6.0.2 (modified / amazing!) Arrow

https://pp4mnkpuppyblog.wordpress.com/

(feel free to contribute)
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Fri 15 Jul 2016, 05:44    Post subject: Alternate image of V1  

@gc

I am assuming that you do not have sound from any app not just VLC.

Could you please pm screenshots of both Alsamixer and the "Retrovol full window" together with the output of:
Code:
aplay -L


@pp4mnklinux

Sorry but this will only be offered as a full install to USB with the possibility of then transferring it to
HD/SSD with a boot from the USB stick or by modifying any existing boot loader.

An ISO approach using BarryK's XERUS ISO results in high memory usage which would preclude older 64-bit hardware
which typically only contained 1GB of RAM. Quirky is also so different from current mainstream Pups that any such
build would not install with UNetbootin. You are I am afraid, stuck with the 3 STEP install procedure detailed above.

_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Fri 15 Jul 2016, 13:57    Post subject:  

Per request
Alsa and Retro are both set, yet no sound as seen in the desktop pic below.
Retrovol pic
Alsamixer pic
Desktop taskbar pic

ETP wrote:
I am assuming that you do not have sound from any app not just VLC.
Funny, I have video+audio via Youtube in a browser??? But, apps built-in the system do not have audio.

Hope this yields clues.
APLAY.lst.gz
Description  FAKE ".gz"
gz

 Download 
Filename  APLAY.lst.gz 
Filesize  1.93 KB 
Downloaded  56 Time(s) 

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Fri 15 Jul 2016, 15:56    Post subject:  

Hi gc,

Thanks for the screenshots & aplay -L output. They show a peculiar mix of settings. It is not clear whether you are trying to output
analogue to a single set/surround sound set of speakers or a signal over HDMI to a monitor equipped with inbuilt
speakers.

I suggest that you run the "Multiple Sound Card Wizard" off the setup menu.

Use YouTube for testing rather than vlc. Leave vlc setup (Tools/preferences/Audio) until you have working sound with YouTube.

Your shot of Alsamixer shows that you have HDA Nvidia card selected but your shot of Retrovol shows a surround sound speaker setup
but with no option to engage PCM in Alsamixer.

Having run the MSC Wizard reboot and check again all settings including the Retrovol Config Hardware Tab which may need setting to match
what you selected in the MSC Wizard. (eg hw:0 or hw:1 or hw2 etc)

If still no joy there is one last resort sound wizard .... Setup/Wizard Wizard/Setup ALSA sound/ (item 4 on the menu)

Once you hopefully have sound then go back to VLC and set the output module to ALSA audio output. The device may be set to default or the
exact device you wish to use.

_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Fri 15 Jul 2016, 16:29    Post subject:  

You might have missed as my post could be confusing. Youtube audio is working from Firefox browser. (will test Seamonkey+Chrome, although I cannot see why they would not work).

Its the attempts to get sound in other built-in desktop tools. There is ONLY 1 motherboard sound adapter and 1 video camera connected to a PC VGA monitor.

I just tried the sound wizard's 2nd box and find that "bark-bark" is working. So something is working although other apps are not.

Maybe time to reboot or to start over on this gpt version on my USB Lexar stick
Sound Adapter seen in Wizard.png
 Description   Step 3 of Wizard
 Filesize   22.22 KB
 Viewed   342 Time(s)

Sound Adapter seen in Wizard.png


Last edited by gcmartin on Fri 15 Jul 2016, 17:11; edited 2 times in total
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Fri 15 Jul 2016, 16:52    Post subject:  

Hi gc,

I do appreciate now that you have some sound but those screen shots do not match up. If you intend to start over there is
nothing to lose by trying the 1st wizard which will force a reconstruction of the Alsa configuration even if only one card shows up.

It can be surprising as to how many things are perceived as sound cards. What speakers is the working sound comming out of and how
are they connected?

_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Fri 15 Jul 2016, 20:39    Post subject:  

Starting from scratch: Reburn the USB Lexar 16GB stick. Upon desktop arrival open a terminal to view mounts and whether IP has been gathered.Upon arrival at desktop
Code:
# mount
/dev/root on / type f2fs (rw,relatime,background_gc=off,user_xattr,inline_data,extent_cache,active_logs=6)
devtmpfs on /dev type devtmpfs (rw,relatime,size=2411472k,nr_inodes=602868,mode=755)
none on /proc type proc (rw,relatime)
none on /dev/pts type devpts (rw,relatime,gid=2,mode=620)
none on /sys type sysfs (rw,relatime)
shmfs on /dev/shm type tmpfs (rw,relatime,size=1200732k)
tmpfs on /tmp type tmpfs (rw,relatime,size=2401460k)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sde1 on /mnt/pool type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:39:a1:ee:6d:7d brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.20/24 brd 192.168.1.255 scope global eth0
       valid_lft forever preferred_lft forever
#


My Desktop is missing the sound icon. <=== Click

Observations
Some of my apps work have sound: eg pmusic, browsers youtube, bark-bark in wizard. Seem VLC has a problem. AND xine when clicked from the Menu>Multimedia will ghost a window to the desktop and disappear.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Sat 16 Jul 2016, 03:26    Post subject:  

Good Morning gc,

Both the mount output and the desktop look fine with the new burn/write. If you right click the space containing the
invisible speaker icon you should be able to get to the Retrovol settings. The missing switch beneath PCM in your original shot of
Alsamixer troubles me as it needs to exist and be turned on. If in "Retrovol-Configuration" the Sound card is showing as hw:0 try editing it
to hw:1
Then click on apply, reboot and take a further look at both Alsamixer & the Retrovol Full Window.

If right clicking the invisible icon does not give you access to Retrovol you can launch the full window from the terminal (retrovol)
then click on "File" at the top of the window to access the config.
image-6.png
 Description   
 Filesize   51 KB
 Viewed   320 Time(s)

image-6.png


_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Sat 16 Jul 2016, 03:36    Post subject:  

Xine Problem
Code:
# xine
This is xine (X11 gui) - a free video player v0.99.9.
(c) 2000-2014 The xine Team.
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  150 (XVideo)
  Minor opcode of failed request:  17 ()
  Serial number of failed request:  2262
  Current serial number in output stream:  2262

#
.
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1031
Location: UK

PostPosted: Sat 16 Jul 2016, 04:17    Post subject: re: xine  

Hi gc,

I suspect that the sound issue may be impacting on xine as it has given me no trouble.
In any event the correct command to launch it from a terminal is not xine but xinewrapper which is
referenced in the .desktop file.
(Either may work depending on your hardware. Both may fail if the cause is the sound issue)

EDIT:

I have just found an interesting thread on much the same issue here:

www.murga-linux.com/puppy/viewtopic.php?t=106606&sid=eceed3d4a9eeb3b61bdee75d075cd945

The outcome was inconclusive but the issue seems to effect both WoofQ & WoofCE pups. There is mention
of attempts to fix the issue in WoofCE. BarryK does not as a rule attempt to fix what is not broken and
I wonder whether later kernels are the common factor or the later versions of Alsa. If for example a HDMI
output is present is an assumption being made that it will be used even when there is nothing plugged into it?
That may also explain the xv video error thrown by xine.

You mentioned above that you are using a VGA monitor but I assume that you have a vacant HDMI output socket on the PC.
If all else fails you may wish to test this wild theory by connecting up a HDMI monitor instead of the vga.

_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Sun 17 Jul 2016, 20:52    Post subject:  

This is an update to what is occurring. I have several 64bit desktops. The problem I have reported is on the AMD-X2. Its behavior is contrast with an Intel-P4. Both currently have individual USB sticks "dd" with this latest DLNA PUP. Each is running the "gpt" version on this DLNA PUP.

On the X2, the youtubes in a browser, no matter which I used, work (with sound) flawlessly. But several desktop apps (for example VLC being the default for video/audio) I get no sound. I tried converting to the "msdos" version of this DLNA PUP and received the same problems on the X2.

I had not notice this with the P4 system where I have used XINE over past week for viewing desktop media. Audio via browsers word as well as did PMusic radio.

There were other anomolies as well on the X2 not seen on the P4.

In any event, I decided to take the USB stick booting from the P4 and see if it would exhibit the same problem on the X2 seen on the X2's stick.

Yes, sadly, I saw several of the same problems.

So, I'm to surmise that the problem is platform-chipset related that the current distro does not do well. The X2/P4 have NO bus cards in its motherboards.

At this stage, I only need 1 DLNA host on the LAN, so, for this mission, the P4 will be used with it planned to serve local and LAN multimedia files to my DLNA capable TVs.

Intents for my LAN to supply DLNA content to uses.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 4 [47 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0647s ][ Queries: 14 (0.0078s) ][ GZIP on ]