Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 17 Aug 2018, 16:52
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
X-Slacko Slim 4.4r20 (unique, stable, and flexible)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 50 of 58 [863 Posts]   Goto page: Previous 1, 2, 3, ..., 48, 49, 50, 51, 52, ..., 56, 57, 58 Next
Author Message
Sage

Joined: 04 Oct 2005
Posts: 5397
Location: GB

PostPosted: Mon 29 Jan 2018, 10:27    Post subject:  

Did exactly as requested. Got the diagnostics , all passed.
Declined to plug in USB, just rebooted (third option).
puppy_xslacko_4.4.sfs not found.
Select 0,1,2
Selected third.
Crazy! This absolutely MUST NOT HAPPEN. There is some fundamental block. No other Puppy or any other of dozens of distros do this. Strikes me someone (not necessarily misty) is trying to be far too smart and fails every time.
This is suppose to inherit the crown of smallest, fastest Puppy. It shouldn't be intended to run on SOTA machines, more something from the 1990s IMHO. Frankly I've no time for these wannabees with too much dosh, trying to claim boasting rights for HW that'd take them to Mars and back - possibly their best destination.
Let's get back to basics: K.I.S.S. is ALWAYS the correct answer.
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2349
Location: Queensland

PostPosted: Mon 29 Jan 2018, 18:07    Post subject:  

Sage,

On my Lenovo 2ghz 2gig ram pc it doesn't find the puppy_xslacko_4.4.sfs when booting from the CD, I did a manual frugal install to the HDD, this boots and runs without problem.

My ACER intel laptop boots from CD ok, as for my P4 machine there appears to be no suitable SIS video driver available.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Mon 29 Jan 2018, 18:41    Post subject:  

@Sage. What is the name and model of your machine? I try my best to fix the issue on your rig. If your machine passed on the simple diagnotics then you can save the tmp folder of the initrd on your hard drive and send it here. I need that file to troubleshoot that problem on your machine.

@Geoffrey can you tell me the results of the diagnostics. Also can you please tell me the name and model of your lenovo laptop where the xslacko slim failed to boot? On the case on acer, does it the desktop environment start?
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2349
Location: Queensland

PostPosted: Mon 29 Jan 2018, 20:52    Post subject:  

mistfire wrote:
@Geoffrey can you tell me the results of the diagnostics. Also can you please tell me the name and model of your lenovo laptop where the xslacko slim failed to boot? On the case on acer, does it the desktop environment start?


It's a Lenovo thinkcentre A61e 6449 with a Sempron cpu of 2ghz with 2 gigs ram, as the pic shows it should work, but it fails to find the puppy_xslacko_4.4.sfs when booted from a CD rom, works fine from a HDD frugal install, weird.

The ACER Aspire laptop boots from CD rom and goes to desktop without a problem, everything seems to function though I may have to play with the mouse as the pad doesn't work double tapping, wireless works ok screen res all good, I'll check it out some more when I find the time.

The P4 tries to run the desktop but fails with the SIS video and falls back to a prompt with the message " VESA BIOS Extensions not detected ".
P1010372.JPG
 Description   
 Filesize   181.94 KB
 Viewed   549 Time(s)

P1010372.JPG


_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Tue 30 Jan 2018, 05:45    Post subject:  

thanks @geoffrey for the screenshot. @sage can you please send a screenshot the same as geoffrey did?
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Tue 30 Jan 2018, 21:14    Post subject:  

Here is a test release of X-Slacko Slim. The initrd has a detailed boot logging to trace what went wrong why puppy SFS cant find.

@Sage and @Geoffrey can you please test this release. In the puppy sfs cant find please select SAVE TEMP FILES to a storage device and upload here in this form. If you cant save just select GO TO PROMPT use this command

Code:
cat /tmp/bootinit.log | tail -n (last to 5-15 lines)


and tell me the results

Download: https://drive.google.com/open?id=1y2MZYxbHr4Gzd1boNORnweqJLQ7kumJY
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2349
Location: Queensland

PostPosted: Tue 30 Jan 2018, 23:54    Post subject:  

mistfire, it appears to look on the sda1 drive and usb, but fails to load the file from the CD
log.jpg
 Description   
 Filesize   148.16 KB
 Viewed   474 Time(s)

log.jpg


_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Wed 31 Jan 2018, 04:51    Post subject:  

@Geoffrey you are right the compiled kernel has a problem on reading CD drives. I made a test earlier using USB external CD Drive also it fail to mount CD drive although the filesystem was recognized.

I wonder what kernel configuration that I need to verify?
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 5397
Location: GB

PostPosted: Wed 31 Jan 2018, 06:48    Post subject:  

Well done, Geoff - it was all getting far too time consuming for me when, clearly, a simple error was all that was involved.
The last fully functional version was 4.2 r57 wr54 initrd. So, for anyone who speaks this bizarre language, the answer lies therein. Don't call me till it's fixed!
Amazing that none of the resident gurus could isolate the fault...
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2349
Location: Queensland

PostPosted: Wed 31 Jan 2018, 07:07    Post subject:  

Booting from the CD I managed to get to a desktop on the P4 machine after fiddling with the xorgwizard, seems stable.

I notice that the CD is found as hdc
screen.jpg
 Description   
 Filesize   22.13 KB
 Viewed   435 Time(s)

screen.jpg

screen2.jpg
 Description   
 Filesize   28.74 KB
 Viewed   439 Time(s)

screen2.jpg


_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Wed 31 Jan 2018, 18:12    Post subject:  

Thanks for that @Geoffrey right now I compiled the kernel using fatdog64 source code. Configuring to 32-bit and applied some my preferences. At first I noticed that the output kernel image was 6.1Mb! I try to trim some builtin modules but keeping the disk drive, usb, keyboard, fb, pcmcia, nvme, and mouse kernel modules. but the kernel filesize was 5.9Mb.
Back to top
View user's profile Send private message 
Volhout

Joined: 28 Dec 2008
Posts: 521

PostPosted: Thu 01 Feb 2018, 08:58    Post subject: wine pet  

Dear mistfire,

Could you please make available, or specify exactly, what WINE sfs you use with this puppy?
I tried several versions out of ppm, and always ended up with missing libraries, and extra packages that had to be found.
A matching WINE PER or SFS (prefer SFS) would be great.

Regards,

Volhout
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Thu 01 Feb 2018, 09:02    Post subject:  

@Volhaut almost any versions of wine should work. I tried wine 1.7 and 2.x from slackware packages. They work fine for me. You may ignore missing packages sometimes.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Thu 01 Feb 2018, 18:31    Post subject:  

I successfully recompile a kernel. The culprit was the source code.

Right now Im trying to simplying the init for searching puppy files. I noticed that the detection of optical drive in the script was less reliable (This might be the culprit on booting Sage's machine). I try to make some improvements on it.

Boot logging is now strictly enforced on the next release and its more readable for easy troubleshooting.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 922
Location: PH

PostPosted: Sun 04 Feb 2018, 21:39    Post subject:  

New X-Slacko Slim iteration released:

Changes:
* Bugfix on CD/DVD drive detection (Both initrd and kernel)
* Some revisions on bluetooth detection (thanks argolance)
* Boot logging is now enabled by default (Initrd and rc.sysinit process only). The logs are now more readable and more detailed for easy troubleshooting (see /tmp/puppyboot.log)

* Some init script changes and simplified searching of puppy sfs files.


Download: https://drive.google.com/open?id=1UhOnI860ozYJx_2xytp62SgUZGFxccBc
MD5 Checksum: 3591553041821f33fd16819ba2fa3c79
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 50 of 58 [863 Posts]   Goto page: Previous 1, 2, 3, ..., 48, 49, 50, 51, 52, ..., 56, 57, 58 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2209s ][ Queries: 14 (0.1478s) ][ GZIP on ]