Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 26 Aug 2016, 09:42
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Skype for Carolite_1.2?
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
Mike7


Joined: 18 Feb 2013
Posts: 340

PostPosted: Tue 19 Apr 2016, 13:17    Post subject:  Skype for Carolite_1.2?  

Hi, all.

Can someone tell me which of the skype versions in the repo. . .:
    skype-4.2.0.13-lina.pet
    skype-4.3.0.37-apulse-lina.pet
    skype-4.2.0.13-lina.sfs
    skype_static-2.2.0.35.sfs

. . .I should download for Carolite_1.2?

Cheers.

Mike

_________________
Carolite-1.2 w/FF38 on bootable 16G flash drive; Asus eeePC 1000HA, Atom CPU, 1G RAM, 160G HDD.
Back to top
View user's profile Send private message 
0xdawg


Joined: 18 Sep 2015
Posts: 31
Location: .de/

PostPosted: Sat 23 Apr 2016, 10:42    Post subject:  

all of those packages are compiled to run on racy/wary derivatives

if you're still on that Asus EEE-netbook i can predict you won't be able to do phone calls without hiccups | heavy lags -- but chatting shouldn't be a problem at all

as 2.2.0.35 is from 2011 it's blocked by skype when logging in probably

4.3.0.37 is your latest version of skype for Linux (dynamic)

_________________
Current Puppy: Carolina 1.3@Wyse X90LE
Back to top
View user's profile Send private message 
Mike7


Joined: 18 Feb 2013
Posts: 340

PostPosted: Sat 23 Apr 2016, 13:12    Post subject:  

Hi, Oxdawg.

Thanks. I'll give 4.3.0.37 a whirl, although, yes, my object was phone calls. However, the few people I want to call long-distance using Skype have computers, so maybe we can do chat instead.

What is the cause of the slow-down and interruptions with an eeepc? Is it the lack of RAM? CPU speed?. . . ?

What is the difference between with and without apulse, do you know?

Thanks for your help with this.

Mike

_________________
Carolite-1.2 w/FF38 on bootable 16G flash drive; Asus eeePC 1000HA, Atom CPU, 1G RAM, 160G HDD.
Back to top
View user's profile Send private message 
0xdawg


Joined: 18 Sep 2015
Posts: 31
Location: .de/

PostPosted: Sat 23 Apr 2016, 13:51    Post subject:  

given the circumstance your cpu is an older single-core, so yea, speed is the obstruction -- just try if phone calls work better for you than i had to expierience on my machine (almost similar setup)
good luck!

As of version 4.3, the ALSA sound system is no longer supported without PulseAudio.

_________________
Current Puppy: Carolina 1.3@Wyse X90LE

Last edited by 0xdawg on Sun 24 Apr 2016, 02:24; edited 1 time in total
Back to top
View user's profile Send private message 
Mike7


Joined: 18 Feb 2013
Posts: 340

PostPosted: Sat 23 Apr 2016, 23:26    Post subject:  

Oxdawg-
Quote:
As of version 4.3, the ALSA sound system is no longer supported without PulseAudio.

Not sure what this means. Does the ALSA that's built into Carolite-1.2 have pulse audio? If not, do I need to install a newer version of ALSA in order for Skype 4.3.0.37 to work?

_________________
Carolite-1.2 w/FF38 on bootable 16G flash drive; Asus eeePC 1000HA, Atom CPU, 1G RAM, 160G HDD.
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1068
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sun 24 Apr 2016, 00:31    Post subject:  

I'm going to assume that Geoffrey wouldn't upload a .pet that didn't work. Use the skype-4.3.0.37-apulse-lina.pet, apulse is "PulseAudio emulation for ALSA".
_________________
X-slacko-4.2 - X-tahr-2.0 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1071

PostPosted: Sun 24 Apr 2016, 00:51    Post subject:  

I don't know Carolite-1.2 but if it is wary compatible then I think you should install for example the following pulseaudio:

https://copy.com/PhfFxjfuHcih

and the following skype4.3:

https://copy.com/WEd4aM21Ii1s

This skype has not working avatars and need some tweaking but is a good start point to test with Carolite. To run skype:

Code:
pulseaudio --start
skype
pulseaudio --kill


If pulseaudio daemon does not start search default.pa with pfind and you need to change the following two lines:

Code:
load-module module-alsa-sink device=hw:0,0
load-module module-alsa-source device=hw:0,0


The following settings in default.pa should generally work:

Code:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop

Last edited by watchdog on Sun 24 Apr 2016, 03:18; edited 1 time in total
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 1068
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sun 24 Apr 2016, 01:42    Post subject:  

watchdog wrote:
I don't know Carolite-1.2 but if it is wary compatible then I think you should install for example the following pulseaudio:

https://copy.com/PhfFxjfuHcih

and the following skype4.3:

https://copy.com/WEd4aM21Ii1s


You don't need to install pulseaudio, apulse in the .pet takes care of that.

_________________
X-slacko-4.2 - X-tahr-2.0 - X-precise-2.4
X-series repo
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1071

PostPosted: Sun 24 Apr 2016, 01:46    Post subject:  

rg66 wrote:

You don't need to install pulseaudio, apulse in the .pet takes care of that.


Someone reported that apulse does not properly work: skype calls hanging down problems.
Back to top
View user's profile Send private message 
0xdawg


Joined: 18 Sep 2015
Posts: 31
Location: .de/

PostPosted: Sun 24 Apr 2016, 02:42    Post subject:  

when i've initially launched skype i did a test call to echo, everything including pulse worked fine using 4.3.0.37-apulse-lina.pet

there's that aforementioned lack of cpu-power which makes real phone calls inedible

_________________
Current Puppy: Carolina 1.3@Wyse X90LE
Back to top
View user's profile Send private message 
Mike7


Joined: 18 Feb 2013
Posts: 340

PostPosted: Sun 24 Apr 2016, 08:43    Post subject:  

I´ll first download and try just skype-4.3.0.37-apulse-lina.pet. If it doesn't work, I'll look into downloading the separate components.

As Oxdawg said, my Skype/Carolite project may be doomed from the start by a slow CPU, But it's worth a try.

M.

_________________
Carolite-1.2 w/FF38 on bootable 16G flash drive; Asus eeePC 1000HA, Atom CPU, 1G RAM, 160G HDD.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0403s ][ Queries: 11 (0.0048s) ][ GZIP on ]