Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 24 Oct 2017, 03:46
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
coreutils-8.25 published Jan. 20, 2016
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
musher0


Joined: 04 Jan 2009
Posts: 10993
Location: Gatineau (Qc), Canada

PostPosted: Sun 17 Apr 2016, 02:07    Post subject:  coreutils-8.25 published Jan. 20, 2016
Subject description: latest as of this writing
 

Hello all.

These are the latest coreutils, v. 8.25, published by the GNU Foundation Jan.
20, 2016.

I provide them for reference, instruction and wise use only. Puppy already has
a good number of them, so please DO NOT copy the contents of this archive
indiscriminately over the files already in Puppy. If you do that, there's a good
chance that you'll put your Puppy in BIG trouble.

As an additional precaution, I have suffixed these utilities with their version number
in order that no Puppy file is squished if you copy the lot. (But don't, use
them on a case-by-case and as-needed basis.)


So, to properly use, for example, fmt ( a utility that reformats the length of lines of
a straight text file; Puppy does not have it by default), you will have to copy it to
/usr/bin and then create a link from fmt-8.25 to fmt. Or type < fmt-8.25 >.

You may however install the man files section without problem. (Linking as
explained above.) Some of you may actually find this helpful.

I provide these "core" utilities to get Puppyists to see what GNU utilities are
available. Consulting the list of these files may save you some scripting, in the
sense that your need may already be covered by one of these utilities. And of
course these utilities (among others) are the essential "second leg" of GNU/Linux
systems.

I compiled these utilities on slim-6, a puplet derived from the latest 32-bit slacko.

So there you go. Use at your own risk -- and with very great caution.

The sha256sum hash is as follows:
Quote:
236331c177b0da182934e6850f09cc11475c7a2573fb2b7ac327d43b8a9a0c9b GNU-coreutils-825_stripped.zip.lz
The download URL is:
-- https://www.adrive.com/public/5psZKN/GNU-coreutils-825_stripped.zip.lz --

BFN.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
moeppyfan


Joined: 11 Feb 2016
Posts: 48

PostPosted: Sun 17 Apr 2016, 15:26    Post subject:  

Nice idea musher0. I replace ALL files from 8.21 (2013) with 8.25 (2016) now, no issues yet... but I keep an eye out Laughing
Screenshot.png
 Description   
 Filesize   46 KB
 Viewed   175 Time(s)

Screenshot.png

Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10993
Location: Gatineau (Qc), Canada

PostPosted: Sun 17 Apr 2016, 15:40    Post subject:  

moeppyfan wrote:
Nice idea musher0. I replace ALL files from 8.21 (2013) with 8.25 (2016) now, no issues yet... but I keep an eye out Laughing

Thanks, moeppyfan.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0405s ][ Queries: 12 (0.0146s) ][ GZIP on ]