Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 23 Aug 2019, 03:08
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Quirky Xerus 8.6 (Aug. 16), Beaver 8.7.1 (Sept. 21), 2018
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 62 [916 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 60, 61, 62 Next
Author Message
linuxcbon

Joined: 09 Aug 2007
Posts: 1259

PostPosted: Mon 18 Apr 2016, 10:33    Post subject:  

Quirky Xerus 7.90

- internet not connected by default !
solved with
Code:
# network_default_connect
# route: SIOCADDRT: File exists
Waiting for interfaces to initialize...
configuring network interface eth0
cheching if interface eth0 is alive...yes
dhcpcd[29590]: sending commands to master dhcpcd process
dhcpcd[29590]: send OK
Success!


- all programs have this
Code:
Unable to update the static FcBlanks: 0x2028


-
Code:
# ppm
tr: warning: an unescaped backslash at end of string is not portable


- pmount slow to start ("probing hardware")

- gparted doesnt reckognize EFI partition in stick, but fdisk does show.
Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 0 716799 716800 350M 0 Empty
/dev/sdb2 136 16519 16384 8M ef EFI (FAT-12/16/32)

- seamonkey
Code:
*** BUG ***
In pixman_region32_reset: Malformed region region
Set a breakpoint on '_pixman_log_error' to debug
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3357
Location: The Blue Marble

PostPosted: Mon 18 Apr 2016, 10:56    Post subject:  

BarryK wrote:
jamesbond,
Yes, I have only used syslinux/isolinux, and have two vmlinuz and initrd.


Gaaaah!! Evil or Very Mad I wasn't aware of this earlier.
http://www.syslinux.org/archives/2015-April/023381.html
http://www.syslinux.org/archives/2015-October/024469.html

Just for fun - testing was done in qemu:
a) grub2-efi works (tested)
b) gummiboot works (tested) - gummiboot recently renamed as "systemd-boot" but it actually has nothing to do with systemd except that it's developed by the same guy (no, not Lennard - it's Kay).
EDIT : C) or you may want to try refind : http://www.rodsbooks.com/refind/

After booting, it fails to start desktop, because of missing fbdev Xorg driver. modesetting driver doesn't work, vesa doesn't work. It should probably work on real machine with intel/radeon/nvidia card.

If you prefer gummiboot, the bootloader is attached. For example of how to use it, I've uploaded the FAT image here: http://www.lightofdawn.org/g.img. Use this g.img instead of efiboot.img and quirky will boot.

Note: let me know when you've grabbed this g.img. I'll remove it after that.

@linuxcbon: http://www.syslinux.org/wiki/index.php?title=Isohybrid#UEFI - isohybrid only adds GPT partition tables to make the efiboot.img visible as ESP. But you need to have efiboot.img already *inside* the ISO to begin with. That's why "isohybrid -u" fails for some random non-UEFI ISO.
gummibootx64.efi.gz
Description  Gunzip before use.
Source: https://cgit.freedesktop.org/gummiboot/
Doc: https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/
gz

 Download 
Filename  gummibootx64.efi.gz 
Filesize  32.8 KB 
Downloaded  230 Time(s) 

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.

Last edited by jamesbond on Mon 18 Apr 2016, 11:26; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 18 Apr 2016, 11:09    Post subject: Quirky Xerus 7.90 (8.0beta)  

I booted the dvd on my macmini, efi wouldn't boot but it did boot from
the other.
I ran the installer and did a frugal install to a 32gb usb-3.0 flash
drive.
I moved the flash drive to an Acer laptop and it booted, I've rebooted
a couple of times since choosing save, I added gkrellm with QPM.

Seems to be working okay so far.
screenshot.jpg
 Description   
 Filesize   77.31 KB
 Viewed   1772 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8974
Location: Perth, Western Australia

PostPosted: Mon 18 Apr 2016, 11:35    Post subject: Re: Quirky Xerus 7.90 (8.0beta)  

Billtoo wrote:
I booted the dvd on my macmini, efi wouldn't boot but it did boot from
the other.


What do you mean by "other"?
Legacy Boot enabled?

Anyway, I haven't researched booting on a Mac.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8974
Location: Perth, Western Australia

PostPosted: Mon 18 Apr 2016, 11:37    Post subject:  

jamesbond wrote:
If you prefer gummiboot, the bootloader is attached. For example of how to use it, I've uploaded the FAT image here: http://www.lightofdawn.org/g.img. Use this g.img instead of efiboot.img and quirky will boot.

Note: let me know when you've grabbed this g.img. I'll remove it after that.


OK, got it.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Sage

Joined: 04 Oct 2005
Posts: 5480
Location: GB

PostPosted: Mon 18 Apr 2016, 11:51    Post subject:  

Quirky Xerus 7.90 (8.0beta)
Not wishing to appear greedy nor churlish, but a 'final' which fits on a CD-RW would still be invaluable in 32bit format for working with land-fill rescued machines. Perhaps one of the gurus circling the fold could take on the task?
Otherwise, working well on older 754 & 939 machines, except with VX5450/512 HDMI card, yes, even with v.11 FP/BBC. Default video setting 1600x??? bit too high for older HW and older users...
Not able to release UEFI kit for testing at present.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 18 Apr 2016, 12:36    Post subject: Quirky Xerus 7.90 (8.0beta)  

I booted the dvd from a usb optical drive on my hp mini Stream 200-009, it has 2gb ram,
Windows 10 on the 32gb SSD.
EFI wouldn't boot but legacy did, I don't want to mess with secure boot
in case I make a mistake and screw things up so nothing will boot,
sorry.

I ran the installer and it seemed to be working well but froze the
computer during the process, not enought ram maybe.

So, I moved my other 32gb usb-3.0 flash drive from the Acer laptop and
booted that, the boot screen shows legacy devices and efi devices, I
chose efi and it booted fine.

Hope this is helpful.
screenshot2.jpg
 Description   
 Filesize   65.74 KB
 Viewed   1949 Time(s)

screenshot2.jpg

Back to top
View user's profile Send private message 
gcav


Joined: 25 May 2012
Posts: 77
Location: Ontario

PostPosted: Mon 18 Apr 2016, 13:46    Post subject: T2 update?  

Hi Barry, is this being updated on your T2?

gcav
Back to top
View user's profile Send private message 
Rodney Byne

Joined: 31 Jan 2014
Posts: 211

PostPosted: Mon 18 Apr 2016, 14:09    Post subject: Savefile  

Hi Barry K,

I installed Xerus iso successfully to USB flashdrive copy/pasting
the dd command from your blog.
Xerus ran normally with the settings adjusted for my needs.

But after all that work time spent, the big surprise came at closedown,
when I realised there are only two location options available
for the savefile - dvd or pc harddrive.

For me neither of these is relevant, so as in all previous puppies,
why is there no gui facility to save back to the USB stick?
Can this omission be rectified in any future update release please?

Best regards.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Mon 18 Apr 2016, 14:47    Post subject: Initial report ... an issue  

Downloaded ISO, Checksum matches, Burn DVD via pBurn, and booted "LIVE" to non-UEFI X2 desktop. (I do not have a UEFI PC at this time for testing). At session end, I noticed that Live does NOT offer a save at shutdown. Maybe an option should display on Live-boot if a save-session should be selected from the desktop or ... (every puppy user is NOT going to pre-read the Xerus blog directions before shutdown attempted and their session's configurations is lost)

Note: Traditionally wired ethernet is/should be discovered upon boot going to desktop. This ISO is not. Might that be reconsidered for home wired LANs to avoid new user confusion. My home LAN as with other home LANs are secure. Assume yours is also.

My system pristine boot info below. Please do not overlook the info in each image's "Description".
FirstRUN-noIP.png
 Description   No IP. Thus the FirstRUN checkbox for Internet date-time WILL NOT WORK.
 Filesize   189.8 KB
 Viewed   1975 Time(s)

FirstRUN-noIP.png

FirstRUN-completes.png
 Description   After FirstRUN completes.
 Filesize   156.64 KB
 Viewed   1658 Time(s)

FirstRUN-completes.png


_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
gcav


Joined: 25 May 2012
Posts: 77
Location: Ontario

PostPosted: Mon 18 Apr 2016, 15:21    Post subject: Re: T2 update? Not April...  

Just realized this is Debian based not T2.... sorry... move along...

gcav wrote:
Hi Barry, is this being updated on your T2?

gcav
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 18 Apr 2016, 16:47    Post subject: Quirky Xerus 7.90 (8.0beta)
Subject description: Sound on hp mini Stream
 

Sound is not supported on my hp mini Stream ootb.
I've connected a powered usb hub and have a usb sound card plugged into
that, so I now have sound, on youtube at least. Smile

Edit: I have sound when playing a movie dvd from the usb optical drive in xine as well.
One problem is when I plug another drive in it overwrites the other drive icon above the panel.
sr0 covered sdb2 until I moved it.
driveicons.jpg
 Description   
 Filesize   16.59 KB
 Viewed   1683 Time(s)

driveicons.jpg

screenshot3.jpg
 Description   
 Filesize   73.29 KB
 Viewed   1682 Time(s)

screenshot3.jpg

alsamixer.jpg
 Description   
 Filesize   37.89 KB
 Viewed   1666 Time(s)

alsamixer.jpg

Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8974
Location: Perth, Western Australia

PostPosted: Mon 18 Apr 2016, 17:33    Post subject: Re: Savefile  

Rodney Byne wrote:
Hi Barry K,

I installed Xerus iso successfully to USB flashdrive copy/pasting
the dd command from your blog.
Xerus ran normally with the settings adjusted for my needs.

But after all that work time spent, the big surprise came at closedown,
when I realised there are only two location options available
for the savefile - dvd or pc harddrive.

For me neither of these is relevant, so as in all previous puppies,
why is there no gui facility to save back to the USB stick?
Can this omission be rectified in any future update release please?

Best regards.


it is not an omission. You wrote an ISO file to the USB stick and booted from that. It is not a USB installation.

You have to run the Installer and install to a USB stick.

Also, as I mentioned, this ISO is specifically for testing UEFI booting, and the Quirky Installer (and save icon) might not be working quite right -- as Quirky has never before been booted from an ISO written to a USB-stick.

Last edited by BarryK on Mon 18 Apr 2016, 17:48; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8974
Location: Perth, Western Australia

PostPosted: Mon 18 Apr 2016, 17:41    Post subject:  

"Back to the drawing board"

The ISO will not boot on a UEFI machine, from optical drive. Only in Legacy Mode.

It will boot on a UEFI machine if the ISO is dd'ed to a USB stick and booted from that.

I am now able to test booting from an optical drive on UEFI-firmware machine.
When I boot my Asus baby laptop cold, the external drive is not recognised. However, if I start Windows, then do a restart, the "warm reboot" allows the UEFI-firmware to recognise the external optical drive.

My disc would not boot. Lubuntu did.

So, I need to delve back in to it...

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 6734
Location: Kentucky

PostPosted: Mon 18 Apr 2016, 17:45    Post subject:  

Attempted the live cd on the hexa-core (UEFI w/secure boot toggled off) but got nothing but a blank monitor. No text,no prompt,so moved to an old box I happened to be playing with.

Booted with everything working except internet,SNS made quick work of that.

Code:
# inxi -Fxx
System:    Host: puppypc9346 Kernel: 4.4.7 x86_64 (64 bit gcc: 5.3.1)
           Desktop: JWM git-976 dm: N/A Distro: Quirky 7.90 xerus64
Machine:   Mobo: ASUSTeK model: A8V-MQ v: Rev 1.xx serial: MB-1234567890
           Bios: American Megatrends v: 0210 date: 03/31/2006
CPU:       Single core AMD Athlon 64 3800+ (-UP-) cache: 512 KB
           flags: (lm nx sse sse2 sse3) bmips: 4801 speed: 2400 MHz (max)
Graphics:  Card: NVIDIA NV18 [GeForce4 MX 4000]
           bus-ID: 05:00.0 chip-ID: 10de:0185
           Display Server: X.org 1.18.3 drivers: nouveau (unloaded: vesa)
           tty size: 80x25 Advanced Data: N/A for root
Audio:     Card VIA VT8233/A/8235/8237 AC97 Audio Controller
           driver: snd_via82xx port: e400 bus-ID: 00:11.5 chip-ID: 1106:3059
           Sound: Advanced Linux Sound Architecture v: k4.4.7
Network:   Card: VIA VT6102/VT6103 [Rhine-II]
           driver: via-rhine port: e800 bus-ID: 00:12.0 chip-ID: 1106:3065
           IF: eth0 state: unknown speed: 100 Mbps duplex: full
           mac: 00:15:f2:3d:a8:d4
Drives:    HDD Total Size: 250.1GB (1.6% used)
           ID-1: /dev/sda model: WDC_WD2500AAKX size: 250.1GB serial: N/A
Partition: ID-1: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      System: supported: raid0
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 110 Uptime: 11 min Memory: 213.2/2008.2MB
           Init: SysVinit v: N/A runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.3.01 running in urxvt) inxi: 2.2.35



Code:
# free
             total       used       free     shared    buffers     cached
Mem:       2056364     885548    1170816     346556      76168     597472
-/+ buffers/cache:     211908    1844456
Swap:      4095996          0    4095996
#


Will try again later on the UEFI box.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 62 [916 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 60, 61, 62 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1253s ][ Queries: 12 (0.0178s) ][ GZIP on ]