Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 15 Nov 2018, 06:37
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko64 & slacko(32)6.3.0.6
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 6 [76 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 6558
Location: Valåmoen, Norway

PostPosted: Wed 06 Apr 2016, 13:28    Post subject:  

Downloading now...
Will test the coming days.

It's frustrating to see how few testers an official Puppy gets.
Come on guys!

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Ted Dog


Joined: 13 Sep 2005
Posts: 4013
Location: Heart of Texas

PostPosted: Wed 06 Apr 2016, 14:22    Post subject:  

Did not know this is the official BK blessed version...
have downloaded it days ago but have not burned to DVD to test, still plan to play/test/reply
Back to top
View user's profile Send private message 
danilone

Joined: 09 Apr 2015
Posts: 4

PostPosted: Wed 06 Apr 2016, 14:31    Post subject: slacko64 & slacko(32)6.3.0.6
Subject description: 32bit UEFI in Slacko(32)
 

@01Micko,

Thanks for another fine piece of work.
May I ask if it is too much of problem adding 32Bit UEFI boot capability to Slacko(32)?
I'm trying to make a Clovertrail machine a Windows-free device.
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1547

PostPosted: Wed 06 Apr 2016, 16:09    Post subject:  

edit: A bunch of random things unreleated to uefi

@SFR: Thanks! You're right, Inkscapelite is quite messy. I just set svg files to open in gpicview instead Laughing

Last edited by Sailor Enceladus on Thu 07 Apr 2016, 10:03; edited 3 times in total
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1669

PostPosted: Wed 06 Apr 2016, 17:26    Post subject:  

Sailor Enceladus wrote:
- inkscape triangle globs

Oh, that annoying crap that's been there for ages...
Some time ago I was trying to fix the sources for compiling in Fatdog and found a fix for that one, too:
Code:
diff -ur inkscapelite-0.36.2/src/widgets/ruler.c inkscapelite-0.36.2_fixed_SFR/src/widgets/ruler.c
--- inkscapelite-0.36.2/src/widgets/ruler.c   2003-10-30 21:48:05.000000000 +0100
+++ inkscapelite-0.36.2_fixed_SFR/src/widgets/ruler.c   2015-11-22 16:38:29.127740500 +0100
@@ -298,6 +298,13 @@
 
      ruler->xsrc = x;
      ruler->ysrc = y;
+
+      if (!ruler->non_gr_exp_gc)
+        {
+          ruler->non_gr_exp_gc = gdk_gc_new (widget->window);
+          gdk_gc_set_exposures (ruler->non_gr_exp_gc, FALSE);
+        }
+
    }
     }
 }
@@ -581,6 +588,13 @@
 
      ruler->xsrc = x;
      ruler->ysrc = y;
+
+      if (!ruler->non_gr_exp_gc)
+        {
+          ruler->non_gr_exp_gc = gdk_gc_new (widget->window);
+          gdk_gc_set_exposures (ruler->non_gr_exp_gc, FALSE);
+        }
+
    }
     }
 }

The ruler on the left still isn't visible, though...

Anyhow, I let it go in the end, 'coz:
- 'Text' tool doesn't work in 64bit build (32bit is ok) - Inkscape segfaults immediately after pressing any key
- crashes a lot while opening images, e.g. most of SVGs from hicolor/scalable/{actions|apps} (notable exceptions are Zigbert's icons)

HTH

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6728
Location: Kentucky

PostPosted: Wed 06 Apr 2016, 19:13    Post subject:  

Attempted to test the 32 bit version on the UEFI hexa-core box. Live cd to ram, booted to an incorrect 1024x768 desktop with a frozen mouse. Switched to the unaccelerated driver and X would not start. Booted again to "no x" and never got to a working desktop. Testing aborted.

Moved cd over to an older non-UEFI box with a bit older Nvidia card and it's running there now.

No problems with regular Slacko 6.3.0 on this box though.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6728
Location: Kentucky

PostPosted: Wed 06 Apr 2016, 19:19    Post subject:  

Older non-UEFI box. Working ok.

Code:
# inxi -Fxx
System:    Host: puppypc13375 Kernel: 3.14.55 i686 (32 bit, gcc: 4.8.2)
           Desktop: JWM 2.3.2 dm: N/A Distro: Slacko Puppy 6.3.0.6
Machine:   Mobo: ECS model: GeForce7050M-M version: 1.0 Bios: American Megatrends version: 080014 date: 05/30/2008
CPU:       Dual core AMD Athlon 64 X2 3800+ (-MCP-) cache: 1024 KB flags: (lm nx pae sse sse2 sse3 svm) bmips: 3990.66
           Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 8400 GS Rev. 3] bus-ID: 02:00.0 chip-ID: 10de:10c3
           X.org: 1.14.3 drivers: nouveau (unloaded: fbdev,vesa) tty size: 80x25 Advanced Data: N/A for root
Audio:     Card-1: NVIDIA High Definition Audio Controller bus-ID: 02:00.1 chip-ID: 10de:0be3 Sound: ALSA ver: k3.14.55
           Card-2: NVIDIA MCP67 High Definition Audio driver: snd_hda_intel bus-ID: 00:07.0 chip-ID: 10de:055c
Network:   Card: NVIDIA MCP67 Ethernet driver: forcedeth port: c880 bus-ID: 00:0a.0 chip-ID: 10de:054c
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1e:90:fe:92:50
Drives:    HDD Total Size: 250.1GB (-)
           1: id: /dev/sda model: WDC_WD2500AAKX size: 250.1GB serial: N/A
Partition: ID: swap-1 size: 4.30GB used: 0.00GB (0%) fs: swap
RAID:      System: supported: linear raid0 raid1 raid10 raid6 raid5 raid4
           No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
           Unused Devices: none
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 99 Uptime: 10 min Memory: 184.6/3035.5MB Runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.2.53 running in urxvt) inxi: 1.9.17



Code:


# report-video
VIDEO REPORT: Slacko Puppy, version 6.3.0.6

Chip description:
VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)

NOTE: there is no /etc/X11/xorg.conf configuration file.

Probing Xorg startup log file (/var/log/Xorg.0.log):
  Driver loaded (and currently in use): nouveau
  Loaded modules: dri2 evdev exa fb fbdevhw glx shadowfb

Actual rendering on monitor:
  Resolution:  1440x900 pixels (380x238 millimeters)
  Depth:       24 planes

...the above also recorded in /tmp/report-video
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1679
Location: Italy

PostPosted: Thu 07 Apr 2016, 05:55    Post subject:  

I did a usb stick by unetbootin from the slacko-6.3.0.6-uefi.iso. I changed isolinux.cfg, syslinux.cfg and extlinux.conf to:

Code:
label slacko
linux vmlinuz
append initrd=initrd.gz pmedia=usbflash pfix=fsck
menu label slacko
text help
Start slacko normally.
endtext


I copied to the usb stick my adrv_slacko_6.3.0.6.sfs and the savefile from sda1. The usb stick is working well and finds the adrv.sfs and the savefile on it on my bios machine. Can I hope it will work on a uefi machine? I remember that using unetbootin with linux mint gives no problem on uefi machines.
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3165
Location: The Blue Marble

PostPosted: Thu 07 Apr 2016, 07:00    Post subject:  

@watchdog: if you don't want to do the "dd" method, use this: http://blog.puppylinux.com/?viewDetailed=00009

EDIT:
@Mick - tested on wife's laptop; 32-bit slacko 6.3.0.6.
UEFI mode:
- boots to desktop (using vesa driver), frozen mouse.
- radeon module not loaded, when forced to load it complains about different symbol version.

BIOS mode:
- Stuck add boot - "loading kernel modules ..."

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
ferretgrandpa

Joined: 15 Feb 2013
Posts: 36

PostPosted: Thu 07 Apr 2016, 09:27    Post subject: works fine on Toshiba  

used the dd to flash drive (must have left something out)
Boots like a charm on my Toshiba Satellite C55T all intel. SB has been off since week two (Late July '14)
Boots nice, connects to wifi with ease, works great out of the box.
Only one apparent problem, it thinks it is a CDROM. which is why I said I must have left something out of my DD string. All other problems, (savefile, add fonts, etc), are probably part of working off a CD.
Back to top
View user's profile Send private message 
Griot


Joined: 12 Sep 2014
Posts: 131
Location: Serbia

PostPosted: Thu 07 Apr 2016, 11:09    Post subject:  

Hello, Mick and Puppians!

Frugal install on HDD, booted with Lilo. Works as advertised. :beer:

FWIW Slacko64 6.3.0 also boots w/o problem with different BIOS settings,
e.g. 'UEFI/Legacy first' with secure boot off.

First boot, PUPMODE=5
PUPSFS=sda4,ext3,/slacko64uefi/puppy_slacko64_6.3.0.6.sfs
PUPSAVE=


Code:
Pup-SysInfo Hardware Report (Summary), Thu 7 Apr 2016

Current Time: 16:39:16
System Uptime: 36 min
Load Average: 0.30 0.52 0.57

▶—— BASE SYSTEM ——◀

PC Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: To be filled by O.E.M.

Motherboard Vendor: Gigabyte Technology Co., Ltd.
Product Name: J1800M-D3P

BIOS Vendor: American Megatrends Inc.
Version: F1
Release Date: 01/28/2015

Intel(R) Celeron(R) CPU J1800 @ 2.41GHz
Max Speed: 2400 MHz
Current Speed of Core 0:2582 MHz, 1:2582 MHz
Core Count: 2
Thread Count: 2

Frequency governor   : powersave
Freq. scaling driver : intel_pstate

▶—— DISPLAY ——◀

Display Specifications:
• Monitor Name: Philips 190X
• Monitor VertRefresh: 75.0 times/s
• Screen Dimensions: 1280x1024 pixels (338x270 millimeters)
• Screen Depth: 24 bits (planes)

Xorg Startup Log (/var/log/Xorg.0.log):
• Xorg Driver in use: ati
• Loaded Modules: dbe dri2 exa extmod fb fbdevhw glx kbd mouse radeon ramdac
• X.Org version: 1.14.3

OpenGL 2D/3D Rendering:
• Direct Rendering: Yes
• Vendor: X.Org
• Renderer: Gallium 0.4 on AMD CAICOS
• Version: 2.1 Mesa 9.1.7

VGA controller [0300]: AMD/ATI [Advanced Micro Devices, Inc.] Caicos [Radeon HD 6450] [1002:6779]
• Kernel Driver: radeon
• Memory Used: 1446.83 KB
• Path: /lib/modules/4.1.11/kernel/drivers/gpu/drm/radeon/radeon.ko
• Description: ATI Radeon

▶—— MULTIMEDIA ——◀

Audio device [0403]: Intel Corporation ValleyView High Definition Audio Controller [8086:0f04] (rev 0e)
• Kernel Driver: snd_hda_intel
--
Audio device [0403]: AMD/ATI [Advanced Micro Devices, Inc.] Caicos HDMI Audio [Radeon HD 6400 Series] [1002:aa98]
• Kernel Driver: snd_hda_intel
• Memory Used: 19.82 KB
• Path: /lib/modules/4.1.11/kernel/sound/pci/hda/snd-hda-intel.ko
• Description: Intel HDA driver

Audio device [0403]: Intel Corporation ValleyView High Definition Audio Controller [8086:0f04] (rev 0e)
• Kernel Driver: snd_hda_intel
--
Audio device [0403]: AMD/ATI [Advanced Micro Devices, Inc.] Caicos HDMI Audio [Radeon HD 6400 Series] [1002:aa98]
• Kernel Driver: snd_hda_intel
• Memory Used: 19.82 KB
• Path: /lib/modules/4.1.11/kernel/sound/pci/hda/snd-hda-intel.ko
• Description: Intel HDA driver

▶—— NETWORK ——◀

Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 0c)
• Kernel Driver: r8169
• Memory Used: 65.06 KB
• Path: /lib/modules/4.1.11/kernel/drivers/net/ethernet/realtek/r8169.ko
• Driver Version: 2.3LK-NAPI
• Description: RealTek RTL-8169 Gigabit Ethernet driver


Keep it up!
Rock on! \m/
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Thu 07 Apr 2016, 12:06    Post subject: LAN adapters missing upon desktop arrivals.  

Wifi/Wired ethernet not present when booted to desktop. This was reported earlier in a prior post. A PupSys-info report is attached, below. It is a non-UEFI Laptop booted Live via DVD.

Questions
  • What additional info would be useful so that the distro could overcome this problem on this PC?
  • What steps should be followed or which options at boot should be used to gain adapters service?
SysInfo_Report.txt.fake.gz
Description  text file with a Fake gz extension
gz

 Download 
Filename  SysInfo_Report.txt.fake.gz 
Filesize  8.63 KB 
Downloaded  161 Time(s) 

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile

Last edited by gcmartin on Thu 07 Apr 2016, 21:59; edited 3 times in total
Back to top
View user's profile Send private message 
ASD

Joined: 22 Mar 2016
Posts: 99

PostPosted: Thu 07 Apr 2016, 15:35    Post subject:  

I tried the 32 bit version using BIOS on a 4G Flash Stick with 1.5G of free space.

It installed easily from another Puppy via YaPI and I'm pleased to report it worked well, with many changes saved to the Flash Stick and many reboots.
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3165
Location: The Blue Marble

PostPosted: Thu 07 Apr 2016, 21:09    Post subject:  

64-bit slacko63-6.3.0.6-uefi.iso on the same machine as http://murga-linux.com/puppy/viewtopic.php?p=897838#897838
UEFI-boot: works very well, screen is running at correct resolution (with radeon driver) and touchpad is enabled, mouse cursor working.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6558
Location: Valåmoen, Norway

PostPosted: Thu 07 Apr 2016, 23:57    Post subject:  

/usr/share/doc/home.htm is a bit outdated:
- woof-nabble has minor activity these days.
- The new blog at http://blog.puppylinux.com/ should be added.
- Barrys blog should be considered. He is invited to share Puppy stuff at our blog.

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 6 [76 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1204s ][ Queries: 12 (0.0106s) ][ GZIP on ]