Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 16 Dec 2018, 20:42
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Wifi-Connect 2017B beta (Deprecated)
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 10 [145 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 8, 9, 10 Next
Author Message
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Tue 05 Apr 2016, 16:06    Post subject:  

Cool @ corvus

The browser icon is missing from the package!!!

For those who don't want random mac address assignments simply leave mac address input box empty and uncheck random mac box!
For those who want a random mac address leave box checked and empty mac address input box.
For those who want regular mac address during scan but random during connection leave as is, entry filled and box checked!
Back to top
View user's profile Send private message MSN Messenger 
corvus


Joined: 12 Jun 2015
Posts: 128
Location: In the peninsula shaped like a boot.

PostPosted: Tue 05 Apr 2016, 16:25    Post subject:  

For info this is what i get when I run wifi-connect from terminal as you can see there is some error, thought:

Code:
root# wifi-connect
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
awk: cmd. line:1: {print $2
awk: cmd. line:1:          ^ unexpected newline or end of string
EXIT="Exit on timeout"
/usr/sbin/wifi-connect: line 123: LegioXXI|Can: command not found
rm: cannot remove ‘/var/run/wpa_supplicant/wlan0’: No such file or directory
Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
dhcpcd[10342]: version 5.5.6 starting
dhcpcd[10342]: all: not configured to accept IPv6 RAs
EXIT="Exit on timeout"
EXIT="Exit on timeout"
dhcpcd[10342]: eth0: broadcasting for a lease
dhcpcd[10342]: wlan0: waiting for carrier
dhcpcd[10342]: wlan0: carrier acquired
dhcpcd[10342]: wlan0: broadcasting for a lease
dhcpcd[10342]: wlan0: offered 192.168.1.120 from 192.168.1.1
dhcpcd[10342]: wlan0: acknowledged 192.168.1.120 from 192.168.1.1
dhcpcd[10342]: wlan0: checking for 192.168.1.120
EXIT="Exit on timeout"
dhcpcd[10342]: wlan0: leased 192.168.1.120 for 86400 seconds
dhcpcd[10342]: forked to background, child pid 10503
EXIT="Exit on timeout"


Regards.

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Tue 05 Apr 2016, 17:20    Post subject:  

I found the source of the errors ... Errors corrected now!
Back to top
View user's profile Send private message MSN Messenger 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Sat 09 Apr 2016, 09:30    Post subject:  

Fixed a couple bugs and added tray menu for saved profiles, so can connect directly using saved profile = 'wifiprofi' script
Last edited by stemsee on Tue 21 Nov 2017, 03:39; edited 1 time in total
Back to top
View user's profile Send private message MSN Messenger 
corvus


Joined: 12 Jun 2015
Posts: 128
Location: In the peninsula shaped like a boot.

PostPosted: Sat 09 Apr 2016, 10:18    Post subject:  

Hi Stemsee, the last version works fine for me. Below is the terminal output, I don't know if the lines in which appears "command not found" and "No such file or directory" they are errors or is normal as well.

Code:
root# wifi-connect
killall: wpa_supplicant: no process killed
dhcpcd[20361]: version 5.5.6 starting
dhcpcd[20361]: all: not configured to accept IPv6 RAs
dhcpcd[20361]: no interfaces have a carrier
dhcpcd[20361]: forked to background, child pid 20390
EXIT="Exit on timeout"
/usr/sbin/wifi-connect: line 115: LegioXXI|Can: command not found
rm: cannot remove ‘/var/run/wpa_supplicant/wlan0’: No such file or directory
Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
EXIT="Exit on timeout"
EXIT="Exit on timeout"
EXIT="Exit on timeout"
EXIT="Exit on timeout"
root#


The browser icon is still missing, for info I use Slimjet-9.0.1-x64.sfs.

Bye.

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Sat 09 Apr 2016, 17:05    Post subject:  

Try this one!
Does it actually connect you to your wifi network?
Wifi-Connect-3.pet
Description 
pet

 Download 
Filename  Wifi-Connect-3.pet 
Filesize  82.51 KB 
Downloaded  183 Time(s) 
Back to top
View user's profile Send private message MSN Messenger 
corvus


Joined: 12 Jun 2015
Posts: 128
Location: In the peninsula shaped like a boot.

PostPosted: Sat 09 Apr 2016, 18:15    Post subject:  

stemsee wrote:

Does it actually connect you to your wifi network?

Yes I can connect both WiFi and ethernet with no problems. I just wanted let you know that in the output from the terminal I noticed those two errors, but the tool works well.
With the latest version, you have uploaded, I have the following terminal output:
Code:
root# wifi-connect
dhcpcd[16055]: version 5.5.6 starting
dhcpcd[16055]: all: not configured to accept IPv6 RAs
EXIT="Exit on timeout"
dhcpcd[16055]: no interfaces have a carrier
dhcpcd[16055]: forked to background, child pid 16086
/usr/sbin/wifi-connect: line 116: LegioXXI|Can: command not found
Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
EXIT="Exit on timeout"
EXIT="Exit on timeout"
EXIT="Exit on timeout"
EXIT="Exit on timeout"

but I can connect to wifi and ethernet and the browser icon now appears.

Greetings.

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Sun 10 Apr 2016, 05:57    Post subject:  

Saved Profile loading 'wifiprofi'
wifi.png
 Description   
 Filesize   144.94 KB
 Viewed   314 Time(s)

wifi.png

Back to top
View user's profile Send private message MSN Messenger 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Thu 14 Apr 2016, 13:06    Post subject:  

Improved a little!

When using saved profiles, it checks for actual wifi access point before attempting to join.

Also gives option to join with wlan1 if available, no option if not.

Shows ip address in tray.

Small gui improvements.

needs testers!

Still to do ....
wps
realtime update of available APs in tray.
Rewire hotspot to work without additional apps.

Last edited by stemsee on Tue 21 Nov 2017, 03:40; edited 1 time in total
Back to top
View user's profile Send private message MSN Messenger 
Atle

Joined: 19 Nov 2008
Posts: 600
Location: Oslo, Norway

PostPosted: Thu 14 Apr 2016, 13:57    Post subject:  

Very exciting work...

Great...

I cross my fingers for the configuration for the hotspot to be in a way where clients are rerouted to for instants a local webserver---
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
corvus


Joined: 12 Jun 2015
Posts: 128
Location: In the peninsula shaped like a boot.

PostPosted: Thu 14 Apr 2016, 15:24    Post subject:  

Hi Stemsee, tried wifi-connect,ethernet connection and wifiprofi, hade no issues to connect or disconnect, as before. Below the terminal outputs:

Code:
# wifi-connect
killall: wpa_supplicant: no process killed
killall: dhcpcd: no process killed
dhcpcd[25080]: version 5.5.6 starting
dhcpcd[25080]: all: not configured to accept IPv6 RAs
EXIT="Exit on timeout"
dhcpcd[25080]: no interfaces have a carrier
dhcpcd[25080]: forked to background, child pid 25114
/usr/sbin/wifi-connect: line 135: LegioXXI|Can: command not found
Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
EXIT="Exit on timeout"
EXIT="Exit on timeout"
EXIT="Exit on timeout"

Code:
# wifiprofi
rm: cannot remove ‘/tmp/profs’: No such file or directory
EXIT="Exit on timeout"
rm: cannot remove ‘/tmp/profiscan’: No such file or directory
EXIT="Exit on timeout"
Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
dhcpcd[4548]: version 5.5.6 starting
dhcpcd[4548]: all: not configured to accept IPv6 RAs
EXIT="Exit on timeout"
dhcpcd[4548]: wlan0: broadcasting for a lease
dhcpcd[4548]: eth0: waiting for carrier
dhcpcd[4548]: wlan0: offered 192.168.1.121 from 192.168.1.1
dhcpcd[4548]: wlan0: acknowledged 192.168.1.121 from 192.168.1.1
dhcpcd[4548]: wlan0: checking for 192.168.1.121
EXIT="Exit on timeout"
dhcpcd[4548]: wlan0: leased 192.168.1.121 for 86400 seconds
dhcpcd[4548]: forked to background, child pid 4761
EXIT="Exit on timeout"

Is it possible to have an wifiprofi menu entry ?
Still no browser icon as shown below.

Regards.

P.S.: How do I write something after the image ?
wifi-connect_tray.jpg
 Description   
 Filesize   28.27 KB
 Viewed   263 Time(s)

wifi-connect_tray.jpg


_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Fri 15 Apr 2016, 01:41    Post subject:  

Wifiprofi menu entry added and eduwifi entry and script removed ... as wifi-connect does a better job!

I am now working on the HotSpot element.

Thanks for testing!
Back to top
View user's profile Send private message MSN Messenger 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Fri 15 Apr 2016, 01:45    Post subject:  

corvus wrote:

P.S.: How do I write something after the image ?


Do you mean in the tray menu?

Like this
Code:
MENU="Text!command!image.png|text!command!image.png|"

That is the format. Using variables in any position is ok too.
Back to top
View user's profile Send private message MSN Messenger 
stemsee

Joined: 27 Jun 2013
Posts: 2276
Location: In The Way

PostPosted: Fri 15 Apr 2016, 02:27    Post subject:  

browser icon and wifiprofi menu (eduwifi removed)! Menu entry corrected for ~/Startup/defaultwifi script generated by wifi-connect when default checkbox selected.

see few posts on

Last edited by stemsee on Fri 15 Apr 2016, 15:02; edited 1 time in total
Back to top
View user's profile Send private message MSN Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 15 Apr 2016, 03:17    Post subject: Just discovered your topic to-day. I will test.  

Wifi tolls are a lot now. Pwireless, frisbee, peasyWifi, Peasyconnect.
Wifi-connect 2016... Nothing against, but take care they don't fight one each other. Then, wireless connection stops and restarts
It's necessary to kill absolutely all wireless tools before launching a a new searcH
Just discovered your topic to-day. I will test. I use Hot-spots, being far from my wife... and my ADSL box.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 2 of 10 [145 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0687s ][ Queries: 12 (0.0132s) ][ GZIP on ]