Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Jul 2016, 23:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
kde4 SFS for slacko64
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
dannydiff


Joined: 28 Feb 2016
Posts: 3
Location: PA, USA

PostPosted: Sun 20 Mar 2016, 22:08    Post subject:  kde4 SFS for slacko64
Subject description: sfs kde4
 

I have made a kde4 layer. It was made from alienbobs ktown. I have updated this to a slimmer version. I have removed soprano, kmix, nepomuk file indexer and akondi. Kde-Services have also been removed. Thanks to all the help from the porteus family. **Note using minimalistic SPLASH screen WILL cause this To crash.. use simple or simple small or none....**

pic kde with kde-breeze

download here:https://www.dropbox.com/s/d1j1q0b1etb8wec/kde-4.14.3-slimmer_slacko64.sfs?dl=0

I am also releasing my version of kde4-breeze.
download here: https://www.dropbox.com/s/ffb3c53bl5y3ana/breeze-kde4-5.5.5-1-x86_64.sfs?dl=0

To help with the Konsole build for kde I'm releasing some extras to help.

libpng: https://www.dropbox.com/s/mexp6lqs2rwidps/libpng-1.6.21-1-x86_64_6.0.sfs?dl=0

libicu48: https://www.dropbox.com/s/sbz38ax25jbodpl/Libicu48_x86_64_6.0.sfs?dl=0

xcb: this helps with the effects in KDE. If you aren't familiar with OpenGL. To use open effects in KDE. Switch renderer to xrender.
https://www.dropbox.com/s/48051p9upab4a5t/xcb-dannydiff_6.0.sfs?dl=0

Any help with the kde layer would be great. I mean that.. I have done all of this myself! ..

You may have to run (well you will have to), kdeinit4 in terminal, this builds the kde library. Sometimes this doesn't fix everything. (if that happens) .. try xinit kdm. Then xwin startkde.

You Can try running various Qt/KDE commands such as "qdbus", "kde4-config --prefix" and "kreadconfig --file kdeglobals --group General --key widgetStyle" on console to verify there is no problem with your base Qt/KDE installation.

If all else fails run kwrapper4 ksmserver in konsole or your console and see what builds.

edit.. Look I know to some this is a no brainer but I have already had question's about this so... YES you need QT4 to use KDE4 layer. QT4 is NEEDED! hope this clears that question up.

_________________
Quote:
"Most people do not really want freedom, because freedom involves responsibility, and most people are frightened of responsibility." Sigmund Freud ..

Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0389s ][ Queries: 11 (0.0051s) ][ GZIP on ]