Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Jul 2016, 23:40
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[RESOLU] terminal inutilisable
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
calixtus06

Joined: 12 Dec 2014
Posts: 96

PostPosted: Wed 16 Mar 2016, 12:36    Post subject:  [RESOLU] terminal inutilisable  

Re bonjour,

Je ne parviens pas à utiliser le terminal, pourquoi ? Je suis débutant

Merci d'avance

Nicolas[/img]
terminalinutilisable.png
Description 
png

 Download 
Filename  terminalinutilisable.png 
Filesize  111.52 KB 
Downloaded  36 Time(s) 

Last edited by calixtus06 on Mon 02 May 2016, 11:08; edited 1 time in total
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 548
Location: France

PostPosted: Wed 16 Mar 2016, 12:51    Post subject:  

Bonsoir Nicolas,

Le terminal fonctionne mais les applications comme apt-get etc. n'existent pas normalement sous Puppy Exclamation
De plus comme l'indique le "#" pas besoin de sudo, Puppy étant en root Wink


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
calixtus06

Joined: 12 Dec 2014
Posts: 96

PostPosted: Fri 18 Mar 2016, 18:47    Post subject:  

M�dor wrote:
Bonsoir Nicolas,

Le terminal fonctionne mais les applications comme apt-get etc. n'existent pas normalement sous Puppy Exclamation
De plus comme l'indique le "#" pas besoin de sudo, Puppy étant en root Wink


Cordialement,
Médor.


quelles sont les commandes du coup pour l'équivalent de uddate, upgrade, auto remove entre autre ?

Merci
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 548
Location: France

PostPosted: Fri 18 Mar 2016, 18:57    Post subject:  

Bonsoir Nicolas,

Sous Puppy il y a un menu graphique pour le gestionnaire des paquets/PPM (Puppy Packages Manager) dans le Menu » Configuration
On peut aussi le lancer dans un terminal par la commande : ppm


Cordialement,
Médor.
Capture_2016-03-19(1).jpg
 Description   
 Filesize   109.51 KB
 Viewed   153 Time(s)

Capture_2016-03-19(1).jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
calixtus06

Joined: 12 Dec 2014
Posts: 96

PostPosted: Tue 22 Mar 2016, 08:29    Post subject:  

M�dor wrote:
Bonsoir Nicolas,

Sous Puppy il y a un menu graphique pour le gestionnaire des paquets/PPM (Puppy Packages Manager) dans le Menu » Configuration
On peut aussi le lancer dans un terminal par la commande : ppm


Cordialement,
Médor.


Salut Médor,

Je ne comprends pas le rapport entre ppm et l'intervention dans le terminal pour l'équivalent des update, upgrade, autoremove etc

Merci pour tes précisions

Nico
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 548
Location: France

PostPosted: Tue 22 Mar 2016, 13:10    Post subject:  

Bonjour Nicolas,

L'utilitaire apt-get de Debian pour la manipulation des paquets en ligne de commande n'est pas intégré normalement dans Puppy Exclamation
Donc les options de apt-get comme apt-get update, apt-get upgrade, apt-get install, etc. sont donc introuvables (command not found) Wink

Les commandes seules : update et upgrade, n'existent pas Exclamation
Par contre en tapant up imédiatement suivi de deux appuis sur la touche TAB, ça sort les commandes existantes up* :
Code:
root@pctoutou ~
# up
update-ca-certificates     update-mime-database
updatedb                   updatenetmoduleslist.sh
update-desktop-database    update-pango-querymodules
update-gdk-pixbuf-loaders  updates_mgr
update-gtk-immodules       update-usbids.sh
update-gtk-immodules-2.0   uptime
root@pctoutou ~
# up


La commande autoupdate existe que si l'on a installé le devx.sfs spécifique à la version de Puppy utilisée qui contient le nécessaire pour la compilation des programmes Exclamation
Quote:
root@pctoutou ~
# autoupdate --help
Usage: /usr/bin/autoupdate [OPTION]... [TEMPLATE-FILE]...

Update each TEMPLATE-FILE if given, or `configure.ac' if present,
or else `configure.in', to the syntax of the current version of
Autoconf. The original files are backed up.

Operation modes:
-h, --help print this help, then exit
-V, --version print version number, then exit
-v, --verbose verbosely report processing
-d, --debug don't remove temporary files
-f, --force consider all files obsolete

Library directories:
-B, --prepend-include=DIR prepend directory DIR to search path
-I, --include=DIR append directory DIR to search path

Report bugs to <bug-autoconf@gnu.org>.
GNU Autoconf home page: <http://www.gnu.org/software/autoconf/>.
General help using GNU software: <http://www.gnu.org/gethelp/>.
root@pctoutou ~
#



Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
calixtus06

Joined: 12 Dec 2014
Posts: 96

PostPosted: Wed 27 Apr 2016, 11:15    Post subject:  

salut, j'ai pas trop compris ce que signifiait les réponses à la commandes up. J'ai bien tapé up et deux clic sur tab mais ensuite que faut il faire pour updater la liste des paquets et upgrader les paquets voire puppy ??

merci à toi si tu repasse par là
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0505s ][ Queries: 12 (0.0060s) ][ GZIP on ]