Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile       

The time now is Sun 09 Aug 2020, 02:59
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Slacko5.7-eee2017 and mini-eee
Moderators: Flash, JohnMurga
Post new topic   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 3 of 4 [50 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Sun 28 Aug 2016, 00:24    Post subject: libgcrypt 1.5.6 update
Subject description: RNG compromised
 

This update applies to both the 2017-eee and mini-eee.

From slackware 14.0 security updates...

patches/packages/libgcrypt-1.5.6-i486-1_slack14.0.txz: Upgraded.
Fix critical security bug in the RNG [CVE-2016-6313]. An attacker who
obtains 580 bytes from the standard RNG can trivially predict the next
20 bytes of output. (This is according to the NEWS file included in the
source. According to the annoucement linked below, an attacker who obtains
4640 bits from the RNG can trivially predict the next 160 bits of output.)
Problem detected by Felix Doerre and Vladimir Klebanov, KIT.
For more information, see:
https://lists.gnupg.org/pipermail/gnupg-announce/2016q3/000395.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-6313
(* Security fix *)
================================================================

A symlink patch is needed in /lib
Remove libgcrypt.so.11.8.4
Right-click on libgcrypt.so.11.8.5 --> link (make sure relative box is checked)
Change the 5 to a 4 --> OK
The new symlink is made

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 28 Aug 2016, 23:33    Post subject: I will download the last version 2017.
Subject description: puppy_slacko_5.7.sfs: 139 M (2016)
 

I will download the last version 2017. What to do with ? renew my Slacko 5.5 fat which is too big . My goal is to find a Slacko without useless libs to add my stuff (useful libs) for applications as Gramps, Datacrow, and others database to manage my collections at home.
s57-2016eee.iso: 144 M that was perfect.
2017 downloading to-day
A laptop can be used outside, with public wireless connection.That is my case. My box is far 600 kms; Frisbee asks for password, SNS does not see wlan0, only eth0, so i used douglas wizard, which works.
I hope my pupsaves Slacko 5.5 will be usable with eee2017... feed back soon

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Wed 31 Aug 2016, 04:43; edited 2 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 29 Aug 2016, 00:39    Post subject: Slackosave from 5.5 is updated 5.7 at boot,
Subject description: keyboard fr, python, Gramps
 

Frisbee and PeasyWifi don't do their job, but Douglas wizard is enough.. Users don't like to ask questions, one tool is efficient, we use it. No time to loose Exclamation to translate my feed-back about Linux bugs in foreign English language, i don't understand error messages written in terminal when lauching frisbee.
Frisbee removed from builtin packages replaced by Frisbee-pelotux.pet: 453 K from my personal tools. but no better results, empty result when searching access points. It's Linux headache !

Sqckosqve from 5.5 is updqted 5.7 qt boot,
keyboard fr to activate each session.... wait and see (efficient no trouble Smile )
Background seems to be Ha Long Bay in Vietnam.. I am surprised to receive postcards from there with stamp 'Saïgon" on it (20jun2016) and not Ho Chi Minh Ville Shocked
No background menu ? i changed it by right click on a desktop icon, then add backdrop.

goffice-lucid-528-ja-2.sfs: added as office tool, big enough to get a text typing application and the so powerfull clone of Excel, Gnumeric
FF27 is enough and a good choice. Wireless settings are kept when rebooting and my keyboard fr too Smile Cache is set at 50mb , well.
i Think my Slacko 5.7 is ready now to begin to work for my Gramps and Datacrow, among other Puppy passenger's hobbies.
As :
Gramps is a software package designed for genealogical research. Although similar to other genealogical programs, Gramps offers some unique and powerful features.
Gramps 3.4.1 is available from the Packages Salix and will need 91MB, with all dependancies. Serveur en Allemagne. Gramps is a professional application, very pleasant to fulfil. But big. Users should search other apps with same dependancies, to get them worth of place they occupy.
# gramps
/usr/bin/gramps: line 28: exec: python2: not found Evil or Very Mad
Help from Puppy Linux Germany
SFS by RSH (LazyPuppy) starts without any trouble ! LP2_Gramps-3.4.1.sfs: 13 M

OpenShot has failed to import some of the Python files or libraries
required for our application to run. Here are some trouble shooting
tips:


No google search ???? Duck Duck go in bookmarks
Gramps.jpg
 Description   Merci Lazy Puppy !
 Filesize   75.01 KB
 Viewed   539 Time(s)

Gramps.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Mon 29 Aug 2016, 21:31    Post subject:  

Quote:
Background seems to be Ha Long Bay in Vietnam.. I am surprised to receive postcards from there with stamp 'Saïgon" on it (20jun2016) and not Ho Chi Minh Ville Shocked
No background menu ? i changed it by right click on a desktop icon, then add backdrop.


That is correct Pelo... Ha Long Bay near Ho Chi Minh City.
Backgrounds in /root/my-applications/MyFiles (panoramio pix... some must give credit to author)

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 30 Aug 2016, 14:02    Post subject: I keep this version, after having tasted newer  

I keep this version, after having tasted newer. It fits my needs. Perhaps there will be better, but i don't need more.
I am rather more searching older Puppies, young ones just born are big and not pretty, bah.. Sad
Retrovol and alsamixer : check there, Tick bars as they should be. (master is virgin. blank) , ... if you need sound, of course.
Roger.jpg
 Description   Drive Mounted : higher than not mounted
 Filesize   48.65 KB
 Viewed   472 Time(s)

Roger.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
benvoliozf

Joined: 02 Sep 2016
Posts: 1

PostPosted: Fri 02 Sep 2016, 09:55    Post subject:  

Hi all.

Super beginner here. I'm having a little bit of a problem. Embarassed

I was able to get this on my eee pc no problem via usb stick. It ran exactly how I wanted and I loved the interface. I prefered frisbee to manage wlan.

I partitioned my SSD wanting part of it to be just for puppy. However, when I went through the puppy install wizard, everything went fine except when it wanted me to run some GRUB instructions. I was not able to locate a grub application to launch, and was not able to boot from the partition when I tried.

What am I missing here.

Thanks all for your time! Thanks for the effort you put into usability-focused distros for old hardware; you're a godsend! Very Happy
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Fri 02 Sep 2016, 11:00    Post subject:  

have a copy of the iso on the usb stick

click the iso file to expand

copy all files to a suitable folder on your partition

run grub4dos to install boot loader

reboot

sorted!

Smile
Back to top
View user's profile Send private message Visit poster's website 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Sat 17 Sep 2016, 20:26    Post subject: Slackware updates  

Recently there has been two updates in the slaacware 14.0 repository
The First is to curl as version 7.50.3. This is buffer-overrun protection.

The Last is gnutls as 3.3.34. THis is general patch and update (nothing special mentioned).

The documentation can be removed in usr/doc.

***EDIT*** One symlink patch needed;
/usr/lib/gnutls.so.28.41.9 is removed, and a symlink is made using gnutls.so.28.41.16 by replacing the 16 with 9 (make sure relative box is checked)

Regards
8Geee

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Thu 22 Sep 2016, 19:49    Post subject: opensslsecurity update
Subject description: both versions
 

As of today Sept.22,2016 there is an important security update needed to
openssl 1.0.2.h ---> i version. In these Puppy Slacko5.7 spins
(5.7-2017, eee-2017, mini-eee, and EONS-2017) the end-user must go to
slackware.com and proceed as follows;

Click on seurity advisory
Click on 2016
near top of list find and click openssl update
At the bottom of listings, find current_version
a.) highlight and copy (CTRL+C) the "solibs"
b.) in the address bar of browser highlight and SHIFT+INS
When asked "open with pupzip", then click YES
puppy package manager will install
Repeat the a.) and b) steps for openssl 1.0.2i package, open with pupzip,
and it will install the 1.0.2i package.
The DOC files in /usr/docs can be deleted (saves a lot of space)
Close browser, disconnect from internet, and shutdown.
Wait about 1 minute and restart.

Regards
8Geee

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."

Last edited by 8Geee on Sun 02 Oct 2016, 21:10; edited 1 time in total
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Sun 02 Oct 2016, 21:06    Post subject: openssl update to "J"  

There is another critical update to openssl 1.0.2, this time from I to J.
All of the slacko5.7-2017 spins need this patch, as the threat level is high.

The instructions in post above will guide to a proper patch.

Regards
8Geee

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 05 Oct 2016, 04:41    Post subject: Slacko5.7-eee2017 and mini-eee, and hungarian Legopen  

I am running the hungarian Slacko Legopen kernel 3.4.82 which is a Puppy looking like Windows..
I should say it is your Slacko 5.7, 8Geee. Some devs leave after having done their own version of a Puppy, so did pFranz, with legopen
legopen.jpg
 Description   gramps added by me
 Filesize   15.66 KB
 Viewed   330 Time(s)

legopen.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Sun 06 Nov 2016, 21:15    Post subject: X11 slackware update  

I have finally resolved a bug while D/L the X11 series (10 files!) of updates recomended by Slackware through the Puppy Update Manager (Slackware updates in menu).

As preamble, make sure Puppy Package Manager is freshly updated. Then upon selecting the Updates from Slackware, such list is new. Since this update is buggy, make copies of personal data, and Firefox configuration with storage elsewhere, not in the drive affected by this update. If you haven't remastered in a while, now is a good time to do so... if the update does fail, the new remaster can be loaded. Else you might find yourself having to do a series of updates BEFORE attempting this one again. Shocked

There are two distinct things I noticed upon a successful attempt;

1.) DO NOT USE THE BROWSER... use the update program only.
2.) DO NOT load the X11 file until last... in short update from the BOTTOM of the list to the top, this ensures that the X11 update is LAST.

Make sure while performing these updates that all messages clear before proceeding to the next update. When finished, disconnect from the internet, and shutdown.

After the restart, You may clear /usr/doc files, and move /root/.packages files into the builtin folder.

Hopefully, this will work for all in need.

Regards
8Geee

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Tue 08 Nov 2016, 22:08    Post subject: Curl 7.51 update  

Right after posting about the X11 updates, yet another reminder that CURL has also been updated from 7.50.3 to 7.51.0. This update involves cookies, so it should be done if using curl.

This update does not need any symlink patches, and the /usr/doc file file may be deleted.

Regards
8Geee

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 2190
Location: N.E. USA

PostPosted: Sat 03 Dec 2016, 21:55    Post subject: firefox SVG image warning  

There is a rather nasty bug found in firefox, about how it handles an SVG type image. AFAIK this is not related to the OS, just the browser. The topic is addressed in the security forum.

A partial remedy/simple patch can work using this method. The only caveat is the new step #8 that involves copy/paste of the header. That requires opening Geany first, do the copy/paste there, and then close browser, disconnect, and proceed.

Regards
8Geee

_________________
Linux user #498913 "Some people need to reimagine their thinking."
"Zuckerberg: a large city inhabited by mentally challenged people."
Back to top
View user's profile Send private message 
T_B

Joined: 08 Apr 2007
Posts: 160

PostPosted: Wed 28 Dec 2016, 10:53    Post subject:  

hi - anyone tried recently to run Kodi successfully on an eeepc700? I am interested in using it to stream video from my desktop with UMS

With UMS I can transcode any video and play it on my cheapo tablet. Would fun to see if it works with puppy as well. Kodi has a built in upnp media client that is very easy to use. I am using Kodi 16.1
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 4 [50 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0864s ][ Queries: 12 (0.0227s) ][ GZIP on ]