Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 08 Dec 2016, 08:29
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Fatdog64 and Lexmark Optra T612 solved
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Mon 21 Dec 2015, 21:20    Post subject:  Fatdog64 and Lexmark Optra T612 solved
Subject description: driver
 

Howdy. I have a motherboard asus p9x79 le and a gpu amd r9 285 with 16GB of ram. I have fatdog64 multisession running just fine.

I have tried to get my printer Lexmark Optra T612 running a few days but no luck so far.
Lexmark's site has drivers for the following: deb looks good?
AIX [8]
COMPAQ TRUE64 [2]
DEBIAN [3]
FEDORA [7]
HPUX [5]
LINPUS [3]
LINSPIRE [1]
MINT 11 [1]
OPENSUSE [4]
PCLINUX [2]
REDFLAG [8]
SUSELINUX [6]
UBUNTU [6]
The number is how many versions.
I've tried Mint and Debian but no luck. I think the installer is wrong.
Any hints?

Last edited by T42 on Wed 30 Dec 2015, 14:41; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Mon 21 Dec 2015, 22:48    Post subject:  

The Lexmark driver you are downloading is x86-32bit and you are running a 64-bit OS. So it won't work.

But your printer appears to be Postscript-capable, so all it needs is a PPD file

1. Go here and search for your printer.
2. Download the PPD file named Lexmark-Optra_T612-Postscript.ppd.
3. Copy the file to /usr/share/cups/model.
4. Run the CUPS setup.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6731
Location: Earth

PostPosted: Tue 22 Dec 2015, 00:46    Post subject:  

I have a century old (so it seems) IBM-Lexmark 522 that has the same print features as you. The PCL5/6 and the PS does work as well as the IBM print stream protocol.

Can I assume you have your printer LAN connected and not attempting to USB connect your printer?

If so, I have found that both and HP5Si as well as Generic Postscript also work. You "may" want to install a separate PUP printer representations on your FATDOG for each stream and compare the test-page output to determine which print quality you find is best.

Hope this helps.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Tue 22 Dec 2015, 11:51    Post subject:  

rcrsn51 I used the PPD in the cups internet site installer yesterday.
"print test page" printer is unresponsive.
Added the PPD file to user/share/cups/model .
There is no run cups setup as there is no cups program- just the internet site.
So I went on the site again and went through the install again. \
"printer is not responding"
Back to top
View user's profile Send private message 
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Tue 22 Dec 2015, 12:04    Post subject:  

gcmarten The printer is on a lan working with 10 or so boxes from Win 3.1 to Win 7. IP is 192.168.0.151. I can see it in my browser.

Where is the "device manager" or the "control panel" so I can see the printers properties?
I think I need a slackware driver for it to work. 64 bit, as there is no "WOW" in Fatdog.
When I tried the Lexmark drivers the error was "bad filters" or some such.
Thank you both for your replies.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Tue 22 Dec 2015, 12:24    Post subject:  

@T42:

1. Because you have been installing the official Lexmark driver, you may have messed up your system. You need a clean install of Fatdog.

2. Copy the PPD file to /usr/share/cups/model.

3. By "CUPS setup", I mean the CUPS web interface at localhost:631 that you are already using.

4. Because this is a networked printer, CUPS should auto-detect it. Is that true?

5. If you select it and follow the steps, you should see your printer listed under Make/Model.

6. When setting up networked printers, a good trouble-shooting step is to first connect by USB.

It may be that your printer's own control panel has a setting that enables Postscript. If you can't find it, you may have to install it with a PCL driver.

In the CUPS setup under Make, choose Generic. Then choose one of the PCL models.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6731
Location: Earth

PostPosted: Tue 22 Dec 2015, 20:40    Post subject:  

As you indicate, the printer works as expected on other systems, but not this distro, as you are unable to get print output as expected.

Would you:
  • Open the printer's webpage and look to see what print streams are "On". Ensure that all of the print streams are oven.

  • On a Windows PC look to see which print stream is being use as the default. In most cases, it should show PCL5/6 OR Postscript.

  • On your FATDOG, using your browser, go to URL "localhost:631" to open the CUPS printer setup (same as what @Rcrsn51 suggests). Using it, it should show you all LAN printers that the PC can see. If not, you will have to setup and test the printer by manually entering its IP address and selecting a suitable "lookalike" assuming you do not see a Lexmark specific. ALSO, you can use the IBM printer 40xx series as these printers have the same printer server engine technology as the Lexmark 50xx and 6xxx printers.
If no data is coming out at all, I may have another test idea that you can run. But, results of these should yield some info that can be helpful toward a resolution.

Hope this is helpful

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Thu 24 Dec 2015, 13:23    Post subject:  

@ rcrsn51 Cups doesnt autodetect the Optra T , but detects three newer printers.
USB connection impossible.
@gcmartin All the boxes are set up with Optra T612(MS) not T612(PS) being that they are all windows.
I got the printer working in Puppy Lucid months ago.
Anyways I'm off and wont be back for a while. If I get it working ,I will get back to you. Thank you both for your help.
mal
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Thu 24 Dec 2015, 13:29    Post subject:  

T42 wrote:
I got the printer working in Puppy Lucid months ago.

Then you need to boot up Lucid again and see what procedure worked. Did you use the Lexmark driver package?
Back to top
View user's profile Send private message 
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Sun 27 Dec 2015, 14:21    Post subject:  

In Puppy I used cups. I chose Optra E.
The driver I chose was :
1 description Lexmark Optra T612
2 location try
3 driver: Lexmark Optra E - CUPS+Gutenprint v5.2.5 (grayscale, 2-sided printing)
4 connection http://192.168.0.151:631/ipp/
5 defaults: blah blah blah
I got Mint 17.3 working by using the Optra T612 that was shared on a win 98 box. But all efforts to try direct failed . The Puppy settings failed as well because Mint cups could not supply the driver [number 3].
Goggling number 3 yields no results. Searching cups or gutenprint = nothing.
Mint has v5.2.1 pre2, but it doesnt work.
Will get back to Fatdog soon and try Puppy's settings.
Back to top
View user's profile Send private message 
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Sun 27 Dec 2015, 15:00    Post subject:  

I tried Puppy's settings in Fatdog but it had only the v5.2.1 driver not v5.2.5.
Good thing about Linux is if something doesnt work in one distro, there are lots to choose from.
My printer works in RedHat 9, Core 2, early Ubuntu, Puppy Lucid, Mint Rosa.
I am trying to escape from Microsoft Win 7 .
My good ones, win XP x64 are aging. Smile
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Sun 27 Dec 2015, 15:33    Post subject:  

Just to be clear: Fatdog's version of Gutenprint doesn't have a Lexmark driver that works with your printer?

Did you try any of the HP PCL drivers instead?

Quote:
I tried Puppy's settings in Fatdog but it had only the v5.2.1 driver

[Edit] Fatdog64-700 has v5.2.10 and it also supports the Lexmark Optra E. So I am unclear as to your problem.

----------------------

Last edited by rcrsn51 on Mon 28 Dec 2015, 19:58; edited 3 times in total
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6731
Location: Earth

PostPosted: Sun 27 Dec 2015, 16:56    Post subject:  

If you see an HP 5xi, if should also work with the Optra Tseries. You can use either PCL or PS as well as duplexing, if needed.

I have never used a USB laser in the last decade. So not much help. All lasers have been LAN connected wired/wireless.

One other option is to send the datastream raw and let MS do all the work to proper datastream to the printer. In this way, the MS machine becomes a print server for the LAN printer(s) you have.

Same can be done should you have any one of the mentioned Linuxes running on your LAN that print correctly. They too, via SAMBA, can be an intelligent print server, as well.

It seems the problem you are having is getting your PUP applications to create a printer datastream that the printer properly interprets.

Question
With the print queue open on your desktop you should be able to see what happens when a print stream is sent to the printer. Do you see the stream arrive then the printer queue go empty? Or are you seeing the stream arrive and "sit" in the queue without printing?

Which?

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
T42

Joined: 02 Jun 2015
Posts: 14

PostPosted: Wed 30 Dec 2015, 14:28    Post subject:  

The printer now works in Fatdog and Mint with the one little nag:
"Status: waiting for printer to finish" in the printer choices.

In Windows I could install the printer using the URL, not so with CUPS.
I replaced the printer motherboard about 5 years ago. The new board was password protected-I didnt know. Windows didnt care.
Yesterday I was playing with the Lexmark EWS and couldnt get anywhere-asking for name and password.
So I reinitalized the nvram and killed the name and password requirement.

Today CUPS saw my printer under "add printer" and Bobs your uncle! I used the PPD file named Lexmark-Optra_T612-Postscript.ppd.

I was trying to delete a Samsung printer in my printer choices that I accidentally added with CUPS in this battle.
The Samsung doesnt show up anywhere except when you try to print something and it is in the printer choices.
Thank you for your patience. mal
edit Jan 5
The Samsung printer name was SECXXX. 25 letters and numbers.
Could not find that name with any search method in Fatdog.
Found grep -r on the net. It found where the name was immediately.
Changed text from cups=1 to cups=0 Problem solved
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1232s ][ Queries: 11 (0.0093s) ][ GZIP on ]