Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile       

The time now is Sun 09 Aug 2020, 01:50
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
tahrpup 6.0 & 6.0.2 CE
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
superchook

Joined: 13 Mar 2006
Posts: 117
Location: Sydney, Australia

PostPosted: Tue 24 Nov 2015, 08:07    Post subject:  tahrpup 6.0 & 6.0.2 CE
Subject description: Error in PPM package description
 

While investigating the mom macros for groff I found that although the package description for the groff_1.22.2-5 package in the Puppy Package Manager said:

[ubuntu-trusty-main](ALREADY INSTALLED) GNU troff text formatting system

it was not in fact installed. It was possible to install it by selecting the package and clicking "Do it!". If you try this after the package has been installed you get a warning dialog.
There was a similar error with perl_5.18.2 and perl-modules_5.18.2

I do not know if this is a problem with the tahr 6.0.3 distribution or the PPM or the Woof CE build system. I have found similar errors in the slacko64 6.3.0 distribution although the package names are of course different due to the different package breakdowns in Debian and Slackware.
Back to top
View user's profile Send private message 
DJ Puppio


Joined: 25 Nov 2015
Posts: 23

PostPosted: Mon 30 Nov 2015, 01:43    Post subject: Weirdness with Spot and Pale Moon 25.8.0(X86)
Subject description: Updating browser may have caused some issues
 

Tahrpup 6.0.2 - running off flash drive, savefile on hard drive

Okay, so I installed the most recent version of Pale Moon.


This behavior pertains to the mouse....
If I click on the Desktop "Browse" icon, I get Pale Moon 25.8.0, using the aero mouse cursor theme. This is the correct version of the browser and the correct cursor theme..

Now, I have the run-as-spot script on my desktop. This runs Pale Moon for Spot if I drop the Browse icon on it. See attached pic.

It does indeed run Pale Moon. And it runs the correct version (25.8.0). But then Pale Moon ends up using the ORIGINAL cursor theme. This is incorrect. It should be using the Aero cursors.


This behavior pertains to Spot...
Not sure if the browser update messed up Spot. I can download and upload root directory files to OneDrive. These are files not in Spot's home folder. Should I be able to do that? I'm pretty sure I couldn't do this with the previous version of Pale Moon.

Note that I ticked "Run internet apps as spot" in Quick Setup. I also use the run-as-spot script.
capture26999.png
 Description   
 Filesize   57.69 KB
 Viewed   292 Time(s)

capture26999.png

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Mon 30 Nov 2015, 02:08    Post subject:  

Try setting up Spot by:
menu->System->Login and Security Manager

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
DJ Puppio


Joined: 25 Nov 2015
Posts: 23

PostPosted: Mon 30 Nov 2015, 08:00    Post subject:  

Yeah, I've done that previously. Pale Moon has the check mark next to it to run apps as spot. But I can go right to OneDrive (from Hotmail) and download a document to Root.


I had actually stopped using the run-as-spot script. I only started trying to use it again when I started to suspect that spot had gained elevated privileges somehow..
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 2202
Location: London, England

PostPosted: Mon 30 Nov 2015, 09:04    Post subject: Re: Weirdness with Spot and Pale Moon 25.8.0(X86)
Subject description: Updating browser may have caused some issues
 

DJ Puppio wrote:
[But then Pale Moon ends up using the ORIGINAL cursor theme. This is incorrect. It should be using the Aero cursors.


If you are running the browser as spot then the HOME directory will have been changed from /root to /root/spot

The cursor theme images need to be found in your HOME directory in a sub-directory named .icons (has a dot so is hidden)

If you want the themed cursor to appear in the browser the best way is to symlink the .icons directory from /root into /root/spot and then restart X

_________________
Oscar in England

Back to top
View user's profile Send private message 
DJ Puppio


Joined: 25 Nov 2015
Posts: 23

PostPosted: Mon 30 Nov 2015, 19:12    Post subject:  

Okay. That fixed the cursor issue. Thank you very much.

I must apologize to the OP. I don't know how my report got into this small thread. I was sure I put it in the larger bug report thread...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0410s ][ Queries: 12 (0.0099s) ][ GZIP on ]