Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 28 Jun 2017, 15:27
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPupSc - Woof-CE, Slackware-Current, LXDE experiment
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 51 [751 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 49, 50, 51 Next
Author Message
Marv


Joined: 04 May 2005
Posts: 817
Location: SW Wisconsin

PostPosted: Thu 26 Nov 2015, 13:04    Post subject:  

Got around to testing 15.11.03 on my Bay-Trail machine (Asrock Q1900M mobo with intel j1900 quad core processor, RTL8168g chipset ethernet, intel 4000 HD graphics, 4Gb RAM, 80Gb SATA HDD).

Frugal Grub4Dos install booted cleanly. Video, sound, mouse, USB all perfect. The RTL8168 would not connect until the patch in the attached pet was applied. Once that was done and the correction in post#2 applied and hplip 3.14.10 installed, the HP4500 set up but would not print (see my post above).

without patch:
Code:
# dmesg | grep r8169                                                                               
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
r8169 0000:04:00.0 eth0: RTL8168g/8111g at 0xf893c000, d0:50:99:20:e4:05, XID 0c000800 IRQ 91
r8169 0000:04:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
r8169 0000:04:00.0: Direct firmware load for rtl_nic/rtl8168g-2.fw failed with error -2
r8169 0000:04:00.0: Falling back to user helper
r8169 0000:04:00.0 eth0: unable to load firmware patch rtl_nic/rtl8168g-2.fw (-11)
r8169 0000:04:00.0 eth0: link down
r8169 0000:04:00.0 eth0: link down
r8169 0000:04:00.0 eth0: link down


with patch:
Code:
# dmesg | grep r8169
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
r8169 0000:04:00.0 eth0: RTL8168g/8111g at 0xf86f4000, d0:50:99:20:e4:05, XID 0c000800 IRQ 90
r8169 0000:04:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
r8169 0000:04:00.0 eth0: link down
r8169 0000:04:00.0 eth0: link down
r8169 0000:04:00.0 eth0: link down
r8169 0000:04:00.0 eth0: link down
r8169 0000:04:00.0 eth0: link up


Code:
Motherboard Vendor: ASRock
Product Name: Q1900M

Intel(R) Celeron(R) CPU J1900 @ 1.99GHz
Max Speed: 2416 MHz
Current Speed of Core 0:2416 MHz, 1:2415 MHz, 2:2415 MHz, 3:2415 MHz
Core Count: 4
Thread Count: 4

Memory Allocation:
 Total RAM: 3494 MB
 Used RAM: 989 MB
 Free RAM: 2505 MB
 Buffers: 93 MB
 Total Swap: 0 MB
 Free Swap: 0 MB

Linux Kernel: 4.2.5-EmSee-32-pae (i686)
Kernel Version: #1 SMP Mon Nov 2 10:21:44 GMT 2015
PAE Enabled: Yes

Distro: Slacko-C Puppy 15.11.3
Desktop Panel: lxpanel 0.6.0-r694
Window Manager: Openbox 3.6.1
Desktop Start: xwin startlxde

OpenGL 2D/3D Rendering:
• Direct Rendering: Yes
• Vendor: Intel Open Source Technology Center
• Renderer: Mesa DRI Intel(R) Bay Trail x86/MMX/SSE2
• Version: 3.0 Mesa 11.0.5

RTL8186g/8111g ethernet chip

Class
• Device
• VendorID=10ec  DeviceID=8168  Rev=11
• Kernel Driver=r8169
• Kernel Module=r816

PRINTERS

DefaultPrinter CUPS-PDF
Printer HP4500



I've tried fiddling around with firewall and firewall settings, also swapped in the slackocurrent kernel but still no printing. Jobs aren't spooled... Got the same behavior in slacko 6.3.0, printer set up fine, just won't print.

Edit: The firmware files are in /lib/firmware of slacko 6.3.0 so also could be taken from there.
RTL8168_patch.pet
Description  RTL 8168 firmware from X-slacko 3.1n
pet

 Download 
Filename  RTL8168_patch.pet 
Filesize  10.5 KB 
Downloaded  171 Time(s) 

_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 817
Location: SW Wisconsin

PostPosted: Thu 26 Nov 2015, 16:51    Post subject:  

Another quirk on both of my machines:
In Puppy Setup, clicking on the Graphics/Screen button locks up the machine (or at least X). Lxrandr runs ok on both and xserverwizard doesn't if run from the terminal. First an error message.. can't find /proc/pci then on the core 2 duo laptop, gives a wild flickering display and on the Bay-Trail seems ok but no button response.

_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 252
Location: The Heart of Muskoka, ON Canada

PostPosted: Thu 26 Nov 2015, 19:40    Post subject:  

Marv wrote:
Another quirk on both of my machines:
In Puppy Setup, clicking on the Graphics/Screen button locks up the machine (or at least X).


Noticed this same issue the other day on my Dell D630 Core 2 Duo laptop.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11348
Location: Stratford, Ontario

PostPosted: Fri 27 Nov 2015, 17:03    Post subject:  

@Marv: The CUPS v2.x in LxPupSc is missing some key components.

1. Go to page 1 and do the "lpadmin" fix.

2. Go here and get the packages cups-filters-1.0.76-i586-1.txz and qpdf-5.1.2-i486-1.txz.

3. Restart CUPS.

However, many print/scan driver packages built for older platforms will need some additional content. I am sending you something to test.
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 817
Location: SW Wisconsin

PostPosted: Fri 27 Nov 2015, 17:54    Post subject:  

rcrsn51 wrote:
@Marv: The CUPS v2.x in LxPupSc is missing some key components.

1. Go to page 1 and do the "lpadmin" fix.

2. Go here and get the packages cups-filters-1.0.76-i586-1.txz and qpdf-5.1.2-i486-1.txz.

3. Restart CUPS.

However, many print/scan driver packages built for older platforms will need some additional content. I am sending you something to test.

Working on the core 2 duo laptop:
1. "lpadmin" fix was applied, hplip 3.14.10 was installed.
2. Previous printer install deleted.
3. Both xxx.txz files above installed.
4. CUPS restarted (reboot).
5. Done both without and with lxpup_print_patch-1.0.pet installed:
a.Reboot.
b.Install HP4500 printer.
c.Print test page.

In both cases under 5, the attached is the result.
post_patch.jpg
 Description   
 Filesize   47.35 KB
 Viewed   1293 Time(s)

post_patch.jpg


_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11348
Location: Stratford, Ontario

PostPosted: Fri 27 Nov 2015, 18:28    Post subject:  

@Marv: I did a clean frugal install of LxPupSc. I did NOT touch the firewall setup. I performed the above steps and installed the hplip_print driver.

I installed a USB HP Deskjet F4280. It worked. I installed a networked Brother laser with socket:// and Gutenprint. It worked. I did a simulated install of your Officejet 4500. It worked.

[Edit] I installed an HP Envy 4500 by WiFi and socket://. It worked.
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 817
Location: SW Wisconsin

PostPosted: Fri 27 Nov 2015, 22:11    Post subject:  

@rcrsn51: I redid the installation leaving hplip til after the patches with the same result. In case it was my savefile updated from 15.11.02, I then did the patches, hplip, printer install on a fresh frugal install of 15.11.03. The exact order outlined, checked that the files in the txzs were installed, stopped and restarted CUPS. Same result. Stopped on the way to the fresh install to print a test page in X-slacko 3.1n to check the printer. Printed fine. I'm stumped for now but LxPupSc isn't my daily so it is on the back burner. I'll attach a gz of the portion of the CUPS error log file pertaining to the final print attempt in the fresh install.

Edit: The patch you sent me by PM did get HP Officejet 4500 g-m printing going for me in Slacko 6.3.0. It had an hpcups filter error previously. Thanks.
lxpupSc_errors.gz
Description 
gz

 Download 
Filename  lxpupSc_errors.gz 
Filesize  2.05 KB 
Downloaded  171 Time(s) 

_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11348
Location: Stratford, Ontario

PostPosted: Sat 28 Nov 2015, 08:35    Post subject:  

Quote:
Officejet_4500: error while loading shared libraries: libpoppler.so.57: cannot open shared object file: No such file or directory

That's definitely an error, but I have no idea where it is coming from. LxPupSc has libpoppler.so.56 and it works correctly in all my tests.

You could try fixing this with a symlink.

[Edit] Slackware has already bumped the cups-filters package up a version and it now needs libpoppler57.
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 817
Location: SW Wisconsin

PostPosted: Sat 28 Nov 2015, 12:24    Post subject:  

rcrsn51 wrote:
Quote:
Officejet_4500: error while loading shared libraries: libpoppler.so.57: cannot open shared object file: No such file or directory

That's definitely an error, but I have no idea where it is coming from. LxPupSc has libpoppler.so.56 and it works correctly in all my tests.

You could try fixing this with a symlink.

[Edit] Slackware has already bumped the cups-filters package up a version and it now needs libpoppler57.


I know it's bad form to symlink to an older lib, but a 57>56 symlink tried and it prints.

_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2740
Location: Worcestershire, UK

PostPosted: Sat 28 Nov 2015, 14:30    Post subject:  

rcrsn51 wrote:
Quote:
Officejet_4500: error while loading shared libraries: libpoppler.so.57: cannot open shared object file: No such file or directory

That's definitely an error, but I have no idea where it is coming from. LxPupSc has libpoppler.so.56 and it works correctly in all my tests.

You could try fixing this with a symlink.

[Edit] Slackware has already bumped the cups-filters package up a version and it now needs libpoppler57.

Thank you both rcrsn51 & Marv for your valuable experiments....much appreciated.

You've hit on a real problem with slackware current based systems - you can't rely on adding things from the slackware current repository to a built system as "things may have moved on".....

I'm going to add the 2 packages identified by rcrsn51 to my next build which will also have other updates, particularly the ppm problem which mavrothal is kindly helping with.

Cheers and thanks for your testing
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2740
Location: Worcestershire, UK

PostPosted: Sun 29 Nov 2015, 14:18    Post subject: LxPupSc-15.11.09-pae  

LxPupSc-15.11.09-pae.iso is now available
md5 = 0aa10b336208acd4efeacd9795437c80

Based on latest woof-ce build of slackocurrent with kernel huge-4.3.0-EmSee 32bit pae with added firmware-140621-big

Fixes include CUPS (thank you rcrsn51 & marv) and ppm (thank you mavrothal). 01micko found some bugs to squash - see post #2.

Pup-volume-monitor has been recompiled for LxPupSc and eudev.

Devx
Kernel 4.3.0 sources

Cheers
peebee

System report:
System: Host: puppypc23839 Kernel: 4.3.0-EmSee-32-pae i686 (32 bit gcc: 4.7.1)
Desktop: LXDE (Openbox 3.6.1) Distro: Slacko-C Puppy 15.11.9
Graphics: Display Server: X.org 1.18.0 drivers: nouveau (unloaded: vesa)
tty size: 80x24 Advanced Data: N/A for root
Audio: Card-1 HDA NVidia driver: HDA-Intel
Card-2 pcsp driver: PC-Speaker
Sound: Advanced Linux Sound Architecture v: k4.3.0-EmSee-32-pae
Info: Processes: 169 Uptime: 1 min Memory: 96.3/3786.7MB
Init: SysVinit runlevel: 5 Gcc sys: N/A
Client: Shell (bash 4.3.421) inxi: 2.2.28

Distro: Slacko-C Puppy 15.11.9
Desktop Panel: lxpanel 0.6.0-r694
Window Manager: Openbox 3.6.1
Desktop Start: xwin startlxde

Development:
Bash: 4.3.42
Geany: 1.25
Gtkdialog: 0.8.4
Perl: 5.22.0
--
busybox: 1.23.1
dhcpcd: 6.8.2
GlibC: 2.22
OpenSSL: 1.0.1p 9 Jul 2015, built on: Thu Jul 9 13:13:17 2015
wpa_supplicant: 2.4

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Sat 05 Dec 2015, 09:46; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 817
Location: SW Wisconsin

PostPosted: Sun 29 Nov 2015, 21:08    Post subject: Re: LxPupSc-15.11.09-pae  

peebee wrote:
LxPupSc-15.11.09-pae.iso is now available
md5 = 0aa10b336208acd4efeacd9795437c80

Downloaded, md5 checked, and installed as pristine frugal Grub4Dos on both the core 2 duo with iwlwifi and the Bay-Trail desktop with the RTL8168g NIC.

Video, sound, touchpad, mouse fine on both.

On connection: The core 2 duo is fine using Frisbee, as it was in 15.11.03. The Bay-Trail box with the RTL8168g now connects immediately on boot with the firmware patch for it found and loaded. Posting from that now. I'll check the ethernet speed on it at some point as that has been a reported issue with that NIC and earlier drivers.

On printing: Both machines now print with straightforward installs of the HP4500 printer. hplip 3.14.10 installed, CUPS sets up the printer correctly. I do need to use the lxpup_print_patch-1.0.pet that rcrsn51 sent me or I get a filter error. Perhaps he will incorporate it in his magnificent printer install page. All in all it's a great leap forward.

Not to mention the PPM which no longer hides under its gray coat after one operation Smile

I'll continue to use it daily on the laptop and leave it as default on the Bay-Trail in the cellar if there are any questions.

Thanks,

_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2856

PostPosted: Mon 30 Nov 2015, 02:21    Post subject: Re: LxPupSc-15.11.09-pae  

Marv wrote:
Not to mention the PPM which no longer hides under its gray coat after one operation Smile

That was the least of the problems. Very Happy

May be a good idea to inactivate the slackware-14.1 repo from the settings as it provides older versions of the same packages as "current" and installing from 14.1 may break things.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2740
Location: Worcestershire, UK

PostPosted: Wed 02 Dec 2015, 15:10    Post subject: LxPupSc-15.12.02-pae  

UPDATED: 7-dec-2015 - rebuild with latest slackware current

LxPupSc-15.12.02-pae.iso is now available
md5 = 2b9b8e4e328ea81a9d7998ae6f9606a5

Based on latest woof-ce build of slackocurrent with kernel huge-4.3.0-EmSee 32bit pae

Main changes in this version are:
- cut-down llvm is included - thanks 01micko - glxgears should now work
- kernel from stemsee now includes firmware - thanks stemsee
- further small changes to ppm - thanks mavrothal

Devx
Kernel 4.3.0 sources

Cheers
peebee

Linux Kernel: 4.3.0-EmSee-32-pae (i686)
Kernel Version: #1 SMP Sat Nov 28 22:54:16 GMT 2015
PAE Enabled: Yes

Distro: Slacko-C Puppy 15.12.2
Desktop Panel: lxpanel 0.6.0-r694
Window Manager: Openbox 3.6.1
Desktop Start: xwin startlxde

Development:
Bash: 4.3.42
Geany: 1.25
Gtkdialog: 0.8.4
Perl: 5.22.0
--
busybox: 1.21.0
dhcpcd: 6.8.2
GlibC: 2.22
OpenSSL: 1.0.2d 9 Jul 2015, built on: reproducible build, date unspecified
wpa_supplicant: 2.4

System: Host: puppypc1109 Kernel: 4.3.0-EmSee-32-pae i686 (32 bit gcc: 4.7.1)
Desktop: LXDE (Openbox 3.6.1) dm: N/A
Distro: Slacko-C Puppy 15.12.2
Info: Processes: 173 Uptime: 4 min Memory: 112.5/3786.7MB
Init: SysVinit v: N/A runlevel: 5 Gcc sys: N/A
Client: Shell (bash 4.3.421 running in lxterminal) inxi: 2.2.28

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Mon 07 Dec 2015, 07:38; edited 3 times in total
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3121
Location: Ontario Canada

PostPosted: Thu 03 Dec 2015, 01:03    Post subject: LxPupSc  

Manual frugal install to a usb-3.0 SSD.

video-info-glx 1.5.3 Wed 2 Dec 2015 on Slacko-C Puppy 15.12.1 Linux 4.3.0-EmSee-32-pae i686

X Server: Xorg Driver: radeon
X.Org version: 1.18.0
dimensions: 3840x1080 pixels (1015x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD REDWOOD (DRM 2.43.0, LLVM 3.7.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.0.6

AMD Phenom(tm) II X6 1045T Processor
Core 0: @800 1: @2700 2: @2700 3: @2700 4: @2700 5: @800 MHz

Installed some kdegames with PPM, they won't run from the menu but do
work with the run on the lxde menu.

That's it so far.
Screenshot.jpg
 Description   
 Filesize   42.36 KB
 Viewed   839 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 51 [751 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 49, 50, 51 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0999s ][ Queries: 14 (0.0174s) ][ GZIP on ]