Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Jun 2019, 14:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPupSc - Woof-CE, Slackware-Current, LXDE build
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 77 of 78 [1164 Posts]   Goto page: Previous 1, 2, 3, ..., 75, 76, 77, 78 Next
Author Message
Marv


Joined: 04 May 2005
Posts: 1170
Location: SW Wisconsin

PostPosted: Mon 20 May 2019, 06:29    Post subject:  

Kernel Release: 5.1.3-lxpup64 installed into the latest LxPupSc64 on my Laptop (2nd gen i5, Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz).

Mitigation there is:

l1tf:Mitigation: PTE Inversion
mds:Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
meltdown:Mitigation: PTI
spec_store_bypass:Vulnerable
spectre_v1:Mitigation: __user pointer sanitization
spectre_v2:Mitigation: Full generic retpoline, STIBP: disabled, RSB filling

Tried again today to get current microcode and the latest version shown on https://downloadcenter.intel.com/download/28087/Linux-Processor-Microcode-Data-File is still:

Version: Latest (Latest) Date: 8/7/2018

Has anyone gotten the intel microcode patches to actually show up and work??? I've checked and I know they are being loaded at boot but no effect at all on mitigation even though their site says the 2520 is covered.

Update: Also installed this kernel in the latest LxPupSc. All good there. The usual clean boot, dmesg exam, cpu and mem use at idle, glxgears FPS all clean/excellent. Mitigation exactly as above. I did manage to download and load 20190312 microcode from the intel site by ignoring the 'latest' but mitigation results unchanged (still shows no microcode).

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic and upupdd for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Tue 21 May 2019, 11:31    Post subject:  

https://sourceforge.net/projects/lxpup/files/Other/Desktops/LXQt-ydrv/

ydrv's to change LxPupSc 32 & 64 to the LXQt desktop

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Wed 22 May 2019, 17:44    Post subject:  

Kernel Release: 5.1.4-lxpup64
Build Date: Wed May 22 18:11:38 BST 2019
Build GCC: 9.1.0
OS Support: GNU/Linux
Architecture: x86_64
SMP Enabled: Yes

From Here

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 1170
Location: SW Wisconsin

PostPosted: Wed 22 May 2019, 21:27    Post subject:  

Kernel Release: 5.1.4-lxpup64 installed in LxPupSc and LxPupSc64 exactly as I did 2 posts above. No change in boot or quick system checks in either pup between 5.1.3 and 5.1.4.

Mitigation also unchanged at:

l1tf:Mitigation: PTE Inversion
mds:Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
meltdown:Mitigation: PTI
spec_store_bypass:Vulnerable
spectre_v1:Mitigation: __user pointer sanitization
spectre_v2:Mitigation: Full generic retpoline, STIBP: disabled, RSB filling

I've been running the current LxPupSc uneventfully with these kernels as my daily though use is pretty light right now.

Thanks,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic and upupdd for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Thu 23 May 2019, 12:59    Post subject:  

Interim to 19.04+4

see post #2

Slackware Current to Wed May 22 23:30:54 UTC 2019

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 1212
Location: Chatswood, NSW

PostPosted: Thu 23 May 2019, 19:44    Post subject: LxPupSc19.04+3 to +4 [SOLVED]
Subject description: Lost Wifi (using the +3 save-file in +4)
 

G'day peebee,

I BADLY made a new LxPup-Sc +4 from the delta and then a frugal. I copied the save-file from +3 which loaded apparently well, but I cannot now connect via my ath9k wifi adapter (USB).

"Problem' was me (again) - I didn't copy the fdrv sfs when I manually made the new Frugal Embarassed Laughing . With the fdrv added, no wifi problem.

No green light in the dongle during booting. Wizards did not report the wifi as a network option.

The dongle-needed ath9k drivers seem the same as in +3 in which wifi is working (posting from this now). My LxPupSc19.04+2 also has good wifi.

Any ideas of what I should try?

David S.

PS:
Just ran dmesg in +3 and +4 (screenshots)
+3 reports an error loading firmware, but then does load?, so usb wifi dongle connects
+4 reports same firmware error but then has another firmware error and no wifi.
Is there a firmware file missing between +3 and +4?
lxpupsc19043-dmesg-wifiworking.jpg
 Description   firmware error but then usb wifi activated
 Filesize   150.88 KB
 Viewed   946 Time(s)

lxpupsc19043-dmesg-wifiworking.jpg

lxpupsc19044-dmesg-nointernet.jpg
 Description   errors with firmware for ath9 usb adapter
 Filesize   138.35 KB
 Viewed   948 Time(s)

lxpupsc19044-dmesg-nointernet.jpg


Last edited by davids45 on Fri 24 May 2019, 18:52; edited 1 time in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Fri 24 May 2019, 02:03    Post subject:  

The fdrv has not changed, but

it doesn't include htc_7010-1.4.0.fw

but

you can get it from gyro's firmware sfs:

http://www.fishprogs.software/puppy/firmware-sfs/

linux_firmware_20190510.sfs

or direct from: http://anduin.linuxfromscratch.org/BLFS/linux-firmware/ath9k_htc/htc_7010-1.4.0.fw

I'll update the fdrv at some point.....

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 1212
Location: Chatswood, NSW

PostPosted: Fri 24 May 2019, 19:00    Post subject: Wifi non-problem fixed
Subject description: Added the fdrv this time
 

G'day peebee,

Thanks for your reply - it made me check the firmware directory in /lib of my +4 and compare it to that in my +3 Pup.

The lack of files in my +4 made me check my install and I saw I hadn't copied the fdrv when making my frugal Pup.

It's now connecting as it should.

Thanks again for your help.

David S.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Sun 26 May 2019, 04:27    Post subject:  

Kernel Release: 5.1.5-lxpup64
Build Date: Sun May 26 07:34:19 BST 2019
Build GCC: 9.1.0
OS Support: GNU/Linux
Architecture: x86_64
SMP Enabled: Yes

From Here

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 1170
Location: SW Wisconsin

PostPosted: Mon 27 May 2019, 19:15    Post subject:  

Kernel Release: 5.1.5-lxpup64 swapped into LxPupSc 19.04 +4 and LxPupSc64 19.04 +4, replacing 5.1.4 on this hardware:

System: Host: puppypc21956 Kernel: 5.1.5-lxpup64 x86_64 (64 bit) Desktop: LXDE (Openbox 3.6.1)
Distro: LxPup-Sc 19.04
Machine: Device: laptop System: FUJITSU product: LIFEBOOK S761 serial: R2500459
Mobo: FUJITSU model: FJNB225 UEFI [Legacy]: FUJITSU // Phoenix v: Version 1.17 date: 03/14/2012
Battery CMB1: charge: 56.0 Wh 100.0% condition: 56.0/56.0 Wh (100%)
CPU: Dual core Intel Core i5-2520M (-MCP-) speed/max: 1311/3200 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.org 1.20.4 drivers: intel (unloaded: modesetting,vesa) FAILED: fbdev
tty size: 134x32 Advanced Data: N/A for root
Network: Card: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) driver: ath9k
Drives: HDD Total Size: 120.0GB (39.7% used)
Info: Processes: 141 Uptime: 48 min Memory: 375.6/3778.4MB Client: Shell (bash) inxi: 2.3.8

Boot, system checks, video FPS, dmesg cleanliness, mitigation, and general 'feel' unchanged in both pups. I've been in upupdd so not a lot of use on the slackware derivs but I had a rain-day today to fiddle with them. I'm currently posting from LxPupSc 19.04 +4 running the usual Slimjet 22.0.4.0 run-as-spot SFS having checked email etc. No multimedia checks done but all seems good so far.

Thanks,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic and upupdd for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Wed 29 May 2019, 04:03    Post subject:  

Interim to 19.04+5

see post #2

Slackware Current to Tue May 28 19:03:49 UTC 2019

OpenSSL: 1.1.1c 28 May 2019, built on: Tue May 28 18:49:19 2019 UTC

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Sat 01 Jun 2019, 04:25    Post subject:  

Kernel Release: 5.1.7-lxpup64
Build Date: Tue Jun 4 13:51:54 BST 2019
Build GCC: 9.1.0
OS Support: GNU/Linux
Architecture: x86_64
SMP Enabled: Yes

From Here

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64

Last edited by peebee on Tue 04 Jun 2019, 12:20; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Sat 01 Jun 2019, 12:09    Post subject: LxPupSc-19.06+0  

LxPupSc-19.06+0-uefi-T-k64 is a 32-bit woof-ce 'testing' branch build with a 64-bit kernel (therefore only compatible with 64-bit capable processors)

LxPupSc-19.06+0-uefi-T-k64.iso {devx} - (devx does not include kernel sources or headers) {kernel 5.1.6-lxpup64 sources}

iso md5 = 7354341ccba39c08ece34cc2f953084e

Interim delta updates and newer kernels may be available.

Delta from 19.04T is available

- kernel 5.1.6 64-bit built with GCC-9.1.0
(alternative 32-bit kernels 3.16.x 4.4.x 4.9.x & 4.14.x also available - all need firmware in the fdrv)
- Made from Slackware-Current as of Fri May 31 19:37:36 UTC 2019
- BUILD_FROM_WOOF='testing;2393b05d;2019-05-31 06:01:53 +0800'
- web browser in adrv is light-48.0
- firmware is in fdrv
- alternative fall-back xorg is in ydrv (no need to install unless needed)

**N.B. the 64-bit kernel means that any kernel drivers have to be built in a true 64-bit system - LxPupSc64 with it's own devx is suggested but use the kernel sources above

Woof-CE build repository is: http://smokey01.com/peebee/slackocurrent/

Chromium, Firefox, Palemoon and Seamonkey are in the repository and installable via Internet -> Get Web Browser

The versions of the browsers as of 01-jun-2019 with their md5sums are:
chromium_74.0.3729.169+pepper_32.0.0.192 RUNS-AS-SPOT :1ea94bfce008dbdb75eb030e31d6ce16
firefox-67.0 :395d58a0686eb97ceb07b8a8a038956a
palemoon-28.5.0 :fb618526e7ccbcf4e9897c75b74ed8ba
seamonkey-2.49.4 :d89486754ca78c70c162aef2d93b3f2e
iron, slimjet, vivaldi and min are also available
Screenshot.png
 Description   
 Filesize   119.12 KB
 Viewed   591 Time(s)

Screenshot.png


_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Mon 10 Jun 2019, 11:59    Post subject:  

Kernel Release: 5.1.10-lxpup64
Build Date: Sun Jun 16 07:34:00 BST 2019
Build GCC: 9.1.0
OS Support: GNU/Linux
Architecture: x86_64
SMP Enabled: Yes

From Here

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3892
Location: Worcestershire, UK

PostPosted: Tue 18 Jun 2019, 03:38    Post subject:  

Kernel Release: 5.1.15-lxpup64
Build Date: Tue Jun 25 07:05:22 BST 2019
Build GCC: 9.1.0
OS Support: GNU/Linux
Architecture: x86_64
SMP Enabled: Yes

Needs firmware (e.g. in fdrv)

From Here

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64

Last edited by peebee on Today, at 03:56; edited 4 times in total
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 77 of 78 [1164 Posts]   Goto page: Previous 1, 2, 3, ..., 75, 76, 77, 78 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0725s ][ Queries: 12 (0.0046s) ][ GZIP on ]