Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 18 Sep 2019, 08:01
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Slacko Woofers
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 10 [136 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 8, 9, 10 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 8707
Location: qld

PostPosted: Sun 18 Oct 2015, 18:09    Post subject:  

Hi ziggy. Just a browser eh? Laughing

Anyway, in future slacko pups I have added tcl/tck to the devx since this tool needs it.

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 19 Oct 2015, 00:58    Post subject: Slacko Woofers  

I did a manual frugal install of Slacko64-6.0.7.2 to a usb-3.0 hard
drive, pc is a macmini.

video-info-glx 1.5.3 Mon 19 Oct 2015 on Slacko64 Puppy 6.0.7.2 Linux 4.1.8 x86_64
2.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
oem: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
product: Intel(R) Sandybridge/Ivybridge Graphics Controller Hardware Version 0.0

X Server: Xorg Driver: intel
X.Org version: 1.14.3
dimensions: 1920x1080 pixels (508x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1.7

Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
Core 0: @1325 1: @1231 2: @1210 3: @1212 MHz

I installed some applications with PPM, PPM worked well on this pc but
on the AAO netbook with the single core AMD Athlon it didn't, took about
2 hours to download and install the same applications.

Getflash worked well on the AAO but PPM didn't.

That's it so far.
Screenshot.jpg
 Description   
 Filesize   93.78 KB
 Viewed   505 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3987
Location: Worcestershire, UK

PostPosted: Mon 19 Oct 2015, 02:16    Post subject: Incremental builds??  

Having gone through a complete "start from scratch" build of Slacko 6.0.7.2 32bit - is it possible to now do an incremental build, downloading and importantly 2createpackage'ing only things that have changed???

Hope so!

Advice on how to do this would be appreciated.

Thanks
peebee

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3987
Location: Worcestershire, UK

PostPosted: Mon 19 Oct 2015, 02:36    Post subject:  

01micko wrote:
there are now a couple of more kernels up at the repo, freshly compiled. I will upload sources as soon as I figure out the best place to upload them. Probably just to pet_packages_slacko{whatever version}.

Thanks Mick...

Just a clarification -- why are huge kernels labelled "tahr" and "slacko" - makes it sound as though they are specific to those types of pup, whereas in my experience they are not (other than the sfs naming)??

Thanks
peebee

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 8707
Location: qld

PostPosted: Mon 19 Oct 2015, 03:20    Post subject:  

The naming is what it is built in, however some modules don't compile if a different gcc is used than the one that built the kernel. If they work for you just use them.
_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 8707
Location: qld

PostPosted: Mon 19 Oct 2015, 03:20    Post subject: Re: Incremental builds??  

peebee wrote:
Having gone through a complete "start from scratch" build of Slacko 6.0.7.2 32bit - is it possible to now do an incremental build, downloading and importantly 2createpackage'ing only things that have changed???

Hope so!

Advice on how to do this would be appreciated.

Thanks
peebee


Yes! I'd be going bananas if not!

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3987
Location: Worcestershire, UK

PostPosted: Mon 19 Oct 2015, 04:11    Post subject: Re: Incremental builds??  

01micko wrote:
peebee wrote:
Advice on how to do this would be appreciated.
Thanks
peebee


Yes! I'd be going bananas if not!

Can you quickly describe how to?

Where do I rerun the merge,0,1,2,3 sequence from?

Thanks
peebee

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 8707
Location: qld

PostPosted: Mon 19 Oct 2015, 07:33    Post subject:  

Any packages I have told you that are fixed, delete the form packages-pet.

Run ./merge2out. This refreshes all the configs. No need to run 0setup again (unless it's been quite a few weeks, or there is some special CVE so that their might be something new in patches repo.)

Run 1download.

Run 2 createpackages, but do not hit enter. Type the name of the package (just the name, no version or arch). Alternatively click on woof_gui and use the drop down in the create packages tab. Do this for each fresh package.

That's it. Run 3builddisto-Z and you are away. (BTW leafpad isn't really fixed yet.. I've had other dramas Rolling Eyes Laughing )

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 19 Oct 2015, 10:20    Post subject: Slacko Woofers  

I did a manual frugal install to an 8gb flash drive, it's running on my
Gateway desktop:

video-info-glx 1.5.3 Mon 19 Oct 2015 on Slacko64 Puppy 6.0.7.2 Linux 4.1.8 x86_64
0.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 560 Ti OEM] (rev a1)
oem: NVIDIA
product: GF110 Board - 12630002 Chip Rev

X Server: Xorg Driver: nvidia
X.Org version: 1.14.3
dimensions: 3840x1080 pixels (1204x343 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 352.55

Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Core 0: @1599 1: @1599 2: @1599 3: @1599 4: @1599 5: @1599 6: @1599 7: @1599 MHz

I installed the proprietary nvidia driver, it didn't work properly
until I edited the xorg.conf and commented out one line:

--------------------------------------------------------------------------------

Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
# Load "type1"
# Load "freetype"
# This loads xtrap extension, used by xrandr
# Load "xtrap"
# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
# This loads dri module (if present). 7.4 loads it by default, have to disable...
# Load "dri" #LOADDRI
# Disable "dri"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
# Disable "glx" #LOADGLX
EndSection

--------------------------------------------------------------------------------

I commented out "Disable "glx" #LOADGLX"
Works now:
# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.387 FPS
301 frames in 5.0 seconds = 60.003 FPS
300 frames in 5.0 seconds = 59.999 FPS
#
Screenshot.jpg
 Description   
 Filesize   17.44 KB
 Viewed   423 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
unicorn316386

Joined: 07 Apr 2015
Posts: 208
Location: Canada

PostPosted: Mon 19 Oct 2015, 13:48    Post subject:  

I just built an iso of slackoware 14.1 x86 (Slacko 6.0.7.2) with kernel 3.12.21.
Looks good to me after adding stardust_zigbert gtk theme and Gradient-grey jwn theme back in from Slacko 5.7. Smile

Some things I notice in the menu:
- Grub4Dos is still in the menu 3 times (twice in System, both should probably be deleted?)
- Leafpad is now in the menu 3 times (Utility and Graphics ones seem wrong and could be deleted?)
- HexChat is in both Network and Internet (XChat picks Network)
- Legacy GRUB menu item should probably be removed (does not work/exist)
- GTK theme selection option is not available in Desktop menu any more? (hmm, maybe this was optional in ./3builddistro-Z)
- Multimedia -> Qt V4 test utility does nothing? Same with Desktop -> Desktop Settings?
- Borders around bottom task bar items aren't working? (circled in red below) Is there any way to fix this?

Otherwise this version all seems quite smooth and good so far here. I'll keep using it Very Happy
Screenshot.png
Description 
png

 Download 
Filename  Screenshot.png 
Filesize  206.99 KB 
Downloaded  264 Time(s) 
Back to top
View user's profile Send private message 
Keef


Joined: 20 Dec 2007
Posts: 967
Location: Staffordshire

PostPosted: Mon 19 Oct 2015, 15:34    Post subject:  

32 bit Slacko 6.0.7.2 (14.1) with kernel 3.14.20 nopae. Apart from wallpaper and locale, just went with defaults.

Shock horror, it actually works.
Had used Unleashed, woof, and woof2 before, and always got a result, but never had much joy with Woof-CE until now, although was getting closer recently.

Anyway, posting from it now, and all seems well. Same menu issues as reported by unicorn316386 though.

Haven't saved and rebooted yet, but I am sure all will go well.....
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 2811
Location: South Australia :-(

PostPosted: Mon 19 Oct 2015, 17:32    Post subject:  

I just did another build of slacko64-6.0.7.2. It seems pretty good but sylpheed doesn't work. Am I the only one to notice this or is it just my build?
It's missing libgpgme.so.11 and libassuan.so.0.

I did a 'git pull origin testing' prior to the build.
./1download
./2createpackages (sylpheed only)
./3builddistro-Z

There are still a few other issues as I previously reported and confirmed by others recently.

gnome-player is still showing up four time in the multimedia menu.
Changing the desktop file from:
Categories=AudioVideo;Audio;Video;Player;TV;
to
Categories=AudioVideo;
solves the problem.

Cheers

_________________
Software <-> Distros <-> Tips <-> Newsletters
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 8707
Location: qld

PostPosted: Mon 19 Oct 2015, 17:56    Post subject:  

@smokey - just reuploading now - sorry Embarassed (sylpheed) - just test it before you rebuild. Can you just check dictd please?

@keef and unicorn316386

Just reuploaded leafpad and hexchat. Should have 1 menu entry now. Thanks for testing.

Jury is still out on grub4dos. I realise it needs fixing but I'm not sure to put it in the new woof GUI that adds extras in 3builddistro-Z or put it in noarch - even though it wont work in armv6/7. Old grub wont work in 64 but will in 32. it's a pet again now but the .desktop wasn't deleted. On to that. The V4L thing require QT, so I might sed in NoDisplay=true to the .desktop file in the woof template. That way it wont show in the menu.

I do have a major bug with gnumeric though in 64 and 32. Pasting from 1 cell to another crashes X!!! AAARRGGHHH! Gnumeric (gtk2) is getting rather old though... what to do?

Maybe BK has patches Confused

There are a couple of other things that I'll get to. @mavrothal is pushing me for a release, which needs to happen but this gnumeric thing and a foobar I did with woof are holding things up. Rolling Eyes

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 19 Oct 2015, 21:13    Post subject: Slacko Woofers  

I woofed another Slacko64-6.0.7.2 tonight and did a manual frugal
install to a 4gb flash drive, pc is an Acer laptop:

video-info-glx 1.5.3 Mon 19 Oct 2015 on Slacko64 Puppy 6.0.7.2 Linux 4.1.8 x86_64
0.0 VGA compatible controller: AMD/ATI [Advanced Micro Devices, Inc.] Park [Mobility Radeon HD 5430/5450/5470]
oem: ATI ATOMBIOS
product: PARK 01.00

X Server: Xorg Driver: radeon
X.Org version: 1.14.3
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD CEDAR
OpenGL version string: 2.1 Mesa 9.1.7

Intel(R) Core(TM) i5 CPU M 430 @ 2.27GHz
Core 0: @1199 1: @1199 2: @1199 3: @1199 MHz

I installed all the usual stuff and still have a little over 2gb left
on this 4gb flash drive.

Not bad Smile

Edit: Getflash isn't working, says no internet connection but there is.
Screenshot.jpg
 Description   
 Filesize   96.5 KB
 Viewed   231 Time(s)

Screenshot.jpg

Screenshot2.jpg
 Description   
 Filesize   105.53 KB
 Viewed   232 Time(s)

Screenshot2.jpg


Last edited by Billtoo on Mon 19 Oct 2015, 23:08; edited 1 time in total
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 2811
Location: South Australia :-(

PostPosted: Mon 19 Oct 2015, 22:56    Post subject:  

Just finished testing a new build, slacko64-6.0.7.2.

Sylpheed is working fine now. I even tested some accounts, all good.

_________________
Software <-> Distros <-> Tips <-> Newsletters
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 10 [136 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0716s ][ Queries: 12 (0.0178s) ][ GZIP on ]