Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Oct 2017, 00:41
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Librepup 6.0.2.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 20 of 22 [323 Posts]   Goto page: Previous 1, 2, 3, ..., 18, 19, 20, 21, 22 Next
Author Message
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Sat 05 Dec 2015, 18:55    Post subject:  

Hello all.

"Curiouser and curiouser", says Alice's Rabbit...

Please see attached screen capture. Does anybody have an explanation?
Why does a gcc error appear when trying to update .Xresources live?

When xrdb is used this way, when I restart Xclock, all the foreground
colors in Xclock are black. They shouldn't be, as these colors have been
carefully chosen to form a theme.

For reference, here is my Xclock color configuration in .Xresources:
Quote:
!XClock config ! Derived from http://unix.stackexchange.com/questions/89304/facelifting-xclock-while-using-xrender-a-long-and-winding-road'
XClock.foreground: #fbfbfb
XClock.background: #b00018
!(...)
XClock.Clock.majorColor: rgba:4e/44/38/ff
XClock.Clock.minorColor: rgba:a0/c0/f0/ff
XClock.Clock.hourColor: rgba:c9/66/11/c0
XClock.Clock.minuteColor: rgba:00/82/9f/c0
XClock.Clock.secondColor: rgba:ff/ff/ff/ff
"Curiouser and curiouser", says Alice's Rabbit...

Thanks in advance for any leads.
xrdb-lib-error_2015-12-05.jpg
 Description   
 Filesize   24.04 KB
 Viewed   935 Time(s)

xrdb-lib-error_2015-12-05.jpg


_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)

Last edited by musher0 on Sun 06 Dec 2015, 00:09; edited 1 time in total
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Sat 05 Dec 2015, 21:57    Post subject:  

Ok... The above was not the only library missing to be able to run xrdb in
librepup. Here is the URL of a *.pet archive containing all of them,
-- https://www.adrive.com/public/bypCZJ/xrdb-missing-libs-librepup-6.x.pet --
and in tree form, their list:
Quote:
.
└── usr
├── lib
│   ├── libcloog-isl.so.4 -> libcloog-isl.so.4.0.0
│   ├── libcloog-isl.so.4.0.0
│   ├── libisl.so.10 -> libisl.so.10.2.2
│   ├── libisl.so.10.2.2
│   ├── libisl.so.13 -> libisl.so.13.1.1
│   ├── libisl.so.13.1.1
│   ├── libmpc.so.3 -> libmpc.so.3.0.0
│   └── libmpc.so.3.0.0
└── share
└── doc
└── libmpc3-1.0.3
├── AUTHORS
├── NEWS
└── README
5 directories, 13 files
Enjoy. BFN.
_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Tue 08 Dec 2015, 15:11    Post subject:  

Hello all.

I'm still in the "curiouser and curiouser" series. In LibrePup, the planner
project manager is missing the libgnomecanvas-2 library.

My LibrePup ppm was on sick leave today, even after updating it. Embarassed Sad
So I'm giving you the URL from the ALT-Sysyphus repo at pkgs.org.

After it got its missing lib, planner worked fine on this 32-bit computer.

I hope this helps. BFN.

musher0

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Wed 09 Dec 2015, 01:12    Post subject:
Subject description: "Curiouser" series continued
 

Hello all.

Here are a couple of other reportedly missing libs:
* you may want to open directory /lib and copy
__ libssl.so.0.9.7 to libssl.so.0.9.8
__ libcrypto.so.0.9.7 to libcrypto.so.0.9.8
Those are actually links to libssl.so.1.0.0 and libcrypto.so.1.0.0,
respectively, who are already in the /lib directory. Those libs are required
by gs (aka ghostscript) and ppmtojpeg.

Add'l note:
* the libgnomecanvas lib above is also supporting notecase.

All of the above will be reported missing (and a few others) if you open a
terminal in a pristine LibrePup and type:
Code:
cd /usr/bin
ldd * | grep not | grep -v dynamic


I did the same for dirs /bin and /usr/local/bin, and no missing libs were reported for the apps in those directories.

I'll keep you posted.

Bye for now.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Wed 09 Dec 2015, 01:12    Post subject:  

Where is iguleder, BTW?
_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Wed 09 Dec 2015, 14:36    Post subject:  

Hello all.

If you need a simple and efficient database program, here's a
portabase *.pet that'll work OOTB in LibrePup-6.0.2.2.

Enjoy!

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 2031
Location: Israel, somewhere in the beautiful desert

PostPosted: Wed 09 Dec 2015, 18:06    Post subject:  

musher0 wrote:
Where is iguleder, BTW?


He's busy.

_________________
My homepage
My GitHub profile
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Sun 13 Dec 2015, 14:41    Post subject:  

Hello all.

I tried to compile a rather new echinus wm from git with the make
included in the librepup devx: it never got past ranlib errors. I compiled
it in librepup with the tahrpup devx instead and its make worked fine.

Please share similar experiences of compiling in librepup if you've had
any, if only to confirm that librepup' devx indeed has a "wild" ranlib --
and that I haven't lost a screw. Thanks in advance.

Now I've got the wonderful new tiling|hybrid wm: "echinus-0.4.8_abs"
running in librepup. (Please see pic below.) Leave a note if interested! Smile

BFN.
echinus-0.4.8_abs_win-man_2015-12-13.jpg
 Description   The seemingly complete task bar is actually made of two apps: ourico
(echinus companion prog.) at left and stalonetray (for the icons) at right.
The bar at the bottom is a conky one-liner.
 Filesize   49.83 KB
 Viewed   615 Time(s)

echinus-0.4.8_abs_win-man_2015-12-13.jpg


_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
futwerk

Joined: 07 May 2011
Posts: 339

PostPosted: Fri 18 Dec 2015, 23:14    Post subject:  

a few backgrounds.
librepup10.jpg
 Description   https://www.mediafire.com/folder/x4v77bi1p58ox/puppy2013
 Filesize   32.77 KB
 Viewed   498 Time(s)

librepup10.jpg

librepup7.jpg
 Description   https://www.mediafire.com/folder/x4v77bi1p58ox/puppy2013
 Filesize   21.01 KB
 Viewed   487 Time(s)

librepup7.jpg

Back to top
View user's profile Send private message 
yerc1

Joined: 09 Jan 2009
Posts: 118

PostPosted: Sat 19 Dec 2015, 15:13    Post subject: echinus-0.4.8_abs  

musher0 wrote:
Now I've got the wonderful new tiling|hybrid wm: "echinus-0.4.8_abs" running in librepup. (Please see pic below.) Leave a note if interested! Smile

Looks really nice.

Questions:
Is your librepup running echinus as its only wm (i.e. jwm removed)?
Can you share your echinus puppy package and your conky config please?
Thanks

EDIT: I found your echinus pet package here http://murga-linux.com/puppy/viewtopic.php?t=47476&start=30
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1119
Location: Vienna Austria

PostPosted: Sat 19 Dec 2015, 16:23    Post subject:  

Awesome work! This distro looks as if it ought to be included in the Free Software Foundation's officially approved distro listings.

Richard Stallman can be contacted at:

rms@gnu.org

Not many distros actually do get an accreditation, but this one seems to possess the necessary attributes AFAIK.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Mon 21 Dec 2015, 08:44    Post subject: Re: echinus-0.4.8_abs  

yerc1 wrote:
musher0 wrote:
Now I've got the wonderful new tiling|hybrid wm: "echinus-0.4.8_abs" running in librepup. (Please see pic below.) Leave a note if interested! Smile

Looks really nice.

Questions:
Is your librepup running echinus as its only wm (i.e. jwm removed)?
Can you share your echinus puppy package and your conky config please?
Thanks

EDIT: I found your echinus pet package here http://murga-linux.com/puppy/viewtopic.php?t=47476&start=30


Thanks yerc1.

Glad you found my echinus *.pet package.

No I haven't removed the jwm window manager from librepup. While I
am confident that echinus can handle all and any windows, it's never a
bad idea to keep a "cascading" window manager such as jwm handy,
for the odd case.

BFN.
~~~~~~~~~
P.S. -- Requested conky config is attached.
.conky-1ligne-wmx2.zip
Description 
zip

 Download 
Filename  .conky-1ligne-wmx2.zip 
Filesize  1.19 KB 
Downloaded  82 Time(s) 

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Mon 21 Dec 2015, 09:05    Post subject:  

tronkel wrote:
Awesome work! This distro looks as if it ought to be included in the Free Software Foundation's officially approved distro listings.

Richard Stallman can be contacted at:

rms@gnu.org

Not many distros actually do get an accreditation, but this one seems to possess the necessary attributes AFAIK.


Hello tronkel.

Long time no see! How are you doing? Smile

I agree with you. I think Iguleder should submit his LibrePup to the FSF.
LibrePup is "that good", IMO. However, he should give it a last polish, I
think, because* I found a few missing links, and while compiling the
new echinus, the "ar" aka "ranlib" in the devx went nuts...

BFN.
~~~~~~~~~~~
* ("Malgré moi": "In spite of myself". How do you say this in proper
English? The meaning is: "I wasn't hunting for problems, but I did find
some accidentally.")

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10985
Location: Gatineau (Qc), Canada

PostPosted: Mon 21 Dec 2015, 09:14    Post subject:  

@futwerk: Very nicely done!
_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1119
Location: Vienna Austria

PostPosted: Mon 21 Dec 2015, 16:07    Post subject:  

@musher0

Yes it's nice to back. I've been messing around with other stuff for quite a while - digital photography mostly, but the latest Puppy developments have pulled me back into the fold.

Comparing Librepup with the other FSF official offerings, it has the potential to overtake many if not all of them. It would be a statement to the world that Puppy has reached something of a pinnacle in it's development and now has the confidence to offer a libre version in it's catalogue lineup - apart from its practical attributes of course. Not so many distros can say that.

Last year (2014) I got to have a chat with Richard Stallman during a lecturing tour he held here in Vienna. Since he uses nothing else other than pure free software on his personal laptop (which never leaves his grasp!), I asked him what make of laptop he uses. The answer was that he had been using this (forget what it was called) obscure laptop, that is now no longer being made. He now recommends the use of old IBM hardware as being the most suitable for use with free software. Such old laptops can be picked up quite cheaply nowadays, so I think I'll have a go and see what transpires.

How are you getting along with Librepup?

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
Display posts from previous:   Sort by:   
Page 20 of 22 [323 Posts]   Goto page: Previous 1, 2, 3, ..., 18, 19, 20, 21, 22 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0766s ][ Queries: 14 (0.0165s) ][ GZIP on ]