Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 13 Feb 2016, 07:06
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
lil bugs I've got in the new pup
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
XP Refugee

Joined: 14 May 2014
Posts: 41

PostPosted: Wed 26 Aug 2015, 23:48    Post subject:  lil bugs I've got in the new pup
Subject description: systray starts, but...
 

Retrovol and firewallstate persistanty hang UP each using about half my CPU. Very annoying. I would like to be able to use the firewall, tho I'm not too chuffed if I can't as I consider it much less a prob than evern Windows WITH a "firewall".
Never had this problem with the old 14.3 was it?
LxPup 15.06 I like, this is the only prob I consistantly have with any USB stick I put it on.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2142
Location: Worcestershire, UK

PostPosted: Thu 27 Aug 2015, 02:57    Post subject: Re: lil bugs I've got in the new pup
Subject description: systray starts, but...
 

XP Refugee wrote:
Retrovol and firewallstate persistanty hang UP each using about half my CPU. Very annoying. I would like to be able to use the firewall, tho I'm not too chuffed if I can't as I consider it much less a prob than evern Windows WITH a "firewall".
Never had this problem with the old 14.3 was it?
LxPup 15.06 I like, this is the only prob I consistantly have with any USB stick I put it on.

Are you running on a fairly slow cpu?

Is the problem fixed by Restarting the WindowManager from Session Control menu?

You could try adding a new line "sleep 1" (sans "") after line 46 "DO" in /root/Startup/z-lxde-startup.sh

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
XP Refugee

Joined: 14 May 2014
Posts: 41

PostPosted: Thu 27 Aug 2015, 03:18    Post subject:  

yeah, it's an Atom processor, but it never happened in the 14.3 pup. I've let it go figureing maybe it would settle out, but no, they stay hung using almost all the CPU. I tried restarting WM to no avail. I just pulled em out of the start up process. Would that command delay their start up until other things had completed? I may play with setting up the firewall alone. I don't know why Retroval is there at all except it's tied to the Alsa sound wizard?
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2142
Location: Worcestershire, UK

PostPosted: Sun 30 Aug 2015, 11:21    Post subject:  

The problem is connected, I believe, to the greater use of svg icons in recent puppies which require processing power at startup. That is why you didn't see it in 14.3.

Here is a small fix pet to add some sleeps to z-lxde-startup.sh

I've tested them on the oldest, slowest laptop I possess - an IBM Thinkpad 600 with only 176MB of memory (but a swap file).

They seem to cure the problem on that machine.....

I'll add this to the next iso as an option

LxPupPrecise-Retro is probably a better bet for old, slow cpu's than the more recent LxPups.....it certainly runs better on the Thinkpad.

Cheers
peebee
screen.png
 Description   
 Filesize   129.45 KB
 Viewed   207 Time(s)

screen.png

lx_slow_cpu_systray_fix-15.06.pet
Description 
pet

 Download 
Filename  lx_slow_cpu_systray_fix-15.06.pet 
Filesize  985 Bytes 
Downloaded  37 Time(s) 

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Mon 31 Aug 2015, 14:34; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
XP Refugee

Joined: 14 May 2014
Posts: 41

PostPosted: Mon 31 Aug 2015, 11:22    Post subject:  

Can't find any info on Retro. It's hard to understand that Netbooks with the atom processor can run XP and even 7, but don't have enough power for (the somewhat primitive looking) systray in this new pup. Everything else about it I like, setting it up was easy, I like the new PPM, no problems installing what I needed. I can certainly live without Retrovol starting up. If I want to use the firewall, must it be put in startup, or can I just turn it on and off as I like? Many thanks for the help on this.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2142
Location: Worcestershire, UK

PostPosted: Mon 31 Aug 2015, 14:32    Post subject:  

XP Refugee wrote:
Can't find any info on Retro.

http://lx-pup.weebly.com/upup-precise.html

I am just about to upload a new version with the same "look and feel" as LxPup-15.06

Have you tried the fix pet above?

I think firewall does need to be started on each boot.....but I'm not an expert as I don't feel the need to have it enabled Embarassed

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
XP Refugee

Joined: 14 May 2014
Posts: 41

PostPosted: Tue 01 Sep 2015, 00:11    Post subject:  

yeah, that's kinda been my feeling about firewall. More of a curiosity I spose. Have not tried it yet, might do it now as I'm on one of the USB's I've almost finished setting up.
Can you tell me if Retroval has any real use? I mean occasionally on a build I get it working so I can adjust volume via the RV icon in the tray, but mostly when it's there it has no effect on anything like PMusic. I run an odd little Altec speaker that seems to have it's own soundcard and sometimes when switching to that I have to use tue sound wizard to tick that choice and check for sound working in that speaker. It's a bit easier than opening ALSA and adjusting that way. Maybe I just need to tinker with it more and get more understanding. I'll post back in a bit after testing the pet.
I looked at that page but saw no screenshots or info on what it was. I DO like the general look and find LxPup to be very user friendly, use it MUCH more than Mint 16 MATE. Little things like having multiple desktops with DIFFERENT pictures, and I have it set to icons on the right show me programs open, so I don't have to do the Windows thing of going down to the bottom to check on things, or activate them.

What is "sleeps" ?
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2142
Location: Worcestershire, UK

PostPosted: Tue 01 Sep 2015, 02:15    Post subject:  

XP Refugee wrote:
yeah, that's kinda been my feeling about firewall. More of a curiosity I spose. Have not tried it yet, might do it now as I'm on one of the USB's I've almost finished setting up.
Can you tell me if Retroval has any real use? I mean occasionally on a build I get it working so I can adjust volume via the RV icon in the tray, but mostly when it's there it has no effect on anything like PMusic. I run an odd little Altec speaker that seems to have it's own soundcard and sometimes when switching to that I have to use tue sound wizard to tick that choice and check for sound working in that speaker. It's a bit easier than opening ALSA and adjusting that way. Maybe I just need to tinker with it more and get more understanding. I'll post back in a bit after testing the pet.
I looked at that page but saw no screenshots or info on what it was. I DO like the general look and find LxPup to be very user friendly, use it MUCH more than Mint 16 MATE. Little things like having multiple desktops with DIFFERENT pictures, and I have it set to icons on the right show me programs open, so I don't have to do the Windows thing of going down to the bottom to check on things, or activate them.

What is "sleeps" ?

retrovol is used for adjusting your sound system(s) - volumes, mics etc. Useful if you skype or listen to a lot of music or films....

sleep just introduces a bit of delay into a script and allows other processes to complete before the systray starts.

LxPupPreciseRetro is built on on an older base and has an older kernel - however crucially it does not have the svg icons in the systray like more modern pups.

The new version is now at:
http://sourceforge.net/projects/lxpup/files/LxPup15.09/
if you want to try it.

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
XP Refugee

Joined: 14 May 2014
Posts: 41

PostPosted: Tue 01 Sep 2015, 15:25    Post subject:  

well, the sleep pet did not work so good, I would have to restart the WM or reboot and then I would get Retrovol, but the firewall icon never did come back, which upon reflection matters not. Seems to be running and taking no CPU. I"ll just stick with the current 15.06 pup and cut Retroval out of the startup. It's just a minor thing I thought someone might want to be aware of. Interesting to me all the icons load perfectly when I have a clean new build, but somewhere as i put in things like right click or Palemoon, the hangup on starting thing begins.

I'm viewing it as a puzzle game now Smile
thanks for your info and help
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0384s ][ Queries: 12 (0.0036s) ][ GZIP on ]