Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 10:48
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
WPA encryption state of play
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
davidknibb

Joined: 03 Aug 2006
Posts: 22

PostPosted: Fri 11 Aug 2006, 03:48    Post_subject:  WPA encryption state of play  

The have been lots of posts about WPA encryption - and it's got difficult to find out where workingsolutions have been posted - some of the posts are useful discussions that don't seem to have culminated in a solution.
I'm using
Puppy 2.02, Hard Disk install on an HP XE2 laptop.
My network card is Linksys WPC54G (ver1.2)

I've worked manually with NDISWRAPPER, and it all works fine with WEP - but not quite with WPA. But my output from

#iwlist wlan0 scan

looks very promising -

wlan0 Scan completed :
Cell 01 - Address: 00:0F:B5:BD:0D:3C
ESSID:"davidsnetwork"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-17 dBm Noise level:-256 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Extra:bcn_int=200
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

----------------------------
It sees that the encryption is WPA in TKIP mode.

So I think that there might be an easy next step (optimism) to
supplying the password
bringing up the interface.

Something that I know well enough how to do in Debian
(iwpriv wlan0 set WPAPSK=xxxxxxxxx)
But don't seem to be able to do in Puppy.

I've looked through dozens of posts and not seen an answer.

Can anyone point me please to the post where an answer is provided.

Many thanks

David
Back to top
View user's profile Send_private_message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Fri 11 Aug 2006, 23:06    Post_subject:  

I don't know if iwpriv is appropriate, maybe it's just for WEP?

The usual way is to use a wpa_supplicant.conf file. Do you have one of those? The readme's for the drivers seem to be pretty good, and should tell you how to use it.

What is your error indication? Some boot message? It would be good for you to print that portion of "dmesg" out here, and give us your wpa_supplicant.conf, and show us what your rc.wireless and rc.local scripts look like also.

I am using ndiswrapper and wpa_supplicant. Getting it running was pretty painful, and I still don't know what the difficulty was. But it is working.
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Sat 12 Aug 2006, 06:50    Post_subject:  

iwpriv is used to access features of wifi drivers which are unique to that driver. This would include control of WPA setup ONLY if the wifi driver has inbuilt support for WPA, but currently there is only one such driver: Ralink.

All other drivers (and ndiswrapper) require the "helper" utility wpa_supplicant. http://www.dotpups.de/dotpups/Wifi/wireless-drivers/wpa_supplicant_README.txt gives detailed information.

I believe your chipset is Broadcom.

davidknibb wrote:
Something that I know well enough how to do in Debian
(iwpriv wlan0 set WPAPSK=xxxxxxxxx)

Mmm, in theory, this should only work with the Ralink driver.

davidknibb wrote:
some of the posts are useful discussions that don't seem to have culminated in a solution.

There's a success story here http://www.murga.org/~puppy/viewtopic.php?t=9376
Back to top
View user's profile Send_private_message 
davidknibb

Joined: 03 Aug 2006
Posts: 22

PostPosted: Mon 14 Aug 2006, 05:44    Post_subject:  

Thanks - I've been away for a few days - I'll follow these up later today if I have time.

Much obliged.

David
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0608s ][ Queries: 11 (0.0124s) ][ GZIP on ]