Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Aug 2018, 19:37
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Compiz 0.8.4 for Puppy 4.3
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
gray


Joined: 23 Feb 2007
Posts: 318
Location: Adelaide - South Australia

PostPosted: Fri 16 Oct 2009, 05:45    Post subject:  Compiz 0.8.4 for Puppy 4.3
Subject description: Wobbly Windows Wule !!
 

Just compiled and tried out the latest version of Compiz (-fusion) on Puppy 4.3.

You can find the compiz-0.8.4.pet file at
www.puppylinux.asia/tpp/NOP

(login puppy password linux)

Assuming you have a window manager that can support compiz (like XFCE in the new NOP 4.3.1 out soon) pretty much follow the steps outlined in this thread
http://www.murga-linux.com/puppy/viewtopic.php?t=32242

However, the python_for_ccsm pet needed a little update to pygtk to work with the latest compiz. A new python_for_ccsm-2.pet can be found in the NOP repository link.

start compiz by adding the following at the top of your .xinitrc file & restart x:

if [ -f /usr/bin/compiz ];then
compiz-manager &
sleep 4
fi

Last edited by gray on Fri 16 Oct 2009, 23:09; edited 1 time in total
Back to top
View user's profile Send private message 
magerlab

Joined: 08 Jul 2007
Posts: 737

PostPosted: Fri 16 Oct 2009, 18:45    Post subject:  

i just tried and can say that in generally it works:)
i installed xorg-dri.pet
and added some lines to etc/X11/xorg.conf
i have fbpanel so run starxt rxvt and then in rxvt compiz-manager
it works ( have 3d desktop and windows iconify like a paper planes:)
unfortunatelly no window decoration
first emerald asked for LibRes.so
i installed from deb
and then i got this

compiz-manager
Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald

(emerald:8272): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
/usr/bin/compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

i do not understand why it says XGL is not present:(
Back to top
View user's profile Send private message 
gray


Joined: 23 Feb 2007
Posts: 318
Location: Adelaide - South Australia

PostPosted: Fri 16 Oct 2009, 19:19    Post subject: GLib-GObject-CRITICA  

The error you get is because you have forgotten to comment out the line in /etc/profile : export XLIB_SKIP_ARGB_VISUALS=1

( I think )

Then reboot.

I use an nvidia card & for that there is no need for the xorg_dri.pet just install nvidia driver pet, libwnck pet, compiz pet & python_for_ccsm-2 pet.

I added libXRes and re-uploaded the pet.
Back to top
View user's profile Send private message 
magerlab

Joined: 08 Jul 2007
Posts: 737

PostPosted: Sat 17 Oct 2009, 05:18    Post subject:  

yes, it helps to have emerald!

strange, but there's some trouble with rox desktop: the first application iconifies and is not responsible uless other app is started
so i use compiz now with PCman-nohal wich i installed from lenny deb.
maybe there's a way to start pcmanfm instead of rox only when using compiz( e.g. to add something to .xinitrc?)
not yet installed python to use for compiz-settings manager
do not know wich of python pets or sfs is better
compizplane.jpg
Description  compiz with fbpanel and pcmanfm desktop
jpg

 Download 
Filename  compizplane.jpg 
Filesize  156.02 KB 
Downloaded  918 Time(s) 
Back to top
View user's profile Send private message 
magerlab

Joined: 08 Jul 2007
Posts: 737

PostPosted: Thu 22 Oct 2009, 02:15    Post subject:  

found a so;ution for Rox and compiz
need to uncheck first item ( Override ....) in Compatibilty tab in Rox-riler options
works nice on eee pc ( though needed some tweaks because Compiz config manager do not fit small screen) - see wiki on eeeuser.com

again and again i can say that puppy is easy and you do not need big brain to use Smile
Back to top
View user's profile Send private message 
glassparrot

Joined: 01 Jun 2008
Posts: 286
Location: Durango, Colorado - USA

PostPosted: Sun 08 Nov 2009, 22:01    Post subject:  

Thank you Gray, for this new version of Compiz. One note I'd like to make here for anyone who is interested - is about the sequence of adding the pets which one needs for compiz. I found it very important to reinstall my nvidia graphics card drivers (which I'm doing manually) AFTER I installed the xorg_xorg_full.dri pet. Nvidia makes a couple important changes to those files, apparently.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger 
Max Headroom


Joined: 28 Jun 2006
Posts: 361
Location: GodZone Kiwi

PostPosted: Sat 14 Nov 2009, 02:21    Post subject: Please, What's the Difference between this New Compiz Pet Vs
Subject description: Please, What's the Difference between this New Compiz Pet Vs
 

Please, What's the Difference between this New Compiz Pet Vs the Previous Fusion?
I'm having Considerable Misery Sad installing this w/ Errors like...
WARNING: Could not open '/lib/modules/2.6.30.5/initrd/kernel/drivers/usb/core/usbcore.ko.gz': No such file or directory
FATAL: Could not open '/lib/modules/2.6.30.5/initrd/kernel/drivers/hid/usbhid/usbhid.ko.gz': No such file or directory
Starting X, specs in /etc/X11/xorg.conf, startup apps /root/.xinitrc
Of Course I've followed instructions installed NVidia 173.14.20 Driver, Libwnck 2.23.4-i686.Pet, & then Compiz-0.8.4 Pet Edited .xinitrc File in /root/ I've done this @ least a Dozen times, & Wasted All of 4 'Ours. Please Help! This is Frugal install NOP 431 r1 w/ NVidia GeForce FX5200 Series.
Yet I Didn't have Any Trouble w/ Fusion-28Jul08pup4-i686.Pet installing on NOP 4.3.1, What's My Problem, Please?
Back to top
View user's profile Send private message Yahoo Messenger 
runtt21


Joined: 07 Jun 2008
Posts: 1651
Location: BigD Texas

PostPosted: Sat 14 Nov 2009, 09:43    Post subject:  

"WARNING: Could not open '/lib/modules/2.6.30.5/initrd/kernel/drivers/usb/core/usbcore.ko.gz': No such file or directory
FATAL: Could not open '/lib/modules/2.6.30.5/initrd/kernel/drivers/hid/usbhid/usbhid.ko.gz': No such file or directory
Starting X, specs in /etc/X11/xorg.conf, startup apps /root/.xinitrc "

Those errors don't have anything to do with compiz .You need to copy the zp430305.sfs to where you have your pup-save file .Or if you have a frugal install copy it to mnt/home . I have seen 4.30 have those errors and that is how I fixed it.
Back to top
View user's profile Send private message Visit poster's website 
Max Headroom


Joined: 28 Jun 2006
Posts: 361
Location: GodZone Kiwi

PostPosted: Sat 14 Nov 2009, 14:49    Post subject: Thanx 4 Replying runtt21
Subject description: Thanx 4 Replying runtt21
 

Thanx 4 Replying runtt21

"Those errors don't have anything to do with compiz" ( Clearly they Don't Refer to Anything Compiz Related or what it Needs, or X for that matter ),

But I Reiterate there is no Problem w/ My Base NOP 431 r1 Frugal install, this Error Only Occurs as a Consequence of installing the NVidia Driver ( or the New Compiz 0.8.4 Pet ). And I Didn't have Any such Fuss installing the Previous Compiz by wow Fusion-28Jul08pup4-i686.Pet on NOP 4.3.1 ( as opposed to r1 ).

Maybe I'll Try installing wows Fusion-28Jul08pup4-i686.Pet on this NOP 431 r1, But I'm Not sure the Problem is w/ the New Compiz Pet, well actually I'm Confused Myself! Confused

But What's the Difference / Advantage / Benefit between the Former Fusion-28Jul08pup4-i686.Pet Vs Latest Compiz-0.8.4 Pet, Anyway? Please!

And Where Can I Find this zp430305.sfs File?

I'm Grafeful 4 Any Help, Thanx!

Smile
Back to top
View user's profile Send private message Yahoo Messenger 
runtt21


Joined: 07 Jun 2008
Posts: 1651
Location: BigD Texas

PostPosted: Sat 14 Nov 2009, 15:22    Post subject:  

And Where Can I Find this zp430305.sfs File?

It should be on the live cd as part of the .iso. The 4.30 puppy has it ,I dont know about 4.31. I am about to finish the new version of macpup ,its based on ttuuxxx's 4.31.1 which is a bug fix version of 4.3.0 and I installed all the stuff from the 4.3.1service pack . It was during testing of the new macpup that I found those errors , But they didn't happen in the build version. The only difference between the two was the build version had the zp.sfs and the test pup-save of the new one did not. But it didn't effect the way the new one ran at all.

I cant really say what is up with the new compiz.I stick with e17 cause it will work with both xorg and xvesa.
Back to top
View user's profile Send private message Visit poster's website 
Max Headroom


Joined: 28 Jun 2006
Posts: 361
Location: GodZone Kiwi

PostPosted: Sat 14 Nov 2009, 17:42    Post subject: :)K runtt21
Subject description: :)K runtt21
 

SmileK runtt21, I've Found that zp430305 File on an old Dingo 4.3 CD like U said, ( I kNew I'd Scene it Sumplace! )? Wink , & I can Confirm that it isn't on / in Any 4.3.1 isos.
I've Copied it to 3 Locations: /mnt/home, /root/ ( as in Desktop Home Link ), & /mnt/home/puppy431 which is where me pupsave file actually is. So this is Hedging Me Bets, having a $ @ way where the Correct Location Actually is 4 a Frugal install, But then the Only Other Question is Shouldn't I Need 2 ReName this File to zp431305.sfs ?
Back to top
View user's profile Send private message Yahoo Messenger 
runtt21


Joined: 07 Jun 2008
Posts: 1651
Location: BigD Texas

PostPosted: Sat 14 Nov 2009, 17:53    Post subject:  

Boot it up and see what happens, If you still have the errors, that means it didn't load and you need to rename it. I think just having it in /mnt/home will do.
Back to top
View user's profile Send private message Visit poster's website 
gray


Joined: 23 Feb 2007
Posts: 318
Location: Adelaide - South Australia

PostPosted: Sat 14 Nov 2009, 19:51    Post subject: error messages  

ruuntt21,

The error messages that you are getting are nothing to do with compiz or the nvidia drivers as such. When the xwin script runs it checks to see if the usbcore & usbhid drivers are loaded. Not sure why but they are reported as missing - though they have in fact been loaded during bootup and are working fine. The "not recognising drivers" is triggered by installing new drivers (in this case nvidia) because the busybox depmod command does not work correctly - it quite often does not register drivers. If you enter depmod-FULL in the terminal the messages should go away.
Back to top
View user's profile Send private message 
Max Headroom


Joined: 28 Jun 2006
Posts: 361
Location: GodZone Kiwi

PostPosted: Sat 14 Nov 2009, 20:47    Post subject: G'day gray
Subject description: G'day gray
 

"If you enter depmod-FULL in the terminal the messages should go away."

Sorry Wot Did U Mean, After installing NVidia Driver, But B4 ReStarting X?

Thanx Mate Smile

Last edited by Max Headroom on Sat 14 Nov 2009, 21:59; edited 1 time in total
Back to top
View user's profile Send private message Yahoo Messenger 
Max Headroom


Joined: 28 Jun 2006
Posts: 361
Location: GodZone Kiwi

PostPosted: Sat 14 Nov 2009, 21:58    Post subject: Hey gray
Subject description: Hey gray
 

Hey gray, I haven't got a clue wot I just did in the Terminal, Following Y'r instructions, I got a Segmentation Fawlt, ReStarted X, & then Hey Presto NVidia Splash Screen Smile BlindFaith I Guess, Hallelujah, Thanx Mate Again!
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0709s ][ Queries: 13 (0.0120s) ][ GZIP on ]