Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 13 Nov 2018, 19:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
HPLIP 2.8.7 - for Puppy 3.x
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Thu 28 Aug 2008, 19:25    Post subject:  HPLIP 2.8.7 - for Puppy 3.x  

As the title says, this is the updated HPLIP for Puppy 3.x. Many thanks go to forum user "lluamco" for his work with bringing the updated HPLIP packages to Puppy 4.0 - With a little more work I was able to find a way to bring them to Puppy 3

Here it goes:

You will need an updated CUPS package (ver. 1.1.23-1) available from the repository:

http://ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-3/cups-1.1.23-1.pet

You will need (for basic printing) Python, hplip-dependencies, and hplip 2.8.7 located here:

http://dotpups.de/puppy4/dotpups/Printing/hplip_for_dingo/
http://puppyfiles.ca/dotpupsde/puppy4/dotpups/Printing/hplip_for_dingo/

libdus, imaging, report-lab, and net-snmp can be added for more functionallity - more info can be found at lluamco's original post: http://www.murga-linux.com/puppy/viewtopic.php?search_id=471362113&t=27519

Last but not least, if you intend to use Firefox 3.x for browsing (and need to print) you will need a few updated gtk libraries that I have included as an attachment.

Printing has been tested in Firefox, Abiword, Gnumeric, and OpenOffice, and all seem functional.

Enjoy,
JB
firefox-3.x-printfix.pet
Description 
pet

 Download 
Filename  firefox-3.x-printfix.pet 
Filesize  35.19 KB 
Downloaded  515 Time(s) 
Back to top
View user's profile Send private message Yahoo Messenger 
ndujoe1

Joined: 04 Dec 2005
Posts: 779

PostPosted: Sun 28 Sep 2008, 09:24    Post subject: HP pcs 1210 printer All in One Success  

I would like to report that I got this Printer working, printing and scanning using this advise given in the forum and installed the following.

I am using Puppy linux 3.01 with Cups 1.2.11
Xsane-0.991
sane_backends-1.0.17
hpijs-2.8.9 hp printer drivers
hpliplite-2.8.9

The installation, recognition and operation was seamless and easy.
Back to top
View user's profile Send private message 
Robby

Joined: 22 Jan 2010
Posts: 2
Location: Spain/Italy

PostPosted: Sat 23 Jan 2010, 08:25    Post subject: Abiword, gnumeric, ePDFview problems
Subject description: Can't print from abiword, gnumeric and ePDFview.
 

Hello, I know this is an old post, but I don't like to duplicate posts if not strictly necessary so...

The question: following above instructions I've been able to print a test page from CUPS to my HP OfficeJet J4580 All In One (this wasn't possible with default CUPS in Puppy 3.01 and "hpijs-1.7: HP printers drivers" found at PETget package manager).

I'm able to print from Seamonkey too.

But I'm still having troubles: dependencies troubles, partially solved, and printing troubles, NOT yet solved.

Last ones (really TRUE question) are:
    I can't print from AbiWord or Gnumeric (printer isn't shown on dialog window)
    I can't print from ePDFView (when I select OfficeJet J4580 printer on dialog window it closes suddenly).

Any suggestions are welcome.

By the way... it's possible to use above instructios to install hplip versions newer than 2.8.7 (located at same places that 2.8.7: http://dotpups.de/puppy4/dotpups/Printing/hplip_for_dingo/)???.

I've tryed with 3.9.2 with no luck.

Thanks in advance. Robby.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0616s ][ Queries: 13 (0.0208s) ][ GZIP on ]