Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Oct 2018, 00:11
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Session not being resumed in slacko64
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
Randyth

Joined: 20 Jul 2018
Posts: 6

PostPosted: Fri 20 Jul 2018, 12:10    Post subject:  Session not being resumed in slacko64  

I'm new to puppylinux, but sofar I'm quite impressed (by the lightness, completeness and speed).

One thing I cannot seem to get working is the session resuming.

My system is a laptop with Windows 10 and I'm booting Slack64 (6.3.2) from a USB stick (created with Win32 Disk Imager). My hard drives layout can be seen in hd_overview2.png .

Now when I change some settings and shutdown the system I'm being prompted to save my session. I'm saving the session on sda4 (my NTFS drive with the windows 10 installation).
I can see the save files being created in the root (see saves_overview.png).

But when I start slacko64 again from the usb drive then the session is not being resumed (none of my altered settings are present). I get presented with the first boot setup window. And when shutting down I get asked again to save a session. When i save the session, then a new session file is being stored again. But at a new startup of Slacko64, the session file is not being used and instead I am in a completely new session.

I must be doing something wrong. But what?
saves_overview.png
 Description   
 Filesize   46.3 KB
 Viewed   372 Time(s)

saves_overview.png

hd_overview2.png
 Description   
 Filesize   30.57 KB
 Viewed   370 Time(s)

hd_overview2.png


Last edited by Randyth on Sat 21 Jul 2018, 07:21; edited 1 time in total
Back to top
View user's profile Send private message 
mjmikulcik

Joined: 09 Jun 2017
Posts: 32

PostPosted: Fri 20 Jul 2018, 13:44    Post subject:  

Welcome to the forum! I believe the problem your facing is with the grub config files and not with how you saved it.

You should see something like this in your grub.cfg file or lickgrub.cfg if you used lick to install
Code:
menuentry 'Slacko64 6.3.2' {
set root=(hd0,4)
linux /slacko64-6.3.2-uefi/vmlinuz pfix=fsck pmedia=ataflash psubdir=(hd0,4)
initrd /slacko64-6.3.2-uefi/initrd.gz
}


The important part is having it point correctly to the vmlinuz and initrd (which it already does), and the psubdir needs to be set to where the savefile is

And since you have multiple savefiles you can add this to the line that starts with "linux"
Code:
savefile=slacko64save.2fs


The "pmedia=ataflash" part makes the puppy run in ram which I always use so that if I mess something up the changes aren't permanent.

Edit: I just saw that you were booting from a USB. I've never done that but the problem is similar. Your savefile isn't on the USB stick, and you need to point the usb config files to recognize the savefile. I suggest moving the savefile to the usb unless you want a clean install everytime you put it in a new computer

Edit2: I've attempted to install to usb as you did, how did you select the destination for the savefile on shutdown
Back to top
View user's profile Send private message 
Randyth

Joined: 20 Jul 2018
Posts: 6

PostPosted: Sat 21 Jul 2018, 07:18    Post subject:  

Thank you for your reply.

I included a screenshot (choose_partition.png) of the partition selection step during the session wizard of slack64 (6.3.2). On this screen I can select the destination for the savefile on shutdown.
On this screen i choose sda4 with success (I can see the created save file on the selected partition. See screenshot in post #1). I just cannot make slacko64 use the save file to resume the session (yet).

I tried editing the grub.cfg file on the USB boot drive to add the root path, but it seems to be on a read-only file-system (see screenshot edit_grub1.png and edit_grub2.png). Therefor I have not yet succeeded in editing the file (see the error message below on screenshot edit_grub2.png).

Any other tips on how I can resume the session in slacko64?
edit_grub2.png
Description 
png

 Download 
Filename  edit_grub2.png 
Filesize  45.68 KB 
Downloaded  59 Time(s) 
edit_grub1.png
Description 
png

 Download 
Filename  edit_grub1.png 
Filesize  43.97 KB 
Downloaded  55 Time(s) 
choose_partition.png
 Description   
 Filesize   28.97 KB
 Viewed   323 Time(s)

choose_partition.png


Last edited by Randyth on Sat 21 Jul 2018, 11:40; edited 1 time in total
Back to top
View user's profile Send private message 
mfb

Joined: 22 Mar 2016
Posts: 60

PostPosted: Sat 21 Jul 2018, 09:17    Post subject:  

Hi,

Try this:

Download SAVEMARK.gz
Rename it deleting the final 3 ".gz" characters
Move it to sda1
reboot

Cheers
SAVEMARK.gz
Description 
gz

 Download 
Filename  SAVEMARK.gz 
Filesize  1 Bytes 
Downloaded  24 Time(s) 
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2700
Location: 500 seconds from Sol

PostPosted: Sat 21 Jul 2018, 10:08    Post subject:  

I'm not sure it matters --I never used grub-- but:

on the attached edit_grub2.png shows that there is no blank line between your "set timeout=10" and menuentry="Start Slacko64" {

Perhaps it's needed in order for your "RAM Only" listing NOT to be the first choice on bootup.

mikesLr
Back to top
View user's profile Send private message 
Randyth

Joined: 20 Jul 2018
Posts: 6

PostPosted: Sat 21 Jul 2018, 11:38    Post subject:  

mfb wrote:
Hi,

Try this:

Download SAVEMARK.gz
Rename it deleting the final 3 ".gz" characters
Move it to sda1
reboot

Cheers


Interesting. I will try this (even though I actually only wanted to use sda4 for storing the save file). Will report back later on result.

@mikeslr, I can't edit the file as it seems to be on a read-only filesystem (see the message in nano below of edit_grub2.png)
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Sat 21 Jul 2018, 11:41    Post subject:  

When you boot, which of the Slacko menu entries are you using?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11145
Location: Charleston S.C. USA

PostPosted: Sat 21 Jul 2018, 16:10    Post subject:  

Make sure you are booting from the normal menu entry. First one.

NOT THE ONE THAT SAYS RAM ONLY
That boots not using the save.

Puppy always runs and loads into RAM.

Slacko is probably a live install on the USB flash drive.
It is using the boot loader that is part of the live install.
It is not using Grub4dos boot loader.

Booting from a USB flash drive install of Puppy.
The boot process is looking to find the save on the USB flash drive.
Yours is probably sdb

Move the save to the USB flash drive, where Slacko is installed.
Place it just on the top of the partition, not inside any folder (directory- Linux term for folder).

Windows 10 does not like to see anything done to the hard drive by any other OS.
I suggest, anything Slacko, go only on the USB flash drive Slacko is on.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Randyth

Joined: 20 Jul 2018
Posts: 6

PostPosted: Sun 22 Jul 2018, 07:10    Post subject:  

Thank you all for the help and patience with me.

I'm always booting the first option (Start Slacko64), with the other options being: 'Start Slacko64 - RAM Only', 'Start Slacko64 No X', 'Start Slacko64 check filesystem' , 'Shutdown' and 'Reboot'.

I also tried adding the save file to the usb drive, but I only have read only access (see screenshot: usb_read_only2.png in this post).


Also during the session savefile wizard I don't have the usb drive as option (see screenshot choose_partition.png in the post above: http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=117862 ).

What else can I try to resume my saved session?

I feel like I might have chosen a 'strange bird in the bite' with slacko64.
But the distribution 'Ubuntu Xenial 64' was giving me problems with the ATI drivers. Maybe I should give Ubuntu Tahr 64 a try.

All I did was download http://distro.ibiblio.org/puppylinux/puppy-slacko-6.3.2/64/slacko64-6.3.2-uefi.iso and use Win32 Disk Imager to prepare my 16gb usb drive.
usb_read_only2.png
 Description   
 Filesize   29.93 KB
 Viewed   178 Time(s)

usb_read_only2.png

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11145
Location: Charleston S.C. USA

PostPosted: Mon 23 Jul 2018, 08:28    Post subject:  

How about posting, an image of what Gparted shows, for the setup, of partitions, on the USB flash drive.

That image you posted of what Pmount shows for sdb.
sdb1 has a totally wrong file system.
It shows it as iso9660 file system. (read only file system)
Normally Puppy is installed to a standard read/write file system like fat32, ntfs, ext 3 or 4, etc.....

I think using Win32 Disk Imager may be the big problem.

If you have another USB flash drive.
Try using the programs in Slacko to do the install.

I have had good luck using Unetbootin in Windows to do installs of Puppy to USB flash drives.
Unetbootin.
http://unetbootin.sourceforge.net/

Note:
A trick when using an installer program not written specifically for Puppy and how it works.
After the install of Puppy.
Look on the drive for a boot loader file that is the boot menu.
Could be grub.cfg, isolinux.cfg, syslinux.cfg.
(may see all 3. Grub.cfg is probably what is used)
Open this file in a text editor.
Anyplace you see
Code:
pmendia=

Change it to
Code:
pmedia=usbflash

That tells Puppy boot process to setup for running from a USB flash. There are some special ways it will make Puppy run.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked

Last edited by bigpup on Mon 23 Jul 2018, 09:14; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Mon 23 Jul 2018, 09:08    Post subject:  

Your save file is on an NTFS partition. The "read-only" message indicates that Puppy sees the partition as "dirty" and refuses to mount the save file.

[Edit] I looked at that screen shot again, and I may have misinterpreted it.

Is sdb1 a read-only ISO9660 partition because of how you made your flash drive - possibly by using dd?

Last edited by rcrsn51 on Mon 23 Jul 2018, 09:57; edited 3 times in total
Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 571
Location: europa near northsea

PostPosted: Mon 23 Jul 2018, 09:10    Post subject: grub.cfg  

In your grub.cfg:

Isn't sda4=(hd0,3)?
The underscore also looks suspicious to me. Leave it out. [edit: underscore is just the cursor, isn't it? Smile ]
So this line should be:
Code:
set root=(hd0,3)

I am not even sure you need this line. Puppy should go and look everywhere for a proper pupsavefile.

Last edited by foxpup on Mon 23 Jul 2018, 09:29; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Mon 23 Jul 2018, 09:15    Post subject: Re: grub.cfg  

foxpup wrote:
Isn't sda4=(hd0,3)?

It depends on your version of GRUB.
Back to top
View user's profile Send private message 
Randyth

Joined: 20 Jul 2018
Posts: 6

PostPosted: Tue 24 Jul 2018, 14:36    Post subject:  

bigpup wrote:
How about posting, an image of what Gparted shows, for the setup, of partitions, on the USB flash drive.

That image you posted of what Pmount shows for sdb.
sdb1 has a totally wrong file system.
It shows it as iso9660 file system. (read only file system)
Normally Puppy is installed to a standard read/write file system like fat32, ntfs, ext 3 or 4, etc.....

I think using Win32 Disk Imager may be the big problem.

If you have another USB flash drive.
Try using the programs in Slacko to do the install.

I have had good luck using Unetbootin in Windows to do installs of Puppy to USB flash drives.
Unetbootin.
http://unetbootin.sourceforge.net/

Note:
A trick when using an installer program not written specifically for Puppy and how it works.
After the install of Puppy.
Look on the drive for a boot loader file that is the boot menu.
Could be grub.cfg, isolinux.cfg, syslinux.cfg.
(may see all 3. Grub.cfg is probably what is used)
Open this file in a text editor.
Anyplace you see
Code:
pmendia=

Change it to
Code:
pmedia=usbflash

That tells Puppy boot process to setup for running from a USB flash. There are some special ways it will make Puppy run.


Your suspicion on Win32 Disk Imager makes sense. I've rewritten the ISO with dd (from within slacko).

See screenshot dd_write.png.
My first impression is that the filesystems and readonly permissions are the same (see screenshot df-t.png).

I'm quite confused. Can someone maybe check if they get a different result with the iso flile: slacko64-6.3.2-uefi.iso file
df-t.png
 Description   
 Filesize   24.96 KB
 Viewed   76 Time(s)

df-t.png

dd_write.png
 Description   
 Filesize   6.07 KB
 Viewed   77 Time(s)

dd_write.png

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11145
Location: Charleston S.C. USA

PostPosted: Tue 24 Jul 2018, 20:02    Post subject:  

Quote:
How about posting, an image of what Gparted shows, for the setup, of partitions, on the USB flash drive.

I think you need to get the USB flash drive partitioned and formatted correctly.

sdb1 is formatted iso9660 and that is just wrong.
Or dd is just writing the iso of Slacko to sdb1 and unpacking it, still in a iso9660 format.

Using dd is just asking for problems. No mistakes, and it is simple to make a wrong command.

Us Gparted to partition and format.
Do you need help using Gparted?

All the partitions need to be formatted in a standard format. Fat32, ext3 or 4 etc........

Make the first partition some size.
Say 5GB.
Format it fat32
Flag it boot.
The rest of the drive you can partition and format how you like.

I still suggest using an installer program that is in Slacko.

Do all Slacko installs to this first partition.

In Windows use Unetbootin
The first partition does need to be formatted fat32 and flagged boot.
Unetbootin will install Slacko to that partition.

About that save writing to the USB flash drive.
The way the flash drive is formatted.
There is no real place to write it.
Partitions are wrong format or have no room.
Doing the above should get this corrected.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1032s ][ Queries: 13 (0.0104s) ][ GZIP on ]