Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Jul 2018, 06:11
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
xenialpup64-7.5-uefi.iso
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Author Message
pp4mnklinux


Joined: 23 Aug 2013
Posts: 191

PostPosted: Sun 17 Jun 2018, 11:17    Post subject:  xenialpup64-7.5-uefi.iso
Subject description: WHERE CAN I FIND SOFT FOR THIS DISTRO?
 

Hello everybody:

One week ago, I posted a question about slimjet 19 instalation in my puppy tahr 6.0.2, and some of u gave me a lot of recommendations, all of them very difficult for me, so I decided to install an updated version, so I installed xenialpup64-7.5-uefi.iso, and I found a lot of difficulties.

Where can I find .pet packages to install at this version.

I installed slimjet 19 and it didn't start.
I cant install THE GIMP, because it is not at the puppy package manager and the pet I have is not useful
I cant install XVID to record videos on my screen.
I cant install....



Is there any place with a list of pets ready to install with xenialpup64-7.5-uefi.iso ??

THE PPM give me options, but except FireFox I can't install anything else.

Please, help me because this distro works fast with my hardware, I wanna use it, but I need xvid and the gimp (slimjet 19 will be welcome too) and I can't find where to have them.


THANKS IN ADVANCE for your help.


HAVE A NICE DAY

_________________
I am using puppy tahr 6.0.2 Arrow

http://www.protopage.com/pp4mnkt3am#puPPy_Linux

(feel free to contribute)
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10733
Location: Charleston S.C. USA

PostPosted: Sun 17 Jun 2018, 12:01    Post subject:  

Xenialpup64 7.5 being a 64bit OS.
Stuff needs to be for 64bit OS.

You may need to just use the 32bit version of Xenialpup 7.5

However, you can run 32bit software, but you need to install the needed 32bit support files.
Probably, a lot of the pets you are trying to use, are 32bit.

Quickpet icon on desktop gives you a lot of stuff for Xenialpup64.
Quickpet>Useful>32bit compatibility sfs
32bit compatibility sfs, loaded by using the SFS-Load-on-the-fly program, will let you run 32bit software.

Puppy Package Manager(PPM)
First, in configure do a database update.

Gimp in PPM
capture28365.jpg
 Description   
 Filesize   41.66 KB
 Viewed   320 Time(s)

capture28365.jpg


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 191

PostPosted: Sun 17 Jun 2018, 14:23    Post subject: Thanks a lot bigpup, but...
Subject description: PPM
 

Thanks for your answer, but I dont know what happened with the gimp.

I tryed to install it using PPM and it told me it cant find some necesary files in my computer.

When doing the same with slimjet (a user gave me the link to download it at one of my posts... http://www.murga-linux.com/puppy/viewtopic.php?t=113594 I installed it but it didnt work.

I dont know what appened, I thought 64 bits versions can work with 32 and 64 bits software, so I decided for a 64 to make it more compatible.

In one of my sites, http://www.protopage.com/pp4mnkt3am#puPPy_Linux , I have a lot of addresses with links to install puppy tahr 6.0.2 software. Can u tell me some place where I can download programms for XENIAL PUP.

THANKS A LOT.


If u cant tell me a software link, can u recomend me the most complete xenial put or the most modern puppy distro to install???

THANKS IN ADVANCE. (I dont wanna install the 32 version, it goes much more slowly and I want spead

32 CPU BLOWFISH 4.37'' 4.55''
64 CPU BLOWFISH 3.97

_________________
I am using puppy tahr 6.0.2 Arrow

http://www.protopage.com/pp4mnkt3am#puPPy_Linux

(feel free to contribute)
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2477
Location: 500 seconds from Sol

PostPosted: Sun 17 Jun 2018, 15:21    Post subject: Applications (specific and in general) for Xenialpup64  

Hi pp4mnklinux,

First a request regarding your future questions. The recommended place to post questions about applications which will run under a specific Puppy, is that Puppy's thread. That's were those familiar with it will look for questions, and the answers they provide will help others having similar questions about that Puppy.

FatDog64-600's xvidcap 1.1.7 will run under Xenialpup64. You can obtain it here: http://distro.ibiblio.org/fatdog/pets/600/. But many fans prefer Simple Screen Recorder which Xenialpup64 includes.

The gimp&mypaint.sfs is the version I use. You can find it here: http://distro.ibiblio.org/puppylinux/pet_packages-tahr64/. Note that it's in the Tahrpup64 folder. Most applications built for Tahrpup64 will run under Xenialpup64.

As an alternative to that, Xenialpup64's Puppy Package Manager works very well (but not perfect) if you want to install or build your own. But there are many options regarding what to include when building Gimp. So, an easier alternative is to use the Gimp.AppImage. Elle's Color-corrected-enhanced version can be found here: https://discuss.pixls.us/t/community-built-software/2137. Another version can be found here: https://bintray.com/probono/AppImages/GIMP. While you're on that page note the line near the top which reads “probono/Appimages/GIMP”. Click the word which reads “Appimages” and your web-browser will open to the first page of probono's accumulated applications. Probono republishes many Appimages. Most work OOTB under Xenialpup64. There's a Search box which is will quickly take you to an application's page, if it exists, or tell you it doesn't. But it's worth scrolling thru the now 21 pages (8 links to applications per page) to see what is currently available. See http://www.murga-linux.com/puppy/viewtopic.php?t=110078 for more information about AppImages, how to use them and links to other repos.

On Xenialpup64 I run Mike Walsh's build of Google-Chrome from this thread, http://murga-linux.com/puppy/viewtopic.php?t=107301. The link at the bottom of the first post will take you to the latest build, albeit it bears the 'Tahrpup64' designation. You don't want the one bearing the "Slacko64" designation. Mike Walsh also builds Slimjet 64-bits. Click the blue My Puppy Packages at the bottom of this post. http://www.murga-linux.com/puppy/viewtopic.php?p=975600#975600. Again you'll want the "Tahrpup64" version.

You can find out about other web-browsers from their threads on the Additional Software>Browsers & Internet Section.

mikesLr
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10733
Location: Charleston S.C. USA

PostPosted: Sun 17 Jun 2018, 21:18    Post subject:  

Quote:
Quickpet>Useful>32bit compatibility sfs
32bit compatibility sfs, loaded by using the SFS-Load-on-the-fly program, will let you run 32bit software.

Do you not understand that loading this will let Xenialpup64 7.5 use 32bit software????

Xenialpup64 7.5 repositories do not have very much in them.
PPM is only place you will find it.
Quickpet again has some stuff.

Any software on this forum made for Tahrpup32 or 64, Xenialpup 32 or 64 has a good chance of working if you do load the 32bit compatibility sfs.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked

Last edited by bigpup on Sun 17 Jun 2018, 23:26; edited 2 times in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10733
Location: Charleston S.C. USA

PostPosted: Sun 17 Jun 2018, 21:25    Post subject:  

Xenialpup64 7.5
PPM>configure updated the database.
Downloaded and installed Gimp 2.8.16

Working OK for me.
capture31308.jpg
 Description   
 Filesize   154.04 KB
 Viewed   271 Time(s)

capture31308.jpg


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked

Last edited by bigpup on Sun 17 Jun 2018, 23:27; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10733
Location: Charleston S.C. USA

PostPosted: Sun 17 Jun 2018, 23:17    Post subject:  

Xenialpup64 7.5

Have not found a Slimjet 19 64bit made for Puppy.
Here is a slimjet 16 sfs that works for me.
https://www.mediafire.com/folder/cetf5lx07zd28/Puppy_Stuff#ma74mmhtzax46

This topic is about Slimjet64 bit sfs packages
http://www.murga-linux.com/puppy/viewtopic.php?t=106957
Give Mike Walsh some time to make a newer version.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 191

PostPosted: Mon 18 Jun 2018, 01:39    Post subject:  THANKS A LOT FOR EVERYBODY
Subject description: thanky
 

Hello:

Very thanful for all your answers.

They give me the opportunity of continuing using this distro.

EXCUSEME for my errors, but I found some difficulties.


HAVE A NICE WEEK.

_________________
I am using puppy tahr 6.0.2 Arrow

http://www.protopage.com/pp4mnkt3am#puPPy_Linux

(feel free to contribute)
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3925
Location: King's Lynn, UK.

PostPosted: Sun 24 Jun 2018, 17:32    Post subject:  

I feel I ought to point out, here and now, that I've pretty much 'given up' on the 64-bit SlimJet packages.

I was having a lot of problems with them a couple of series back, and that, together with also doing the Chrome and Iron packages (and not having much time to do all of them), led to my 'rationalising', and deciding to concentrate on just Chrome and Iron.....which were proving somewhat easier to deal with! And, unlike peebee, who packages every single point release of Chromium, you've probably noticed that I only package one version of every major release.

Don't get me wrong. I love SlimJet as a browser.....but I'm afraid there's a limit to the amount of time I can put into this stuff nowadays. I simply had to draw the line somewhere, and.....well, SlimJet drew the 'short straw', as it were. On top of all that, I'm starting to move back towards Firefox for the first time in almost a decade, due to the release of Quantum (which to my mind is how FF should have been years ago...) I'm very impressed with it.....and it now handles streaming services every bit as well as Chrome does.

(And it no longer crashes at the slightest excuse....!)

Sorry about that, boys & girls. If anybody else feels they would perhaps like to tackle the 64-bit version of SlimJet.....feel free.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Freddie1

Joined: 28 Apr 2018
Posts: 29

PostPosted: Sun 15 Jul 2018, 14:15    Post subject: Installing gimp
Subject description: Missing widgets
 

Hardware: Acer Aspire one
OS: Xenialpup64 7.5
The OS is installed on an SSD w/o any other software over 100gig free
RAM: 2 gig

Installed gimp through the ppm: It appeared successful however there was a notation about two files not present but that they were expected to be installed during the boot process. I rebooted and gimp fails. Trying to execute from the menu does nothing, it's as if I never clicked on the menu item. Entering gimp in the terminal provides a message that I am missing libgimpwidgets. tried finding libgimpwidgets in the ppm, doesn't exist.

Any suggestions
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 846
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Sun 15 Jul 2018, 14:27    Post subject: Re: Installing gimp
Subject description: Missing widgets
 

Freddie1 wrote:
Hardware: Acer Aspire one
OS: Xenialpup64 7.5
The OS is installed on an SSD w/o any other software over 100gig free
RAM: 2 gig

Installed gimp through the ppm: It appeared successful however there was a notation about two files not present but that they were expected to be installed during the boot process. I rebooted and gimp fails. Trying to execute from the menu does nothing, it's as if I never clicked on the menu item. Entering gimp in the terminal provides a message that I am missing libgimpwidgets. tried finding libgimpwidgets in the ppm, doesn't exist.

Any suggestions


You did not list the whole name of the missing libs so I am taking a guess.
If your missing libs are on this file list then the .deb package from here contains your missing libs.

.

_________________
Giving with an expectation for return brings misery.
Back to top
View user's profile Send private message 
Freddie1

Joined: 28 Apr 2018
Posts: 29

PostPosted: Sun 15 Jul 2018, 14:35    Post subject:  

@perdido, thank you, the missing file is in the list from your link.
Back to top
View user's profile Send private message 
Freddie1

Joined: 28 Apr 2018
Posts: 29

PostPosted: Sun 15 Jul 2018, 14:51    Post subject:  

Installing the libgimp2.o files as suggested almost works, I get a popup message when it is executed. The screen shot shows the issue, I don't know enough about puppy to take action based on the message..
capture7908.png
 Description   
 Filesize   23.93 KB
 Viewed   71 Time(s)

capture7908.png

Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 846
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Sun 15 Jul 2018, 15:16    Post subject:  

Freddie1 wrote:
Installing the libgimp2.o files as suggested almost works, I get a popup message when it is executed. The screen shot shows the issue, I don't know enough about puppy to take action based on the message..


Are there any error messages when starting from terminal or on shutdown from terminal?

look at the directory etc/gimp/2.0
Is there a file named controllerrc


.

_________________
Giving with an expectation for return brings misery.
Back to top
View user's profile Send private message 
Freddie1

Joined: 28 Apr 2018
Posts: 29

PostPosted: Sun 15 Jul 2018, 15:29    Post subject:  

There are a lot of messages in the terminal, maybe gimp didn't install properly:

(gimp:19503): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-tls-backend. Expected type is GTlsBackend.

(gimp:19503): GLib-GObject-WARNING **: Two different plugins tried to register 'GTlsBackendGnutlsPkcs11'.

(gimp:19503): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-tls-backend. Expected type is GTlsBackend.

(gimp:19503): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyResolverGnome'.

(gimp:19503): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gimp:19503): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-proxy-resolver. Expected type is GProxyResolver.

(gimp:19503): GLib-GObject-WARNING **: Two different plugins tried to register 'GLibProxyResolver'.

(gimp:19503): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gimp:19503): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-proxy-resolver. Expected type is GProxyResolver.
GIMP-Error: Unable to run plug-in "bimp-locale"
(/root/.gimp-2.8/plug-ins/bimp-locale)

Failed to execute child process "/root/.gimp-2.8/plug-ins/bimp-locale" (Permission denied)

Unable to read initialization file script-fu.init
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1060s ][ Queries: 13 (0.0136s) ][ GZIP on ]