Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 16 Dec 2018, 02:34
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to get older version addons for old Seamonkey?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
snayak

Joined: 14 Sep 2011
Posts: 420

PostPosted: Sat 16 Jun 2018, 07:25    Post subject:  How to get older version addons for old Seamonkey?  

Hi,

To find addons for my Seamonkey verson, I goto Tools->Addons Manager. There I search for required addons.
I noticed, when I use a new version of Seamonkey, my search shows me some addons which are not shown when I use a older version. Seems like addons get updated and if not compatible to old versions of Seamonkey, it is not shown in searches.

How can I get an older version of addon which is suitable to my Seamonkey version?

Also I noticed, some addons which are available for Firefox are not available for Seamonkey. Is there a solution for such a case?

Sincerely,
Srinivas Nayak

_________________
[Precise 571 on AMD Athlon XP 2000+ with 512MB RAM]
[Fatdog 720 on Intel Pentium B960 with 4GB RAM]

http://srinivas-nayak.blogspot.com/
Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 229

PostPosted: Sat 16 Jun 2018, 08:01    Post subject: Re: How to get older version addons for old Seamonkey?  

snayak wrote:
Hi,

To find addons for my Seamonkey verson, I goto Tools->Addons Manager. There I search for required addons.
I noticed, when I use a new version of Seamonkey, my search shows me some addons which are not shown when I use a older version. Seems like addons get updated and if not compatible to old versions of Seamonkey, it is not shown in searches.

How can I get an older version of addon which is suitable to my Seamonkey version?

Also I noticed, some addons which are available for Firefox are not available for Seamonkey. Is there a solution for such a case?

Sincerely,
Srinivas Nayak


Hello Srinivas,

Here is an adblocker for Seamonkey

https://addons.mozilla.org/seamonkey/downloads/file/541651/adblock_plus-2.8.2-an+fx+sm+tb.xpi?src=version-history
Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 229

PostPosted: Sat 16 Jun 2018, 08:02    Post subject:  

What other extensions do you require?
Back to top
View user's profile Send private message 
snayak

Joined: 14 Sep 2011
Posts: 420

PostPosted: Sat 16 Jun 2018, 09:42    Post subject:  

Thanks darry,

adblocker is quite useful though... Smile

I am interested for general solution to this kind of old version addon finding problem rather than anything in particular.

_________________
[Precise 571 on AMD Athlon XP 2000+ with 512MB RAM]
[Fatdog 720 on Intel Pentium B960 with 4GB RAM]

http://srinivas-nayak.blogspot.com/
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11392
Location: S.C. USA

PostPosted: Sat 16 Jun 2018, 10:01    Post subject:  

Basically, if a search does not list an older add-on for the Seamonkey version you are using.
That older add-on is no longer usable with that newer Seamonkey version.

The features, code, ability, how it basically works, etc.... is constantly changing in browsers.
They add features, change them, delete stuff, change how the browser works, etc.......

So, some old add-ons just do not work anymore on the newer version of Seamonkey.

Example:
Quote:
Extensions with binary components such as Lightning, Enigmail and HTML Validator only work on certain platforms (e.g. Windows). Furthermore they need to be adjusted for each new SeaMonkey release, which also means that an old version of such an add-on can break SeaMonkey.

SeaMonkey 2.29 dropped support for the legacy JavaScript Debugger interface (JSD1). Hence add-ons that relied on it, like the JavaScript Debugger (Venkman) that came bundled with SeaMonkey, or Firebug 1.x, have stopped working. While Venkman has been discontinued, Firebug can simply be upgraded to a more recent version (2.x) which supports the new JSD2 interface.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 140

PostPosted: Sat 16 Jun 2018, 11:28    Post subject:  

To locate addons for older Firefox versions and derivitives (e.g Seamonkey, Palemoon, Light, etc) use your search engine to look for "<name of your required addon> :: versions".
Click on (what should be) the first result, example below.

Then scroll down the list until you get to the first version which doesn't report "This add-on is not compatible with your version of Firefox.", which will also be the first for which the button "Add to Firefox" is highlighted in green.
The more recent Firefox version your derivitive is based on, the sooner you'll get to it. (Unfortunately with Palemoon it's quite possible there'll be none compatible, and from what bigpup says above, maybe also Seamonkey; can't comment since i've not used it since Wary's default installed version!)

Click on that green "Add to Firefox" button and install as normal.

Note you obviously can't necessarily expect the same full functionality and/or security which you could if using the latest version, so use at your own risk having made usual appropriate backups!
capture25870.png
 Description   example
 Filesize   29.06 KB
 Viewed   128 Time(s)

capture25870.png

Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 229

PostPosted: Sat 16 Jun 2018, 16:31    Post subject:  

Salty is right I looked up adblocker this way went to https://addons.mozilla.org/en-US/seamonkey/addon/adblock-plus/versions/
till I came to an older version which I have tested with version 2.46 an appimage gtk2 version so it should work with 2.40.

The point is an older version should still work based on my experimenting with this method.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2153
Location: Out wandering... maybe.

PostPosted: Sat 16 Jun 2018, 18:10    Post subject:  

Easier method would be just to go straight to addons.mozilla.org; you may need to open the site in Seamonkey to look for Seamonkey extensions, because I'm not sure offhand how to switch to Seamonkey/Thunderbird extensions with Mozilla's redesign of the site for Firefox. Rolling Eyes

If the extension you're looking for (still) comes up when you search for it on AMO, you can call up a list of the older versions of the extension from that extension's page - just go to the "More information" box on the left side of the page, and under "Version History," click on the "See all versions" link.

(That explanation was probably more complex than it needed to be, but eh. Smile )

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * [ Puppy Precise 5.7.1 JP, Frugal install ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11392
Location: S.C. USA

PostPosted: Sat 16 Jun 2018, 18:26    Post subject:  

The main point is the older version may still work, it may not.
If the Seamonkey internal add-on access will not show it as a usable download.
Do not use it!
The browser has changed too much and no longer supports that add-on.
The add-on needs to be updated to work in the newer Seamonkey version.
Some add-ons do get updated.
Some do not and just go away or are replaced by something else.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2153
Location: Out wandering... maybe.

PostPosted: Sun 17 Jun 2018, 02:02    Post subject:  

...or Mozilla radically changes the way it handles extensions, and a lot of useful extensions drop by the wayside because they can't/won't be updated. Neutral

bigpup, I believe AMO has some protection against that. It's not perfect, but it'll try to prevent you from using wildly out-of-date extensions depending upon your client/browser version.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * [ Puppy Precise 5.7.1 JP, Frugal install ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1240s ][ Queries: 13 (0.0344s) ][ GZIP on ]