Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Oct 2018, 23:51
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
(SOLVED) - Xenialpup64-7.5.pet and printing
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
LeithR

Joined: 24 Jan 2011
Posts: 277
Location: Kemnay, Aberdeenshire/Scotland

PostPosted: Tue 01 May 2018, 04:01    Post subject:  (SOLVED) - Xenialpup64-7.5.pet and printing  

Yesterday I set up a DELL Inspiron with Xenialpup64-7.5, the OS works beautifully - but - After connecting an HP Deskjet 3050 printer using hplip-print-3.16.5.pet and hplip-scan-3.16.5.pet via CUPS I get a "Filter Failure" error message and I can't print.

To investigate this problem further I connected the printer to my other DELL laptop with Slacko-6.9.9.9.pet which has hplip-print/scan-3.16.5. and that combination worked perfectly.

I then connected another basic HP 2024 printer to both DELL laptops and the one with Xenialpet64-7.5 on-board offered the same "Filter Failure" error message.

It seems that it is the 64 bit OS that is at the root of the problem. Is there are solution or advice to solve this conundrum?

Thanks for reading!

Last edited by LeithR on Tue 01 May 2018, 13:57; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Tue 01 May 2018, 13:27    Post subject:  

Those are 32bit pets.

They may still work if you install the 32bit compatibility sfs so there is needed files to run 32bit software in 64 bit Xenialpup64.

the 32bit compatibility sfs can be downloaded and installed from Quickpet.
Quickpet>Useful>

If still not working.

Uninstall the hplip pets you installed and try using this one for 64 bit.
https://archive.org/download/Puppy_Linux_Skami_Driver_Repo/hplip_print_scan_64bit-3.15.9.pet
Here is a deb package that may work.
https://archive.org/download/Puppy_Linux_Skami_Driver_Repo/hplip-print-scan_3.17.9_amd64.deb

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
LeithR

Joined: 24 Jan 2011
Posts: 277
Location: Kemnay, Aberdeenshire/Scotland

PostPosted: Tue 01 May 2018, 13:56    Post subject:  

Hi there Bigpup,
Many thanks, the 32 bit compatibility sfs worked.
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1487
Location: france

PostPosted: Sat 19 May 2018, 04:53    Post subject: Re: (SOLVED) - Xenialpup64-7.5.pet and printing  

LeithR wrote:
...using hplip-print-3.16.5.pet and hplip-scan-3.16.5.pet ...

Hi LeithR,
The links to download these pet files are broken in the rcrsn51 post. Do you still have these files ? If yes can you please give a link to download them ?
Thank you,
Philippe
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Sat 19 May 2018, 05:52    Post subject:  

My HP print/scan driver packages in PET format were out of date and I'm not going to make any more. It was too hard to stay compatible with all the Puppy versions.

However, there are hplip-print-scan Debian packages (32 and 64bit) here: [deleted]. Any future HPLIP releases will be there.

If Puppy community members want to continue having this resource, they should confirm what does/does not work.

Update: Zero feedback after three months. Links deleted.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0405s ][ Queries: 14 (0.0084s) ][ GZIP on ]