Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 May 2018, 15:09
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Connaissez-vous QtWeb ?
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [56 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
musher0


Joined: 04 Jan 2009
Posts: 12192
Location: Gatineau (Qc), Canada

PostPosted: Fri 09 Mar 2018, 07:17    Post subject:  

Re-rallô !

Je pense que j'ai enfin quelque chose pour toi, pour moi, et pour tout le monde !!!
Et c'était sous notre museau de Puppyistes :
http://puppylinux.org/wikka/GtkYoutubeViewer

J'ai tenté d'installer mps-youtube-machin, et je me suis cogné le museau justement,
sur les dépendances de python3. Le confrère du côté anglophone don570 avait à redire
l'autre jour sur la piètre implémentation de python dans Puppy : maintenant je le crois !

Ce youtube-viewer et son jumeau gtk-youtube-viewer sont en perl. Perl a un utilitaire
nommé CPAN (alias cpan) qui s'occupe de télécharger et installer les modules perl qui
pourraient manquer. Il suffit de taper en console < cpan module::machin >. Donc aucun
problème de dépendances ou presque (voir plus bas) avec un script perl.

-- Comment faire --
On commence par télécharger youtube-viewer, d'ici:
https://github.com/trizen/youtube-viewer/archive/master.zip

On le déballe dans un endroit commode,

On entre dans son répertoire, et on ouvre une console.

On tape en console : < perl Build-PL >
Ensuite, c'est le fin du fin, youtube-viewer dispose pour lui-même d'un installateur
de dépendances < ./Build installdeps >. On tape ça.
Enfin on tape < ./Build install. >

Pour obtenir la version gtk, on répète en ajoutant --gtk à la première commande :
Code:
perl Build-PL --gtk
./Build installdeps
./Build install
Comme la version gtk a besoin de la version en ligne de commande, il faut installer
les deux.

-- Pépins --
-- il a fallu que je modifie un lien dans les biblios de Puppy pour libtinfo au moyen de
cette commande : < ln -sv /lib/libncursesw.so.5.9 /usr/lib/libtinfo.so.5 >. Aussi bien le
faire d'avance ?!

-- il y a un module optionnel de youtube-viewer qui ne s'installe pas,
« Term::ReadLine::Gnu::XS ». Ou je n'ai pas su comment faire. Mais comme il est
optionnel, youtube-viewer va fonctionner quand même sans.

-- Le visionneur recommandé est mpv. D'après divers témoignages, Mplayer peut faire
l'affaire si on tolère les vidéos hachurés. Vlc, apparemment, fait patate avec youtube-
viewer, ce ne serait pas la peine.

Comme j'ai mpv, je n'ai pas testé les deux autres, à toi de jouer (tester).

-- Avant de faire sa première recherche avec gtk-youtube-viewer, pour éviter les
frustrations, il est bon d'aller dans son tableau « préférences » et de spécifier :
< video_player_selected => "mpv" >

J'ai fait un test avec la chanson « First We Take Manhattan » de Leonard Cohen (version
de la télé allemande). Il faut attendre quelques secondes pendant le téléchargement,
mais après, cela fonctionne comme un charme.

Alors voilà : je te suggère gtk-youtube-viewer pour ton vieux bazou faiblard -- et même
pour un ordi puissant. Je crois que je vais l'adopter officiellement pour le xenialPup-706.

Je crois avoir rapporté fidèlement à la suite toutes les étapes que j'ai franchies, mais j'ai
pu en oublier. Si tu as des ennuis, fais-moi signe ?

À+

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)

Last edited by musher0 on Fri 09 Mar 2018, 22:07; edited 1 time in total
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 221

PostPosted: Fri 09 Mar 2018, 20:43    Post subject:  

Vraiment, ta célérité et ta bonhomie vont devenir légendaires. Je n'ai pas le temps de suivre!

Je vois tout ça et je te tiens au courant. Merci.
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 221

PostPosted: Sat 10 Mar 2018, 03:01    Post subject:  

hello,

j'ai téléchargé et suivi tes indications pour installer gtk-youtube-viewer.

Il ne faut pas oublier de monter le devx avant de commencer (en tout cas pour mon système). Et encore, je ne suis pas sûre que cela soit suffisant (voir plus loin).

J'ai remarqué qu"il fallait taper

Code:
perl Build.PL


et non

Code:
perl Build-PL


Sinon, après l'installation (assez interminable, il faut bien le dire, et qui fait bien chauffer l'ordinateur...), en lançant gtk-youtube-viewer j'ai un message d'erreur qui semble concerner la version de perl (d'où ma remarque sur le dvx) et aussi un problème de compilation. Qu'à cela ne tienne, je pourrai recommencer. Je n'ai pas encore enregistré la session, mais je me demande si les 60 Mo qui me restent sur le fichier de sauvegarde sont suffisants pour cette installation. Dans le doute, je poste ce message avant d'enregistrer la session et que le système explose, et que je sois obligée d'éteindre l'ordinateur en catastrophe.

Si tu as une idée sur les messages d'erreur, ça m'intéresse bien sûr. Et aussi je ne sais pas très bien comment trouver la bonne version de perl (bien que tu ais écrit que le cpan étaient un vrai couteau suisse qui pouvait télécharger tout ce dont le programme avait besoin).

À bientôt,

PS: au fait, c'est quoi mpv? Gnome mediaplayer est installé, ça ne fait pas l'affaire?
capture28044.jpg
Description 
jpg

 Download 
Filename  capture28044.jpg 
Filesize  48.51 KB 
Downloaded  60 Time(s) 
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 12192
Location: Gatineau (Qc), Canada

PostPosted: Sat 10 Mar 2018, 03:38    Post subject:  

Allô.

Le message dit "Begin failed" , c.-;a-d. "Début raté.". Ensuite, "arrêté à la ligne 4."

Ta version de perl n'est pas assez forte, Tu as la 5.14 et il veut la 5.16. Puis, il
mentionne quelque chose pour la ligne 14 ou 24 (pas clair pour mes vieux yeux).

En somme, t'as qu'à NE PAS sauvegarder. Rien ne va exploser !
Et puis tu laisses tomber. (Dommage.)

T'es sur quel Puppy, pour cette expérience ?

À+

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 221

PostPosted: Sat 10 Mar 2018, 06:35    Post subject:  

En fait, j'ai sauvegardé et il me restait 1mo sur le fichier de sauvegarde! De quoi fermer l'ordinateur correctement et augmenter un peu le FS.

C'est dommage cette histoire de perl (ça me fait penser que ça fait vraiment longtemps que je n'ai pas mangé d'huîtres), ça ne s'altoversionnise pas ces choses là ? (c'est mieux que update, non?)

Je vais regarder un peu tout ça, et puis je laisserai tomber si vraiment il n'y a pas de solution (mais pas de trop haut).

Merci, à bientôt,

J'oubliais : je conduis une précise-5.7.3 cabriolet Pipoca.
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 866
Location: rabat

PostPosted: Mon 16 Apr 2018, 13:24    Post subject: You Tube avec Qt web  

Ta question première était voir You Tube avec Qt web qui fait chauffer ta machine à 70° pas plus. Que te dire ? ce sont des navigateurs pour pauvres. Là le Puppy builder magyar l'a mis par défaut sur sa Slacko, c'est mieux que Dillo, mais You tube rien, juste l'écran noir dans le cadre de la video
Slegopen Slacko Article de la presse au sujet de QTweb (de la presse spécialisée).
gtk-you tube-viewer devrait downloader les vidéos You Tube à son rythme, pour que tu les regardes tranquillement après.
Je cherche un peu, ya des américains qui disent que QTweb fait you Tube, à condition de lui mettre un vieux flasplayer (<12).
Capture-QtWeb.jpg
 Description   QtWeb Sur Petite RaM
 Filesize   73.51 KB
 Viewed   20 Time(s)

Capture-QtWeb.jpg


Last edited by hamoudoudou on Fri 20 Apr 2018, 06:38; edited 1 time in total
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 221

PostPosted: Mon 16 Apr 2018, 17:47    Post subject:  

Doudou, je te remercie,

justement ces derniers jours, j'ai téléchargé gtk_youtube_viewer-3.0.2_precise.pet, qui s'ouvre mais qui ne va pas plus loin dans le sens qu'il ne répond rien quand je fais une recherche (oups error, nothing found...)

Si tu as une idée de ce qui peut manquer, ça serait sympa.

D'un autre côté, je suis moins pressée car j'ai récupéré mon petit portable avec une ram plus conséquente, et j'ai réussi à le faire repartir (un bout de scotch bien placé sur un faux contact). Il chauffe un peu mais avec un petit ventilateur dans le derrière, il bombe. Du coup j'ai laissé l'autre antiquité de côté, juste en cas de SOS.

Mais quand même, ce gtk_youtube_viewer m'intrigue.

À bientôt,
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 866
Location: rabat

PostPosted: Wed 18 Apr 2018, 06:12    Post subject: il ne faut pas harceler petihar..  

il ne faut pas harceler petihar.. Je repondrais quand le topic sera passé en page 5 . Faut laisser les reponses affluer.
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 221

PostPosted: Wed 18 Apr 2018, 19:00    Post subject:  

Joyeux Noël.
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3094
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Thu 19 Apr 2018, 15:04    Post subject:  

Hum... Vos fils sont absolument décevants, car vous croyez indispensable de les truffer de blagues, de bons mots, de choses qui noient le poisson dans l'eau!

très durs à suivre, et das du tout de la pub pour la soi-disant pensée cartésienne francophone, plutôt l'inverse, bien que les sujets soient intéressants...
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 866
Location: rabat

PostPosted: Thu 19 Apr 2018, 23:53    Post subject: On va pas se coltiner QtWeb pour rien !  

c'est petihar qui pose la question. Il l'a posée là, nous on a répondu.. C'est juste pour lui rappeler qu'on poste un truc marrant. Si çà l'intéresse pas QTweb, on laissera le fil dans les oubliettes. On va pas se coltiner QtWeb pour rien !
Tu l'a essayé, oui, avec tes Puppies chéries ? avec ton Lubuntu ? Si oui, tu nous fait un debreefing, si non tu repars avec ta moralisation.
Un peu d'humour, voire de discorde est moins barbant que les cours au tableau qui ne passionnent que les vieux théoriciens des années 80
Et nos fils sont brefs.. on s'endort pas dessus.
MikeWalsh a repris QtWeb ici.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [56 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0454s ][ Queries: 13 (0.0041s) ][ GZIP on ]