Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Aug 2018, 19:04
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Xenialpup 7.5 32&64 bit cpu frequency scaling not working
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
Ledster

Joined: 26 Aug 2006
Posts: 83
Location: Devon, England

PostPosted: Wed 07 Feb 2018, 17:01    Post subject:  Xenialpup 7.5 32&64 bit cpu frequency scaling not working  

HP 15bs162sa laptop, Intel i5-8250U quad core, 4 Gb ddr4 memory, 1Tb hard disk, UEFI, Intel radio chip 3168NGW (AC3168).
Running xenialpup 7.5 32 or 64 bit cpu frequency scaling does not work. Both Hardinfo and frequency scaling prog show the processor running at 3.4 GHz (its rated frequency is 1.6GHz (3.4GHz in turbo mode).
Any changes I make in the cpu frequency prog are ignored and if I open the prog again the settings have gone back to the default.
Tried tahrpup 6.0.6 and frequency scalling works fine.
FWIW xenialpup says the scaling driver is 'intel_pstate' and 'performance', while tahrpup says 'acpi_cpufreq' and 'ondemand'.
Tried the remove button and a restart - no change. It did not remove.
I do not like the cpu running flat out all the time, seems to run hotter and use the battery faster.
Looks like the driver needs changing, but how and what to?
note - all pups are being run from usb sticks (is it possible to set up more than one pup on a usb stick?).

Hope someone can help.
Cheers
Ledster
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 1068
Location: SW Wisconsin

PostPosted: Wed 07 Feb 2018, 17:33    Post subject: Re: Xenialpup 7.5 32&64 bit cpu frequency scaling not working  

Ledster wrote:
HP 15bs162sa laptop, Intel i5-8250U quad core, 4 Gb ddr4 memory, 1Tb hard disk, UEFI, Intel radio chip 3168NGW (AC3168).
Running xenialpup 7.5 32 or 64 bit cpu frequency scaling does not work. Both Hardinfo and frequency scaling prog show the processor running at 3.4 GHz (its rated frequency is 1.6GHz (3.4GHz in turbo mode).
Any changes I make in the cpu frequency prog are ignored and if I open the prog again the settings have gone back to the default.
Tried tahrpup 6.0.6 and frequency scalling works fine.
FWIW xenialpup says the scaling driver is 'intel_pstate' and 'performance', while tahrpup says 'acpi_cpufreq' and 'ondemand'.
Tried the remove button and a restart - no change. It did not remove.
I do not like the cpu running flat out all the time, seems to run hotter and use the battery faster.
Looks like the driver needs changing, but how and what to?
note - all pups are being run from usb sticks (is it possible to set up more than one pup on a usb stick?).

Hope someone can help.
Cheers
Ledster
Pass
Code:
intel_pstate=disable
as a kernel parameter. Then on your next and subsequent boots wcpufreq should work as normal. So long as the intel driver is enabled in the kernel on intel hardware it will take precedence over the other (acpi_cpufreq etc.) drivers and governors. The tahrpup kernel doesn't have it enabled while the xenialpup kernel must going from your info above. If you are using syslinux on the USB sticks, the kernel parameter can be passed in syslinux.cfg. I only do USB boots to rescue now so I just have one pup on a stick but I have had good success using Grub4Dos for multiple pups on USB hdds and sticks in the past.

Edit: Compiling the kernel with
Code:
#CONFIG_X86_INTEL_PSTATE is not set
eliminates this snafu. (=n may work, having it commented out is more usual) As perhaps you can tell, I'm no fan Laughing of the Intel pstate governor.
_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, and LxPupBB for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS. Now tazpup for puzzles Smile
Back to top
View user's profile Send private message 
Ledster

Joined: 26 Aug 2006
Posts: 83
Location: Devon, England

PostPosted: Thu 08 Feb 2018, 09:51    Post subject:  

@Marv
Thanks for your answer.
I have never compiled a kernel so wouldn't know how to proceed.
How do I pass your suggestion as a kernel parameter?
I don't know if I am using syslinux or not, but it is on the usb stick. Does this mean it is being used? It was put there when I used the "UEFI installer - Flash Drives" option.
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 1068
Location: SW Wisconsin

PostPosted: Thu 08 Feb 2018, 10:17    Post subject:  

No need for compiling your own kernel. Assuming you are using syslinux, you should find syslinux.cfg on the USB drive. Open it with a text editor such as geany and add intel_pstate=disable (space delimited) to the string you see. For example the contents of my syslinux.cfg are
Code:
default vmlinuz  initrd=initrd.gz intel_pstate=disable pmedia=usbflash pfix=copy
By design, I have no UEFI hardware so don't really know exactly what the installer does in that case. Sorry.
_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, and LxPupBB for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS. Now tazpup for puzzles Smile
Back to top
View user's profile Send private message 
Ledster

Joined: 26 Aug 2006
Posts: 83
Location: Devon, England

PostPosted: Thu 08 Feb 2018, 11:59    Post subject:
Subject description: SOLVED
 

Sorry about this - I must have been looking at the wrong usb stick! No syslinux on the right one.
However, good news. Looking around found a file in /boot called "config-4.9.58".
Opened this, searched for intel_pstate and found "config_x86_intel_pstate=y" (on line 680 of several thousand!). Hashed this out. and rebooted. Driver is now "acpi-cpufreq" and working fine.

Edit: don't know if it matters, but I had already put "intel_pstate=disable" in grubcfg on the vmlinuz line. It did not work on its own but may be required.

Thanks for the help
Ledster
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10883
Location: Charleston S.C. USA

PostPosted: Thu 08 Feb 2018, 13:04    Post subject:  

entered in error
_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
oldprinter

Joined: 12 Nov 2017
Posts: 7

PostPosted: Wed 21 Feb 2018, 07:18    Post subject: "intel_pstate=disable"  

Marv and Ledster -

The "intel_pstate=disable" in grubcfg on the vmlinuz line, works like a charm.

I've tried it in Tahr 6.0.5 and in Xenialpup64 7.5, both booting on a uefi boot (with secureBoot off) machine, Also works on my legacy machines, after adding it to syslinux.cfg.

Many, many thanks for this.

Tom
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0444s ][ Queries: 12 (0.0066s) ][ GZIP on ]