Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 16 Aug 2018, 12:30
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Playing .webm files in Tahrpup? (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
a_salty_dogg


Joined: 15 Dec 2013
Posts: 94

PostPosted: Thu 01 Feb 2018, 20:27    Post subject:  Playing .webm files in Tahrpup? (Solved)  

Can't play .webm files "natively" (i.e. with a simple left click) in Tahrpup 6.03.

They all show in roxfiler as a "gear" icon.

They'll happily play in VLC via right click context menu, or directly if I add ,mp4 to the end of the file name.

"Set run action" in the context menu is greyed out for this file extension, so unable to access or set it.

Going from the other direction, there seems to be no "set file association" option in either of the media players I currently have installed, VLC or Mplayer.

Never met this (minor, admittedly) problem with any Puppy version I've used before, as far as I recall.

Can anyone please assist?

Last edited by a_salty_dogg on Sun 08 Apr 2018, 20:11; edited 1 time in total
Back to top
View user's profile Send private message 
matchpoint

Joined: 26 Jan 2018
Posts: 169

PostPosted: Thu 01 Feb 2018, 23:07    Post subject:  

a_salty_dogg,

Open your /root/Choices/MIME-types/video_webm file as text and check that it reads exec defaultmediaplayer "$@"

Is the "set run action" dialog greyed out for other file types?
Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 94

PostPosted: Thu 01 Feb 2018, 23:25    Post subject:  

Good morning matchpoint, thanks for your interest, appreciated.

Confirm it says that - exec defaultmediaplayer "$@"

No, I've never noticed "set run action" greyed out before with any file type.
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1792
Location: London, England

PostPosted: Thu 01 Feb 2018, 23:36    Post subject:  

I have a .webm file here and I took a look in TahrPup 6.0.5 32bit fresh boot.
The "Set Run Action" is not greyed out for me.
Anyway, left click in ROX appears to need the script file named application_octet-stream
This can be placed in /root/Choices/MIME-types
or /root/.config/rox.sourceforge.net/MIME-types
This script can contain something like:-
Code:
#! /bin/sh
exec defaultmediaplayer "$@"

When I tested it, the native VLC complained that it did not have a suitable video codec but the audio played. I installed my gMPlayer and it all worked fine in that.

_________________
Oscar in England

Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 94

PostPosted: Thu 01 Feb 2018, 23:53    Post subject:  

Thank you OscarTalks, created that file in
/root/Choices/MIME-types/application_octet-stream
but no effect on a .webm file I just tested, still no left-click and set run action still greyed out.

Oh, btw to be clear, "left click" works, and always has, just fine with all other video types, .avi, .mp4, .flv, etc.
It's only .webm, and only in this specific puppy, which is a problem.
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1792
Location: London, England

PostPosted: Fri 02 Feb 2018, 03:18    Post subject:  

Hmm, since the manual fix did work in my test it becomes difficult to know what else to suggest. I presume you did remember to make sure the file is executable? You could name a specific media player (rather than defaultmediaplayer) in that file. Doing so would bypass the default applications chooser for files of that type.

Mine here is 6.0.5 and if yours is 6.0.3 there is a slim possibility that you have a bug which got fixed in the later version.

If you could test a boot with pfix=ram (fresh with no save) and try the fix like that it might shed some light.

The option being greyed out is perhaps the most worrying sign. It makes me wonder if something you have installed is interfering with the MIME mechanism for association of .webm files for some reason. If so, you might have to experiment a bit to try to identify the offending program.

_________________
Oscar in England

Back to top
View user's profile Send private message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 1578
Location: Japan

PostPosted: Fri 02 Feb 2018, 05:25    Post subject:  

a_salty_dogg wrote:
Thank you OscarTalks, created that file in
/root/Choices/MIME-types/application_octet-stream
Not a good idea. "application_octet-stream" is another name for "unknown binary file", i.e. ROX has no clue what it is. It is impossible to guess how to handle such file. There is a good reason why by default there is no MIME-type file /root/Choices.

Quote:
but no effect on a .webm file I just tested, still no left-click

You should see an error message. Which one?

OscarTalks wrote:
I presume you did remember to make sure the file is executable?
If he really did it would explain the greyed-out option. You can't set a run action for an executable file since the run action is already defined: execute it. So if the .webm file, which is a data file and should not be executable, is in fact marked as executable (wrench icon!) the "set run action" option will be greyed out.

I don't have Tahrpup and don't know why ROX does not recognize the MIME type. ROX is not very clever and primarily determines the MIME type by looking at the extension. Add a .jpg extension to any file and ROX will happily try to open this file in the image viewer. If the video file has an .webm extension ROX should regard it as a video file. You should verify that the .webm extension is indeed associated with video. Check the file /usr/share/mime/globs . Should have an entry like "video/webm:*.webm".
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1792
Location: London, England

PostPosted: Fri 02 Feb 2018, 05:42    Post subject:  

Hello Mochi,
Thanks for offering your advice on this.
First of all, I did mean the file in MIME-types should be executable, not the .webm media file.

When I use the Set Run Action in ROX on my .webm file in TahrPup it wanted to create the file application_octet-stream in order to set the association, but I did wonder if there was something not right with that.

Interestingly the same thing happens in StretchPup, but in Wheezy ROX is using /root/Choices/video_webm in order to detect the association so it may be that something is missing or wrong in the more recent versions of ROX. You are probably right to say we need to look at the globs file.

_________________
Oscar in England

Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 94

PostPosted: Fri 02 Feb 2018, 06:28    Post subject:  

@ OscarTalks

Restarted in RAM (would be 6.02 as 6.03 was installed as quickpet upgrade so resides in my save file) and found same results; gear icon, only played in context menu, and "set run action" greyed out.
Then also started up a Precise CD in RAM to make certain not a problem with my files or drives. Played a few of the same webm's and started up without problem.
How do I name a specific media player if I can't get to "set run action" and there's no "set file association" settings in my media players?

@ MochiMoppel

Hello and thanks for jumping in.
No error message when I try to "left click" the file, just the usual outline box which appears around the file name & icon, then nothing.
Do get an error message when I try to click on the greyed out "set run action", thus
Code:
You can only set the run action for a regular file

The files DO show in properties as Type application/x-executable (no idea how I would change that)
Yes, if I add .mp4 (for example) to the end of the name of any .webm file it will play as normal and "set run action" option becomes available.
Yes, confirm there is a line in usr/share/mime/globs video/webm:*.webm
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1792
Location: London, England

PostPosted: Fri 02 Feb 2018, 06:42    Post subject:  

OK, try this
Delete any application_octet-stream file
Right click the .webm file and look at properties to make sure it is NOT set as executable (uncheck the tickboxes).
Run the command
Code:
update-mime-database /usr/share/mime

This generates or updates the globs file and other stuff in /usr/share/mime
The gear icon is now replaced with a video media icon and left click works on the .webm file

_________________
Oscar in England

Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 94

PostPosted: Fri 02 Feb 2018, 07:24    Post subject:  

YES! Very Happy
After running that command all .webm's have changed globally from gear to video icon, now open with left click in default player, show in properties as video/webm, and "set run action" available again (if I wanted it which I don't now of course!)

Many thanks to everyone for sharing your knowledge and time to help me.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0785s ][ Queries: 12 (0.0059s) ][ GZIP on ]