Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Jan 2018, 05:46
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 29 of 30 [442 Posts]   Goto page: Previous 1, 2, 3, ..., 27, 28, 29, 30 Next
Author Message
jrb


Joined: 11 Dec 2007
Posts: 1088
Location: Smithers, BC, Canada

PostPosted: Mon 01 Jan 2018, 23:19    Post subject:  

Hi PeeBee,
Thanks again for the great work! I thought I would try Woofing up a custom ArtfulPup of my own so I followed your excellent instructions. The only problem I had was with 1download. I kept getting:
Code:
Downloading busybox-1.25.0-i686_s700.pet
  - from http://smokey01.com/peebee/artfulpup/extras/pet_packages-artfulpup
  failed (file not found on server or could not finish download)

I got around this by using pmirror to download http://smokey01.com/peebee/artfulpup/extras and temporarily ##ing out all packages from that source in DISTRO_PKGS_SPECS-ubuntu-artful. Thought you might like to know.

Cheers, J
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3080
Location: Worcestershire, UK

PostPosted: Tue 02 Jan 2018, 03:13    Post subject:  

jrb wrote:
Hi PeeBee,
Thanks again for the great work! I thought I would try Woofing up a custom ArtfulPup of my own so I followed your excellent instructions. The only problem I had was with 1download. I kept getting:
Code:
Downloading busybox-1.25.0-i686_s700.pet
  - from http://smokey01.com/peebee/artfulpup/extras/pet_packages-artfulpup
  failed (file not found on server or could not finish download)

I got around this by using pmirror to download http://smokey01.com/peebee/artfulpup/extras and temporarily ##ing out all packages from that source in DISTRO_PKGS_SPECS-ubuntu-artful. Thought you might like to know.

Cheers, J

Wow - many thanks @jrb - you must be the first to try that.....

Apologies for the download failure - I really should have tested that Embarassed - now fixed by correcting the directory structure on smokey01.com

Should work as advertised now (I hope!)

Cheers!
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
jrb


Joined: 11 Dec 2007
Posts: 1088
Location: Smithers, BC, Canada

PostPosted: Wed 03 Jan 2018, 08:09    Post subject:  

peebee wrote:
Should work as advertised now (I hope!)

Worked perfectly! Some of my mods took a bit of fiddling, but all went well in the end.

Thanks again, J
artful2.jpg
 Description   
 Filesize   39.09 KB
 Viewed   801 Time(s)

artful2.jpg

Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1695
Location: lincoln, uk

PostPosted: Wed 03 Jan 2018, 08:45    Post subject:  

post 'em up

Smile
Back to top
View user's profile Send private message Visit poster's website 
gyro

Joined: 28 Oct 2008
Posts: 1426
Location: Brisbane, Australia

PostPosted: Fri 05 Jan 2018, 06:06    Post subject:  

I've just found an issue with the "/etc/init.d/udev" script.
An error about "ps" failing is reported in "/tmp/bootsysinit.log".
I've found that this line of code in "udev" fails:
Code:
if ! ps --no-headers --format args ax | egrep -q '^\['; then
The 'ps' fails because in puppy it's a script that contains this line:
Code:
[ "`which ps-FULL`" != "" ] && exec ps-FULL $@
Which fails because "which" is not in the PATH as defined in the "udev" script.
This could be fixed by changing the PATH definition in "udev", but I suspect that this script is borrowed from elsewhere, so best not to have a local patch.
Suggested fix is to change the offending line in "/bin/ps" to:
Code:
[ "`/usr/bin/which ps-FULL`" != "" ] && exec ps-FULL $@
or
Code:
[ -x /bin/ps-FULL ] && exec /bin/ps-FULL $@
Either of these removes the requirement for "which" to be in the PATH.
The patched "ps" should still work the same as before.

gyro
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3080
Location: Worcestershire, UK

PostPosted: Fri 05 Jan 2018, 12:14    Post subject:  

gyro wrote:
I've just found an issue with the "/etc/init.d/udev" script.
gyro

Thanks @gyro....

Pull request initiated on github to change woof-code/rootfs-skeleton/bin/ps:
https://github.com/puppylinux-woof-CE/woof-CE/pull/1123

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 949
Location: SW Wisconsin

PostPosted: Sat 06 Jan 2018, 14:08    Post subject:  

ArtfulPup 17.11 +8 running sucessfully with the 4.14.11 32b PAE kernel from LxPupSc 18.01 +1T. glxgears FPS and hardinfo CPUhash and FPUraytracing benchmarks pretty much unchanged from the stock kernel on this i5. By the release notes and kernel changelog the 4.14.11 should have kpti backported into it. With the newer kernel, on the i5 laptops I do add the following two lines to rc.local to bring the brightness up on boot.
Code:
brightness=`cat /sys/class/backlight/acpi_video0/max_brightness`
echo $brightness > /sys/class/backlight/acpi_video0/brightness
# inxi -bw
System: Host: puppypc1857 Kernel: 4.14.11-lxpup-32-pae i686 (32 bit)
Desktop: JWM 2.3.7 Distro: ArtfulPup 17.11
Machine: Device: laptop System: FUJITSU product: LIFEBOOK S761 serial: R2500459
Mobo: FUJITSU model: FJNB225
UEFI [Legacy]: FUJITSU // Phoenix v: Version 1.17 date: 03/14/2012
Battery CMB1: charge: 56.0 Wh 100.0% condition: 56.0/56.0 Wh (100%)
CPU: Dual core Intel Core i5-2520M (-HT-MCP-) speed: 2501 MHz (max)
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.org 1.19.5 drivers: modesetting (unloaded: fbdev,vesa)
tty size: 80x24 Advanced Data: N/A for root
Network: Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
Card-2: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express)
driver: ath9k
Drives: HDD Total Size: 64.0GB (25.4% used)
Weather: Conditions: 5 F (-15 C) - Clear Time: January 6, 11:52 AM CST
Info: Processes: 126 Uptime: 2 min Memory: 110.6/4897.3MB
Client: Shell (bash) inxi: 2.3.7

cheers,

_________________
Pups currently in kennel Very Happy LxPupSc, X-slacko 4.4 and X-tahr 2.0 for my users; LxPupSc, LxPupArtful, ArtfulPup & XFCE_XenialPup64 for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
gyro

Joined: 28 Oct 2008
Posts: 1426
Location: Brisbane, Australia

PostPosted: Mon 08 Jan 2018, 09:02    Post subject:  

I've just noticed another minor issue reported in "/tmp/bootsysinit.log".
It complains about line 80 of "rc.sysinit", but the actual problem is line 79.
The issue can be avoided by changing line 79 of "rc.sysinit" from:
Code:
SWAPSIZEBYTES=`fdisk -l $ONESWAP | grep $ONESWAP | cut -f 5 -d ' '` #bytes
to
Code:
SWAPSIZEBYTES=`fdisk -l $ONESWAP | grep -m1 $ONESWAP | cut -f 5 -d ' '` #bytes
The problem is that "fdisk" in artfulpup is just a link to "busybox fdisk" and wheras the real "fdisk" produces only 1 line containing $ONESWAP, "busybox fdisk" produces 2 lines containing $ONESWAP, resulting in $SWAPSIZEBYTES containing 2 lines of data, instead of just a number.
This causes line 80 to fail, so later code does not increase the size of the "tmpfs" by half the size of the swap partition.
e.g. I have 4GiB of memory so the "tmpfs" starts as 2GiB, but I also have a 4GiB swap partition, so "tmpfs" should end up as 4GiB.
Without the patch my "tmpfs" ends up at 2GiB, with the patch it ends up at 4GiB, as it should.

gyro
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3080
Location: Worcestershire, UK

PostPosted: Mon 08 Jan 2018, 12:02    Post subject:  

gyro wrote:
The issue can be avoided by changing line 79 of "rc.sysinit"
gyro

Pull request raised on github....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3080
Location: Worcestershire, UK

PostPosted: Thu 11 Jan 2018, 15:11    Post subject:  

Update +10 - BUILD_FROM_WOOF='testing;358697d4;2018-01-10 22:32:18 +0800' + Ubuntu updates
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
hamoudoudou


Joined: 24 Jul 2014
Posts: 302
Location: rabat

PostPosted: Fri 12 Jan 2018, 05:26    Post subject: Hobbies as genealogy need Puppy Linux,  

Artfulpup is really a nice puppy, but i fail to run Gramps with it. (Dpup Stretch the same). Old version is better than no version at all. as emergency OBprecise allows me to continue and record may relatives, soldiers first world war...
Hobbies as genealogy need Puppy Linux, Keep tis app running please.. How ? Devs will find what is wrong, sure.
Gramps: genealogical research program
Where Python is installed would be to change , said zippytex, an efficient Gramps user (and Linux expert)
OBprecise.jpg
 Description   My database are big enough now, i would not have to give them up.
 Filesize   58.12 KB
 Viewed   288 Time(s)

OBprecise.jpg

Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1393
Location: GERMANY

PostPosted: Fri 12 Jan 2018, 12:08    Post subject:  

Hi you guys !

Artful Pup is quite awful .
But........tried to install Audacious Audio-Player..... no chance .
Same for Vlc-player...... no chance .....

Is there any possibility to get them as a sfs-Package maybe ?.....somewhere ?
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 302
Location: rabat

PostPosted: Fri 12 Jan 2018, 17:00    Post subject: mediaplayers VLC Audacious :  

mediaplayers VLC Audacious :
If people on tahrpup want mediaplayers needing FFmpeg and with artfulpup mediaplayers needing QT , that is just what will be unavailable..
choose your Puppy looking what apps are default, lot of puppies have VLC.. Those will VLC will miss applications needing FFmpeg..
If puppy still want to be a light OS, it cannot afford to have doublons, or more for a same functionality. VLC will do what Audacious does, Audacious will not play videos.
Artfulpup is the best Puppy since Precise 5.7.1. IMO
Gnome-mplayer wll do as well as VLC, better than VLC. However if you want VLC and Artfulpup, i am sure we can succeed.. But you had better to choose tahrpup.. VLC is included.
392.jpg
 Description   PPM artfull provides Audacious 3.9.2. Nothing to do, just launch music
 Filesize   33.41 KB
 Viewed   164 Time(s)

392.jpg

Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 302
Location: rabat

PostPosted: Sat 13 Jan 2018, 00:32    Post subject: Gramps launched thanks to python 2.6 !  

Very Happy success
Just install python pet provided here
Muggins : "Made from the latest sourceforge debian release. It needs the attached libdb-4.4.so.pet, plus Technosaurus's Python%2B-2.6.4-i486.pet."
Merci Muggins what would we do whitout devs as you, change our hobbies ?
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1393
Location: GERMANY

PostPosted: Sat 13 Jan 2018, 05:37    Post subject:  

Hi hamoudoudou !

What i do appreciate on Vlc-Audacious-Smplayer is , they have some cool gimmicks like Equalizer ,Stereo-Effects for fine tuning sound.... in contrast to Gnome-Mplayer or mplayer ..
One can enhance Sound Quality dramatically . So this is (for me) a real Flaw in Artful Pup not getting Vlc/Audacious .
It seems ,for my demands , Tahrpup -Xenial/Debian Dogs will fit better .

Greetings !
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 29 of 30 [442 Posts]   Goto page: Previous 1, 2, 3, ..., 27, 28, 29, 30 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0869s ][ Queries: 15 (0.0315s) ][ GZIP on ]