Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Oct 2018, 10:45
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
X-Slacko Slim 4.4r23 (unique, stable, and flexible)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 49 of 61 [911 Posts]   Goto page: Previous 1, 2, 3, ..., 47, 48, 49, 50, 51, ..., 59, 60, 61 Next
Author Message
Sage

Joined: 04 Oct 2005
Posts: 5417
Location: GB

PostPosted: Thu 04 Jan 2018, 04:16    Post subject:  

Sorry, originally reported this in non-slim version, now removed.
Quote:
4.4r5
Thought I'd give it one more try! Tried all boot options. Always: Fatal Error. "puppy_slacko_4.4.sfs not found"
Nothing works! Always get the 0,1,2 menu, all of which are irrelevant.
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 5417
Location: GB

PostPosted: Thu 04 Jan 2018, 04:26    Post subject:  

Quote:
@Sage it looks like you tried the latest X-Slacko Slim.

Did you try the initrd-fallback mode? It was only a pristine initrd from X-Slacko compressed in xz.

By the way did you boot it on BIOS or UEFI?


Yes, have corrected.

Booted live on a BIOS machine.
"..initrd-fallback mode?" - Uh? Too many hoops to achieve the objective? Surely, if it is to be a 'live', 'compact', and 'slim' - it has to be complete in itself (just like all previous Puppies), maybe a few simple boot code options, and just run?! I just don't understand all the exortations to 'do this' 'do that' 'did you do the other'. Maybe time to redefine the purpose and ignore requests asking to run the nation's economic model on a 17yr-old 32bit PC?!
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Wed 17 Jan 2018, 04:50    Post subject:  

New X-Slacko iteration released

Changes:
* Linux kernel 4.14.12
* Improved NVME support
* dc applet bug is fixed
* more fixes

Download: https://drive.google.com/file/d/108atkodRCTs7gpXeqrUf9tHv-hJfW92B/view
MD5 Checksum: cca8a74bc579c8a67423ab0b52848569
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Thu 18 Jan 2018, 06:21    Post subject:  

Problem on download links are now fixed. You can download X-Slacko Slim easily
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1090

PostPosted: Thu 18 Jan 2018, 17:35    Post subject:  

Thanks for this update. This time I find it very difficult to use it in QEMU VM on Fatdog64-721. For some reason the mouse cursor can move only inside the right half of the QEMU window. When I drag the mouse cursor to the left side it jumps outside the VM window and into the host desktop.

edit: I should add that I resized the xslacko-slim desktop to 1280x880 from the 1920x1200 that the VM defaults to on my monitor. But even before resizing the mouse pointer can't move the the far left of the QEMU window without jumping outside.

_________________
Fatdog64-721|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2362
Location: Queensland

PostPosted: Fri 19 Jan 2018, 06:03    Post subject:  

I tried the latest version, still get a fatal error can't find puppy_xslacko_4.4.sfs
I've tried every option with no luck, doesn't work on any of my computers, Pentium 4 2.93GHz, AMD Sempron 2GHz and a ACER laptop Celeron M Processor 1.86 GHz.

Any ideas why this is so, I'm simply downloading and burn the image to DVD in windows using ImgBurn which I use for every other ISO without problem. Confused

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 5417
Location: GB

PostPosted: Fri 19 Jan 2018, 07:40    Post subject:  

Quote:
I tried the latest version, still get a fatal error can't find puppy_xslacko_4.4.sfs

Had exactly the same experience. I answered misty's questions but he still hasn't got back to us.

Quote:
initrd-fallback mode
- absolutely no idea what this is all about. I think he's doing something unusual which is only understandable by his inner circle, hence my comment. It used to be a good release several versions ago: just got to keep it simple and mainline, otherwise just end up talking to one's self!!!
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Fri 19 Jan 2018, 21:25    Post subject:  

@Sage sorry for late reply. I have an idea to trace that problem on your pc. can you please boot X-Slacko Slim using this boot parameter

Code:
pfix=initrd


That will bring to initrd shell immediately then type this on the shell

Code:
probepart


After that please post the result shown by probepart here
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2362
Location: Queensland

PostPosted: Wed 24 Jan 2018, 07:48    Post subject:  

mistfire wrote:
Code:
pfix=initrd


That will bring to initrd shell immediately then type this on the shell

Code:
probepart


After that please post the result shown by probepart here


My frugal install
Code:
/# probepart
/dev/sda||0


It's not finding the two partitions which should be
Code:
# probepart
/dev/sda1|ext4|273192960
/dev/sda2|ext4|39385088

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Thu 25 Jan 2018, 21:41    Post subject:  

@Geoffrey that was weird. ext4 filesystem, ide, and sata kernel module was already builtin on the kernel. Am I missing something?
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2362
Location: Queensland

PostPosted: Thu 25 Jan 2018, 23:57    Post subject:  

mistfire wrote:
@Geoffrey that was weird. ext4 filesystem, ide, and sata kernel module was already builtin on the kernel. Am I missing something?


I know, strange that it doesn't mount the the drive to find puppy_xslacko_4.4.sfs file, this happens on the three computers I have, whether it boots from cd or from manual frugal install on the HDD.

It must be the kernel, as when I changed it to the one from x-slack it finds the puppy_xslacko_4.4.sfs, though I know it won't boot correctly with this, it does show where the problem lay.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Fri 26 Jan 2018, 03:17    Post subject:  

@Geoffrey I will try to recompile the kernel using X-Slacko 4.4 configuration
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Mon 29 Jan 2018, 05:18    Post subject:  

New X-Slacko Slim iteration released

Changes:
* Recompiled linux kernel 4.14.12 (all possible disk drive drivers are now built in)
* Improved initrd
+ new pfix options --- pfix=diag (run basic diagnostics first before booting)
+ more verbose logging
+ some fixes on init script
* Improved bluetooth management (thanks argolance)


Download: https://drive.google.com/open?id=1VxXG9WK5kHTu7L5kjGoMvI7B_Qpl_pKy
MD5 Checksum: 2afda1e6ec98c2d51146daad7a55af41

Last edited by mistfire on Mon 29 Jan 2018, 05:36; edited 2 times in total
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 962
Location: PH

PostPosted: Mon 29 Jan 2018, 05:21    Post subject:  

@Geoffrey and @Sage can you please test this version using pfix=diag boot parameter
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2362
Location: Queensland

PostPosted: Mon 29 Jan 2018, 07:47    Post subject:  

mistfire wrote:
@Geoffrey and @Sage can you please test this version using pfix=diag boot parameter


Good one it boots and loads, appears to function on my ACER laptop but the P4 has SIS video on board, this fails to work at all, which I was hoping it would, as X-Slacko works with it, other pups have problems displaying the tray icons and glitchy windows for applications.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 49 of 61 [911 Posts]   Goto page: Previous 1, 2, 3, ..., 47, 48, 49, 50, 51, ..., 59, 60, 61 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1341s ][ Queries: 15 (0.0881s) ][ GZIP on ]