Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 07 Dec 2019, 14:35
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup Stretch 7.5 CE (RC-5)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 10 of 47 [696 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 45, 46, 47 Next
Author Message
radky

Joined: 02 May 2010
Posts: 981

PostPosted: Mon 25 Dec 2017, 19:52    Post subject:  

@upnorth wrote:
Quote:
I think I found it in ob autostarts file line 194-197, so I'll leave that alone. When set automatically it works fine.

Yes, those lines were included in autostart to provide consistency in the ROX-Filer interface while in FbBox, but you can edit or comment out if necessary.

Thanks for your report!

_________________
PupMates
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6734
Location: Kentucky

PostPosted: Mon 25 Dec 2017, 20:57    Post subject:  

Manual frugal install / upgrade from the last alpha.No problems.
Code:

# inxi -Fxx
System:    Host: puppypc21200 Kernel: 4.9.71 i686 (32 bit gcc: 6.3.0)
           Desktop: JWM 2.3.7 dm: N/A Distro: Dpup Stretch 7.5
Machine:   Device: desktop Mobo: ASUSTeK model: M5A97 LE R2.0 v: Rev 1.xx serial: 150545593600028
           BIOS: American Megatrends v: 2601 date: 03/24/2015
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 42139
           clock speeds: min/max: 1400/3500 MHz 1: 2000 MHz 2: 2000 MHz
           3: 1400 MHz 4: 1400 MHz 5: 2000 MHz 6: 1400 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0 chip-ID: 10de:0a65
           Display Server: X.org 1.19.2 drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root
Audio:     Card-1 NVIDIA High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0be3
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383
           Sound: Advanced Linux Sound Architecture v: k4.9.71
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000
           bus-ID: 02:00.0 chip-ID: 10ec:8168
           IF: eth0 state: up speed: 1000 Mbps duplex: full
           mac: 1c:87:2c:5a:bb:e2
Drives:    HDD Total Size: 1120.2GB (6.7% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB serial: N/A
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB serial: N/A
           ID-1: swap-1 size: 8.60GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      System: supported: linear raid0 raid1 raid10 raid6 raid5 raid4
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 12.5C mobo: N/A gpu: 29.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 30 min Memory: 276.5/16111.0MB
           Init: SysVinit v: N/A runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.121 running in lxterminal) inxi: 2.3.8



Code:
# free
             total         used         free       shared      buffers
Mem:      16497632      1629728     14867904       429912       116704
-/+ buffers:            1513024     14984608
Swap:      8396796            0      8396796
#
Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 967
Location: Mid-mitten

PostPosted: Tue 26 Dec 2017, 07:08    Post subject:  

Finally got around to trying this out (the latest 4.9.71 kernel version, extra firmware .sfs and devx loaded, running openbox/fbpanel - USB flash drive frugal install w/savefile), and it's simply a fantastic Pup! Everything working OOTB (Frisbee WiFi on a Netgear N150 dongle, sound, monitor resolution, etc). Just a great, very complete and solid Pup, Radky - congratulations! Cool

Only extremely tiny issue so far - Galculator's results window background color is not "taking", and it's theme (drop down menus, mostly) is displaying differently than the selected default - likely a GTK2 vs. GTK3 issue (as I believe Galculator is now completely ported to GTK3...?). Pic attached.

I've always been mighty impressed with your Pup apps, Radky - so useful, well thought out and executed - and have included them in any Pups that I've stuck with/remastered. That same level of talent and quality shows in this Dpup Stretch, and it's truly a blessing for Puppy and the community as a whole to have you here with this great offering. Thank you, very, very much!! Smile

Bob
Screenshot.jpg
 Description   Results window background color not effected via preferences GUI...
 Filesize   28.46 KB
 Viewed   1285 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4455
Location: Sydney Australia

PostPosted: Tue 26 Dec 2017, 07:12    Post subject:  

Browser lockup on a bank site stlll occurs in the RC.

I sent you a PM.

Chris.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1413

PostPosted: Tue 26 Dec 2017, 11:40    Post subject:  

I have completed remastering this for Firefox 57.

At first I was trying to share a user profile with my 64 bit version that I have offline and use with Debian Dog. That didn't work out, so I started fresh and did the following.

1. Desktop preferences.
2. Delete
/opt/palemoon
/usr/bin/palemoon and /usr/bin/pminstaller.sh
/usr/share/applications/palemoon.desktop and /usr/share/applications/palemoon-updater.desktop
/root/.moonchild productions (didn't exist because I didn't start palemoon yet)
3. Copy firefox32 folder to /opt (Get from http://murga-linux.com/puppy/viewtopic.php?t=112376 made by fredx181. It already has apulse and the browser setting change for sound built in to it.)
4. Set /opt/firefox32/ff as browser default in Default Applications.
5. Reboot and set save folder.
6. /opt/palemoon was still there. Did this 2x to confirm. See note below. Deleted it again, saved and rebooted.
6. Remaster and choose only defaults (except I did choose a
separate zdrive file but I think that doesn't matter).

The ISO came out to 324 meg with xz compression. I didn't do any manual cleaning and I am pretty sure I remastered the adrive into it.

Seems to work great. Netflix ran fine after it asked me to enable DRM and it downloaded the widevine files.

I can't tell if it is faster than in DD 64, but it certainly isn't noticeably slower.

Seems to make it a good 32 bit Netflix capable distro.

Notes:

There is some bug/anomoly/feature with the first time save file. After step 5, after rebooting, /opt/palemoon was still there (but other deleted stuff was gone), so deleted it again, and rebooted again. That got rid of it. The first time I did it, I didn't notice it and /opt/palemoon ended up in the remaster (which was 383 meg). BTW, I am on hard drive but in pupmode 13 by using pmedia=ataflash in menu.1st.

Noticed one other small thing. When I mounted the ISO and then ran the remaster, it kept telling me to insert a cd and wouldn't run, even though the mounted ISO file showed in the dialog box. When I actually followed the instructions and waited for it to tell me to mount the ISO file, then it worked.
image-1.png
 Description   
 Filesize   150.05 KB
 Viewed   1221 Time(s)

image-1.png

Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 981

PostPosted: Tue 26 Dec 2017, 15:02    Post subject:  

James C wrote:
Quote:
Manual frugal install / upgrade from the last alpha.No problems.

Thanks James!

Moat wrote:
Quote:
Everything working OOTB.

Good news Moat, and thanks for the kind words! Smile

Quote:
Galculator's results window background color is not "taking"

Yes, this is an issue with GTK3 theming. Many gtk themes common to FbBox (and Puppy in general) are GTK2 based, as is the Murrine theming engine. To provide reasonable theming for the occasional GTK3 application, FbBox provides a single GTK3 theme that is made available each time you change the global theme in the Desktop Appearance module.

Many GTK3 themes are coded to specifically support certain versions of GTK, and some GTK3 applications do not display well when matched with non-supporting GTK3 themes. Consequently, authors of GTK3 themes are constantly editing their scripts to improve compatibility with a wider range of applications.

In Dpup Stretch RC, the GTK3 theme was selected for good support of the pnmixer application and many common GTK3 apps. Unfortunately, rendering of color in galculator is not fully supported when the GTK3 theme is utilized. On the other hand, there are many GTK3 themes which provide correct color for galcuator, but tooltips are almost unreadable. I'll continue the search for compatible GTK3 theming.

cthisbear wrote:
Quote:
Browser lockup on a bank site still occurs in the RC.

Following (I hope) the steps outlined in your PM, I did not experience browser (Pale Moon) lockup when I visited your bank web site.

PS - It seems functional javascript is required to navigate the site.

dancytron wrote:
Quote:
I have completed remastering this for Firefox 57.

Great post! Your steps will be helpful for those requiring a Netflix browser.

I have very little experience with remastering, so at the moment I have no explanation for the failed deletion of Pale Moon on your first attempt.

Thanks dancytron! Smile

_________________
PupMates
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4455
Location: Sydney Australia

PostPosted: Tue 26 Dec 2017, 19:27    Post subject:  

Thanks for testing that mate.

Chris.
Back to top
View user's profile Send private message 
petihar


Joined: 09 Apr 2007
Posts: 362

PostPosted: Wed 27 Dec 2017, 13:06    Post subject: Bluetooth
Subject description: connectiing a phone and my hi-fi system
 

Hi Radky and every one,
Very good job, everything is ok for me on my Acer Aspire1 V5. Installed vlc and firefox quantum with some difficulties but quickly overcome.
I am now trying to install bluetooth ... but here is another matter! I have followed all the tutorials found on the forums and help online ...: bluez bluetooth bluez-tools rfkill blueman ... nothing works fine. I would like to connect my phone and my hi-fi system ...
Has anyone managed to run the bluetooth? If so, what is the process? which packages need to be installed?
Thanks in advance, Bien cordialement petihar
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4455
Location: Sydney Australia

PostPosted: Thu 28 Dec 2017, 09:01    Post subject:  

User agent >>> Palemoon...thanks for that Radky.

Cheers...Chris
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 981

PostPosted: Thu 28 Dec 2017, 13:30    Post subject:  

petihar wrote:
Quote:
Has anyone managed to run the bluetooth?

I have no bluetooth devices, so unable to test at the moment. Perhaps those with bluetooth capability could offer their experience.

Thanks

--

cthisbear wrote:
Quote:
User agent >>> Palemoon...thanks for that Radky.

You’re welcome chtisbear.

_________________
PupMates
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2817
Location: Montenegro

PostPosted: Fri 29 Dec 2017, 03:59    Post subject:  

When trying to save session dpup says there are no suitable partitions to save to and exits without saving...

I have 3 ext4 partitions with space available on them.

Btw, the version I downloaded is from first post but I see there were some updates in the meantime?

_________________
puppy.b0x.me stuff mirrored HERE or HERE
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
radky

Joined: 02 May 2010
Posts: 981

PostPosted: Fri 29 Dec 2017, 10:10    Post subject:  

Hi dejan555,

7.0.0a2 beta-2 was the version available when you first posted to this thread on 21 Nov 2017. The current testing version is 7.5 RC which includes Woof-CE updates through 12-12-2017.

I have no problem saving to my ext3 partitions, but I will create and test an ext4 partition. Maybe others could also report their experience with ext4 partitions.

Thanks

_________________
PupMates
Back to top
View user's profile Send private message 
petihar


Joined: 09 Apr 2007
Posts: 362

PostPosted: Fri 29 Dec 2017, 10:31    Post subject:  

Hello, Radky,
Thank you for your answer, even if I'm no further along. I'm really disappointed that it's so hard to set up a Bluetooth accessory on puppy. It's a real lack on a distribution today. Speakers, keyboard, mouse, phone... all these devices can't be used on a puppy? I'm going to continue my search for a solution... but I'm close to giving up everything because I'm not knowledgeable enough to "tweak" and apparently nobody can help.
Yours sincerely, petihar.

Translated from french with www.DeepL.com/Translator
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1931
Location: Italy

PostPosted: Fri 29 Dec 2017, 10:51    Post subject:  

radky wrote:
Maybe others could also report their experience with ext4 partitions.


I have installed stretch 7.5 rc in an ext4 partition of an external usb hd: no problems here.
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 981

PostPosted: Fri 29 Dec 2017, 11:10    Post subject:  

dejan555

I created an ext4 partition and frugally installed Dpup Stretch 7.5 to my WD sata drive.

The installation proceeded without difficulty.

Boot Partition: sda11 (Size 20G, Free 19G)
Boot File System: ext4
Boot Media: satahd

PUPMODE=12
PUPSFS=sda11,ext4,/testext4/puppy_stretch_7.5.sfs
PUPSAVE=sda11,ext4,/testext4/stretchsave-testext4

dejan555, I'll continue testing. Smile

Thanks

---

Also, thank you watchdog for reporting your experience with ext4.

_________________
PupMates
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 10 of 47 [696 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 45, 46, 47 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0873s ][ Queries: 13 (0.0270s) ][ GZIP on ]