Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Sep 2018, 21:44
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Silverlight sur Puppy
Moderators: Béèm, darkerror05, linuxcbon
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
Dorothée


Joined: 27 Nov 2012
Posts: 228

PostPosted: Sun 10 Dec 2017, 17:23    Post subject:  Silverlight sur Puppy  

Je me colle à l'ouverture du fil de Silverlight, mais sans pouvoir aller beaucoup plus loin.

En voici la définition sur Wikipedia:

Quote:
Silverlight est un plugin pour navigateur Web multi-plateforme (Windows et Mac OS), qui permet de développer des applications Web riches dans un moteur de rendu vectoriel. Il fonctionne de façon similaire à Adobe Flash dont il se veut une alternative.
Techniquement, Silverlight est l’équivalent de la CLR de Microsoft mais pour les navigateurs Web.

Silverlight a comme concurrents principaux Adobe Flash, Flex et, dans une moindre mesure, des solutions telles que JavaFX ou Quicktime d’Apple. Tout dépend si l’on se place du côté outil de conception de véritables applications ou de simple diffuseur de média (vidéos, musiques…).

La technologie est encore utilisable dans de nombreux navigateurs (Internet Explorer, par exemple) dans les systèmes d’exploitation Windows et Mac OS X, via l’utilisation d’un plugin, mais pas dans les dernières versions des navigateurs modernes. Silverlight n'est plus supporté dans Google Chrome depuis septembre 2015 (version 45), ni dans Firefox depuis mars 2017 (version 52). Edge, le nouveau navigateur par défaut de Windows 10, pourtant provenant du même éditeur, ne l'a jamais supporté.

Microsoft a annoncé la fin du développement de Silverlight 5 en 2012, sauf pour les correctifs. La fin du support sera le 12 octobre 2021.

Par contre, il y a ici un sujet sur Silverlight pour Linux (pipelight). J'avais essayé, il y a un certain temps, de faire fonctionner ce plugin sur puppy, mais sans succès. Il faut dire que je ne suis pas la reine des compilatrices.

https://korben.info/installer-silverlight-sous-linux.html

Peut-être que des plus compétents que moi y arriveront.

Cordialement,
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12696
Location: Gatineau (Qc), Canada

PostPosted: Sun 10 Dec 2017, 18:05    Post subject:  

Si, si, t'es une reine !!! Wink
_________________
musher0
~~~~~~~~~~
Siempre será canción nueva... (V. Jara, Manifiesto)
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 228

PostPosted: Sun 10 Dec 2017, 19:42    Post subject:  

Quels gentlemen ces hommes du nord!
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 472

PostPosted: Mon 11 Dec 2017, 14:34    Post subject:  

Je confirme, en copiant/collant "Silverlight Linux" je match l'article de Korben.
snapshot-2.png
 Description   
 Filesize   57.62 KB
 Viewed   143 Time(s)

snapshot-2.png

Back to top
View user's profile Send private message 
PacificRW


Joined: 31 Jan 2014
Posts: 116
Location: France

PostPosted: Tue 12 Dec 2017, 09:41    Post subject:  

Salut à tous et merci à Dorothée pour ce post, parfaitement pertinent, et à Fabrice pour cette piste qui ouvre l'horizon. A bientôt
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 472

PostPosted: Tue 12 Dec 2017, 14:17    Post subject:  

Ne m'excusez pas, je suis technique, je n'avance pas avec des belles paroles. Cool

Sinon on peut ouvrir un fil littérature pour les aficionados de maître Capello ?

Balancez les références de vos machines, les id hardware, composants et autres informations indispensables, parce que moi j'ai d'autres chats à fouetter.
582441-jacques-capelovici-dit-maitre-capello-637x0-2.jpg
 Description   
 Filesize   88.12 KB
 Viewed   127 Time(s)

582441-jacques-capelovici-dit-maitre-capello-637x0-2.jpg

Back to top
View user's profile Send private message 
PacificRW


Joined: 31 Jan 2014
Posts: 116
Location: France

PostPosted: Fri 15 Dec 2017, 02:41    Post subject:  

Salut à tous ! Bonne nouvelle Very Happy

J'ai suivi le conseil d'Argolance :

Dans Firefox, j'ai entré dans la barre d'adresse "about:config"
Puis, sur la page "attention danger" j'ai cliqué sur "je prends le risque"
Dans la liste, j'ai cliqué droit sur "media;libavcodec.allow-obsolete"
(Voir saisie ci-dessous)
Cliqué sur "Inverser" pour passer la valeur de "False" à "True"

Et alors là ! Je suis bluffé ! Tout fonctionne ! L'image, le son, en direct ou en replay, sur toutes les chaînes, sur tous les sites et même sur Canal+ (à condition d'être abonné).
Plus question de Silverlight et autres béquilles Confused
Argolance, l'informatique est grande et tu es son prophète Laughing
171215_071654_737x309_easyshot.jpg
 Description   
 Filesize   38.16 KB
 Viewed   108 Time(s)

171215_071654_737x309_easyshot.jpg

Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3371
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 15 Dec 2017, 18:46    Post subject:  

Bonsoir,
Quote:
Argolance, l'informatique est grande et tu es son prophète

N'empêche que ce n'est pas réellement la bonne solution, car Arrow comme il est justement dit ici
Quote:
C'est vraiment un mauvais conseil pour moi. Vous dites essentiellement aux gens d'ouvrir explicitement une vulnérabilité de sécurité sur leur système plutôt que de la corriger.
Traduit avec www.DeepL.com/Translator

Mais je n'ai personnellement pas trouvé d'autre solution (même en compilant livavcodec ou en installant des versions plus récentes à partir du PPM).
Alors, en attendant que ça soit "fixé", je ne vois pas comment se passer de ce pis-aller pas vraiment "brillant"... Confused

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
hamoudoudou

Joined: 24 Jul 2014
Posts: 1467
Location: rabat

PostPosted: Fri 15 Dec 2017, 23:11    Post subject: Là est le probléme des versions Ubuntu  

Là est le probléme des versions Ubuntu Qui utilsent libavcodec. Très vite la version n'est plus en accord avec les logiciels du PPM, pas uniquement Firefox. Artfulpup a fait marche arrière, intelligemment
Libavcodec m'a fait passer soit aux nouvelles Dpup, Soit aux DOGS ou retourner vers les Versions Precise,
MPV notamment... Toutes les applis nécessitant FFMPEG sont impactées. Le deni ne fera pas Avancer. Argolance a découvert le bât qui blesse.. PeeBee l'anglais a pris le taureau par les cornes,
Quant à Firefox qui sort sans arrêt des nouvelles versions pour être toujours au top, libre à Lui.. Les autres marques de navigateurs nous mettraient en danger, en changeant moins souvent. C'est plausible. Mais franchement parano. Si vous shuntez vers une vieille version libavcodec; attention danger, vous allez vous faire pirater vite fait. Pirater quoi, vous seuls le savez.
Back to top
View user's profile Send private message 
PacificRW


Joined: 31 Jan 2014
Posts: 116
Location: France

PostPosted: Sat 16 Dec 2017, 12:44    Post subject:  

Salut à vous tous !
Il est évident que la solution préconisée ci-dessus pose un problème de sécurité. Nous en sommes tous conscients. J'ai suivi le lien fourni par Argolance et constaté les interrogations soulevées.
En fait, on ouvre une faille de sécurité.
Puppy/Linux est-il aussi exposé que Windows dans ce cas ? Question naïve ?
Et aussi dans le cas d'une non-installation en local, avec système sur clé USB, mais pupsave sur le DD Embarassed ?
Comment limiter les risques ? Sans virer libavcodec Smile ?
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3371
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 16 Dec 2017, 14:51    Post subject:  

Quoiqu'il arrive, une faille de sécurité en cache toujours une autre! Alors...
Ça fait belle lurette que je ne m'en fais plus trop pour ça (je ne m'en porte pas plus mal et refais quand même régulièrement des installations "propres"). Mais cette obsession de la sécurité est typiquement "linuxienne", avec ses "sudo" et compagnie.
Y a toujours une part de risque, c'est sûr! Mais quel risque au juste avec Puppy et ses modes particuliers de fonctionnement, comparé à cette misérable passoire qu'est Windows?

_________________

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0675s ][ Queries: 13 (0.0062s) ][ GZIP on ]