Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Jan 2018, 12:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Firefox 57 quantum videos are not loading
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
totolanio

Joined: 03 Jan 2015
Posts: 199

PostPosted: Tue 05 Dec 2017, 10:42    Post subject:  Firefox 57 quantum videos are not loading
Subject description: Stay in pause forever
 

Hello,

Since I upgraded firefox to this horrible quantum, I can't load videos. The grey bar fills so it downloads it, but then it never starts and stays in a "pause" mode forever.

I was using firefox for a long time on lxtahrpup and it just updated automatically with the builtin browser update system.

I'm using a 2006 computer too.

What can I do?


PS: I looked for alternatives and didn't find anythingfor old slow computer in 32-bit

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 436
Location: Connecticut, United States

PostPosted: Tue 05 Dec 2017, 11:26    Post subject:  

deleted
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3311
Location: King's Lynn, UK.

PostPosted: Tue 05 Dec 2017, 12:09    Post subject:  

Hi, totolanio.

You could always do what I've done. I'm not a Firefox fan by any means, and have always preferred the Chromium-based browsers.....but I'm once again using Firefox as my 'back-up' browser; this time, FF52esr.

Having got the pulseaudio problem out of the way, I put together a .pet of this one for somebody else on the Forums just the other day. It includes Oscar's apulse 'fix' for the audio; sound works perfectly, and NetFlix plays back in it without any problems. I'm running this in multiple Pups from a single, remote, sym-linked 'install' of FF. Admittedly, I haven't yet tried it with YouTube.....I very rarely visit the site, TBH.

My box is from 2004.....

You can find the .pet here, if you're interested:-

http://www.mediafire.com/file/8x5c11n3vnd0t0d/FireFox-52-esr.pet

Entirely up to you, of course. This version is one of the 'extended support releases'; it will be 'safe' until at least July 2018, when it will automatically update to the next ESR version.....probably based on FF59.


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
gjuhasz


Joined: 29 Sep 2008
Posts: 362

PostPosted: Tue 05 Dec 2017, 14:40    Post subject: Re: Firefox 57 quantum videos are not loading
Subject description: Stay in pause forever
 

totolanio wrote:
I looked for alternatives and didn't find anything for old slow computer in 32-bit


Try Puli 6.1.1

32-bit beta is announced at http://www.murga-linux.com/puppy/viewtopic.php?t=96964&start=235 (you can test it if you install its 6.1.0 predecessor on a pendriva and overwrite the main files with their counterparts from the 6.1.1 diff fileset).

    - Latest iron, slimjet, vivaldi and firefox (e.g., FF59.x alpha) browsers are OK.
    - Youtube OK (video + sound).
    - Web skype OK (opens from iron browser).


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 199

PostPosted: Wed 13 Dec 2017, 11:21    Post subject:  

I already use FF ESR but that's not a real solution because it will not work in few months and the problem will be the same Sad

And I don't think changing to another puppy distrib will solve the problem, right?

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 978

PostPosted: Wed 13 Dec 2017, 12:41    Post subject:  

totolanio wrote:
I already use FF ESR but that's not a real solution because it will not work in few months and the problem will be the same Sad

And I don't think changing to another puppy distrib will solve the problem, right?


Run this page and tell us what you get.

https://www.youtube.com/html5

What pages are the problem? You might need to install flash player for some.

Also, look for the shield emblem in the url line. It turns off some of what firefox thinks are bad tracking sites. It broke CBS News video for me until I clicked on it and turned it off.
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 199

PostPosted: Thu 14 Dec 2017, 12:56    Post subject:  

Hmm I already checked all these simple things.

The page says everything is fine

Any video doesn't work, it's not related to youtube as I said.

And no shield thing


Using lxtahrpup

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 199

PostPosted: Tue 19 Dec 2017, 10:59    Post subject:  

Up in case someone can help, still have no clues on what to do
_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1655
Location: London, England

PostPosted: Tue 19 Dec 2017, 11:36    Post subject:  

There are various threads about videos and sound in Firefox Quantum dotted around on the forum. One example here http://murga-linux.com/puppy/viewtopic.php?t=112125&start=113
You probably just need to make sure the 3 apulse libs are installed. I suggest putting these inside the firefox directory which may be under /usr/lib or /opt
http://smokey01.com/OscarTalks
Then relax the sandbox security setting in about:config. Modify from 3 to 2 and add the whitelist settings or modify down to 0 and you should not need to do the whitelist changes at all.

_________________
Oscar in England

Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2841
Location: USA

PostPosted: Tue 19 Dec 2017, 12:08    Post subject:  

Mike Walsh wrote:
Hi, totolanio.

You could always do what I've done. I'm not a Firefox fan by any means, and have always preferred the Chromium-based browsers.....but I'm once again using Firefox as my 'back-up' browser; this time, FF52esr.

Having got the pulseaudio problem out of the way, I put together a .pet of this one for somebody else on the Forums just the other day. It includes Oscar's apulse 'fix' for the audio; sound works perfectly, and NetFlix plays back in it without any problems. I'm running this in multiple Pups from a single, remote, sym-linked 'install' of FF. Admittedly, I haven't yet tried it with YouTube.....I very rarely visit the site, TBH.

My box is from 2004.....

You can find the .pet here, if you're interested:-

http://www.mediafire.com/file/8x5c11n3vnd0t0d/FireFox-52-esr.pet

Entirely up to you, of course. This version is one of the 'extended support releases'; it will be 'safe' until at least July 2018, when it will automatically update to the next ESR version.....probably based on FF59.


Mike. :wink:


Does this run on Lupu (5.28), or it is for newer versions?

_________________
Add swapfile
WellMinded Search
Back to top
View user's profile Send private message 
Moose On The Loose


Joined: 24 Feb 2011
Posts: 778

PostPosted: Sat 23 Dec 2017, 15:25    Post subject: Re: Firefox 57 quantum videos are not loading
Subject description: Stay in pause forever
 

totolanio wrote:
Hello,

Since I upgraded firefox to this horrible quantum, I can't load videos. The grey bar fills so it downloads it, but then it never starts and stays in a "pause" mode forever.


<short rant>
If version N works and version N+M doesn't work where M is a positive number, (N+M) is NOT an upgrade from N
</short rant>

I am using seamonkey 2.46.

Many videos work. It appears that the ones that don't are using some quirky violation of the HTML standards. Often Chrome based browsers will assume different things than Mozilla browsers assume when trying to work around mistakes in the page.
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 199

PostPosted: Wed 10 Jan 2018, 10:48    Post subject:  

OscarTalks wrote:
There are various threads about videos and sound in Firefox Quantum dotted around on the forum. One example here http://murga-linux.com/puppy/viewtopic.php?t=112125&start=113
You probably just need to make sure the 3 apulse libs are installed. I suggest putting these inside the firefox directory which may be under /usr/lib or /opt
http://smokey01.com/OscarTalks
Then relax the sandbox security setting in about:config. Modify from 3 to 2 and add the whitelist settings or modify down to 0 and you should not need to do the whitelist changes at all.


Oscar, your solution solved my problem! As usual!


BUT I decided to try to find what was the exact source of the problem and I'm not sure.

=====
VIDEO:
=====


With:
Code:
security.sandbox.content.level;3


The video never starts.

With:
Code:
security.sandbox.content.level;2
security.sandbox.content.read_path_whitelist;/dev/snd/
security.sandbox.content.syscall_whitelist;53
security.sandbox.content.write_path_whitelist;/dev/snd/


The video never starts.

So I suppose I didn't whitelist the right path, but I don't know which one it is.

With:
Code:
security.sandbox.content.level;1
security.sandbox.content.read_path_whitelist;/dev/snd/
security.sandbox.content.syscall_whitelist;53
security.sandbox.content.write_path_whitelist;/dev/snd/


The video never starts.

With:
Code:
security.sandbox.content.level = 0


It works perfectly fine.

Is it a real security concern to have it set to 0?


=====
AUDIO :
=====


I had apulse-0.1.8-i686-wz.pet installed, but I removed it and updated to 0.1.10 and it solved the audio missing from videos.

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
trelu

Joined: 17 Sep 2017
Posts: 4

PostPosted: Wed 10 Jan 2018, 14:08    Post subject:  

I had the exact same problem and have used OscarTalk's solution to fix it. However, like totolanio, I've only been able to get it to work with the sandbox level on 0. The level 1 and 2 whitelist settings don't work.

totolanio wrote:

With:
Code:
security.sandbox.content.level = 0


It works perfectly fine.

Is it a real security concern to have it set to 0?


I was wondering this too.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0621s ][ Queries: 14 (0.0063s) ][ GZIP on ]