Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 22 Apr 2018, 16:18
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Modprobe PPA not recognizing Iomega Zip 100 drive
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Fri 10 Feb 2017, 19:23    Post subject:  Modprobe PPA not recognizing Iomega Zip 100 drive  

I have an old HP that I just don't want to retire until I get some old files off a Iomega Parallel Port Zip 100. All necessary modules appear to be loading correctly but still not seeing the drive. I checked the port by connecting an old printer to the drive and it is recognized by CUPS. I have read many older post by searching google and tried many of the resolves. Still not successful. Has anyone been able to correctly configure a Zip 100 with Slacko 6.3.2? Greatly appreciate any help, I always like keeping at one Linux machine around.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 12820
Location: Arizona USA

PostPosted: Fri 10 Feb 2017, 19:52    Post subject:  

Linux recognizes file systems, not drives per se. If there's nothing in the drive, maybe that's why nothing shows up. What does Gparted say?
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7827
Location: World_Hub

PostPosted: Fri 10 Feb 2017, 19:59    Post subject:  

Don't forget your "sg" module.

Failing the above, try unloading your "lp" module.

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Fri 10 Feb 2017, 21:51    Post subject: Modprobe PPA not recognizing Iomega Zip 100 drive  

Did both:
Disk in drive on boot and after.
Gparted list only my two hard drives sda and sdb, nothing for the zip as sdc.
I also verified SG is listed in lsmod, it is.
rmmod lp, no luck
I also read somewhere that possible conflict with imm and ppa at same time, rmmod imm, still no luck
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7827
Location: World_Hub

PostPosted: Fri 10 Feb 2017, 22:26    Post subject:  

Let's leave luck outta this.

Run the leads here >> https://help.ubuntu.com/community/IomegaZIPDrive

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Sat 11 Feb 2017, 07:58    Post subject: Modprobe PPA not recognizing Iomega Zip 100 drive  

$ cat /proc/scsi/scsi
This reveals my sda, sdb, and my cdrom, no Zip Drive in the list.
I have verified both ppa and sg modules are loaded.
When I look at my system information during boot or dmesg after trying various changes I never see the drive bump, my printer connected to the drive will bump. I hope everyone has patience, this may take some time. I have tried most things I located on the internet.
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7827
Location: World_Hub

PostPosted: Sat 11 Feb 2017, 08:35    Post subject:  

Before making a "rules" suggestion, disconnect your printer, blacklist "lp" and reboot.

Upon reaching the desktop again, modprobe both modules, then connect your drive.

Try this and leave us an "lsmod -v" dump to review, then we'll take the next step.

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Sun 12 Feb 2017, 07:23    Post subject: Modprobe PPA not recognizing Iomega Zip 100 drive  

Needed to leave yesterday and did not get back until late.
Disconnected drive, rmmod imm, rmmod vfat, rmmod lp, then reboot.
modprobe ppa, modprobe sg
module view below:
—— 57 Loaded Kernel Modules (lsmod) ——◀

Total Memory Used: 2339.81 KB

MODULE: BYTES USED BY
8139too 16607 0
ac97_bus 810 1 snd_ac97_codec
b43 335458 0
bcma 27305 1 b43
ccm 6122 2
cfg80211 177229 2 b43,mac80211
ctr 2755 2
drm 182913 2 i915,drm_kms_helper
drm_kms_helper 30419 1 i915
floppy 47590 0
gameport 5786 3 ns558,snd_riptide
i2c_i801 8306 0
i915 613419 0
ip_tables 9235 3 iptable_filter,iptable_mangle,iptable_nat
iptable_filter 996 1
iptable_mangle 1092 0
iptable_nat 2074 0
lpc_ich 11556 0
mac80211 243327 1 b43
mii 3215 1 8139too
nf_conntrack 49015 8 nf_nat_ftp,nf_nat,nf_nat_ipv4,xt_conntrack,nf_conntrack_ftp,nf_conntrack_irc,iptable_nat,nf_conntrack_ipv4
nf_conntrack_ftp 5399 1 nf_nat_ftp
nf_conntrack_ipv4 5862 5
nf_conntrack_irc 2843 0
nf_defrag_ipv4 951 1 nf_conntrack_ipv4
nf_nat 9614 3 nf_nat_ftp,nf_nat_ipv4,iptable_nat
nf_nat_ftp 1376 0
nf_nat_ipv4 2784 1 iptable_nat
ns558 1703 0
parport 24249 2 ppa,parport_pc
parport_pc 20273 0
ppa 8632 0
psmouse 74525 0
rfkill 7782 2 cfg80211
sg 23414 0
snd 42415 14 snd_pcm_oss,snd_ac97_codec,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_riptide,snd_seq_oss,snd_mpu401_uart,snd_seq_device,snd_mixer_oss,snd_pcsp,snd_opl3_lib
snd_ac97_codec 84397 1 snd_riptide
snd_hwdep 4490 1 snd_opl3_lib
snd_mixer_oss 11681 1 snd_pcm_oss
snd_mpu401_uart 4527 1 snd_riptide
snd_opl3_lib 6866 1 snd_riptide
snd_pcm 64042 4 snd_pcm_oss,snd_ac97_codec,snd_riptide,snd_pcsp
snd_pcm_oss 32518 0
snd_pcsp 6178 0
snd_rawmidi 14189 2 snd_mpu401_uart,snd_seq_midi
snd_riptide 15507 0
snd_seq 37877 6 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy,snd_seq_midi
snd_seq_device 3996 6 snd_seq,snd_rawmidi,snd_seq_oss,snd_seq_dummy,snd_opl3_lib,snd_seq_midi
snd_seq_dummy 843 0
snd_seq_midi 3880 0
snd_seq_midi_event 4256 2 snd_seq_oss,snd_seq_midi
snd_seq_oss 23004 0
snd_timer 14206 3 snd_pcm,snd_seq,snd_opl3_lib
ssb 43156 1 b43
video 9980 1 i915
xt_conntrack 2581 4
xt_pkttype 743 1
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7827
Location: World_Hub

PostPosted: Sun 12 Feb 2017, 10:32    Post subject:  

I meant "lsusb -v", not lsmod.
_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Sun 12 Feb 2017, 12:13    Post subject: Modprobe PPA not recognizing Iomega Zip 100 drive  

This is from System Information, more in terminal window if needed. How do you copy the terminal window for paste?

—— USB DEVICES (lsusb) ——◀

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


▶—— USB DEVICES (lsusb -t) ——◀

Bus 01.Port 1: Device 1, Class=root_hub, Driver=uhci_hcd/2p, 12Mbit/s


▶—— USB DEVICES (lsusb -v) ——◀

Bus 001 Device 001:
ID = 1d6b:0001 Linux Foundation 1.1 root hub
USB Version = 1.10
Manufacturer = Linux 3.14.55 uhci_hcd
Product = UHCI Host Controller
Serial Number = 0000:00:1f.2
Class = Hub
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7827
Location: World_Hub

PostPosted: Sun 12 Feb 2017, 15:33    Post subject:  

So it's not detected by lsusb?

dmesg.. Yes or no?

If yes, post ONLY the relevant output.

For copy'n paste, have the window you wanna paste into open.

Highlight the output you're after, minimize your terminal, return focus to your paste window and center-clk.

If there's no middle mouse button, it's your left and right buttons simultaneously.

If lousy old Urxvt doesn't comply, pipe the output to file with: dmesg > /root/dmesg.txt

==

For what it's worth, I had an old Iomega, that, no matter which system I tried to access it from simply couldn't be read. My guess is the dern thang just died.

Maybe try from Pup Tahr or bring it to your local library and see if their system can pry it open.

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Sun 12 Feb 2017, 15:39    Post subject: Modprobe PPA not recognizing Iomega Zip 100 drive  

Got it sorry:

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed (or root) hub
bMaxPacketSize0 64
idVendor 0x1d6b Linux Foundation
idProduct 0x0001 1.1 root hub
bcdDevice 3.14
iManufacturer 3 Linux 3.14.55 uhci_hcd
iProduct 2 UHCI Host Controller
iSerial 1 0000:00:1f.2
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed (or root) hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0002 1x 2 bytes
bInterval 255
Hub Descriptor:
bLength 9
bDescriptorType 41
nNbrPorts 2
wHubCharacteristic 0x000a
No power switching (usb 1.0)
Per-port overcurrent protection
bPwrOn2PwrGood 1 * 2 milli seconds
bHubContrCurrent 0 milli Ampere
DeviceRemovable 0x00
PortPwrCtrlMask 0xff
Hub Port Status:
Port 1: 0000.0100 power
Port 2: 0000.0100 power
Device Status: 0x0001
Self Powered
Back to top
View user's profile Send private message 
jdavis31647

Joined: 05 Feb 2017
Posts: 7

PostPosted: Sun 12 Feb 2017, 15:45    Post subject: Modprobe PPA not recognizing Iomega Zip 100 drive  

I used it on an old Red Hat Linux at one time, should have copied things then. Possibly if I am bored one day may install Win 95 on the second drive to see what happens.

Strange that it won't recognize it with Slacko 5.3.2, thanks for the effort I was just reaching out if I may be missing something silly.
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7827
Location: World_Hub

PostPosted: Sun 12 Feb 2017, 15:54    Post subject:  

Try another live disk. Need a link?
_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 851
Location: Ann Arbor MI USA

PostPosted: Sun 03 Dec 2017, 11:54    Post subject: Parallel port zip drive (zip100atapi)
Subject description: Works with Wary 5.1 but NOT with Tahr Puppy or Ubuntu 14
 

What worked for me:
modprobe sg
modprobe ppa

An icon sda4 appeared.

Click on icon, see drive's contents (it is mounted).

pmount ignored the drive (only floppy, optical, or usb found)

Tahr did not find the drive. Lupu 5.11 could not handle the i810 video on this 2004 DELL 2400 desktop. I did not try the latest lupu, the base version of which also has video shortcomings. (Sulu lupu often works but no fbcon support). Wary is the best puppy 5 for older hardware.

I have 12 of these drives and then 75 disks to test.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0501s ][ Queries: 12 (0.0068s) ][ GZIP on ]