(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
and continue your work there. Thank you.

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 26 Nov 2020, 14:58
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup Stretch 7.5 CE (RC-5)
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 3 of 48 [712 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 46, 47, 48 Next
Author Message

Joined: 04 Jan 2009
Posts: 15041
Location: Gatineau (Qc), Canada

PostPosted: Sun 19 Nov 2017, 12:40    Post subject:  

Thanks, mavrothal, for the reminder on Puppy's do-ocracy type of leadership.

For me, what comes out of your descriptive post is that Puppy is a do-ocracy topped
by an elitist "reproducility" panel. IMO, that secondary structure can seriously weigh
down and even contradict do-ocracy principles and initiatives.

So I do not stand corrected, but I take good notice.

To push the do-ocracy model to the limit, I think no one could claim to be Puppy's
"Executive Director" or "Marketing Director", for example, on a do-ocracy basis.
It just doesn't sound right in the context of a do-ocracy. There has to be "go-to"
persons for such functions.

So I still believe that some direction should be imprinted every now and then by
someone at the helm, to maintain the balance between Puppy's two "forces", and
to take decisions concerning the internal well-being of the distro as well as its
outside image.


"You want it darker? We kill the flame." (L. Cohen)
Back to top
View user's profile Send private message 

Joined: 04 Jan 2009
Posts: 15041
Location: Gatineau (Qc), Canada

PostPosted: Mon 20 Nov 2017, 02:02    Post subject:  

Hello radky.

Where is the devx archive please? I searched the pages of this thread and could not find
an URL to download it from.


"You want it darker? We kill the flame." (L. Cohen)
Back to top
View user's profile Send private message 

Joined: 21 Sep 2008
Posts: 4391
Location: Worcestershire, UK

PostPosted: Mon 20 Nov 2017, 02:57    Post subject:  

musher0 wrote:
Where is the devx archive please?


LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 

Joined: 04 Jan 2009
Posts: 15041
Location: Gatineau (Qc), Canada

PostPosted: Mon 20 Nov 2017, 07:14    Post subject:  

Thanks, peebee.


I spent the night trying out your incarnation of DPupStretch-7. I haven't tested
everything, that's impossible in only a couple of hours.

My impression is that your StretchPup-7a2 is generally very well behaved.

I had bugs with the jwm-tray-2 (the one on top of the monitor).
-- My outside monitor (the one I usually use ) is 1920x1080. The top tray stays
somewhat to the right when at boot-up lxrandr changes to this second screen -- until
I run your jwm-menu and click "Apply" at the bottom.

-- To launch anything from it, this tray seems to understand either a very short left-
click on an icon or repeated double-clicks. The behaviour is not constant.

-- I had a bug with the time-sync script, in the sense that psync appears to
NOT work properly until a network connection is established. I suspect an unaware
user may find this a hair-pulling experience if the battery on his / her computer is
weak or dead.

Is it possible to get the Pup to connect immediately at first boot? It may ease the
experience for a newbie.

-- Debian has decided to go for "hybrid" executables in their Stretch issue. In itself,
it's none of our business.

However, that created a problem when I decided to change the default terminal from
lxterminal back to urxvt in the defaultterminal file. After that when I clicked on the
console icon, your ldd utility ran, listing all the libs used by urxvt. I found that
irritating at first, and then I found it funny!

Running elfdit on it, like so:
cd /usr/bin
elfedit --input-type=dyn --output-type=exec urxvt
solved the problem. After this modification, urxvt ran normally by clicking on its
desktop icon.

(Elfedit is in the devx, which is why I asked above where yours was.)

It may be worth checking if other executables behave similarly. I know geany and
mtpaint do not call your ldd utility to get analyzed ( Smile ) when you click on their icon,
they simply run! But I did not check any others.

-- Perhaps improve, so the user can better see them, the appearance of:

-- the clock on the jwm taskbar by adding the following xml code in file

-- the xload insert by editing its code in /root/.jwmrc-tray to:
<Swallow name="xload" width="64">
xload -nolabel -bg "#3f6fa9" -scale 3
This bit of code doubles xload's width and provides 2 horizontal lines
in it so the user does not have to squint to see what's happening in the xload.

-- Aside from that, it lacks a small choice of fonts, GTK2 and jwm themes and a
few nice backgrounds. I don't mean anything big, just "A Choice". Is there a way
you could provide a complement to your Pup with those in it? I found your
StretchPup a tad spartan ex-factory.

Why not include the themes Oscar_Talks' produced for the new version of jwm?

As to the included GTK2 themes, when browsing through them with gtk_chtheme,
you get the impression that they are all "more of the same". Variety is lacking.

Speaking of the gtk_chtheme utility, may I suggest that it has its own *.desktop file
and entry in the menu, as it used to be. IMO, having access to it only from your
jwm-desk utility is too remote; I felt I needed a quicker access to it.

-- I never tried your pArchive interface, because I found its layout forbidding. Sorry
for being so frank. I do miss the traditional entry for SFR's UExtract in every
directory shown by the right-click menus.

-- You have almost nothing in the .Xdefaults and .Xresources files in your Pup.
Maybe populate them with a view to countering the prejudice that CLI is boring.
Simply including colors in ~/.Xresources, like so:
! Nicer terminal colors
! Inspired by : https://wiki.gentoo.org/wiki/Rxvt-unicode
! Viewed on 2017-11-19 at 03h15
*background: #0f0f0f
*foreground: #c8c8c8

*color0:  #251f1f
*color8:  #5e5e5e
*color1:  #eb4509
URxvt*color9:  #FF5454
*color2:  #94e76b
URxvt*color10: #54FF54
*color3:  #ffac18
URxvt*color11: #FFFF54
*color4:  #46aede
URxvt*color12: #5454FF
*color5:  #e32c57
URxvt*color13: #FF54FF
*color6:  #d6dbac
URxvt*color14: #54FFFF
*color7:  #efefef
URxvt*color15: #FFFFFF
could make a big difference.

It's the same with .bashrc; certainly a prompt with an inspiring motto would spice up
the terminal. Maybe something like this:
PROMPT_COMMAND='DIR=`pwd|sed -e "s!$HOME!~!"`; if [ ${#DIR} -gt 30 ]; then CurDir=${DIR:0:12}...${DIR:${#DIR}-10}; else CurDir=$DIR; fi';titlebar="\D{Le %A %d %B %G, %r}"
PS1="\nKnow thyself\e[1;36m(Socrates)\e[m | \D{%a %d %b, %R}\n[\$CurDir]>"
Change the motto to what speaks to you, of course.

That, and a few aliases that you could advertise in some doc, would make life at
the console easier for the user.

-- Finally, may I suggest the inclusion ex-factory of a second window manager,
again, nothing huge, but still competent. (The name "blackbox" comes to mind, but
there are many other good small WM's.) In an attempt to dismiss the idea the
general public may get that Puppy is a "farm club" for the jwm WM.

Submitted in a positive spirit. IHTH.

Best regards.

Style edits, Nov. 22, 2017. musher0
Description  This capture illustrates that on a 2nd monitor larger than the one jwm
booted on: 1) the top is not centered; 2) jwm cannot maximize a window

Filename  jwm-can't-maximize-properly.jpg 
Filesize  143.74 KB 
Downloaded  765 Time(s) 

"You want it darker? We kill the flame." (L. Cohen)

Last edited by musher0 on Sun 03 Dec 2017, 14:27; edited 2 times in total
Back to top
View user's profile Send private message 

Joined: 22 Mar 2016
Posts: 94

PostPosted: Mon 20 Nov 2017, 08:04    Post subject:  

Back to top
View user's profile Send private message 

Joined: 15 Aug 2016
Posts: 1743

PostPosted: Mon 20 Nov 2017, 12:22    Post subject:  

mfb wrote:
@ musher0

I suggest you delete the bottom section of your above post and act honourably by transmitting your idea to 01micko by PM.


He (Musher) is at it again! Just the past few days he's been stirring up the pot and posting nonsense in a "Security" thread where I asked him to stop three times (1 time nice, 1 time joking, and 1 time angry he was keeping at it).

Dang it, Musher, stop it! What has happened to you? You are randomly attacking people, posts, threads with subversive/destructive behavior and you don't even seem to realize it.

Here are some facts about Dpup:

1) When Dpup started, Ttuuxxx was the leader. Period. Jilst even posted and said it was probably best for Ttuuxxx to take over.

2) Ttuuxxx was doing stuff so fast that it was crazy. The guy is simply great when it comes to compiling kernels and such.

3) But almost as soon as Dpup started, Musher immediately started feuding with Ttuuxxx. Started calling him a, and I quote, a "Dictator", and other things. I watch Ttuuxxx try to ignore it, I even tried to joke with Musher to get him to realize what he was doing, but he wouldn't stop.

4) I couldn't take it anymore, and simply went elsewhere, with Ttuuxxx's blessing in giving his kernel a go, and then after I just went to other pups and ddogs. I never went back, simply, because of Musher's behavior.

5) Ttuuxxx even resurfaced about 4-5 weeks ago, made a post/comment about what happened in another thread, but still has decided to not yet return.

Just now, I come here today, in Radky's great creation & thread, and I am greeted with Musher exhibiting the exact same subservice/destructive behavior he has in other threads. It's unbelievable.

I keep repeating---it is bad enough we've got to deal with Pelo/Hamhamdoudou doing this stuff, where one minute he is ok, normal, the next he is psycho trying to "stir the pot" where he shouldn't. But we shouldn't have to deal with another one, and that's what Musher---someone in the past I used to look up to and repeatedly tried to defend against others---has become, imho.

This is so disappointing. I had to endure and watch Starhawk get driven away by this behavior, and I've watched six different people over the past several months get so disgusted with Musher's behavior that they've left and not posted since. Two of them were newbies, if you can believe that.

I am worried I am going to watch another of our (Radky or who's next?) posters/developers driven away also. Crying or Very sad It's one thing to complain about something, Musher, but it is entirely another thing to keep repeatedly displaying the subversive & destructive behavior you do.

P.S. Dang it, Flash, how much more of this are you going to let go on? I am not the only one who has PMed you about this behavior from this person, that much I know for a fact! This is 7 different threads in the past several weeks that he has pulled this behavior, and the other 6 threads (including mine from the other day) have become waste-grounds where conversations cannot be conducted because of that behavior. You can't have normal conversations, because he comes on and one minute sanity exists and all is ok, then the next minute, it's off-the-rails and the thread becomes a place that is not nice to go to.
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1566

PostPosted: Mon 20 Nov 2017, 13:20    Post subject:  

peebee wrote:
musher0 wrote:
Where is the devx archive please?


Thanks peebee for the link to the devx.

If you guys are having an issue with the "fire spinning thing" in Palemoon 27.6.x blinking on and off annoyingly every time a tab is loading, the developer is aware the issue and says it will be fixed in the next point release 27.6.2:

Back to top
View user's profile Send private message 

Joined: 04 Jan 2009
Posts: 15041
Location: Gatineau (Qc), Canada

PostPosted: Mon 20 Nov 2017, 13:28    Post subject:  

It's all in your perception of it, belham2.
if you want to hang your dog you give him a bad name first, /
Qui veut noyer son chien l'accuse de la rage.

AFAIK, all of us live under democratic rule, which fosters freedom of expression.

My blurb on radky's StretchPup, above, aims at improving it. If you think otherwise,
it's your choice.

I did a test and posted a report. I expressed my opinion. Radky does what he wants
with it. And that will be ok by me.

In my post before that, I basically said that that I thought 01micko at this time was
lacking leadership of the Puppy distro. Mavrothal answered by exposing his position
about this. I may not agree with him and he with me, but at least it was done with
respect, and now we both know what the other think on the subject.

I never licked anybody's shoes, and I'm not about to start now. I'm a free thinker,
and I'm actually glad if that upsets anyone to the point where the other person stops
emoting and starts thinking.

There is no possible dialogue about anything if people do not start by speaking what
they consider to be the truth as they see it.


As to the ttuuxxx episode, he came across, in my perception, as wanting to retain
entire control of the DPupStretch process for himself, and I wouldn't have it. Not that
I am happy with the incident, but since that incident happened, at least half a dozen
StretchPups have been produced, including by you.

Had I not intervened, DPupStretch-7 would have become ttuuxxx's "territory", for lack
of a better word. That's what I perceived and that's what I acted on.

When I forked DPupStretch for a French variant, I was also under the impression that
I was preserving the capacity to develop DPupStretch in my language and
languages other than English, for reasons I do not wish to explain in public.

Finally, browse through those early posts, and you'll see that ttuuxxx refused to work
in co-operation. He decided that, it was his right, but then please do not act surprised
if there are now over half a dozen variants of the DPupStretch7 in the wild, including

There was a suggestion to co-operate on the DPupStretch project, voiced by me.
Mavrothal -- to my surprise -- even wished me good luck.

There was a refusal to co-operate, voiced by ttuuxxx. Which, as I said above, was his
right. As I understand it, he felt more comfortable working the way he always worked,
with his method, etc.

The DPupStretch exploded development we have now, is a result of those initial
positions and counter-positions.

I have made my peace with co-operating within Puppy: it cannot exist because
individualities, including mine, are too strong. End of story.

Best regards.

"You want it darker? We kill the flame." (L. Cohen)
Back to top
View user's profile Send private message 

Joined: 07 Apr 2009
Posts: 3721
Location: Ontario Canada

PostPosted: Mon 20 Nov 2017, 17:22    Post subject: Dpup Stretch CE  

I installed the beta to a usb-3.0 SSD for use on my lenovo desktop pc:

# inxi -bw
System: Host: puppypc31943 Kernel: 4.9.63-pae i686 (32 bit) Desktop: JWM 2.3.7 Distro: Dpup Stretch 7.0.0a2
Machine: Device: desktop System: LENOVO product: 7491B8U v: ThinkCentre M58e serial: MJ01509
Mobo: LENOVO model: N/A serial: INVALID BIOS: LENOVO v: 5HKT39AUS date: 06/17/2009
CPU: Dual core Intel Core2 Duo E8400 (-MCP-) speed/max: 2336/3003 MHz
Graphics: Card: NVIDIA GF108 [GeForce GT 430]
Display Server: X.org 1.19.2 driver: nvidia tty size: 144x32 Advanced Data: N/A for root
Network: Card: Marvell 88E8057 PCI-E Gigabit Ethernet Controller driver: sky2
Drives: HDD Total Size: 446.4GB (0.4% used)
Weather: Conditions: 39 F (4 C) - Overcast Time: November 20, 3:51 PM EST
Info: Processes: 172 Uptime: 3:43 Memory: 737.5/4040.7MB Client: Shell (bash) inxi: 2.3.8

I noticed that the kernel had been updated 3 days after the 4.9.62
release so I used the kernel kit to compile the latest release and used
the change_kernels scipt to install the update.

Then after loading the
devx_stretch_7.0.0a2.sfs,kernel_sources-4.9.63-stretch.sfs, downloading
the NVIDIA-Linux-x86-384.98.run, I blacklisted the nouveau module,
rebooted and ran the NVIDIA-Linux-x86-384.98.run installer (didn't have
it update automatically) then ran xorgwizard and chose the new
driver,resolution,and bith depth, then xwin.

Installed some applications with PPM.

I'm using a tv for a monitor so volume control is done with the tv
remote control.

Pretty sure radky will update the kernel for the next beta but I had
nothing better to do Smile

Thanks for this Dpup.

Edit: another one today
# uname -ra
Linux puppypc31943 4.9.64-pae #1 SMP Tue Nov 21 05:52:20 EST 2017 i686 GNU/Linux
 Filesize   95.78 KB
 Viewed   1871 Time(s)


Last edited by Billtoo on Tue 21 Nov 2017, 10:24; edited 1 time in total
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1566

PostPosted: Mon 20 Nov 2017, 17:40    Post subject:  

radky wrote:
PS - Recently, I noticed a similar intermittent 'desktop freeze' on my intel desktop PC. Finally, I realized the problem occurred only while running a 64-bit Pup (or 32-bit PAE). A quick test with the MemTest86 utility identified a faulty RAM module (high address error). Removing the bad memory module eliminated my problem. Smile

Neat. I tried booting into memtest86+ 5.01 following the instructions here out of interest. The test took 17.5 minutes, then said it passed with no errors. Darn, was hoping it showed up as bad so I would have an excuse to upgrade from 1GB to 2GB. Laughing

Sailor Enceladus wrote:
The only solution I know that works on my laptops is to compile jwm-905 (the version used in slacko 5.7) and use it's templates for each puppy. If you post the devx I can make a pet of it and see if it solves this problem in your stretch too.

Uploaded a jwm905 compiled with this dpup-stretch here: http://murga-linux.com/puppy/viewtopic.php?p=956982#956982

Might experiment with compiling more commits around this timeframe (906-961) first to see if still ok before border removing.
Back to top
View user's profile Send private message 

Joined: 30 Nov 2008
Posts: 2817
Location: Montenegro

PostPosted: Tue 21 Nov 2017, 03:18    Post subject:  

Ooo, a new Dpup! Very Happy
I will try this out as soon as I have some free time.

puppy.b0x.me stuff mirrored HERE or HERE
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 

Joined: 18 Jul 2012
Posts: 1555

PostPosted: Tue 21 Nov 2017, 14:26    Post subject:  

Just installed this for a quick look.

Looks good.

Internet did not autoconnect, but Simple Network fixed that immediately.

My sometimes troublesome Intel G30 graphics were recognized and glxgears worked. I did get a dialog box before X loaded asking me if I wanted to do something about graphics, but I chose the default (i.e. do nothing) and it worked fine.

Palemoon was fast and smooth (faster than Chrome on Debian Dog).

Keep up the good work. It will be nice to have Stretch as an official Puppy.
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1566

PostPosted: Wed 22 Nov 2017, 22:13    Post subject: jwm menu freezes the desktop bug  

Sailor Enceladus wrote:
Might experiment with compiling more commits around this timeframe (906-961) first to see if still ok before border removing.

My understanding now from compiling and testing a bunch of jwm snapshots is that 905 works and 1101 can freeze, and that the bug seems to have came into being between snapshot 1082 and 1092, and that replacing traybutton.c in 1092 with the one from 1082 (before tray button actions and clock actions were combined to actions.c) seems to fix jwm1092 too.

edit: Think I managed to fix it by restoring "active" behavior to the way it was in 1082. Now to try this in latest jwm

diff -ru jwm-1092a/src/action.c jwm-1092b/src/action.c
--- jwm-1092a/src/action.c   2015-04-21 21:02:04.000000000 -0400
+++ jwm-1092b/src/action.c   2017-11-23 09:22:07.283853839 -0500
@@ -84,7 +84,7 @@
                cp->grabbed = 1;
                if(cp->Redraw) {
-                  (cp->Redraw)(cp);
+                  (cp->Redraw)(cp,1);
                   UpdateSpecificTray(cp->tray, cp);
@@ -120,15 +120,13 @@
-   cp->grabbed = 1;
    if(cp->Redraw) {
-      (cp->Redraw)(cp);
+      (cp->Redraw)(cp,1);
       UpdateSpecificTray(cp->tray, cp);
    ShowRootMenu(menu, x, y);
-   cp->grabbed = 0;
    if(cp->Redraw) {
-      (cp->Redraw)(cp);
+      (cp->Redraw)(cp,0);
       UpdateSpecificTray(cp->tray, cp);
@@ -141,9 +139,8 @@
    const ActionType *ap;
    const int mask = 1 << button;
-   cp->grabbed = 0;
    if(cp->Redraw) {
-      (cp->Redraw)(cp);
+      (cp->Redraw)(cp,0);
       UpdateSpecificTray(cp->tray, cp);
diff -ru jwm-1092a/src/traybutton.c jwm-1092b/src/traybutton.c
--- jwm-1092a/src/traybutton.c   2015-04-21 21:02:04.000000000 -0400
+++ jwm-1092b/src/traybutton.c   2017-11-23 09:08:41.761551061 -0500
@@ -52,7 +52,7 @@
 static void Destroy(TrayComponentType *cp);
 static void SetSize(TrayComponentType *cp, int width, int height);
 static void Resize(TrayComponentType *cp);
-static void Draw(TrayComponentType *cp);
+static void Draw(TrayComponentType *cp, int active);
 static void ProcessButtonPress(TrayComponentType *cp,
                                int x, int y, int button);
@@ -233,7 +233,7 @@
    cp->pixmap = JXCreatePixmap(display, rootWindow,
                                cp->width, cp->height, rootVisual.depth);
-   Draw(cp);
+   Draw(cp,0);
 /** Resize a button tray component. */
@@ -252,7 +252,7 @@
 /** Draw a tray button. */
-void Draw(TrayComponentType *cp)
+void Draw(TrayComponentType *cp, int active)
    ButtonNode button;
@@ -262,7 +262,7 @@
    ResetButton(&button, cp->pixmap, &rootVisual);
-   if(cp->grabbed) {
+   if(active) {
       button.type = BUTTON_TRAY_ACTIVE;
    } else {
       button.type = BUTTON_TRAY;
diff -ru jwm-1092a/src/tray.h jwm-1092b/src/tray.h
--- jwm-1092a/src/tray.h   2015-04-21 21:02:04.000000000 -0400
+++ jwm-1092b/src/tray.h   2017-11-23 09:25:06.532882763 -0500
@@ -115,7 +115,7 @@
    /** Callback to redraw the component contents.
     * This is only needed for components that use actions.
-   void (*Redraw)(struct TrayComponentType *cp);
+   void (*Redraw)(struct TrayComponentType *cp, int active);
    /** The next component in the tray. */
    struct TrayComponentType *next;

Maybe changing cp->grabbed in one or some of those places screwed up HandleTrayButtonRelease in tray.c occasionally.

edit2: Found another way that fixes the ~1087+ jwm problem using less code I think:

--- jwm-1092a/src/action.c   2015-04-21 21:02:04.000000000 -0400
+++ jwm-1092c/src/action.c   2017-11-23 11:21:22.121759421 -0500
@@ -72,6 +72,7 @@
    const int mask = 1 << button;
    int mwidth, mheight;
    int menu;
+   int realgrab;
    menu = -1;
    for(ap = actions; ap; ap = ap->next) {
@@ -120,15 +121,18 @@
+   realgrab = cp->grabbed;
    cp->grabbed = 1;
    if(cp->Redraw) {
+      cp->grabbed = realgrab;
       UpdateSpecificTray(cp->tray, cp);
    ShowRootMenu(menu, x, y);
    cp->grabbed = 0;
    if(cp->Redraw) {
+      cp->grabbed = realgrab;
       UpdateSpecificTray(cp->tray, cp);
Back to top
View user's profile Send private message 

Joined: 24 Aug 2005
Posts: 2008
Location: Maine, USA

PostPosted: Thu 23 Nov 2017, 14:41    Post subject:  

Thank you for taking on this distro. Since I consider that I "own" the connectwizard (only because I was that last person to change it significantly), I am concerned about the report of the ethernet connection not being established at first bootup. That leads me to a related concern.

The initial-connect problem is the result of the /usr/local/bin/defaultconnect script being preset to 'sns'. Usually, the initial default is the connectwizard itself. Then the ethernet is connected at bootup. With sns as the initial default, sns needs a connection record that it created when the user set up the connection. But none exists during initial bootup, so nothing happens.

However, I see no way to get to the connectwizard, to change the default! In older puppies, right-clicking on the "connect" icon displays a menu that includes "Execute the Internet Connection Wizard". But the tool-bar connect icon does not appear to produce that menu. So, how does one change the connection manager, if we cannot get to the connect wizard to select it?
Back to top
View user's profile Send private message 

Joined: 02 May 2010
Posts: 981

PostPosted: Thu 23 Nov 2017, 20:41    Post subject:  

Terry H wrote:
New install on laptop with Intel i3 -5005U and Intel 7265D wifi card using fdrv for wifi card firmware. As with desktop PC all is working very well.

Thanks Terry.

mavrothal wrote:
If merge2out is run from the cloned woof-CE git will have the current branch, commit hash and date.

The build is now adjusted. Thanks.

James C wrote:
Quick manual frugal install. Sound and display correct on initial boot,had to use SNS for wired internet. Installed 4 or 5 things,all good.

Thanks James. Now that your summer vacation is over, we hope to see you more often. Smile

peebee wrote:
Send me a PM if you think we should try and get the dpup-stretch repo uploaded to ibiblio....

The dpup-stretch packages are still in evolution. Maybe a bit later... Thanks!

peebee wrote:
[bit later] another oddity is that some packages (abiword and gnumeric for example) do not appear in the list of built-in packages.... /root/.packages/woof-installed-packages

Now corrected.

Billtoo wrote:
Pretty sure radky will update the kernel for the next beta.

Will do!

dejan555 wrote:
Ooo, a new Dpup!

Looking forward to your report dejan555.

PS - Your vintage dpup is still popular today. Any suggestions you may have for this release are certainly welcome.

dancytron wrote;
Just installed this for a quick look.

Thanks dancytron. A quick look is fine with me.

Sailor Enceladus wrote:
Think I managed to fix it (JWM freeze) by restoring "active" behavior to the way it was in 1082. Now to try this in latest jwm.

Sailor, this is great! If successful, maybe the patch could be submitted (or suggested) to Joe at JWM headquarters.

rerwin wrote:

The initial-connect problem is the result of the /usr/local/bin/defaultconnect script being preset to 'sns'

Thanks rerwin, I'll set /usr/local/bin/defaultconnect to connectwizard in the next release.

However, I see no way to get to the connectwizard.

To lessen the application load in the menu, several apps are now available in PupControl or JWMdesk.

From the desktop, you can access the connectwizard as follows:

1 - PupControl -> Network tab -> Network Wizard
2 - JWMdesk -> Puppy Setup -> Internet

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 48 [712 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 46, 47, 48 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1038s ][ Queries: 13 (0.0174s) ][ GZIP on ]