Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 14 Dec 2017, 13:36
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Announcements
woof-CE needs you
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 80 of 81 [1213 Posts]   Goto page: Previous 1, 2, 3, ..., 78, 79, 80, 81 Next
Author Message
radky

Joined: 02 May 2010
Posts: 760

PostPosted: Sat 18 Nov 2017, 13:12    Post subject:  

A new iteration of Dpup Stretch is now available for testing.

http://murga-linux.com/puppy/viewtopic.php?t=112125

Thanks

_________________
PupMates
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 231
Location: rabat

PostPosted: Sat 18 Nov 2017, 13:37    Post subject: Specific Topic created by Radky  

"Why not a topic about Dpup Stretch ? Information is lost here, title 'Woof-CE needs you'
Is Dpup-Stretch only For training or for Public release ? Who is the Project leader ? "
Specific Topic now created by Radky I suppose That i can replace tttuxxx , sailor enceladus versions by radky's one . They were working nice, Devs working together under leadership of one was a clever idea.
'For testing" By who ?
All feed backs give 'Green light' Cool
Questions to be transfered to Dpup Stretch Topic .

Woof-CE needs me ? Really ? Surprising.
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4745
Location: Republic of Novo Zelande

PostPosted: Sat 18 Nov 2017, 14:31    Post subject: Re: Why not a topic about Dpup Stretch ?
Subject description: Is Dpup-Stretch only For training ?
 

belham2 wrote:
P.S. Volume icon has been always working great on my Luddite machines here.
Did you know that the Luddites were actually great adopters of technical innovation - despite the fact that the term is generally used to suggest that a person does not like new technology.

In fact the Luddites were only fighting against technology that made people redundant and impoverished.

"New" is not "better" unless it advances human enjoyment of life and freedom.

I like being a Luddite.
Cool
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 429
Location: Connecticut, United States

PostPosted: Sat 18 Nov 2017, 16:23    Post subject:  

I am having problems today building with woof-ce testing. I posted on the Users forum section but it would be better here:
http://www.murga-linux.com/puppy/viewtopic.php?t=112126

I get this error during the running of #./3builddistro-Z

Code:
* Extracting initrd_progs-20170322-static.tar.xz...
Arch: x86_64

* Using default locale
* Using default keymap


*** INITRD: initrd.gz [x86_64]
*** /DISTRO_SPECS: xenialpup64 7.0.8.4 x86_64

chroot: can't execute 'echo': No such file or directory
ERROR: could not 'chroot' into sandbox3/rootfs-complete
This means that something is incomplete, perhaps a library
needed by bash. Check it out. Have to exit script now.


during the running of 3builddistro-Z it exits early no ISO is made.
I am attempting to build Xenial 64bit with the kernel option 31 using woof-CE-testing on a Tahr 6.0.6 64bit.
any help will be totally appreciated!
Back to top
View user's profile Send private message Visit poster's website 
belham2

Joined: 15 Aug 2016
Posts: 1361

PostPosted: Sat 18 Nov 2017, 17:18    Post subject:  

rockedge wrote:
I am having problems today building with woof-ce testing. I posted on the Users forum section but it would be better here:
http://www.murga-linux.com/puppy/viewtopic.php?t=112126

I get this error during the running of #./3builddistro-Z

Code:
* Extracting initrd_progs-20170322-static.tar.xz...
Arch: x86_64

* Using default locale
* Using default keymap


*** INITRD: initrd.gz [x86_64]
*** /DISTRO_SPECS: xenialpup64 7.0.8.4 x86_64

chroot: can't execute 'echo': No such file or directory
ERROR: could not 'chroot' into sandbox3/rootfs-complete
This means that something is incomplete, perhaps a library
needed by bash. Check it out. Have to exit script now.


during the running of 3builddistro-Z it exits early no ISO is made.
I am attempting to build Xenial 64bit with the kernel option 31 using woof-CE-testing on a Tahr 6.0.6 64bit.
any help will be totally appreciated!


Hi Rockedge,

In the woof-out*/packages-xenial64/busybox/bin folder, there should be a shortcut called "echo", which gets copied into rootfs-complete. Does it exist? If not, what is the partition you're working from formatted as?? I remember SailorE saying awhile back it's gotta be something (building in woof seems to prefer Ext2 or 4) that can create Linux shortcuts. If its not, then that "can't execute ECHO..." error will pop up.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 429
Location: Connecticut, United States

PostPosted: Sat 18 Nov 2017, 17:21    Post subject:  

Hello! thanks for the quick info! I have the partition formatted as ext4 and woof-out folder is in /mnt/home.
I just managed to get an 32bit xenialpup to build on the same machine successfully.

I will try to build the 64bit version with kernel selection 31 again this time in /root/ftpd
I will report the results....

Last edited by rockedge on Sat 18 Nov 2017, 18:48; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
belham2

Joined: 15 Aug 2016
Posts: 1361

PostPosted: Sat 18 Nov 2017, 17:24    Post subject:  

rockedge wrote:
Hello! thanks for the quick info! I have the partition formatted as ext4


So the build is being done in an Ext 4 partition? Dang, that (not having Ext 2 or 4) is usually what causes that darn echo error to pop up.

Let me look at some of my recent build partitions I've still got and see if I can spot what might be going on.


[Edit] The tahr you're using, frugal install, full install, or...????
Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1361

PostPosted: Sat 18 Nov 2017, 17:32    Post subject:  

Rockedge,

Is this (below) what you are seeing (this was being built in my Tahr64 6.0.6 too)?
chroot-cant.png
 Description   
 Filesize   188.78 KB
 Viewed   439 Time(s)

chroot-cant.png

Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1361

PostPosted: Sat 18 Nov 2017, 17:37    Post subject:  

Ok, found it (early this year) where I ran into this problem:

Start reading here, see if anything helps:

http://www.murga-linux.com/puppy/viewtopic.php?p=955534#955534
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 429
Location: Connecticut, United States

PostPosted: Sat 18 Nov 2017, 18:49    Post subject:  

that is exactly what I see!
Back to top
View user's profile Send private message Visit poster's website 
rockedge


Joined: 11 Apr 2012
Posts: 429
Location: Connecticut, United States

PostPosted: Sat 18 Nov 2017, 20:49    Post subject:  

I was able to build a Xenialpup64 using the same woof-CE on a different machine using a 32bit xenial. All of the host OS's are frugally installed on a ext4 drive.
Back to top
View user's profile Send private message Visit poster's website 
rockedge


Joined: 11 Apr 2012
Posts: 429
Location: Connecticut, United States

PostPosted: Sat 18 Nov 2017, 23:45    Post subject:  

on a machine that successfully built xenialpup64 with the kernel 4.9.15 failed when building xenialpup64 with the kernel 4.9.58 is showing the following error when running #./3builddistro-Z

Code:
huge-4.9.58-xenialpup64.tar.bz2         : 5ef4ab0c3c097b3301cba549a279d410
huge-4.9.58-xenialpup64.tar.bz2.md5.txt : #
5f6c5e1addcc105928c25c0d20de07ce
#
fe94dce1a8be442dbf85774282c0fcbda5931e74
#
4415f572a8f17c14229e5829dab76902e35bb4b2334dc7f42d64418bd71e6fcc
checksum failed


interesting to learn why I can not build some of the options and how much does the machine matter?
Back to top
View user's profile Send private message Visit poster's website 
rockedge


Joined: 11 Apr 2012
Posts: 429
Location: Connecticut, United States

PostPosted: Sun 19 Nov 2017, 13:02    Post subject:  

built 4 xenialpup64's...... 2 on a Dell inspirion 32bit running xenialpup and 2 on a Dell Optiplex 990 64 bit Tahr 6.0.6.
on the second one I ran woof-ce on a 16gig USB stick for 2 versions with different kernels.

It does seem to be an problem around the hard drive being used and although the HDD is ext4 it will not finish the scripts and make the iso when I have the woof-out on this HDD.

Perhaps it is some small configuration difference....important is I have 2 nice new Xenialpup64's with kernel 4.9.15 and 4.9.58!
Back to top
View user's profile Send private message Visit poster's website 
jrb


Joined: 11 Dec 2007
Posts: 1085
Location: Smithers, BC, Canada

PostPosted: Mon 20 Nov 2017, 08:56    Post subject: WOOFCE_2createpackages_Problem
Subject description: Debs being converted to empty packages
 

Has anyone else had a problem with WOOFCE's /2createpackages messing up? I just happen to notice in /root/.packages/builtin_files that some of the packages listed were 0 bites and showed no contents. So I WOOFed up a plain vanilla stretch-7.0.0a2 with the latest WOOFCE and checked the /packages-stretch, sure enough 20 packages were empty. Shocked The .debs are not empty and I can build the packages manually.

I'm working in an EXT4 partition with both DPUP stretch and XenialPup. Both situations give the same results

See attached pic for details.

Edit: Correction, not all of these packages are empty. Some of them have correct contents but show as 0 size in /root/.packages/builtin_files but others are indeed empty
WOOFCE_2createpackages_Problem.jpg
 Description   
 Filesize   93.93 KB
 Viewed   258 Time(s)

WOOFCE_2createpackages_Problem.jpg

Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1326

PostPosted: Tue 21 Nov 2017, 11:35    Post subject:  

@jrb: I have a few 0 byte ones too, I think in my case it's because they're only used in the devx.
Screenshot.png
 Description   
 Filesize   95 KB
 Viewed   146 Time(s)

Screenshot.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 80 of 81 [1213 Posts]   Goto page: Previous 1, 2, 3, ..., 78, 79, 80, 81 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Announcements
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1418s ][ Queries: 15 (0.0496s) ][ GZIP on ]