Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 14 Dec 2017, 15:09
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
JL64-704 Slackware-14.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 18 of 18 [261 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18
Author Message
Dry Falls

Joined: 16 Dec 2014
Posts: 516
Location: Upper Columbia

PostPosted: Mon 13 Nov 2017, 12:27    Post subject:  

step wrote:
Thanks Dry Falls. What is your convention for listing downloads for each update? The download folder contains many more files than the ones you listed. Which ones should I download to have a complete system? Which ones to skip? Of course, older versions of isos and sfs files can be skipped. But what about the other sfs files? What about those that start with a Number"_"?

Hi Step. Tough question. "Convention" may be a bit strong a word because of the madness in my method! Actually, I haven't gotten around to a decent help file.

SFS-update (Tazoc's 'lhp-update') is a zenity program with a brief description of the sfs files available. It seems limited to around 60 entries. Browsing gdrive isn't really very friendly, but it's what I'm stuck with.

Basically, numbered sfs files load first, then caps alphanumerically. I've continued Tazoc's use of 5_DISTROVERSION.sfs for desktop enhancements -- like an adrive. Not critical but contains gimp, evince, xsane, extra fonts and themes plus some dependencies.

2_perpy contains perl and python for running without devx. (gcc, boost are also available as sfs files). Because it's slackware, some bit of perl, python and qt are required. For example, wpa-gui needs qt4. So these are included on the iso.

I wanted Lighthouse to be even more modular (makes it a lot easier to upgrade) but also, to trim down the base file to a more manageable size (for handling as well as memory usage) and remove old stuff which gets in the way. Proper package files (in /var/log) are essential when using gslapt manager, which is the preferred package manager in JL64.

Here's what I run for everything:

1 5_JL64-704.sfs
2 Backgrounds-JL64.sfs -eyecandy
3 Devx-JL64_704.sfs
4 Xfce-4.12.0-1-x86_64-16.sfs -powermanagement, parole, midori
5 compiz-0.8.12.3-x86_64-JL64-4.sfs -eyecandy compositor
6 ffmpeg-3.0.9-x86_64-lt.sfs -required by pmusic, among others
7 gstreamer-14.2.sfs -all gst files needed by xfce
8 icecat-52.3.0.en-US.linux-x86_64.sfs -big browser
9 qtlite-4.8.7-JL64-7.sfs (in /opt) [full qt4/5 is required by kde/plasma]
10 xscreensaver-5.37-x86_64-JL64.sfs -eyecandy

OTHER
samba for networking (prone to upgrading)
NLS_base contains locales and internationalization tools so is necessary outside us
DOC has full documentationn, info, etc.
man_tools contain the man pages and manipulation tools
InstScripts will be moved to devx (/var/log/scripts) handy for removepkg.
kernel sources for building modules, etc.

zW32 are the 32bit libraries (taken from Peebee's lxpupsc) now separate from Wine. This will autoload if present.

Minimally, while it will run as a standalone, I'd recommend 2_perpy, gstreamer, qtlite and your choice of browser (although surf works pretty well). Xfce pretty much completes it.

ps. If you run an all-intel box like me, I found this kernel boot parameter seems to prevent freezing/loockup coming out of sleep:
Code:
intel_idle.max_cstate=1


df

edit link for cstate: https://gist.github.com/wmealing/2dd2b543c4d3cff6cab7#file-c-states-md

Last edited by Dry Falls on Mon 11 Dec 2017, 20:02; edited 1 time in total
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 516
Location: Upper Columbia

PostPosted: Mon 11 Dec 2017, 19:54    Post subject: JL64-704v5  

updated iso. see opening post for link & mdsum; k4.14.2

Changes to:
    DOC_JL64-704.sfs|df189838227fa1ba3a2f75d303d5b1dc2c6615ae|74|
    Devx-JL64_704.sfs|7e432a2e1cbc0d2de4c569625aedf24b51baf26b|262|
    NLS_base-JL64_704.sfs|c3b359e4deaaa0571a908216368417e95d6f2c99|106|
    Xfce-4.12.0-1-x86_64-17.sfs|98e475b7b35e47a71cdcfed4eb4893a3295c56ff|38|
    chromium-62.0.3202.75-x86_64-1alien.sfs|8ea010c518cccc326de8be130ed70b24de1d58b1|61|
    ffmpeg-3.0.10-x86_64-1.sfs|5cc704550137ef5d52cb6d252a0ef0ce301c6140|10|
    gstreamer-14.2.sfs|97b5f26259cbd0dc3c429fadca6a34af20d8605c|17|
    gtk-doc-reference_704.sfs|efbd20e25be6d2bb964f87030c819377efe0069e|17|
    kernel-firmware-20171109git-noarch-1.sfs|5b7fd5d45ec4e93cd66fa7eb771fffc75a57881e|75|
    kernel_sources-4.14.2-JLx86_64.sfs|3e1fc868b03f2ead4651a9b4c5efc377d5afddbc|117|
    kodi-16.1-x86_64-1gv.sfs|0ea5eedc4330b121919aa5526f3548c9e3cb1cdc|31|
    man_tools-14.2-4.sfs|573e67a1ab4df0abd9cfd9220d9eb5d3aa3a33c6|32|
    mediacenter-10.sfs|d9440c240a5d12d5a27d6025e5aaed2e52183d69|74|
    mozilla-firefox-57.0-x86_64-1.sfs|ebc6bc647346c72ce216c969323c4f167f5b2112|45|
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 4808
Location: Ontario

PostPosted: Mon 11 Dec 2017, 20:33    Post subject:  

I got 505 error when I clicked for md5sum txt
http://just-lighthouse.000webhostapp.com/JL64-704v5.iso.md5sum.txt
______________________________
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 516
Location: Upper Columbia

PostPosted: Mon 11 Dec 2017, 20:50    Post subject:  

Quote:
I got 505 error when I clicked for md5sum txt

Thanks for pointing that out, Don. Just fixed it (forgot to upload it!)

df
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 4808
Location: Ontario

PostPosted: Yesterday, at 21:35    Post subject:  

I tried newest 704 v5 last night and I like most of it.
It can run blender 2.79 and mypaint 1.3 appimage nicely
with my Intel 945G chipset which is something the newest fatdog64 720
can't do. SAMBA server worked as well.

____________________________________

Here's some suggestions...

I suggest changing the defaultaudioplayer and defaultmediaplayer to parole
so there is more control on playback.

Update to gimp 2.8.22 and mtpaint 3.49.13

To help in the setting up of a samba server there should be ReadMe file in
/root/spot/Downloads

To stop the windows of apps suddenly popping up I suggest a change for the top dock preferences. This solved the problem for me.

_________________________________________
screenshot-lighthouse.png
 Description   Change suggested
 Filesize   34.04 KB
 Viewed   27 Time(s)

screenshot-lighthouse.png

Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 516
Location: Upper Columbia

PostPosted: Yesterday, at 23:04    Post subject:  

Hi Don. Gimp is from the slackware64 14.2 most recent (gcc-5-30). The upgrade is in "current" and goes with gcc-7.20. It's in JL64-706.

Mtpaint is from Salix repo, and up to date. I've pretty much quit compiling my own and replaced with "official versions. What's improved iv v.3.49?

I picked ffplay as default for running without xfce. Personally, I use fredx's mpv for media player and audacious for default music. Pmusic for radio stations.

I'll check into the dock preferences. You can turn off notifications in xfce settings manager, Don't know what happened to the Readme file. I'll track it down and put it back! In setup (lighthouse looknfeel) / or in the panel: Network Setup Manager, quite a bit of help pops up for setting up samba.


Meanwhile here is a patch:
v5-v6.tar.gz, actually two deltas - one for iso and one for Devx. Openssl upgrade and some trimming of the base file thanks to 666Phill (link)

df
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 18 of 18 [261 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1832s ][ Queries: 15 (0.0112s) ][ GZIP on ]