Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Nov 2017, 05:32
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Firefox : impression ferme le navigateur
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
augras

Joined: 11 Nov 2013
Posts: 1456
Location: france

PostPosted: Sat 07 Oct 2017, 04:28    Post subject:  Firefox : impression ferme le navigateur  

Bonjour,
Est-ce que vous avez remarqué que sur les dernières versions de firefox, au moins à partir de la 52 (je suis passé de la 45 à la 52 sans passé par les intermédiaires), version ESR ou classique, le fait de vouloir imprimer ferme le navigateur, sans réaliser l'impression.
Le simple fait de faire fichier puis imprimer le ferme. Parfois on peut aller un peu plus loin mais au moment de valider l'impression le navigateur se ferme aussi.
On ne peut plus imprimer à partir de firefox.
C'est un problème qui c'est déjà produit, y compris sous mac et windows : j'ai testé différentes solutions proposées, sans succès. Dans le cas présent seul linux semble concerné : peut-être seulement puppy mais je n'ai pas d'autres linux.
Peut-être même que tahrpup6.0.5 : j'ai constaté le problème sur tahrpup6.0.5 directement, et il se produit également sur triton6.0 basé sur cette tahrpup.
Vous pouvez vérifier sur votre puppie ?
Merci,
Philippe
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3069
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 07 Oct 2017, 06:33    Post subject:  

Bonjour,
Je viens de faire un test avec Firefox 52.4.0 ESR sur ToOpPy 2.2 (Puppy Precise 5.7.1) et l’impression se passe correctement.
Il faudrait lancer Firefox en console et voir le message d'erreur s'il y en a un!

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
augras

Joined: 11 Nov 2013
Posts: 1456
Location: france

PostPosted: Sat 07 Oct 2017, 07:38    Post subject:  

Merci argolance,
Problème uniquement sur tarhpup et sa descendance alors ?
Dans la console la ligne qui pourrait expliquer le problème est je pense celle-ci
Code:
/usr/lib/firefox/firefox: symbol lookup error: /usr/lib/i386-linux-gnu/gtk-3.0/3.0.0/printbackends/libprintbackend-cups.so: undefined symbol: ippSetOperation

En cherchant avec cette erreur, il n'y a pas grand chose en fait, je suis tombé sur le fil de tarhpup et quelqu'un qui avait le même soucis mais avec Glabels !
La solution serait une recompilation de Glabels par rcrsn51 mais personne n'a jamais fait de retour.
Une amie que j'ai équipée avec tarhpup vient de me dire que thunderbird plantait quand elle voulait imprimer !... même erreur.
Il semblerait donc que le coupable soit cups. Pourquoi ?
En fait tous ces programme utilisent gtk3 : de la à en conclure qu'il faille une version minimale de cups pour qu'il fonctionne avec les logiciels gtk3.... ça y ressemble.
est-ce que l'on a une version plus récente pour vérifier ? Je vais voir dans le ppm.
Philippe
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1456
Location: france

PostPosted: Sat 07 Oct 2017, 07:51    Post subject:  

La version de cups installée est la 1.5.3 qui officiellement serait compatible avec les applications gtk3.
Philippe
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1456
Location: france

PostPosted: Sat 07 Oct 2017, 08:00    Post subject:  

J'ai posté sur le fil anglais des bugs http://murga-linux.com/puppy/viewtopic.php?p=970173#970173 mais il n'y a pas eu de posts sur ce fil depuis 1 an !
Philippe
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1456
Location: france

PostPosted: Mon 16 Oct 2017, 13:52    Post subject:  

Bonsoir,
Plus personne n'a d'imprimante ?
Sur une proposition de watchdog j'ai testé avec tahrpup6.0.6 et ça fonctionne : cups 1.7.5 au lieu du 1.5.33. Je ne sais pas si effectivement la résolution du problème tient à ce changement de version.
Philippe
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0420s ][ Queries: 14 (0.0114s) ][ GZIP on ]