Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 14 Nov 2018, 15:50
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to update SlimJet? Tahrpup 6.0.5
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
SolusUmbra

Joined: 11 May 2017
Posts: 39

PostPosted: Mon 04 Sep 2017, 10:02    Post subject:  How to update SlimJet? Tahrpup 6.0.5  

It says I can update SlimJet but I haven't a clue how to do it.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4364
Location: King's Lynn, UK.

PostPosted: Mon 04 Sep 2017, 12:31    Post subject:  

Hallo, SolusUmbra.

Yes, the browser will tell you there's a new version available.....but all it does is send you to FlashPeak's website, where you can download the new version, which you then have to install yourself. It's not like FireFox, where the updater does all the work for you.....or, indeed, the Windows version of Chrome, where the same thing happens.

However, it's quite simple in Puppy. You unload the old SlimJet SFS.....and you load the new SlimJet SFS. Easy-peasy. Don't, whatever you do, download and install the Debian/Ubuntu .deb packages; if you do, you'll bugger up permissions throughout Puppy, and it takes forever to get them right again.....because Debian/Ubuntu are designed as multi-user systems, where everybody is just a user. Unlike Pup, which was designed as a single-user system.....where that user is, of necessity, in full control of the system. This is why Pup 'runs as root'.

------------------------------------------------------------------

Puppy packages usually come in two different types. There's the traditional .pet packages, which load with a click.....and are uninstalled through the PPM (Puppy Package Manager.)

Or, there's the SFS (Squash File System) packages, which tend to get used for larger programs. When you install a .pet package, it occupies 'Puppy-space', in your save-file/folder. SFS packages tend to get put in /mnt/home (the root of your Pup's partition), then loaded/unloaded with a single-click, using shinobar's SFS 'load on the fly' utility. This way, they only occupy partition-space.....but never 'Puppy-space'.

I hope that makes sense!

Large applications, like browsers, almost always tend to get made up as SFS packages, for two reasons. The first is the one I've just given. The second is because browsers are frequently up-dated.....and the SFS system allows you to swap 'em over very easily, since it doesn't actually alter your browser settings.

OscarTalks' regularly updates his series of 32-bit SlimJet packages.....and I do the same for the 64-bit Puppies. You can find Oscar's SlimJet packages here:-

http://www.murga-linux.com/puppy/viewtopic.php?t=97172

.....and mine here:-

http://www.murga-linux.com/puppy/viewtopic.php?t=106957

If you're not quite certain exactly how to use 'em, we can soon guide you through the process. It's very easy.

Hope that helps.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
SolusUmbra

Joined: 11 May 2017
Posts: 39

PostPosted: Mon 04 Sep 2017, 12:55    Post subject:  

Ok, so I'm going to take a stab in the dark and say that my browser at the moment is a .pet because I found it listed in the Puppy Package Manager.
I see on the site that there is a .pet and a sfs download.
https://yadi.sk/d/fd8rBM0WoF9sB

Not sure which one I need to download.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11256
Location: Charleston S.C. USA

PostPosted: Mon 04 Sep 2017, 13:19    Post subject:  

Use the pet download.

The Puppy Package Manager(PPM). installed it.
A new pet install should install over the old one.

If you want to make sure the old Slimjet was a install and not a sfs download.
Look in the PPM uninstall.
If it is listed. It is an installed program.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked

Last edited by bigpup on Mon 04 Sep 2017, 13:36; edited 1 time in total
Back to top
View user's profile Send private message 
SolusUmbra

Joined: 11 May 2017
Posts: 39

PostPosted: Mon 04 Sep 2017, 13:27    Post subject:  

So I don't need to uninstall the old one first?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11256
Location: Charleston S.C. USA

PostPosted: Mon 04 Sep 2017, 13:47    Post subject:  

Usually yes.

The new install will just replace the old install.
However, really depends on what it is and exactly who coded it and for what version of Linux.

The PPM(puppy package manager) can install stuff coded for other Linux operating systems, but usually work OK on Puppy.
Tahrpup's PPM offers some stuff that was coded for Ubuntu Linux.
So, a install over one of those programs could have issues.

The only 100% way to be sure.
Uninstall the old version by using the PPM uninstall.
Install the new version.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
SolusUmbra

Joined: 11 May 2017
Posts: 39

PostPosted: Mon 04 Sep 2017, 14:09    Post subject:  

Thank you, both
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1823
Location: London, England

PostPosted: Mon 04 Sep 2017, 18:53    Post subject:  

I have just uploaded SlimJet 15.1.2.0 (32bit)
This version has a fix for the YouTube downloader button so take note if this feature is important to you.
This works OK in TahrPup and Slacko 6.3.2 (and anything later) but be aware that it won't run in earlier Puppies such as Precise or Slacko 5.7
https://yadi.sk/d/fd8rBM0WoF9sB?force_show=1

_________________
Oscar in England

Back to top
View user's profile Send private message 
SolusUmbra

Joined: 11 May 2017
Posts: 39

PostPosted: Mon 04 Sep 2017, 19:05    Post subject:  

Thank you I was wondering what happened to that button.
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 271
Location: Norway

PostPosted: Tue 05 Sep 2017, 03:06    Post subject: slmjet 15.1.2.0 (32bit)
Subject description: not saving password - solved-
 

Thank you OscarTalks - I just installed your slimjet 15.1.2.0 (32bit).pet (in tahr6.0.6) and it works flawlessly. Superthanx Smile
Just a little tip: I couldn't get slimjet to save passwords - until I found the setting:

Use quick form filler instead of default password manager

I unticked it and slimjet now asks to save passwords like chrome does Wink

---edit ---
I'm over the moon about this version of slimjet - everything just works (utube, embedded videos, javascript-mp3-stuff) no nagging about running as root, cast (to chromecast) works fine. My chrome-theme and also the extension "rescroller" (which is a must for me to enlarge scrollbar) works. This is now my favorite browser ! (on 32bit) yippikayey Smile
Back to top
View user's profile Send private message Visit poster's website 
thatlldopig

Joined: 14 Mar 2006
Posts: 4

PostPosted: Thu 24 May 2018, 10:02    Post subject:  

Oh, God I just installed the ubuntu/deb version of Slimjet. I can confirm this is a Very Bad Thing. My xenial pup is only a few weeks old, so I think I will just write everything down and re-install. Slimjet never came up and all the other browsers (Firefox, Waterfox, Palemoon) died, except for Chrome. Live and learn. I really should browse the boards more. Thanks for the heads up anyway. Better late than never.
Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 229

PostPosted: Thu 24 May 2018, 14:38    Post subject:  

I have made a Wiki entry to make it easier to track .pets for this browser.

It is advisable where possible to use our wiki first to see if there is info on a particular program though in this particular case there was nothing about Slimjet.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0602s ][ Queries: 12 (0.0092s) ][ GZIP on ]