Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 24 Sep 2017, 11:34
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
exfat [RESOLU]
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Sun 01 Jan 2017, 12:22    Post subject:  

La commande que tu indiques ne fonctionne pas : il faut utiliser mount.exfat

Le script suivant fonctionne :
Code:
#!/bin/bash

mount.exfat /dev/sdb1 /mnt/sdb1 &
rox /mnt/sdb1 &

Et pour démonter :
Code:
#!/bin/bash
umount /mnt/sdb1

La contrainte étant que la clé soit toujours identifiée comme sdb1 !
Par contre le démontage laisse une fenêtre rox vide ouverte : on peut la fermer avec quelle commande ?
Et un cycle montage/démontage fonctionne une fois : ensuite la fenêtre s'ouvre vide après le script de montage.
Il faut actualiser rox pour qu'il ait bien pris en compte le démontage avant de relancer un montage : tu sais comment le faire s'actualiser ?
Merci,
Philippe

EDIT :
En fait il faut actualiser uniquement la fenêtre rox du point de montage et pas actualiser rox avant de relancer le script (ça fonctionne comme ça aussi mais c'est peut-être plus simple d'actualiser la fenêtre qui s'ouvre vide qui une fois actualisée affiche le contenu de la clé ? )

Last edited by augras on Sun 01 Jan 2017, 12:45; edited 2 times in total
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1660
Location: France

PostPosted: Sun 01 Jan 2017, 12:42    Post subject:  

Bon, la commande de démontage est commune...
As-tu l'icône du disque qui indique le montage lors de ta commande de montage Question
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Sun 01 Jan 2017, 12:46    Post subject:  

Non, l'icône n'apparait jamais.
J'ai fait un edit d emon message précédent avec une précision.
Philippe
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1660
Location: France

PostPosted: Sun 01 Jan 2017, 13:05    Post subject:  

Dommage ça aurait été assez simple de modifier drive_all si Pmount affichait au moins l'icône du disque...

En fait /bin/mount sous Puppy est un script qui utilise busybox mount ou bien mount-FULL cette dernière risque de fonctionner :
mount-FULL -t exfat /dev/sdc1 /mnt/sdc1


Faudrait voir sur une des dernière version de Barry K si l'exfat et géré Question
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Sun 01 Jan 2017, 13:37    Post subject:  

Je confirme que la commande mount-FULL telle que tu l'as écrite fonctionne.
C'est quoi les dernières versions de Barry Kauler : Quirky ?
Philippe

EDIT :
la commande fonctionne même directement sans option
mount-FULL /dev/sdb1 /mnt/sdb1
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Mon 02 Jan 2017, 05:33    Post subject:  

Bonjour,
C'est en cours de résolution définitive par Mavrothal : https://github.com/puppylinux-woof-CE/woof-CE/commit/18bfb65c789d4f679fe744ead345c2c5d540cc8b
J'ai remplacé les 4 fichiers de tahrpup par les nouveaux et l'icône apparaît automatiquement sur le bureau... sauf qu'au clic sur l'icône c'est pMount qui s'ouvre au lieu de rox avec le contenu de la clé. La clé apparaît bien dans pMount mais au clic pour la monter message d'erreur "unable to mount sdb1". Un montage à la main en console avec mount-full ou mount.exfat monte bien la clé et pMount peut alors la démonter.
Ça ne doit vraiment pas être grand chose à corriger.
Philippe
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1660
Location: France

PostPosted: Tue 03 Jan 2017, 08:00    Post subject:  

Bonjour Philippe,

Ce qui me chagrine c'est la modification du code de filemnt car le diff s'applique sur une version plus récente de woof ce 7.0 testing Exclamation

Je n'ai pas la même version originale de filemnt sur la 6.3.2 et il se peut qu'il existe d'autres modifications du code par ailleurs ...


Cordilement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1660
Location: France

PostPosted: Tue 03 Jan 2017, 11:28    Post subject:  

Je viens de récupérer les fichiers originaux dans Slacko-6.9.6.4 (pre 7.0) + drive_all ...

Peux-tu tester sous Windows de copier sur ta clé exFAT un répertoire et des fichiers avec des noms accentués puis de vérifier sous Puppy.


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Wed 04 Jan 2017, 15:24    Post subject:  

Bonsoir,
Tout fonctionne normalement !
J'ai testé sur raring, tahrpup605 nopae, TritonPrecise5.7.3, ASRIEdu 310 nopae, Slacko32-5.9.3, SlaXen6.0. Pas réussi à faire fonctionner sous ToOpPyprecise2.0 ce qui est assez incompréhensible.
Sous puppy les caractères accentués sont bien gérés. Pas de windows à la maison pour tester si le passage de windows à puppy fonctionne bien : je fais ça demain au boulot.
J'ai préparé un .pet qui rassemble tout le nécessaire y compris les deux paquets exfat nécessaires compilés dernièrement sur le fil de tahrpup : c'est avec lui que j'ai testé.
Je pense le poster sur le forum : j'attends un ok. Si tu veux le tester je peux te l'envoyer.
Il comprend les fichiers suivants modifiés pour l'occasion :
/sbin/probepart
/usr/local/pup_event/frontend_startup
/usr/sbin/filemnt
/usr/sbin/pmount
/usr/local/bin/drive_all
/usr/local/pup_event/frontend_change
/usr/local/pup_event/frontend_funcs
/bin/mount
Il les faut vraiment tous.
Retour demain pour windows.
Philippe
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1660
Location: France

PostPosted: Wed 04 Jan 2017, 15:47    Post subject:  

Bonsoir Philippe,

Ici j'ai compilé sous slaxen/slacko-6.3.2 les sources de exfat-utils-1.2.5 et de fuse-exfat-1.2.5
Je vais pouvoir formater une clé en exfat pour vérifier les modifications des derniers scripts de woof ce, etc. Wink

Édité :
J"ai encore un petit problème à résoudre mais grosso modo ça fonctionne Wink


Cordialement,
Médor.
Capture_2017-01-04.jpg
 Description   
 Filesize   72.36 KB
 Viewed   171 Time(s)

Capture_2017-01-04.jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Thu 05 Jan 2017, 04:05    Post subject:  

Bonjour,
Je viens de tester le passage de fichiers enregistrés sous windows vers raring et vice versa : pas de soucis de caractères accentués à aucun moment.
Bonne journée,
Philippe
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1425
Location: france

PostPosted: Sat 07 Jan 2017, 09:21    Post subject:  

Bonjour,
Les modifications sont prévues pour le prochain woofce mais pour toutes les puppies anciennes il faut faire à la main.
J'ai regroupé les fichiers modifiés dans un .pet en y ajoutant la dernière version exfat-1.2.4-i686-20160626-trusty.pet compilée par jlst sur le fil anglophone de tahrpup6.0.5CE. Son paquet a été compilé pour trusty mais les tests effectués montre que ça fonctionne pour d'autres : à vous de tester avant d'adopter.
Et effectivement faite un test en ram avant car les fichiers antérieurs ne sont pas sauvegardés mais remplacés : pas de retour en arrière possible en désinstallant ce .pet.
Je note ce fil résolu.
Merci aux participants et particulièrement à mavrothal et jlst.
Philippe
exfat_old_puppies_trusty.pet
Description 
pet

 Download 
Filename  exfat_old_puppies_trusty.pet 
Filesize  166.04 KB 
Downloaded  38 Time(s) 
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12537
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 13 Jun 2017, 04:10    Post subject: cartes SD, çà pourra me servir..  

merci Augras. Quand je vas me lancer sur cartes SD, çà pourra me servir..
Ton topic est plus un tuto qu'une panne à réparer. Faut pas qu'il s'enlise. Argolance l'avait pas vu.
J'ai plusieurs de ces cartes qui chôment. Je vas leur mettre au moins une puppy dessus, au milieu de centaines de photos.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 4 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0487s ][ Queries: 13 (0.0063s) ][ GZIP on ]