Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Apr 2017, 09:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
JL64-702 Slackware-14.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 15 [218 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15
Author Message
icake

Joined: 26 Jul 2012
Posts: 392

PostPosted: Thu 13 Apr 2017, 07:22    Post subject: jl64-702 language pets
Subject description: Chinese language pets for jl64-702
 

I have created 6 half-Chinese language pets and 2 Chinese language pets for jl64-702 and they are now available for public sharing. For details please see here: http://www.murga-linux.com/puppy/viewtopic.php?t=82937&start=405
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 1929
Location: In The Way

PostPosted: Fri 14 Apr 2017, 10:52    Post subject:  

Hi DryFalls

Have you added save directory loading to the initrd by chance? Maybe consider adding it. Save me some work lol.

stemsee
Back to top
View user's profile Send private message MSN Messenger 
eztuxer


Joined: 06 Nov 2008
Posts: 511
Location: Belgium

PostPosted: Fri 14 Apr 2017, 19:28    Post subject:  

Hi dryfalls !

Same problem with alt gr key keyboard over here with azerty be latin 1 belgian keyboard.
I can't remember how to access boot parameter to try to input "pkeys=be", it's been too long ago since I used it last.
Also last versions do not detect my pci and usb wifi hardware.
Last I tried I was able to use a save file on USB stick.
Booting works fine.
On Fat House latest iso booting is dead, but before last updates everything worked fine; keyboard, sound card, wifi, etc... but no save file. Sad
So what is needed is once again a blend of LH & FH Smile
The best of both worlds in one package.
I am really missing Puppy since I had to switch to 64 bit, so far nothing is working for my Lenovo POS.
Except for Linux Mint and windblow$ 10 Sad

Thank you guys for all the work, it will work sometime soon.

_________________
Don't poop it down... Pup it Up !
Back to top
View user's profile Send private message Visit poster's website 
Dry Falls

Joined: 16 Dec 2014
Posts: 471
Location: Upper Columbia

PostPosted: Mon 17 Apr 2017, 12:32    Post subject:  

hey there eztuxer.
pkeys boot parameter goes after 'linux /vmlinuz' in grub2, or after 'append' in the others (syslinux, menu 1st, etc). Also, you might want to run with 5_JL64-702-8.sfs which has extra kbd utilities, including salix tools 'keyboardsetup' you can run from console or gtk wizard from menu. Also, the enlightenment DE runs a different setup/configuration altogether at the first time you run it. Might be worth a try. Meanwhile, here is a package with extra keymaps from fatdog 710...

@Stemsee, I fiddled some with save to directory in the init script, but usually ended up breaking it. As far as I have experienced, the only stable/trouble-free save-to-folder is in fatdog. Lighthouse has always had save-to-partition, quirky style, as an option. It is very well with flash media. A step short of full install. And contrary to what some have said, you can have multiple save-files on the same partition. With two or more (real or dummy) save files, select 0 at prompt and you will boot into pupmode 6 or 7.

df
kbd-keymaps-fd1.txz.fake.gz
Description 
gz

 Download 
Filename  kbd-keymaps-fd1.txz.fake.gz 
Filesize  19.01 KB 
Downloaded  5 Time(s) 
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 471
Location: Upper Columbia

PostPosted: Tue 18 Apr 2017, 23:14    Post subject: sfs-update  

new host for JL64-update (sfs-update) package list. Click to unzip attached file and drop into /usr/sbin (replaces existing script)...
sfs-update.gz
Description 
gz

 Download 
Filename  sfs-update.gz 
Filesize  11.75 KB 
Downloaded  6 Time(s) 
Back to top
View user's profile Send private message 
eztuxer


Joined: 06 Nov 2008
Posts: 511
Location: Belgium

PostPosted: Fri 21 Apr 2017, 10:50    Post subject:  

Found again how to enter pkeys=be (F1) and keyboard work fine now.
Also kb change remains in save file.
But still no internet.
oot# lspci
00:00.0 Host bridge: Intel Corporation Device 2280 (rev 35)
00:02.0 VGA compatible controller: Intel Corporation Device 22b1 (rev 35)
00:13.0 SATA controller: Intel Corporation Device 22a3 (rev 35)
00:14.0 USB controller: Intel Corporation Device 22b5 (rev 35)
00:1a.0 Encryption controller: Intel Corporation Device 2298 (rev 35)
00:1b.0 Audio device: Intel Corporation Device 2284 (rev 35)
00:1c.0 PCI bridge: Intel Corporation Device 22c8 (rev 35)
00:1c.2 PCI bridge: Intel Corporation Device 22cc (rev 35)
00:1c.3 PCI bridge: Intel Corporation Device 22ce (rev 35)
00:1f.0 ISA bridge: Intel Corporation Device 229c (rev 35)
00:1f.3 SMBus: Intel Corporation Device 2292 (rev 35)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter

root# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 174f:1173 Syntek
Bus 001 Device 005: ID 0bda:0821 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 012: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 008: ID 0b05:1723 ASUSTek Computer, Inc. WL-167G v2 802.11g Adapter [Ralink RT2571W]
Bus 001 Device 006: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102/2.0 / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick
Bus 001 Device 004: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root#

Xenial pup works fine (except numpad).
Xenialpup64 7.0.8.4 beta
Using it to post this, but I still prefer JLH & LHFD.
I know it will work soon.

_________________
Don't poop it down... Pup it Up !
Back to top
View user's profile Send private message Visit poster's website 
Dry Falls

Joined: 16 Dec 2014
Posts: 471
Location: Upper Columbia

PostPosted: Sat 22 Apr 2017, 01:15    Post subject: wifi?  

Hi ez.

(make sure python sfs module is loaded)

from wizardwizard -> startup | services,
disable (uncheck) Frisbee and restart to see if kernel & X (dhcp & wpa) can find/load your system. you can try frisbee.sh (newer frisbee for wlan) instead. Or disable both and from the menu, select Stemsee;s wifi-connect or another method. experiment. (may want to move frisbee_tray out of ~/Startup!)

Of course there's the 'connect' icon in the Desktop folder ('Launcher") but that is some pretty old stuff.

The kernel is configured pretty heavily for intel, but you could still try the firmware sfs addon in case something's missing.

Another thing to try is the network manager sfs, which contains other networking software as well and auto-loads the networking applet.

If you can find something that works for both eth0 and wifi/wlan, I'll change the default. Unfortunately, I only have eth0 hard-wired to the satellite. No way to test this stuff from here.

Thanks (really!)
df
Back to top
View user's profile Send private message 
eztuxer


Joined: 06 Nov 2008
Posts: 511
Location: Belgium

PostPosted: Sat 22 Apr 2017, 17:32    Post subject:  

df,

Removed frisbee from startup folder, however after reboot I still get some pesky OSD pop ups claiming "Sucsess" wlan2 connected, etc... Evil or Very Mad

I think some other automatic setup is running in // as I am using the Puppy Network Manager which is working on all other puppies so far.

Also with Firefox I get this :


Quote:
trying to connect to pay wifi hotspot :
https://proximus.portal.fon.com/jcp/10216561768748022A48B52801XXXXXXXX48:02:2a:48:b5:28:1:2000201704222245eedc77666c7a0182dc5b786b31adc063ad0d7462?res=notyet_sg&nas_ip_address=172.28.185.8

I get this:

Secure Connection Failed

An error occurred during a connection to proximus.portal.fon.com. Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.


Code:
<root> ~
bash-4.3# ifconfig wlan2
wlan2     Link encap:Ethernet  HWaddr 44:1C:A8:56:77:7D 
          inet addr:62.4.225.64  Bcast:62.4.231.255  Mask:255.255.248.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1358 (1.3 KiB)  TX bytes:1832 (1.7 KiB)


DHCP does not display the usual progression bar in PNM... (stinks) jumps to wlan2 config ok, do you want to save config ? directly.

I am terrible at networking Wink

Keeping the faith ...

Thank you for all your efforts, E Z

_________________
Don't poop it down... Pup it Up !
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 15 of 15 [218 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0667s ][ Queries: 15 (0.0200s) ][ GZIP on ]