Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 23 Jun 2017, 08:25
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Adobe Flash Player Auto Updater
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 7 [96 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 2279
Location: Queensland

PostPosted: Tue 13 Dec 2016, 23:12    Post subject:  

OscarTalks wrote:
Regarding the updater, I know it still works without this step, but do you think it would be a good idea for the script to
Code:
chown root:root libflashplayer.so
at some point?


Done, implemented chown root:root, re-uploaded Auto Updater version 1.6 with this change, the 5 or so people who downloaded it, if you like re-download.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Back to top
View user's profile Send private message 
sfs

Joined: 02 Nov 2013
Posts: 38
Location: Russia

PostPosted: Wed 21 Dec 2016, 04:44    Post subject:  

For pepperflash. Change path 4 your libpepflashplayer.so in OS
update_pepflash.gz
Description 
gz

 Download 
Filename  update_pepflash.gz 
Filesize  691 Bytes 
Downloaded  76 Time(s) 

_________________
PuppyRus-Arch
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 2629
Location: King's Lynn, UK.

PostPosted: Wed 21 Dec 2016, 12:18    Post subject:  

SFS, you've excelled yourself, man!! (Again...)

I run ALL my Chromium-based browsers (Chrome, Chromium, SlimJet & Iron) from a remote partition, sym-linked into each of 8 different Pups in the appropriate locations; I have one folder for 32-bit, and another folder for 64-bit. Each of these folders also has a PepperFlash folder, sym-linked into the browsers where they expect to find it.

I've modified your script to produce two copies, one for each architecture's 'path' to the appropriate folder, and have made them executable (Right-click->Properties->Click on the top executable check-box->Refresh->OK). I've now placed the appropriate copy of your script in each Pup @ /root/Startup, so that the updater will run automatically at boot.

This is what I've really wanted for I don't know how long..!

Many, many thanks. Very Happy

BTW: For anybody else who might be interested, I'm going to do a thread, linking to your post (and giving you the credit, of course..!!) I shall also explain how to set it to run automatically.

This, along with Geoff's version, will all help to make Pup that much easier for newbies.

Bal'shoye spaseeba! (Probably got that wrong... Embarassed Laughing )


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 2629
Location: King's Lynn, UK.

PostPosted: Mon 02 Jan 2017, 15:13    Post subject:  

Hiya, Geoff.

As a previous poster put it, 'I hate to be the bearer of bad news....again' Laughing

I've a sneaking suspicion 1.6 has got a bug in it. Just used it to update Flash in a brand-new install of Tahr64.....and it gave me the 32-bit version. So PaleMoon wasn't detecting it, and said 'Not Installed'.

When I was using 1.5 in my main install of Tahr64, it always detected the right version of Flash that was required. 1.6 isn't doing this.....and in fact, looking at the script, it appears to be set for 'i386' ONLY.

Or does it need to have an existing version of Flash to compare to, before updating for the first time?


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2279
Location: Queensland

PostPosted: Wed 25 Jan 2017, 07:52    Post subject:  

Mike Walsh wrote:
Hiya, Geoff.

As a previous poster put it, 'I hate to be the bearer of bad news....again' Laughing

I've a sneaking suspicion 1.6 has got a bug in it. Just used it to update Flash in a brand-new install of Tahr64.....and it gave me the 32-bit version. So PaleMoon wasn't detecting it, and said 'Not Installed'.

When I was using 1.5 in my main install of Tahr64, it always detected the right version of Flash that was required. 1.6 isn't doing this.....and in fact, looking at the script, it appears to be set for 'i386' ONLY.

Or does it need to have an existing version of Flash to compare to, before updating for the first time?


Mike. Wink


Yeah Mike, it 32 bit only, it should work without there being a flash version installed, I do find it hangs for a few minutes in X-Tahr, I think it's wget that's the problem, I was going to see about doing a 64bit update, but as I don't use 64bit so haven't found the enthusiasm to do so.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Back to top
View user's profile Send private message 
Subito Piano


Joined: 27 May 2007
Posts: 585
Location: UPSTATE New York

PostPosted: Sat 04 Feb 2017, 16:19    Post subject:  

Geoffery -- THANKYOUTHANKYOUTHANKYOU!!

Phil -- very thoughtful of you to put that in Tahr.

Pale Moon was frustrating me -- no more! Smile

_________________
"God is love" - I John 4:12
Tahrpup 6.0.5
(A/V Linux for live digital synth)
Back to top
View user's profile Send private message Visit poster's website 
mgolden


Joined: 10 Aug 2014
Posts: 58

PostPosted: Sun 19 Feb 2017, 20:18    Post subject:  

Geoffrey,

This updater seems to have broken with the latest version of flash.

I'm seeing:

"Adobe Flash update has already started...
New Version 24.0.0.221"
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2279
Location: Queensland

PostPosted: Sun 19 Feb 2017, 22:43    Post subject:  

mgolden wrote:
Geoffrey,

This updater seems to have broken with the latest version of flash.

I'm seeing:

"Adobe Flash update has already started...
New Version 24.0.0.221"


Yeah, it seems "awk" isn't finding the version string in libflashplayer.so, Adobe must of changed something, so I have gone back to using "busybox strings", that fixed it.

It now only looks for new versions at adobe.com/software/flash/about, that sped things up as it was hanging for a long time for me at get.adobe.com/flashplayer.

Updated to update_flash-1.7, see first post

PS remove /root/.flash_update if it still exist before running the new one.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Back to top
View user's profile Send private message 
mgolden


Joined: 10 Aug 2014
Posts: 58

PostPosted: Wed 22 Feb 2017, 12:02    Post subject:  

Geoffrey wrote:


Yeah, it seems "awk" isn't finding the version string in libflashplayer.so, Adobe must of changed something, so I have gone back to using "busybox strings", that fixed it.

It now only looks for new versions at adobe.com/software/flash/about, that sped things up as it was hanging for a long time for me at get.adobe.com/flashplayer.

Updated to update_flash-1.7, see first post

PS remove /root/.flash_update if it still exist before running the new one.


Thank you kind sir!
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 8798
Location: Charleston S.C. USA

PostPosted: Wed 22 Feb 2017, 17:08    Post subject:  

Geoffrey,

Thanks for keeping up with the constant movement of where you get Flash player!

It seems to be a full time job!!!

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
sfs

Joined: 02 Nov 2013
Posts: 38
Location: Russia

PostPosted: Fri 10 Mar 2017, 04:01    Post subject:  

Code:
INSTALLED_VERSION="`sed -n '/LNX /s/.*LNX \([0-9,]\+\).*/\1/p' "$pf" | tr -dc 0-9, | sed 's/,/./g'`"

_________________
PuppyRus-Arch
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 2629
Location: King's Lynn, UK.

PostPosted: Wed 10 May 2017, 18:57    Post subject:  

Hiya, Geoff.

This must be getting boring, fast.

Any ideas what's causing this?




It's been doing this for several weeks now, so I've simply reverted to using the old, manual method of GetFlash-1.7. Which is a shame, 'cos this has always been a really neat utility (when it condescends to behave itself...) Laughing


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2279
Location: Queensland

PostPosted: Fri 12 May 2017, 00:33    Post subject:  

Mike Walsh wrote:
Hiya, Geoff.

This must be getting boring, fast.

Any ideas what's causing this?




It's been doing this for several weeks now, so I've simply reverted to using the old, manual method of GetFlash-1.7. Which is a shame, 'cos this has always been a really neat utility (when it condescends to behave itself...) Laughing


Mike. Wink


I've been without net, I'll have a look when I get the chance Mike Wink

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 2629
Location: King's Lynn, UK.

PostPosted: Fri 12 May 2017, 05:33    Post subject:  

Righty-ho, Geoff.

I'll leave it with you. As & when, mate.

Glad to hear you're back with us..!


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2279
Location: Queensland

PostPosted: Sat 13 May 2017, 17:02    Post subject:  

Ok Mike I had a look, Adobe changed the About page, so grep wasn't finding the version number.

Easy fix, edit line 109 in /usr/bin/update_flash, change grep -A2 Linux to grep -A3 Linux.

make sure you delete the ~/.flash_update folder if it exists before running the script.

tell me if that fixes it for you as I have no idea how you got



If it's a goer I'll update the package.

Wink

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 7 [96 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1255s ][ Queries: 15 (0.0106s) ][ GZIP on ]