Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Jul 2017, 18:50
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
light-49.0 mozilla browser for 32-bit Puppies as sfs or pet
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 5 [62 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Wed 22 Feb 2017, 16:06    Post subject:  

@watchdog
I've installed racy 5.5. I'm posting from it now. Seems OK on this machine. I've installed your .pet.

Quote:
Remember that dbus and dbus-glib from wary's repository are required.


I've installed dbus-1.2.4.2permissive-1-w5.pet and
dbus-glib-0.82-w5.pet. With the first I got a message to say I had to reboot before it would work. I am just about to do that.

Ken.
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1182
Location: GERMANY

PostPosted: Wed 22 Feb 2017, 16:11    Post subject:  

Hi Semme !

Quote:
you run private browsing mode enabled, correct?


No

Maybe somebody else is encountering the same problem .

But me anyway dont care if sound or not on youtube .
Just copy URL from Youtube video and paste it into

Smplayer----Menu ---open >URL .....

is anyway better watching Videos on Youtube with Smplayer.
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7775
Location: World_Hub

PostPosted: Wed 22 Feb 2017, 16:22    Post subject:  

Maybe, but you didn't specify your version or whether YouTube failed with add-ons enabled or disabled.

Works fine for me without Flash. Besides, isn't YT all HTML5 these days?

Either way, I'll let it go..

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1182
Location: GERMANY

PostPosted: Wed 22 Feb 2017, 16:33    Post subject:  

Hi Semme !
Thanks for your good will ......

Tried with Add Ons disabled ......Video works but no sound ......

Not so important .....
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Wed 22 Feb 2017, 16:54    Post subject:  

@watchdog
Sorry but didn't work. Below is output from terminal.

Code:
# light
/usr/bin/light: line 3: 10350 Illegal instruction     /lib/light/glibc219/lib/ld-linux.so.2 --library-path /lib/light/glibc219/lib:/lib/light/glibc219/usr/lib:/lib/light/glibc219/libstdc++:/usr/X11R7/lib:/lib/light /lib/light/light "$@"


Can you tell me if there is a way to fix this?

Ken.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 11882
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 22 Feb 2017, 21:19    Post subject:  

Sad light crashes before having any problem with YouTube. It crashed right as soon as opening .... (Pupjibaro Jessie, 6.4.2). Sorry josejp24. It was a nice try Smile
_________________
Damned Puppy, stay plugged with Papa Evil or Very Mad !
Back to top
View user's profile Send private message Yahoo Messenger 
watchdog

Joined: 28 Sep 2012
Posts: 1387
Location: Italy

PostPosted: Thu 23 Feb 2017, 02:14    Post subject:  

keniv wrote:
@watchdog
Sorry but didn't work. Below is output from terminal.

Code:
# light
/usr/bin/light: line 3: 10350 Illegal instruction     /lib/light/glibc219/lib/ld-linux.so.2 --library-path /lib/light/glibc219/lib:/lib/light/glibc219/usr/lib:/lib/light/glibc219/libstdc++:/usr/X11R7/lib:/lib/light /lib/light/light "$@"


Can you tell me if there is a way to fix this?

Ken.


Geoffrey has sent a private message to me. My original package is working in Carolina but he suggested a one more tweak to play videos. I have repackaged light e I'm uploading it for testing. It works with my hardware using the vesa graphic driver in racy 5.5. I installed videodownloadhelper, noscript, js, ublockorigin extension and they are working. I played some videos. I don't know about your error. Uninstall the old package and install the new one from googledrive. Try the vesa driver (reboot required).

light-49.0-racy5-glibc219tweak.pet:

https://drive.google.com/file/d/0B9iMb4UZBeFkd01peG02Z0trSTA/view?usp=sharing

EDIT: I found this:

https://marylou.byu.edu/wiki/index.php?page=I+keep+getting+Illegal+Instruction+errors.+What+do+I+do%3F

It seems that your cpu does not like my package.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Thu 23 Feb 2017, 08:37    Post subject:  

@watchdog
Have just come in and read your post. Thanks for all of that. I'm not using vesa as I'm sure I read it needed xorg. I'll change to versa and do the other things you recommend and report back though it will be a bit later today. Thanks again for your help with this,

Regards,

Ken.

Found time to try this. It still does not work . On trying it in a terminal I got no output! Maybe it is my processor. I have attached two images from Syst Info for the CPU. As it's an intel chip I think this would be the relevant bit of the stuff on your link.

Quote:
Alternatively, if you wanted to request any intel processor except Harpertown processors, you could do it like this:

#PBS -l nodes=2:ppn=8,walltime=30:00,pmem=1gb,feature='intel:!harpertown'


I don't know if it's relevant to Syst Info data on my CPU. I'm well out of my depth here.

Ken.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Thu 23 Feb 2017, 09:56    Post subject:  

Just realised that I forgot to change to vesa. Done that now but still get the same result as in previous post.

Ken.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1387
Location: Italy

PostPosted: Thu 23 Feb 2017, 13:08    Post subject:  

There is not to be fan of light browser. I prefer palemoon which well works for old puppies on many machines. You can just use an old version of seamonkey or firefox keeping careful blocking scripts in your browsing behaviour. I just played with light browser but I think it cannot become our main browser.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Thu 23 Feb 2017, 14:15    Post subject:  

I made a new save file. I installed only your latest pet and the two dbus pets. It did not work. Running in a terminal gave the same "illegal instruction" output. Sorry to say it's time to give up. I have gained a pet I like in Racy 5.5 which I had not tried and runs quite well on my machine. Thanks for all the help with trying to get light to work on my machine.

Regards,

Ken.
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1192

PostPosted: Thu 23 Feb 2017, 14:51    Post subject:  

keniv wrote:
I made a new save file. I installed only your latest pet and the two dbus pets. It did not work. Running in a terminal gave the same "illegal instruction" output. Sorry to say it's time to give up. I have gained a pet I like in Racy 5.5 which I had not tried and runs quite well on my machine. Thanks for all the help with trying to get light to work on my machine.

Regards,

Ken.

Oh, I think that's the "your CPU doesn't have SSE2 which light is compiled to require" problem:
http://murga-linux.com/puppy/viewtopic.php?p=942291#942291
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 411
Location: Scotland

PostPosted: Thu 23 Feb 2017, 19:05    Post subject:  

Yes I'm fairly sure thats the problem. Some discussion on this in earlier posts.

Ken.
Back to top
View user's profile Send private message 
XP Refugee

Joined: 14 May 2014
Posts: 60

PostPosted: Fri 24 Feb 2017, 20:26    Post subject: no sound on youtube  

works fine in Palemoon and Firefox. Weird. I might like this Light. Acer netbook, needs all the help it can get.
lxpup 15.06 I believe.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 11882
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 08 Mar 2017, 11:55    Post subject:  Now in LXpup Xenial. Light 49 works very well.
Subject description: Griffith search my movies from allociné (covers ok)
 

Now in LXpup Xenial. Light 49 works very well. You Tube not tested yet. I will advise later.
Links to allociné (french movies) succeed when with Palemoon no connect (Griffith). Perhaps the browser is not guilty, but there is a difference in favour of light.. I think to remasterize LXpup with it, after checking You Tube.
Nothing bad about Palemoon, just to change my habit.

YOU TUBE : no trouble to access (LXpup Xenial.)

_________________
Damned Puppy, stay plugged with Papa Evil or Very Mad !
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 4 of 5 [62 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0562s ][ Queries: 15 (0.0093s) ][ GZIP on ]