Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 21 Oct 2017, 08:35
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
JL64-704 Slackware-14.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 14 of 17 [247 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Author Message
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Sat 04 Feb 2017, 11:22    Post subject: gtkrc  

trimmed .xinitrc a bit. fixed lx-appearance compatibility - gtk changes made via lx-appearance will persist between DE changes.

edit: sorry, error. reupload.

df
lx-gtk-3.pet
Description 
pet

 Download 
Filename  lx-gtk-3.pet 
Filesize  4.64 KB 
Downloaded  39 Time(s) 
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Mon 20 Feb 2017, 14:19    Post subject:  

eztuxer wrote:
Posting from JLH 64.
I made a .txt file with the email...
More precisely, the support of the "alt gr" key & the up down left right arrows is dead.
Will try to swap /etc/keymap config file with that from FD


The same here with Italian keyboard layout, anyway a wonderful Puppy derivative. Thanks Dry Falls for the huge work.

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Tue 21 Feb 2017, 18:39    Post subject:  

Hi Corvus, and thanks. As to the keyboard layout, I made a new Italiano pupsave setting country and keyboard from the firstrun dialog. Everything worked fine. For some reason, if you do it later (from menu | personalize settings or setup) it fails to write to xorg.conf. In that case, copy the following to /etc/xorg.conf (which should be blank as xorg server no longer uses it but WILL read from it):
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc102"
    Option         "XkbLayout" "it" #xkeymap0
EndSection
(change "XkbModel" to whatever is appropriate)

for a language pack, there are many available from slackware with gslapt (if you're running kde), in your case, kde-l10n-it-4.14.3-noarch-1.txz.

Unfortunately, the puppy language pack available through PPM is limited in its usefulness, and then fixmenus wrecks it. Something I need to work on.

Unfortunately as well, /usr/local/apps/XkbConfigurationManager is the same as in woof-CE and depends on keyboard written to xorg.conf. I'm in the process of rewriting ~/root/xinitrc. Hopefully this will be fixed for the next release.

df
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Wed 22 Feb 2017, 19:19    Post subject: keyboard layout issue  

Hi Dry Falls, I'm posting from JL64 right now. I followed your suggestions but no success, it is not only "alt gr" key issue but the problem afflicts many of the keys located on the right side of the keyboard:
- "alt gr" acts as "enter";
- "stamp r sist" acts as "canc";
- "canc" does not work;
- "pagup" acts as "/";
- "up" "down" "left" and "right" keys doesn't works, and other keys work in the wrong way.
I tried differents keyboard layout and differents keyboard settings via Countrywizard but nothing to do.
The problem is not hardware related because I use also Fatdog710, Slacko64 6.3.2, Tahr64 6.0.6 and other distrò and haven't issues, not with keyboard. Laughing
I'll continue to experiment but I believe that the solution is beyond my knowledge.

Best regards Smile

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Fri 24 Feb 2017, 18:01    Post subject: keymaps  

I believe I've found the problem. Keymaps (in /lib as well as in initrd.xz) are still from 2011, from lh64-602. here are keymaps from fatdog 710 (extract and drop into /lib, replacing old files):

Worth testing anyway...
keymaps.tar.gz
Description 
gz

 Download 
Filename  keymaps.tar.gz 
Filesize  35.47 KB 
Downloaded  30 Time(s) 
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Fri 24 Feb 2017, 19:47    Post subject:  

I'm sorry Dry Falls, but even changing the folder does not change anything. Sad
_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Mon 27 Feb 2017, 19:01    Post subject:  

Hi Dry Falls, I tried several versions of Just-lighthouse and I found it one in which my keyboard work OOTB downloaded from the following link: http://archive.org/download/Puppy_Linux_Lighthouse64/150816-JL64-603.iso.
I tried to replace the folder /lib/keymaps of JL64-702 Slackware-14.2 with that of 150816-JL64-603 but did not work.
Hope this helps.

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Tue 28 Feb 2017, 03:52    Post subject:  

Corvus, I was wondering if you have an older box or laptop? I was thinking it must be a kernel/firmware issue or syntax in the .xinitrc script. Have you tried the firmware sfs addon? How about k4.1.11 kernel package? It's true that slackware64-14.2 is substantially different than 14.1 and its earlier xorg server (in JL64-603 & 604), but I suspect the error is mine. I really appreciate your help with this. Hopefully we'll find the culprit and fix it.

Here is the current .xinitrc I'm using. Maybe that will have an effect.

df
.xinitrc.gz
Description 
gz

 Download 
Filename  .xinitrc.gz 
Filesize  9.06 KB 
Downloaded  32 Time(s) 
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Wed 01 Mar 2017, 17:07    Post subject:  

Dry Falls wrote:
Corvus, I was wondering if you have an older box or laptop?

Sorry for the lack of information, here is my inxi output:
Quote:
System: Kernel: 4.1.3-JL-64 x86_64 (64 bit, gcc: 4.8.2) Desktop: Openbox 3.5.0
Machine: System: ASUSTeK (portable) product: X555LB version: 1.0 Mobo: ASUSTeK model: X555LB version: 1.0 Bios: American Megatrends version: X555LB.204 date: 01/13/2015
CPU: Dual core Intel Core i7-5500U CPU (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9586.74 Clock Speeds: 1: 2400.375 MHz 2: 2400.281 MHz 3: 2497.125 MHz 4: 2400.00 MHz
Graphics: Card: Intel Device 1616 bus-ID: 00:02.0 X.org: 1.12.3 drivers: vesa,fbdev (unloaded: intel) tty size: 124x24
Audio: Card-1: Intel Device 160c driver: snd_hda_intel bus-ID: 00:03.0 Sound: ALSA ver: k4.1.3-JL-64 Card-2: Intel Device 9ca0 driver: snd_hda_intel bus-ID: 00:1b.0
Network: Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169 ver: 2.3LK-NAPI port: e000 bus-ID: 02:00.0 IF: enp2s0 state: down mac: <filter> Card-2: Atheros Device 0036 driver: ath9k bus-ID: 03:00.0 IF: wlp3s0 state: up
Drives: HDD Total Size: 2016.3GB (1.6% used) 1: id: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB 2: USB id: /dev/sdb model: SanDisk_Ultra size: 15.9GB


Dry Falls wrote:
I was thinking it must be a kernel/firmware issue or syntax in the .xinitrc script. Have you tried the firmware sfs addon?

Tried your .xinitrc script and the firmware sfs addon no success.

I have tried several JL64 versions and noticed that Just-Lighthouse64-604.6.8 is the last version on which my keyboard is working properly, from Just-Lighthouse64-604.6.8.2 up to JL64-702 my keyboard does not work in the correct mode.

corvus

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Thu 02 Mar 2017, 06:03    Post subject: k4.1.3  

Hi Corvus. Just to humor me, could you try this kernel package with JL64-702.sfs (plus minimally, 2_gvfs and python-2.7 addons)? It is identical to your JL64-603 which works except for distrospecs and BOOTCONFIG files. It's an older kernel configuration and older yet busybox. Anyway, this test, if it still doesn't work for you, will rule out the kernel and initrd as the root of the problem...

k4.1.3.tar.gz

thanks,
df
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Thu 02 Mar 2017, 13:38    Post subject:  

Tried, unfortunately my keyboard does not work properly, you can rule out the kernel and initrd as the root of the problem.

corvus

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Sun 05 Mar 2017, 16:06    Post subject:  

Corvus, did you try boot parameter "pkeys=it"? May be a timing problem. Otherwise, log out and at prompt, type xorgwiz-auto or xorgwiz-vintage (either of these set up the system for, and then call xorgwizard). If that doesn't work, I think your keyboard just doesn't tolerate xorg-server-1.18.3+. I'm going to try and rebuild JL64-604 for older machines, but that is down the road. 603 was really a pre-alpha experiment and has much amiss. It's good to know that the 4.1 series kernel worked for you.

df
Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 126
Location: In the peninsula shaped like a boot.

PostPosted: Sun 05 Mar 2017, 17:40    Post subject:  Fully functional keyboard  

Dry Falls wrote:
Corvus, did you try boot parameter "pkeys=it"?

This did the trick I'm very happy Thanks. Very Happy What changes if you specify the keyboard layout in the boot parameter instead of the quick setup settings?
Anyway Thanks again Dry Falls for the time you have dedicated to the resolution of my problem.

corvus

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Sun 26 Mar 2017, 22:47    Post subject: Just-Lighthouse64-702rc2  

Just-Lighthouse64-702rc2.delta.tar.gz Delta uploaded

see O/P

df
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 495
Location: Upper Columbia

PostPosted: Wed 05 Apr 2017, 17:23    Post subject:  

JL64-702.iso
md5sum: a1cef0bf845eef23d22ac44908a20733

see op

df
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 14 of 17 [247 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0602s ][ Queries: 15 (0.0124s) ][ GZIP on ]