Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Mar 2017, 04:37
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Installing printers in Fatdog64
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 10:58    Post subject:  Installing printers in Fatdog64
Subject description: I'm running Fatdo64 v. 702```
 

I downloaded 64BitInstaller.pet and then I extracted it. It created a directory and dropped shell scripts candi, candi64, debbi, debbi64, petti, remov, etc..

My printer is an HP V40 officejet. Which shell script do I run for that printer?

Is it impossible to use CUPS - it redirects me to a webpage - I think the one for the 64Bit installer.

Just curious - it would be nice to install a printer or two
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 12:01    Post subject: I now know how to run - I went to the directory and ran the
Subject description: install script
 

When the dialog goes up, I can choose the Fatdog64 radio button, but at the bottom, I only see

Brother, Canon, Epson, and PET.

HP is not listed so I guess I would choose PET?
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 12:04    Post subject: Trouble with installation dialog
Subject description: I picked petti64 for the "Input box"
 

And it said, "not a pet package". I guess it's a script, that's why. I don't know where the packages are.

I'm downloading hplip - that should help. Now I have to select which Linux distribution. Fatdog64 is not listed. I'll have to work on this.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11050
Location: Stratford, Ontario

PostPosted: Fri 03 Mar 2017, 12:40    Post subject:  

I don't think that you are following the instructions correctly. Please post a request for help here and we can do it step-by-step.

You are about to get things badly buggered up.
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 12:42    Post subject: I've now downloaded a .pet package
Subject description: hplip_print_scan_tahr64-3.16.11 (3).pet
 

I've never worked with a .pet file. I would assume I need to extract this. Then somehow use the 64 bit installer? Why do the directions say do not "click install'?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11050
Location: Stratford, Ontario

PostPosted: Fri 03 Mar 2017, 12:49    Post subject:  

If you want to continue this conversation, go to the other thread.
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 13:15    Post subject: I now have usr, var, etc, pet.specs and pinstall.sh
Subject description: I now have these files
 

I ran pinstall.sh and it just adds hpaio to the .d dir or something and maybe one or two other things.

Should I now run 64bit installer? Or rn something else?
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 14:12    Post subject: After using an unzipper in local/bin, ExtractZip.sh or somet
Subject description: I then ran 64Bitinstaller (after manually populating usr, etc, and var
 

with all of the files in the .pet.

Now the installer does not error out. So I gave it the .pet in the iinstall and chose the PET radio button. It never ever said anything like "done" or "success" so I assume it ran ok. I guess I can try the next step in the proces.s
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 15:22    Post subject: My cups server is 64-bit so CUPS looks for files in lib64
Subject description: but the .pet extracted files are all put into lib dirs.
 

Hmmph. Perhaps I need a CUPS32 server running, perhaps not. I don't know. I'll look around and see if I can find a Cups32. I realize there might be other ways to "Add a Printer" but CUPS makes it seem easy - I just click through a bunch of screens.

I just found the file HP_OfficeJet_V40.ppd while I was looking for a 32-bit cups. This might help.
Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 636
Location: Mid-mitten, USA

PostPosted: Fri 03 Mar 2017, 15:57    Post subject:  

rcrsn51 wrote:
If you want to continue this conversation, go to the other thread.
Exclamation
Back to top
View user's profile Send private message 
PappyPuppy

Joined: 30 Sep 2016
Posts: 97

PostPosted: Fri 03 Mar 2017, 16:56    Post subject: I got the HP V40 printer working on my Fatdog64 distro.
Subject description: CUPS web setup is at http://localhost:631
 

Perhaps some people were using symbolic links or simply use lib as the default for 64-bit. I don't know who made the ,pet file I downloaded - he would know why he used lib instead of lib64.

I solved the problem by copying all the files from lib to lib64. I then removed the printer that erred and simply chose "Add Printer" again (using the CUPS web install link). The original printer I had installed did not resurrect itself (at least not by any simple things I tried). Reinstalling after deleting the failed printer setup was an easy way to solve the problem.

For those who need to use CUPS, here's a link to use to start it on Fatdog64:
http://localhost:631
Then follow the dialogs and hit continue.

For my printer:
http://localhost:631/printers/HP_OfficeJet_V40

I have not tried to set up the scanner, I don't anticipate having problems with that.

One little detail I forgot:
Description: HP OfficeJet V40
Location: Local Printer
Driver: HP OfficeJet V40 - CUPS+Gutenprint v5.2.10 (color, 2-sided printing)
Connection: usb://HP/OfficeJet%20V40?serial=MY16RB40TPWN
Defaults: job-sheets=none, none media=na_letter_8.5x11in sides=one-sided

The above is the setup I chose in the list of setups presented me. I believe either of the V40 drivers would work although I have not tested the 2nd one with the new 64-bit file move.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11050
Location: Stratford, Ontario

PostPosted: Fri 03 Mar 2017, 17:25    Post subject: Re: I got the HP V40 printer working on my Fatdog64 distro.
Subject description: CUPS web setup is at http://localhost:631
 

PappyPuppy wrote:
Perhaps some people were using symbolic links or simply use lib as the default for 64-bit. I don't know who made the ,pet file I downloaded - he would know why he used lib instead of lib64.

That's because you were too stubborn to switch to the other thread and get an explanation.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0788s ][ Queries: 14 (0.0231s) ][ GZIP on ]