Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 19 Nov 2018, 16:04
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
ibus-hangul (Korean input) setup on tahrpup
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
gychang


Joined: 29 Nov 2008
Posts: 198
Location: Davis, CA

PostPosted: Thu 10 Mar 2016, 08:52    Post subject:  ibus-hangul (Korean input) setup on tahrpup  

Running tahrpup 6.0.5, and would like Korean font input.

After installing ibus-hangul and setup for both English and Hangul, I am unable to start the daemon (don't see the icon on the bar).

1. do I need to install any particular pages (installed most Korean fonts)
2. how do I start the ibus-daemon?

_________________
---
trying to learn linux...
---
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7852
Location: World_Hub

PostPosted: Fri 11 Mar 2016, 06:40    Post subject:  

Did you install with all dependencies? Does the ibus-setup-hangul script run?

Looks like you need to run "ibus-daemon --help" and write a small startup script..

Here, look @ the "Run iBus" note near the bottom.

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3127
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sun 12 Feb 2017, 19:41    Post subject:  

Hi

I did try to install ibus-hangul in

Ubuntu LTS 16.04 64 bit proposed at the Puppy Forum as «dog» XenialDog (Ubuntu 16.04 'Xenial Xerus' LTS, 32-bit)

installing it using synaptic (what else Rolling Eyes )...

I also did of course install some font (UnGungseo regular at it give good classic rendering of hangul as painted with the brush).

I make also the same operation in Kubuntu 17.04 (being yet unstable! I know it! But all precedent versions of Kubuntu become dark and dark and dark because the cursor let traces on the screen on my Dell laptop... 17.04 is the first one without that defavorable problem).

Until today:

- I can activate Hangul in original Kubuntu 17.04
- I can't do it with success in the dog.

But it would be very important for me to have the possibility in both.

I explain in the next and separate message why Idea !

Some ideas what I can try to do?

See pls following picture made in LubuntuQt 64 17.04:

- red points: the regular screen tools for Hangul writing
- yellow point: supplementary icon "ibus-settings" that I am using to turn off ibus and restart it as needing

cubes in color: read pls the nxt message

Reference: http://www.murga-linux.com/puppy/viewtopic.php?t=40192
hangul1.jpg
 Description   
 Filesize   19.52 KB
 Viewed   397 Time(s)

hangul1.jpg

Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3127
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sun 12 Feb 2017, 20:43    Post subject:  

As you see at the red points and cubes I always use a layout and version with special characters for French and German language as I am French and live in Germany, what else Laughing (and I love languages: the language of a people is the mirror of his soul and civilization because it is the fundament for both...)

You can try it using

Code:
setxkbmap us intl


it is the us layout variant international WITH DEAD KEYS (it is very important, else are the ^'``"° not on the characters but come before...)

Beginning to write in that mode, all is ok (red marks)

As soon I commute to Hangul writing, it is not possible to write French or German correctly. You can't use "the version «intl»" any more (the needing signs are occult) and you have to deconnect ibus to continue to write French and German.

"Finish" signs (é is a finish sign, like ü, or œ , or æ, or ß; to write those signs in us intl, you only need to press AltGr tipping the sign for ex. e or s etc.) reappear willing after deconnection of Hangul and reselection of us intl (violet cube under é) but in more complex signs (è, ù, à etc. Here, you have to tip 2 signs pressing AltGr, in pinyin 3 signs if you need ü with ^ on it for the ton, yes, us intl is able to write pinyin) they follow each other Mad Mad Mad (see blue cubes!):

the dead key function did be disactivated by ibus and/or not reactivated as ibus goes off alt. as us did be required hitting at the keyboard icon!

An idea pls, how to reactivate it now, this important function «dead keys» Question Rolling Eyes Idea
habgul2.jpg
 Description   
 Filesize   27.02 KB
 Viewed   381 Time(s)

habgul2.jpg

Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3127
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 17 Mar 2017, 17:55    Post subject:  

pls see http://www.murga-linux.com/puppy/viewtopic.php?p=948018#948018
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0662s ][ Queries: 13 (0.0108s) ][ GZIP on ]